Installation

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category General
  • Assigned To
    Márcio Silva
    André Silva
  • Operating System Hyperbola GNU/Linux-libre
  • Severity High
  • Priority Medium
  • Reported Version Milky Way v0.2
  • Due in Version Starfix
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Installation
Opened by J. Doe - 30/12/2017
Last edited by André Silva - 07/01/2018

FS#183 - UEFI boot not working

Booting from UEFI with a USB gives the message:

No configuration file found
Boot:

0.2 and 0.2.1

Closed by  André Silva
07.01.2018 09:53
Reason for closing:  Fixed
J. Doe commented on 30.12.2017 18:31

Confirmed by Emulatorman

Admin
André Silva commented on 04.01.2018 20:16

Hi, could you test from your UEFI machine our live image beta version released today? I've added syslinux support to UEFI boot mode with similar options than legacy BIOS one, however it requires testing before be released as official version.

J. Doe commented on 05.01.2018 01:53

Freezes after 'Configuring kernel parameters [ok]' every time.

Admin
André Silva commented on 05.01.2018 12:10

It isn't related to syslinux since your machine booted the system. Couldn't be it a known firmware issue?

Anyway, i've pushed another beta revision for testing. I've tested it from QEMU/OVMF and an UEFI machine and it works well.

Admin
André Silva commented on 06.01.2018 14:23

By the way, KMS (kernel mode-setting), the display mode is set by the kernel and it could be one of reasons about this issue, try disable it. See ArchWiki article about how to pass options to the kernel from syslinux.

There is kernel parameter list explained in ArchWiki that is useful. For a complete list of all options, please see the kernel documentation.

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing