Packages

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Testing
  • Assigned To
    André Silva
  • Operating System All
  • Severity Medium
  • Priority Medium
  • Reported Version White Hole
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Packages
Opened by Luke - 08/09/2019
Last edited by Luke - 08/09/2019

FS#1409 - [qtcreator] requires libsystemd.so

Description: The currently packaged version of QtCreator is built with SystemD support, and on v0.3 no longer works.

Steps to reproduce:

  • pacman -S qtcreator
  • qtcreator
  • All plugins fail to load
  • Receive following error message:

Cannot load plugin because dependency failed to load: ProjectExplorer(4.2.2)
Reason: /usr/lib/qtcreator/plugins/libProjectExplorer.so: Cannot load library /usr/lib/qtcreator/plugins/libProjectExplorer.so:
(libsystemd.so.0: cannot open shared object file: No such file or directory)

We need to see if it is possible to build binary without libsystemd.so or remove the package.

Closed by  Luke
08.09.2019 17:04
Reason for closing:  Fixed
Additional comments about closing:  

Fixed with https:// git.hyperbola.info:50100/packages/extra. git/commit/?id=d683503702977e3faef1856c2 45d40e028a5d698

Admin
Luke commented on 08.09.2019 13:35

I believe removing the following line from the cmake build configuration could solve the problem:

CONFIG+=journald

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing