Packages

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Any
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Any
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Packages
Opened by Alon Ivtsan - 21/05/2019
Last edited by André Silva - 22/05/2019

FS#1380 - [openssl-1.0] Newer version required for plowshare MEGA plugin

As per this bug report the MEGA plugin cannot be compiled using the OpenSSL version provided in hyperbola.

https://github.com/mcrapet/plowshare-module-mega/issues/18

This described solution works (I successfully upgraded the package to version 1.0.2r).

  Install the openssl-1.0 package.
  Run ./configure with the following arguments:

./configure –enable-local OPENSSL_LIBS=’-L/usr/lib/openssl-1.0 -lssl -lcrypto’ OPENSSL_CFLAGS=’-I/usr/include/openssl-1.0’

  run make

Unfortunately this solution (upgrading openssl-1.0) breaks some other packages such as phantomjs and avidemux, so it would be great if the package could be upgraded by Hyperbola’s developers alongside all its dependencies.

Closed by  André Silva
22.05.2019 02:40
Reason for closing:  Won't fix
Additional comments about closing:  

End of OpenSSL support [0]

Admin
André Silva commented on 22.05.2019 02:30

Currently we are removing OpenSSL support to use LibreSSL as our default provider of SSL and TLS protocols through a migration between v0.2 and v0.3. It has been announced in our news [0] . Also you can follow our TODO about it to see our development [1]

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing