All Projects

ProjectCategoryTask TypePrioritySeveritySummaryStatusProgress
PackagesAnyFreedom IssueVery HighCritical [pacman] uses "Linux" term instead of "GNU/Linux" in it ...Closed
100%
Task Description

The man page of pacman says:

DESCRIPTION
        Pacman is a package management utility that tracks installed packages on a Linux
        system

And I propose to change “Linux system” to “GNU/Linux system”.

PackagesAnyFreedom IssueVery HighCritical [xmind] is probably directing users to proprietary soft ...Closed
100%
Task Description

xmind when installed is showing that “this version is not licensed”, so that cannot be right. Even though there is GPL license on Github, that vague information in the software can and is wrongly understood:

Further it is asking for license key to get the “Pro” version.

Thus xmind is pointing to proprietary software.

That means xmind shall be removed from Hyperbola immediately as such as it is now cannot be in the fully free GNU distribution.

PackagesAnyPrivacy IssueVery HighCritical [purple-facebook] only useful with Facebook service Closed
100%
Task Description

Description:

community/purple-facebook 0.9.3-1
    Facebook protocol plugin for libpurple

It is up to maintainers to decide of course. IMHO I would remove this one as it uses proprietary network Facebook, exclusively, and even mentioning the word in the package.

See:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

A free system distribution must not steer users towards obtaining any nonfree information for practical use, or encourage them to do so.

ServicesMail Service IssueBug ReportVery HighCritical hyperbola.info having incorrect SPF records (or usage o ...Closed
100%
Task Description

As reported here: https://forums.hyperbola.info/viewtopic.php?id=110

the domain Hyperbola.info is using such SPF record that does not allow the IP address 185.26.126.154 to send emails from bissen.hyperbola.info as seen on: https://mxtoolbox.com/SuperTool.aspx?action=spf%3ahyperbola.info&run=toolpage

Correct the SPF record as to enable deliveries of emails.

This is negatively impacting Hyperbola project in public mail servers which may consider hyperbola.info domain as domain sending spam.

Jun 10 11:12:41 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:14:57 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:16:02 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:16:50 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:17:28 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:18:17 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:19:12 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:21:01 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:21:37 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:22:22 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:22:36 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:22:54 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
Jun 10 11:23:09 stw1 courieresmtpd: error,relay=::ffff:185.26.126.154,from=<sysadmin@hyperbola.info>: 517 SPF fail bissen.hyperbola.info: Address does not pass the Sender Policy Framework
PackagesAnyBug ReportMediumCritical [wesnoth]: prevents upgrade of Hyperbola, colliding fil ...Closed
100%
Task Description

Description:

I have tried to upgrade hyperbola.

Critical upgrades cannot be installed when wesnoth is installed, there are conflicting files

Steps to reproduce:

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 arch-keyring-201808...  1605.2 KiB   617K/s 00:03 [#########] 100%
 hyperbola-keyring-2...   215.9 KiB   635K/s 00:00 [#########] 100%
 linux-libre-lts-4.9...    59.6 MiB   749K/s 01:22 [#########] 100%
 openvpn-2.4.6-1.hyp...   402.2 KiB  1149K/s 00:00 [#########] 100%
 iceweasel-uxp-52.9....    39.8 MiB   839K/s 00:49 [#########] 100%
 libgdm-3.24.1-1.hyp...    57.3 KiB  1912K/s 00:00 [#########] 100%
 ntp-4.2.8.p11-2.hyp...  1798.4 KiB   833K/s 00:02 [#########] 100%
 sddm-0.14.0-2.hyper...     3.2 MiB   770K/s 00:04 [#########] 100%
 lxdm-0.5.3-4.hyperb...    98.4 KiB   984K/s 00:00 [#########] 100%
 tp_smapi-lts-0.43-1...    26.6 KiB  2.60M/s 00:00 [#########] 100%
 wesnoth-data-1.14.4...   395.1 MiB   745K/s 09:03 [#########] 100%
 wesnoth-1.14.4-1.hy...     5.5 MiB   616K/s 00:09 [#########] 100%
(12/12) checking keys in keyring                   [#########] 100%
(12/12) checking package integrity                 [#########] 100%
(12/12) loading package files                      [#########] 100%
(12/12) checking for file conflicts                [#########] 100%
error: failed to commit transaction (conflicting files)
/usr/share/icons/hicolor/128x128/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/icons/hicolor/16x16/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/icons/hicolor/256x256/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/icons/hicolor/32x32/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/icons/hicolor/512x512/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/icons/hicolor/64x64/apps/wesnoth-icon.png exists in both 'wesnoth-data' and 'wesnoth'
/usr/share/metainfo/wesnoth.appdata.xml exists in both 'wesnoth-data' and 'wesnoth'
Errors occurred, no packages were upgraded.
PackagesAnyBug ReportVery LowCritical [apache]: cannot start if NetworkManager is not started Closed
100%
Task Description

Description:

Apache web server shall be running with or without the external network, and without NetworkManager.

rc-service httpd start

will give the message that NetworkManager must be started first, and will not start apache web server. I cannot find in which file is that written.

Steps to reproduce:

1. Disconnect network. Start computer.

2. Try to start apache with above command.

That makes no sense, as Apache can run on local network without NetworkManager and it is not written in the description.

PackagesAnyFeature RequestVery HighHigh[backuppc]: contains systemd filesResearching
0%
Task Description

Description:

Since Hyperbola follows the Init Freedom Campaign, systemd unit files removal is required or add OpenRC init scripts to replace it.

Additional info:
* package version(s)

community/backuppc 4.1.2-1 [installed]

   Enterprise-grade system for backing up Linux, Windows and MacOS PCs

* config and/or log files etc.

Additional info:

Steps to reproduce: install it

PackagesAnyFeature RequestVery HighHigh[gpsd]: contains systemd filesResearching
0%
Task Description

Since Hyperbola follows the Init Freedom Campaign, systemd unit files removal is required or add OpenRC init scripts to replace it.

Additional info:
* package version(s)

extra/gpsd 3.16-3 [installed]

   GPS daemon and library to support USB/serial GPS devices

* config and/or log files etc.

Additional info:

Steps to reproduce: install it

PackagesStableFeature RequestVery HighHigh[hiawatha]: remove systemd files, provide openrcResearching
0%
Task Description

Description:

Hiawatha contains only systemd files.

It shall be removed and openrc shall be provided

PackagesStableBug ReportMediumHighopensmtpd: permission problemsIn Progress
0%
Task Description

Description:

cat msg | /usr/sbin/sendmail – sendmail: No such file or directorycannot create temporary file /var/spool/smtpd/offline/1572544775.XXXXIqNsFX

Additional info:
* package version: 6.4.2p1-1.hyperbola2.backports1

It is same problem as here:
https://github.com/OpenSMTPD/OpenSMTPD/issues/839

I could solve it with:

sudo chmod g+s /usr/sbin/smtpctl
sudo chmod g+s /usr/sbin/smtpctl

and then

sudo rc-service smtpd start

Even though I think I should not need to start it to use only sendmail.

PackagesAnyBug ReportVery LowHighDesite "noauto" specified in /etc/fstab all devices get...Unconfirmed
0%
Task Description

Description:

I have tried all combinations, but despite “noauto” specified in /etc/fstab all devices get mounted at boot.

Who can help me, not to mount a device during boot?

PackagesAnyImplementation RequestVery LowHigh[glom]: should depend on libgdaUnconfirmed
0%
Task Description

Description:

glom cannot run without libgda, so it should depend on libgda package

ServicesWiki Page IssueBug ReportVery LowHigh HTML design on Wiki not readable Closed
100%
Task Description

The wiki pages look really too narrow and not readable on even half a screen of the laptop.

PackagesAnyUpdate RequestVery LowHigh[proj]: please update to latest versionUnconfirmed
0%
Task Description

Description:

https://proj4.org/index.html

This package have valuable geodetic applications, and I intend to present Hyperbola GNU/Linux-libre soon in universities and schools in East Africa.

The coordinate system there is not WGS84 and this package only in new version is providing the conversion from East African geographic coordinates to WGS84, and will be very usable in many industrial and private applications.

PackagesAnyBug ReportVery LowHigh error: extract: not overwriting dir with file /usr/loca ...Closed
100%
Task Description

Description:

after upgrade there are errors that shall not be there. I cannot know why.

admin-> upgrade-hyperbola
:: Synchronizing package databases...
 core                             186.6 KiB   283K/s 00:01 [###############################] 100%
 extra                           1918.8 KiB   259K/s 00:07 [###############################] 100%
 community                          4.1 MiB   217K/s 00:19 [###############################] 100%
 DEB_Arch_Extra                     4.2 KiB  0.00B/s 00:00 [###############################] 100%
 DEB_Arch_Extra.sig               280.0   B  0.00B/s 00:00 [###############################] 100%
:: Starting full system upgrade...
warning: elinks: local (0.13-18) is newer than community (0.12pre6-1.hyperbola1)
resolving dependencies...
looking for conflicting packages...

Packages (5) filesystem-2017.03-2.hyperbola10.4  icedove-uxp-52.9.20181107-1
             iceweasel-uxp-52.9.20181107-1  licenses-20140629-2.hyperbola3
             pacman-mirrorlist-20181031-1.hyperbola1.1

Total Download Size:    79.91 MiB
Total Installed Size:  226.65 MiB
Net Upgrade Size:        0.26 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 filesystem-2017.03-2.hyperb...    13.0 KiB  0.00B/s 00:00 [###############################] 100%
 licenses-20140629-2.hyperbo...    68.4 KiB   171K/s 00:00 [###############################] 100%
 pacman-mirrorlist-20181031-...     5.6 KiB  0.00B/s 00:00 [###############################] 100%
 icedove-uxp-52.9.20181107-1...    37.6 MiB   403K/s 00:06 [############################---]  93     icedove-uxp-52.9.20181107-1...    37.9 MiB   41-----------------------------]      iceweasel-uxp-52.9.20181107...     3.8 MiB   867K/s 00:42 [##-----------------------------]       iceweasel-uxp-52.9.20181107...     3.8 MiB   600K/s 01:01 [##-----------------------------      iceweasel-uxp-52.9.20181107...     4.0 MiB   773K/s 00:47 [###----------------------------]    iceweasel-uxp-52.9.20181107...     4.1 MiB   702K/s 00:51 [###----------------------------]   iceweasel-uxp-52.9.20181107...    39.8 MiB   212K/s 03:12 [###############################] 100%
(5/5) checking keys in keyring                             [###############################] 100%
(5/5) checking package integrity                           [###############################] 100%
(5/5) loading package files                                [###############################] 100%
(5/5) checking for file conflicts                          [###############################] 100%
(5/5) checking available disk space                        [###############################] 100%
:: Processing package changes...
(1/5) upgrading filesystem                                 [###############################] 100%
error: extract: not overwriting dir with file /usr/local/share/man
error: problem occurred while upgrading filesystem
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
PackagesAnyBug ReportVery LowHighgroff: package not built with URW fonts properly or suc...Unconfirmed
0%
Task Description

Description:

groff is typesetting system similar to TeX/LaTeX however, it is very small and very usable. It is not built properly with URW fonts, or such are missing, I cannot know all details. Overall groff package is basically somehow broken.

It shall depend on proper fonts, and such fonts should already be built, including their Unicode versions.

Package is only partially built.

PackagesAnyBug ReportDeferHigh[texlive-most] cannot export LaTeX - input csr10' fail...Deferred
50%
Task Description

I was using GNU Emacs, and tried to export LaTeX file or make a PDF. It seems that texlive package is broken, some fonts are missing.

The group named texlive-most cannot be properly installed.

admin→ pacsearch texlive

extra/texlive-bibtexextra 2016.43765-1 (texlive-most)
    TeX Live - Additional BibTeX styles and bibliography databases
extra/texlive-bin 2016.41290-12.hyperbola1 [installed]
    TeX Live binaries (Hyperbola rebranded)
extra/texlive-core 2016.43757-1.hyperbola2 (texlive-most) [installed]
    TeX Live core distribution, without nonfree add-on packages (Hyperbola rebranded)
extra/texlive-fontsextra 2016.43763-1.hyperbola2 (texlive-most) [installed]
    TeX Live - all sorts of extra fonts, without nonfree add-on packages
extra/texlive-formatsextra 2016.41438-3 (texlive-most) [installed]
    TeX Live - collection of extra TeX 'formats'
extra/texlive-games 2016.43415-1 (texlive-most)
    TeX Live - Setups for typesetting various board games, including chess
extra/texlive-genericextra 2016.43605-1 (texlive-most) [installed]
    TeX Live - mixed bag of generic macro packages and fonts
extra/texlive-htmlxml 2016.43769-1 (texlive-most)
    TeX Live - Packages to convert LaTeX to XML/HTML, and typeset XML/SGML
extra/texlive-humanities 2016.43711-1 (texlive-most)
    TeX Live - LaTeX packages for law, linguistics, social sciences, and humanities
extra/texlive-langchinese 2016.43669-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Chinese texts
extra/texlive-langcjk 2014.0-1
    TeX Live - CJK (Chinese, Japanese, Korean) metapackage
extra/texlive-langcyrillic 2016.43417-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Cyrillic texts
extra/texlive-langextra 2016.43739-1 (texlive-lang)
    TeX Live - Bundle of all extra language support
extra/texlive-langgreek 2016.43222-1 (texlive-lang)
    TeX Live - Fonts and support for typesetting Greek
extra/texlive-langjapanese 2016.43741-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Japanese texts
extra/texlive-langkorean 2016.43130-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Korean texts
extra/texlive-latexextra 2016.43768-1.hyperbola2 (texlive-most) [installed]
    TeX Live - Large collection of add-on packages for LaTeX, without nonfree add-on packages
extra/texlive-music 2016.43375-1 (texlive-most)
    TeX Live - Music typesetting packages
extra/texlive-pictures 2016.43767-1 (texlive-most) [installed]
    TeX Live - Packages for drawings graphics
extra/texlive-plainextra 2016.43137-1 (texlive-most) [installed]
    TeX Live - A collection of add-on packages and macros for plain TeX
extra/texlive-pstricks 2016.43710-1 (texlive-most) [installed]
    TeX Live - Additional PSTricks packages
extra/texlive-publishers 2016.43764-1 (texlive-most)
    TeX Live - LaTeX classes and packages for specific publishers
extra/texlive-science 2016.43747-1 (texlive-most)
    TeX Live - Typesetting for mathematics, natural and computer sciences

[~]
admin→ sudo pacman -S texlive-most

:: There are 15 members in group texlive-most:
:: Repository extra
   1) texlive-bibtexextra  2) texlive-core  3) texlive-fontsextra  4) texlive-formatsextra  5) texlive-games  6) texlive-genericextra
   7) texlive-htmlxml  8) texlive-humanities  9) texlive-latexextra  10) texlive-music  11) texlive-pictures  12) texlive-plainextra
   13) texlive-pstricks  14) texlive-publishers  15) texlive-science

Enter a selection (default=all):
warning: texlive-core-2016.43757-1.hyperbola2 is up to date -- reinstalling
warning: texlive-fontsextra-2016.43763-1.hyperbola2 is up to date -- reinstalling
warning: texlive-formatsextra-2016.41438-3 is up to date -- reinstalling
warning: texlive-genericextra-2016.43605-1 is up to date -- reinstalling
warning: texlive-latexextra-2016.43768-1.hyperbola2 is up to date -- reinstalling
warning: texlive-pictures-2016.43767-1 is up to date -- reinstalling
warning: texlive-plainextra-2016.43137-1 is up to date -- reinstalling
warning: texlive-pstricks-2016.43710-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (15) texlive-bibtexextra-2016.43765-1  texlive-core-2016.43757-1.hyperbola2  texlive-fontsextra-2016.43763-1.hyperbola2
              texlive-formatsextra-2016.41438-3  texlive-games-2016.43415-1  texlive-genericextra-2016.43605-1
              texlive-htmlxml-2016.43769-1  texlive-humanities-2016.43711-1  texlive-latexextra-2016.43768-1.hyperbola2
              texlive-music-2016.43375-1  texlive-pictures-2016.43767-1  texlive-plainextra-2016.43137-1  texlive-pstricks-2016.43710-1
              texlive-publishers-2016.43764-1  texlive-science-2016.43747-1

Total Download Size:     27.66 MiB
Total Installed Size:  1300.90 MiB
Net Upgrade Size:       110.88 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 texlive-bibtexextra-2016.43765-1-any                   1541.4 KiB   275K/s 00:06 [###############################################] 100%
 texlive-games-2016.43415-1-any                          416.5 KiB   356K/s 00:01 [###############################################] 100%
 texlive-htmlxml-2016.43769-1-any                       1197.6 KiB   300K/s 00:04 [###############################################] 100%
 texlive-humanities-2016.43711-1-any                     299.0 KiB   664K/s 00:00 [###############################################] 100%
 texlive-music-2016.43375-1-any                           12.2 MiB   398K/s 00:31 [###############################################] 100%
 texlive-publishers-2016.43764-1-any                       9.2 MiB   471K/s 00:20 [###############################################] 100%
 texlive-science-2016.43747-1-any                          2.9 MiB   376K/s 00:08 [###############################################] 100%
(15/15) checking keys in keyring                                                  [###############################################] 100%
(15/15) checking package integrity                                                [###############################################] 100%
(15/15) loading package files                                                     [###############################################] 100%
(15/15) checking for file conflicts                                               [###############################################] 100%
(15/15) checking available disk space                                             [###############################################] 100%
:: Processing package changes...
( 1/15) reinstalling texlive-core                                                 [###############################################] 100%
>>> updmap custom entries should go into /etc/texmf/web2c/updmap-local.cfg
>>> fmtutil custom entries should go into /etc/texmf/web2c/fmtutil-local.cnf
( 2/15) installing texlive-bibtexextra                                            [###############################################] 100%
( 3/15) reinstalling texlive-fontsextra                                           [###############################################] 100%
( 4/15) reinstalling texlive-formatsextra                                         [###############################################] 100%
( 5/15) installing texlive-games                                                  [###############################################] 100%
( 6/15) reinstalling texlive-genericextra                                         [###############################################] 100%
( 7/15) installing texlive-htmlxml                                                [###############################################] 100%
( 8/15) reinstalling texlive-latexextra                                           [###############################################] 100%
( 9/15) installing texlive-humanities                                             [###############################################] 100%
Optional dependencies for texlive-humanities
    texlive-pictures: for package qtree [installed]
(10/15) installing texlive-music                                                  [###############################################] 100%
Optional dependencies for texlive-music
    python2: for scripts from the lilyglyphs packages [installed]
(11/15) reinstalling texlive-pictures                                             [###############################################] 100%
(12/15) reinstalling texlive-plainextra                                           [###############################################] 100%
(13/15) reinstalling texlive-pstricks                                             [###############################################] 100%
(14/15) installing texlive-publishers                                             [###############################################] 100%
(15/15) installing texlive-science                                                [###############################################] 100%
Optional dependencies for texlive-science
    python2-pygments: for pygmentex
:: Running post-transaction hooks...
(1/3) Updating TeXLive filename database...
(2/3) Updating TeXLive format files...

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf ecrm1000

! I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf ecrm1000

! I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.
fmtutil [ERROR]: running `pdftex -ini   -jobname=utf8mex -progname=utf8mex -enc *utf8mex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [WARNING]: inifile pdfmex.ini for pdfmex/pdftex not found.
fmtutil [ERROR]: running `pdftex -ini   -jobname=csplain -progname=csplain -etex -enc csplain-utf8.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfjadetex -progname=pdfjadetex *pdfjadetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=jadetex -progname=jadetex *jadetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [WARNING]: inifile mex.ini for mex/pdftex not found.
fmtutil [ERROR]: running `xetex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex csplain.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex -enc csplain-utf8.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `luatex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex csplain.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
error: command failed to execute correctly
(3/3) Updating TeXLive font maps...
[~]
a
PackagesTestingBug ReportMediumMedium[emacs] crush after swayResearching
0%
Task Description

I have installed Hyperbola on two laptops. And I have noticed that after running sway and exiting out of sway, GNU emacs crushers on console. It is easy to repeat it:

1. Run sway
2. Exit sway or killall sway
3. Try running emacs on console, there will be crush
4. log out, log in, and emacs will work on console again

Yet it should not crush.

PackagesAnySecurity IssueVery LowMediummount.davfs: unknown file system davfs due to paths cha...Unconfirmed
0%
Task Description

This is same issue as on:
https://bugzilla.redhat.com/show_bug.cgi?id=1151273

The paths changed and trying to mount davfs file system defined in /etc/fstab fails with error: unknown file system davfs

To remedy, I made symlink in /sbin to mount.davfs

The transition of paths had to take that in account as many mounted remote disks failed after upgrade.

PackagesAnyFreedom IssueMediumLow[ext3grep]: vague terminology "Content" in description ...Deferred
0%
Task Description

Description:

community/ext3grep 0.10.2-4
    A tool to investigate an ext3 file system for deleted content and possibly recover it

Description is vague because of the word “content”. Why not say instead “data”?

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFreedom IssueMediumLow[webfs]: vague terminology "Content" in description of ...Deferred
0%
Task Description

Description:

community/webfs 1.21-13
    Simple and instant http server for mostly static content.

Description is vague because of the word “content”. Why not simply say “files” instead and be more specific.

Even empty files without data inside can be served.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFreedom IssueMediumLow[openstreetmap-map-icons-svn]: using vague "public doma...Deferred
0%
Task Description

Description:

community/openstreetmap-map-icons-svn 31588-1 [installed]
    A set of public domain licensed map icons for general OSM use

It is questionable if it is “Licensed” or dedicated.

See the file:
/usr/share/licenses/openstreetmap-map-icons/svg-twotone/LICENSE.txt

it does not matter if the file is named “LICENSE”, it could be also named anyhow else.

There must be reason why the organization Creative Commons is not using the word “License” in that text, and that is why I propose to simply say in description:

    A set of public domain map icons for general OSM use
PackagesAnyFreedom IssueMediumLow[autoconf-archive]: using vague "freely" term in descr...Deferred
0%
Task Description
community/autoconf-archive 1:2017.03.21-1
    A collection of freely re-usable Autoconf macros

See:
https://www.gnu.org/philosophy/words-to-avoid.html#FreelyAvailable

Don’t use “freely available software” as a synonym for “free software.” The terms are not equivalent. Software is “freely available” if anyone can easily get a copy. “Free software” is defined in terms of the freedom of users that have a copy of it. These are answers to different questions.

PackagesAnyFreedom IssueMediumLow[python-biopython]: using vague "freely" term in descri...Deferred
0%
Task Description
community/python-biopython 1.69-1
    Freely available Python tools for computational molecular biology

See:
https://www.gnu.org/philosophy/words-to-avoid.html#FreelyAvailable

Don’t use “freely available software” as a synonym for “free software.” The terms are not equivalent. Software is “freely available” if anyone can easily get a copy. “Free software” is defined in terms of the freedom of users that have a copy of it. These are answers to different questions.

PackagesAnyFreedom IssueMediumLow[python2-biopython]: using vague "freely available" ter...Deferred
0%
Task Description
community/python2-biopython 1.69-1
    Freely available Python tools for computational molecular biology

See:
https://www.gnu.org/philosophy/words-to-avoid.html#FreelyAvailable

Don’t use “freely available software” as a synonym for “free software.” The terms are not equivalent. Software is “freely available” if anyone can easily get a copy. “Free software” is defined in terms of the freedom of users that have a copy of it. These are answers to different questions.

PackagesAnyFreedom IssueMediumLow [linux-atm]: using term "under Linux" in vague sense Closed
100%
Task Description
core/linux-atm 2.5.2-4
     Drivers and tools to support ATM networking under Linux.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

Let us not make it vague. If it refers to kernel, then let us say “Linux kernel”. If it refers to operating system, let us say so.

In general, packages referring to kernel as Linux which is correct, I am leaving alone and will not report it here. Only those referring to operating system name or when stated in vague manner.

PackagesAnyFreedom IssueMediumLow [man-pages]: using term "Linux" Closed
100%
Task Description
core/man-pages 4.11-1 (base)
     Linux man pages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

Instead I propose to say “Operating system manual pages”

PackagesAnyFreedom IssueMediumLow [net-tools]: using word "Linux" in vague manner Closed
100%
Task Description
core/net-tools 1.60.20160710git-1
     Configuration tools for Linux networking

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueMediumLow[man-pages-de]: using kernel name without operating sys...Deferred
0%
Task Description

Description:

community/man-pages-de 1.22-1
     German Linux man pages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueMediumLow[man-pages-ru]: using kernel name without operating sys...Deferred
0%
Task Description

Description:

community/man-pages-ru 4.08_2329_2272_20170321-2
     Russian Linux man pages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueMediumLow[man-pages-zh_cn]: using kernel name without operating ...Deferred
0%
Task Description

Description:

community/man-pages-zh_cn 1.6.3.1-1
     Simplified Chinese Linux man pages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueMediumLow[man-pages-zh_tw]: using kernel name without operating ...Deferred
0%
Task Description

Description:

community/man-pages-zh_tw 1.6.3.1-1
     Traditional Chinese Linux man pages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow Vague terminology "open source" in description of packa ...Closed
100%
Task Description

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

we shall avoid vague terminology such as “open source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “open source”.

That is why I propose for all the packages here listed to change the term in their descriptions from “open source” to free (libre) software.

core/openssl 1.1.0.e-1 [installed]
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
extra/aiksaurus 1.2.1-5
    A cross-platform, open-source thesaurus
extra/assimp 3.3.1-1
    Portable Open Source library to import various well-known 3D model formats in an uniform manner
extra/cmake 3.8.0-1 [installed]
    A cross-platform open-source make system
extra/gstreamer 1.12.0-1 [installed]
    GStreamer open-source multimedia framework core library
extra/java-openjfx 8.u121-1
    Java OpenJFX 8 client application platform (open-source implementation of JavaFX)
extra/java-openjfx-doc 8.u121-1
    Java OpenJFX 8 client application platform (open-source implementation of JavaFX) - documentation
extra/java-openjfx-src 8.u121-1
    Java OpenJFX 8 client application platform (open-source implementation of JavaFX) - sources
extra/java-rhino 1.7.7.1-1.hyperbola1
    Open-source implementation of JavaScript written entirely in Java - JAR
extra/kdegames-kigo 17.04.0-1 (kde-applications kdegames)
    An open-source implementation of the popular Go game
extra/libgdiplus 4.2-1 [installed]
    An Open Source Implementation of the GDI+ API
extra/libical 2.0.0-2
    An open source reference implementation of the icalendar data type and serialization format
extra/liblouis 3.0.0-2
    Open-source braille translator and back-translator
extra/libofa 0.9.3-6 [installed]
    An open-source audio fingerprint by MusicIP
extra/libomxil-bellagio 0.9.3-1 [installed]
    An opensource implementation of the OpenMAX Integration Layer API
extra/libupnp 1.6.21-1 [installed]
    Portable Open Source UPnP Development Kit
extra/mlt 6.4.1-6 [installed]
    An open source multimedia framework
extra/mlt-python-bindings 6.4.1-6 [installed]
    An open source multimedia framework
extra/opencore-amr 0.1.5-1 [installed]
    Open source implementation of the Adaptive Multi Rate (AMR) speech codec
extra/openjdk7-src 7.u131_2.6.9-1.hyperbola4
    OpenJDK Java 7 sources
extra/openjdk8-src 8.u121_3.3.0-1.hyperbola4
    OpenJDK Java 8 sources
extra/openjpeg 1.5.2-1 [installed]
    An open source JPEG 2000 codec
extra/openjpeg2 2.1.2-2 [installed]
    An open source JPEG 2000 codec, version 2.1.2
extra/openslp 2.0.0-2.hyperbola1
    Open-source implementation of Service Location Protocol, with OpenRC support
extra/openssl-1.0 1.0.2.k-3 [installed]
    The Open Source toolkit for Secure Sockets Layer and Transport Layer Security
extra/rhino 1.7.7.1-1
    Open-source implementation of JavaScript written entirely in Java
extra/rhino-javadoc 1.7.7.1-1.hyperbola1
    Open-source implementation of JavaScript written entirely in Java - Javadoc
extra/sofia-sip 1.12.11-3
    An open-source SIP User-Agent library
extra/swt 4.6.2-3
    An open source widget toolkit for Java
extra/tomcat7 7.0.76-1
    Open source implementation of the Java Servlet 3.0 and JavaServer Pages 2.2 technologies
extra/tomcat8 8.0.42-1
    Open source implementation of the Java Servlet 3.1 and JavaServer Pages 2.3 technologies
extra/unixodbc 2.3.4-2
    ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources
extra/wildmidi 0.4.0-1 [installed]
    Open Source MIDI Synthesizer
extra/x265 2.4-1 [installed]
    Open Source H265/HEVC video encoder
extra/xapian-core 1:1.4.2-1 [installed]
    Open source search engine library.
extra/xsd 4.0.0-2
    An open-source, cross-platform W3C XML Schema to C++ data binding compiler
extra/xvidcore 1.3.4-1 [installed]
    XviD is an open source MPEG-4 video codec
community/adobe-source-han-sans-cn-fonts 1.004-2
    Adobe Source Han Sans Subset OTF - Simplified Chinese OpenType/CFF fonts
community/adobe-source-han-sans-jp-fonts 1.004-2
    Adobe Source Han Sans Subset OTF - Japanese OpenType/CFF fonts
community/adobe-source-han-sans-kr-fonts 1.004-2
    Adobe Source Han Sans Subset OTF - Korean OpenType/CFF fonts
community/adobe-source-han-sans-otc-fonts 1.004-2
    Adobe Source Han Sans - Pan-CJK OpenType/CFF Collection fonts
community/adobe-source-han-sans-tw-fonts 1.004-2
    Adobe Source Han Sans Subset OTF - Traditional Chinese OpenType/CFF fonts
community/adobe-source-han-serif-cn-fonts 1.000-1
    Adobe Source Han Serif Subset OTF - Simplified Chinese OpenType/CFF fonts
community/adobe-source-han-serif-jp-fonts 1.000-1
    Adobe Source Han Serif Subset OTF - Japanese OpenType/CFF fonts
community/adobe-source-han-serif-kr-fonts 1.000-1
    Adobe Source Han Serif Subset OTF - Korean OpenType/CFF fonts
community/adobe-source-han-serif-otc-fonts 1.000-1
    Adobe Source Han Serif - Pan-CJK OpenType/CFF Collection fonts
community/adobe-source-han-serif-tw-fonts 1.000-1
    Adobe Source Han Serif Subset OTF - Traditional Chinese OpenType/CFF fonts
community/beignet 1.3.1-2
    An open source OpenCL implementation for Intel IvyBridge+ iGPUs
community/bzrtp 1.0.5-1
    Opensource implementation of ZRTP keys exchange protocol
community/cimg 1.7.1-1
    Open-source C++ toolkit for image processing
community/displaycal 3.2.4.0-1
    Open Source Display Calibration and Characterization powered by Argyll CMS (Formerly known as dispcalGUI)
community/dokuwiki 20170219_b-1
    Simple to use and highly versatile Open Source wiki software
community/dsdp 5.8-1
    A free open source implementation of an interior-point method for semidefinite programming
community/dspam 3.10.2-14
    A scalable, open-source statistical anti-spam filter
community/fcitx-mozc 2.20.2673.102-2
    Fcitx Module of A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)
community/flightgear 2017.1.3-1
    An open-source, multi-platform flight simulator
community/flightgear-data 2017.1.3-1
    Base-Data for the opensource flight-simulator.
community/freehdl 0.0.8-8
    An open-source (C++ generating) VHDL simulator
community/freevo 1.9.0-14
    An open-source home theatre PC platform
community/gerbv 2.6.1-4
    An open source Gerber file (RS-274X only) viewer
community/glfw-wayland 3.2.1-1
    A free, open source, portable framework for graphical application development (wayland)
community/glfw-x11 3.2.1-1
    A free, open source, portable framework for graphical application development (x11)
community/goaccess 1.2-1
    An open source real-time web log analyzer and interactive viewer
community/gocr 0.50-2
    Open-source character recognition (OCR)
community/hyperion 1.03.2-9
    An opensource 'AmbiLight' implementation
community/inn 2.6.1-1
    Complete open source Usenet system. De facto standard for handling news routing, news spool and serving the spool to customers.
community/irrlicht 1.8.4-1
    An open source high performance realtime 3D graphics engine.
community/irrlicht-docs 1.8.4-1
    An open source high performance realtime 3D graphics engine.
community/languagetool 3.7-1
    An open source language checker
community/libasl 0.1.7-3
    Free and open source hardware accelerated multiphysics simulation platform (Advanced Simulation Library)
community/libdlna 0.2.4-16
    Open-source implementation of DLNA (Digital Living Network Alliance) standards
community/libnoise 1.0.0-4
    A portable, open-source, coherent noise-generating library for C++
community/libopenshot 0.1.4-1 [installed]
    A high quality, open-source video editing, animation, and playback library for C++, Python, and Ruby.
community/love 0.10.2-1
    An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences
community/love08 0.8.0-2
    An open-source 2D game engine which uses the versatile Lua scripting language to create dynamic gaming experiences
community/luminancehdr 2.5.0-2
    Open source graphical user interface application that aims to provide a workflow for HDR imaging
community/lxlauncher 0.2.5-2 (lxde)
    Open source clone of the Asus launcher for EeePC
community/lxlauncher-gtk3 0.2.5-2 (lxde-gtk3)
    Open source clone of the Asus launcher for EeePC (GTK+ 3 version)
community/manaplus 1.7.4.15-1
    Free OpenSource 2D MMORPG client for Evol Online, The mana world and similar servers
community/mathjax 2.7.1-1
    An open source JavaScript display engine for mathematics that works in all modern browsers
community/mediaproxy 2.6.1-2
    Open-source media proxy for OpenSER
community/metasploit 4.13.22-1
    Advanced open-source platform for developing, testing, and using exploit code
community/mixxx 2.0.0-8
    Free, open source software for digital DJ'ing.
community/mongodb 3.4.3-1
    A high-performance, open source, schema-free document-oriented database
community/mosquitto 1.4.11-5
    An Open Source MQTT v3.1/v3.1.1 Broker
community/obs-studio 18.0.2-1
    Free, open source software for live streaming and recording
community/ode 0.14-1
    An open source, high performance library for simulating rigid body dynamics
community/opendkim 2.10.3-4
    An open source implementation of the DKIM sender authentication system. Based on a fork of dkim-milter.
community/opendmarc 1.3.2-1
    Free open source software implementation of the DMARC specification
community/openra 20170421-1
    An open-source implementation of the Red Alert engine using .NET/Mono and OpenGL
community/openscenegraph 3.4.0-5
    An Open Source, high performance real-time graphics toolkit
community/opensips 2.2.3-1
    An Open Source SIP Server able to act as a SIP proxy, registrar, location server, redirect server ...
community/opensubdiv 3.1.1-1 [installed]
    An Open-Source subdivision surface library
community/pdfsam 3.3.0-1
    A free open source tool to split and merge pdf documents
community/pokerth 1.1.1-17
    Open source Texas Hold'em Poker simulator
community/polymake 3.1-1
    Open source software for research in polyhedral geometry
community/portaudio 190600_20161030-1 [installed]
    A free, cross-platform, open source, audio I/O library.
community/pymol 1.8.6.0-2
    Molecular visualization system on an Open Source foundation
community/python-scipy 0.19.0-1
    SciPy is open-source software for mathematics, science, and engineering.
community/python-tornado 4.5.1-1
    open source version of the scalable, non-blocking web server and tools
community/python2-scipy 0.19.0-1
    SciPy is open-source software for mathematics, science, and engineering.
community/python2-tornado 4.5.1-1
    open source version of the scalable, non-blocking web server and tools
community/radare2 1.4.0-1
    Open-source tools to disasm, debug, analyze and manipulate binary files
community/rdesktop 1.8.3-3
    An open source client for Windows Remote Desktop Services
community/repo 1.12.37-1
    The Multiple Git Repository Tool from the Android Open Source Project
community/simgear 2017.1.3-1
    A set of open-source libraries designed to be used as building blocks for quickly assembling 3d simulations, games, and visualization applications.
community/slrn 1.0.3-2
    An open source text-based news client
community/stone-soup 0.19.5-1
    Open-source, single-player, role-playing roguelike game of exploration and treasure-hunting
community/sysdig 0.15.1-2
    Open source system-level exploration and troubleshooting tool
community/tkabber 1.1.2-1
    Tkabber is an open source Jabber client, written in Tcl/Tk.
community/topbeat 1.3.1-1
    Open source server monitoring agent that stores metrics in Elasticsearch
community/ttf-overpass 2.1-2
    An open source font family inspired by Highway Gothic esp. suited for signs, lettering and web sites
community/unrealircd 4.0.11-2
    Open Source IRC Server
community/wiredtiger 2.9.1-1
    High performance, scalable, production quality, NoSQL, Open Source extensible platform for data management
community/xwax 1.6-1
    Open-source vinyl emulation software for Linux.
community/zynaddsubfx 3.0.1-1
    Opensource software synthesizer capable of making a countless number of instruments.
PackagesAnyFreedom IssueVery LowLow[texmacs] ERROR: Unbound variable: eval-when, and not s...Unconfirmed
0%
Task Description
texmacs 
ERROR: Unbound variable: eval-when

it cannot start

InstallationGeneralImplementation RequestVery LowLowTo make installation instructions and get use of live I...Unconfirmed
0%
Task Description

I have installed multiple times Hyperbola, 4 times on 4 different notebooks.

What I have noticed is that the live ISO is quite huge in relation to the task that should be done. Namely. the live ISO shall at least contain some first packages, so that they do not need to be downloaded online.

Best would be if the live ISO can be copied straight and that system can run from ISO/DVD without having Internet. At least one simple graphical environment shall be included.

Further, I have noticed that there is only network instructions as HTML file.

I would rather call it installation-instructions.html to make it clear for people what it is. Or simply: INSTALL.html so that people understand what it is.

It says just network.html if I remember well.

Then there is absolutely no point or link or reference to the installation instructions.

Each time I got a network I had to go to either duckduckgo search engine or to hyperbola.info website and then I tried with lynx to find installation instructions.

It is not straight, not quite clearly in open, it is in Wiki, but that is quite hard to find.

We have to put ourselves in the shoes of those in need of free software. Millions of people need free software.

Many of us live in a developed western countries.

Yet millions of people in need of this software live in South America, Africa, Asia, Eastern Europe.

There are millions of students that could advance their study, and that could progress faster with free software.

In those countries Internet is often non-existent, universities may be located in poor network areas, Internet is being fetched by using mobile phones.

So if there is a live distribution, such shall at least contain basic software, which really can fit onto any DVD, and that as such can be copied on the computer without using Internet. Upgrades could be fetched by using Internet.

And there shall be clear reference, link or file about installation. There shall be no need to go to Internet to install the software.

PackagesAnyBug ReportVery LowLow[gimp] [gegl] Module '/usr/lib/gegl-0.3/lens-correct.so...Assigned
0%
Task Description

admin→ gimp IMG_20170909_153350828.jpg
GEGL-Message: Module ‘/usr/lib/gegl-0.3/lens-correct.so’ load error: liblensfun.so.1: cannot open shared object file: No such file or directory
GEGL-Message: Module ‘/usr/lib/gegl-0.3/matting-levin.so’ load error: libumfpack.so.5: cannot open shared object file: No such file or directory

(gimp:12519): GLib-GObject-WARNING **: g_object_set_valist: object class ‘GeglConfig’ has no property named ‘cache-size’

Those are errors I get when running Gimp.

PackagesAnyFreedom IssueVery LowLow[freecad] Steering users towards non-free softwareUnconfirmed
0%
Task Description

Description: FreeCAD may be free software, yet its features are steering users towards non-free software. It is asking for Teigha File Converter which is proprietary software, and it is asking for the path in order to enable the option import/export.

Additional info:

* package version: community/freecad 0.16-9

Steps to reproduce:

After attempt to open the DWF/DXF file FreeCad is to request the Teigha File Converter which is proprietary software.

Under the menu Edit → Preferences → Import/Export → DWG, one can see the request to enter the path to Teigha File Converter.

Teigha File Converter with proprietary license

FreeCAD requesting the path to Teigha File Converter

PackagesAnyFreedom IssueVery LowLow[libspnav] extra/libspnav 0.2.3-1, mentions "alternativ...Unconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

extra/libspnav 0.2.3-1 [installed]
    Alternative to the proprietary 3Dconnexion device driver and SDK for their 3D input devices

PackagesAnyFreedom IssueVery LowLow[classpath] meantioning "replacement to proprietary cod...Unconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

community/classpath 0.99-3
    A free replacement for Sun's proprietary core Java class libraries.

My suggestion is to describe what software does, and to remove that it is free replacement for proprietary code, as it gives some kind of legitimacy to proprietary software.

PackagesAnyFreedom IssueVery LowLow[mp3wrap] mentioning in description to be "alternative"...Unconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

extra/mp3wrap 0.5-4
     Tool for wrapping mp3 files. A free independent alternative to AlbumWrap

Description is pointing to proprietary software, it should not, it shall be changed.

It is not alternative to proprietary, and description shall be changed. It gives some kind of legitimacy to proprietary software.

PackagesAnyFreedom IssueVery LowLow[pinta] mentioning proprietary software Paint.NETUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

community/pinta 1.6-2 [installed]
     Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users

I am not quite sure what the policy is in Hyperbola on this one. I am referring to the reference to the proprietary software Paint.NET. That is for me steering users to verify what is Paint.NET – we shall not be doing it. It should be removed from description.

I am fine if authors have in documentation something explaining how they started software project. But I am not fine in descriptions which are public and accessible on Internet to have such references to illegitimate proprietary software.

Just to clarify, the word “alternative” is just fine in this description and need not be removed.

PackagesAnyFreedom IssueVery LowLow[breeze]: referring to assets in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

extra/breeze 5.9.5-1 (plasma)
    Artwork, styles and assets for the Breeze visual style for the Plasma Desktop
PackagesAnyFreedom IssueVery LowLow[knewstuff]: referring to assets in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

extra/knewstuff 5.33.0-1 (kf5)
    Support for downloading application assets from the network

PackagesAnyFreedom IssueVery LowLow[kpackage]: referring to assets in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

extra/kpackage 5.33.0-1 (kf5)
    Framework that lets applications manage user installable packages of non-binary assets

PackagesAnyFreedom IssueVery LowLow[openmw]: referring to assets in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

community/openmw 0.41.0-3.hyperbola1
    A libre engine reimplementation for Morrowind-based role-playing games, without wizard installation support to install nonfree assets from Morrowind to run Morrowind
PackagesAnyFreedom IssueVery LowLow[retroarch-assets-xmb]: referring to assets in descript...Unconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

community/retroarch-assets-xmb 401-1 (libretro)
    XMB menu assets for RetroArch

Why not use “elements” instead?

PackagesAnyFreedom IssueVery LowLow[warsow-data]: referring to assets in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

community/warsow-data 2.1.2-1.hyperbola2
    Free online multiplayer competitive FPS based on the Qfusion engine (data files), without nonfree assets

PackagesAnyFreedom IssueVery LowLow[libsmf]: referring to "BSD-licensed" in descriptionUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

The expression “BSD-style license” leads to confusion because it lumps together licenses that have important differences. For instance, the original BSD license with the advertising clause is incompatible with the GNU General Public License, but the revised BSD license is compatible with the GPL.

To avoid confusion, it is best to name the specific license in question and avoid the vague term “BSD-style.”

community/libsmf 1.3-5
    A BSD-licensed C library for handling SMF ("*.mid") files.
PackagesAnyFreedom IssueVery LowLow[gfbgraph]: using exclusively proprietary networkUnconfirmed
0%
Task Description
extra/gfbgraph 0.2.3+10+gbc03c1f-1
    GLib/GObject wrapper for the Facebook Graph API

In my opinion this software is for exclusive use of proprietary network. This software shall be removed from Hyperbola.

PackagesAnyFreedom IssueVery LowLow[kaccounts-integration]: to reconsider mentioning or di...Unconfirmed
0%
Task Description

Description:

In my opinion, this software shall be either removed, or features disabled to access either Google or Facebook, as those are proprietary networks.

Further, using those proprietary networks is steering users towards non-free software, directly, or indirectly, as many times Javascript need to be handled that is proprietary.

extra/kaccounts-integration 17.04.0-1 (kde-applications kdenetwork)
    Small system to administer web accounts for the sites and services across the KDE desktop, including: Google, Facebook, Owncloud, IMAP, Jabber and others

See:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

A free system distribution must not steer users towards obtaining any nonfree information for practical use, or encourage them to do so.

Showing tasks 1 - 50 of 146 Page 1 of 31 - 2 - 3 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing