All Projects

ProjectCategoryTask TypePrioritySeveritySummaryStatusProgress
PackagesStableSecurity IssueVery HighCritical [iceweasel-uxp] Issue with HTTPS websites Closed
100%
Task Description

With latest iceweasel-uxp, I can’t connect to some HTTPS websites :

For example :

https://pkgs.fedoraproject.org/ is an example

SEC_ERROR_UNKNOWN_ISSUER

PackagesStableBug ReportVery HighCritical [iceweasel-uxp] Broken addons with latest update Closed
100%
Task Description

Some addons are currently broken with latest iceweasel-uxp (iceweasel-uxp 52.9.20190926-1)

DownThemAll
Save to Wayback Machine
Self-Destructing Cookies
(and probably others)

g4jc suggested to drop PGO as it could be the culprit.

https://forums.hyperbola.info/viewtopic.php?pid=1149#p1149

Regarding addons, I'm fairly certain flipping the switch on PGO (which makes the browser faster at the expense of wrecking code) is the culprit. We were warned not to use it, and this is planned to be rolled back.

However, Hyperbot has to be scheduled to rebuild the packages and I do not set it's schedule. Will advise.
PackagesStableBug ReportHighCritical [vhba-module-lts] modprobe: ERROR: could not insert 'vh ...Closed
100%
Task Description
filename:       /lib/modules/4.9.77-gnu-1-lts/extramodules/vhba.ko
license:        GPL
description:    Virtual SCSI HBA
version:        20161009
author:         Chia-I Wu
srcversion:     E5A3E6F70DFD436A6B1C8D6
depends:        scsi_mod
vermagic:       4.9.27-gnu-1-lts SMP mod_unload modversions

Can’t insert module vhba

Error :

modprobe: ERROR: could not insert ‘vhba’: Exec format error

PackagesStableBug ReportHighCritical [alsa-tools] create missing firmware folder since firmw ...Closed
100%
Task Description

### Some context ###

I use hdajackretask on my G41M-ES2L motherboard (Libreboot)

Alsamixer doesn’t offer automute feature so every time I plug my headphones, the sound is playing by my speakers.
So to work around this, I use hdajackretask from alsa-tools package.

It allows to install a boot override to solve the issue.

Yesterday, I reinstalled Hyperbola on my system and the boot override because of missing /lib/firmware directory. (Although it was present before, something changed ?)

The error message was (I translate)

/mv: can't move '/tmp/hda-jack-retask-VH3KIZ/hda-jack-retask.fw' to /lib/firmware/hda-jack-retask.fw' No file or folder of this type

So I created a folder “firmware” in /lib/
and copied hda-jack-retask.fw in it.

Then I rebooted, 100% working.

I don’t know if the fix should apply to the PKGBUILD of alsa-tools (to create a /lib/firmware directory) or something else ?

PackagesAnySecurity IssueHighCritical [octopi] uploads system logs to ptpb.pw without confirm ...Closed
100%
Task Description

Octopi 0.9.0 is uploading system logs to ptpb.pw without confirmation through :

Tools
→ SysInfo → ptpb.pw

I think it should be either disabled or add at least a patch to ask for a confirmation.
An other way could be to patch this :

src/globals.cpp
240: * Generates SysInfo file and paste it to ptpb site
255:  QString ptpb = UnixCommand::getCommandOutput("curl -F c=@- https://ptpb.pw/?u=1", tempFile->fileName());
256:  return ptpb;

to :

src/globals.cpp
240: * Generates SysInfo file and paste it to ptpb site
255:  QString ptpb = UnixCommand::getCommandOutput("curl -F c=@- **https://ptpb.pw/", tempFile->fileName());
256:  return ptpb;

This way, you can at least ask for log deletion with the help of log uuid as explained here : https://ptpb.pw/#id10

PackagesStableBug ReportHighCritical  [gufw] FileNotFoundError: [Errno 2] '/usr/sbin/ufw': ' ...Closed
100%
Task Description

gufw 17.04.1-3

Impossible to start application, error message :

FileNotFoundError: [Errno 2] Aucun fichier ou dossier de ce type: '/usr/sbin/ufw': '/usr/sbin/ufw'
PackagesTestingBug ReportMediumCritical [iceweasel-uxp-ublock-origin] Can't add filters and/or  ...Closed
100%
Task Description

I can’t update filters or update with iceweasel-uxp-ublock-origin.
When I toggle the additional filters list, it is empty.

PackagesStableBug ReportMediumCritical [mkinitcpio] crc32c_generic module missing with regular ...Closed
100%
Task Description

With latest 0.3 hyperbola, with the (simple) following partitioning :

/ (ext4)
/swap

The standard HOOK in /etc/mkinitcpio.conf

"HOOKS="base udev autodetect modconf block filesystems keyboard fsck"

fails to include crc32c_generic module, resulting in non bootable system.

The generated fallback initramfs include it though.

The issue was not present with 0.2.9, with the exact same partitioning.

PackagesStableBug ReportMediumCritical [virt-manager] Failed to initialize a valid firewall ba ...Closed
100%
Task Description

[virt-manager] Failed to initialize a valid firewall backend

I cannot start any virtual machine with current virt-manager.
The error message is the following :

Failed to initialize a valid firewall backend

My username is in “kvm” group.

The only modification to the libvirt config files I made are in /etc/libvirt/qemu.conf

[...]
# Some examples of valid values are:
#
#       user = "qemu"   # A user named "qemu"
#       user = "+0"     # Super user (uid=0)
#       user = "100"    # A user named "100" or a user with uid=100
# 
#user = "root"
user = "david"
[...]

The libvirtd service is enabled (and start without error)
Also, the optional dependencies are correctly installed :

ebtables: required for default NAT networking [installed]
dnsmasq: required for default NAT/DHCP for guests [installed]
bridge-utils: for bridged networking [installed]

This was working fine previously (with 0.2.9) so I don’t know why this isn’t working anymore. As said previously, my config hasn’t changed.

PackagesStableBug ReportMediumCritical [v4l-utils] Error in `dvbv5-scan': double free or corru ...Closed
100%
Task Description

With : v4l-utils 1.12.3-1.hyperbola1

dvb5-scan utility currently segfaults with rtl2832

*** Error in `dvbv5-scan': double free or corruption (fasttop): 0x000000000090be90 ***
======= Backtrace: =========
/lib/libc.so.6(+0x727ad)[0x7f4f9a9657ad]
/lib/libc.so.6(+0x78e6f)[0x7f4f9a96be6f]
/lib/libc.so.6(+0x796ce)[0x7f4f9a96c6ce]
/usr/lib/libdvbv5.so.0(free_dvb_dev+0x13)[0x7f4f9acafa53]
/usr/lib/libdvbv5.so.0(dvb_dev_free_devices+0x28)[0x7f4f9acafaf8]
/usr/lib/libdvbv5.so.0(dvb_dev_free+0x4e)[0x7f4f9acafe2e]
dvbv5-scan[0x401729]
/lib/libc.so.6(__libc_start_main+0xf1)[0x7f4f9a9135a1]
dvbv5-scan[0x4019fa]

This seems to have been fixed, see :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=859008

I don’t know if a patch is available for it though..

PackagesStableBug ReportMediumCritical [lynis] Unable to run audit on remote target because of ...Closed
100%
Task Description

With lynis 2.4.8-1.hyperbola2

sudo lynis audit system remote 192.168.0.100

fails because dmidecode is not installed to /usr/sbin/ :

/usr/share/lynis/include/functions: line 1359: /usr/sbin/dmidecode: No such file or directory

With hyperbola 0.3 :

which dmidecode
/usr/bin/dmidecode
PackagesStableBug ReportMediumCritical[torsocks] which: no getcapRequires Testing
90%
Task Description

Current torsocks version is broken.
It returns the following error when attempting to torify application :

which: no getcap
PackagesTestingBug ReportVery LowCritical [iceweasel-uxp] missing extensions Closed
100%
Task Description

Hello,

I can’t manually install some extensions I was using successfully with iceweasel-esr (52.9.x) previously.
Notably :

https-everywhere https://addons.mozilla.org/en-US/firefox/addon/https-everywhere/ watch-with-mpv https://addons.mozilla.org/en-US/firefox/addon/watch-with-mpv/ tampermonkey https://addons.mozilla.org/en-US/firefox/addon/tampermonkey/ Save URL to Wayback Machine https://addons.mozilla.org/en-US/firefox/addon/save-url-to-wayback-machine

How to install them with iceweasel-uxp ?

PackagesStableBug ReportVery LowCritical [hypervideo] YouTube's DRM has prevented this software  ...Closed
100%
Task Description

With the recent update to hypervideo, my workflow is broken as I can’t archive several youtube channels with hypervideo, the error is always the following :

WARNING: unable to extract html5 player; please report this issue on https://issues.hyperbola.info/ . Make sure you are using the latest version; type 'pacman -Sy hypervideo' as root. Be sure to call hypervideo with the --verbose flag and include its complete output.
[youtube] {22} signature length 44.40, html5 player None
ERROR: Signature extraction failed: Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1194, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1127, in _extract_signature_function
    raise ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL", expected=True)
hypervideo.utils.ExtractorError: YouTube's DRM has prevented this software from obtaining the video URL
 (caused by ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL",)); please report this issue on https://issues.hyperbola.info/ . Make sure you are using the latest version; type 'pacman -Sy hypervideo' as root. Be sure to call hypervideo with the --verbose flag and include its complete output.
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1194, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1127, in _extract_signature_function
    raise ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL", expected=True)
hypervideo.utils.ExtractorError: YouTube's DRM has prevented this software from obtaining the video URL
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1194, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1127, in _extract_signature_function
    raise ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL", expected=True)
hypervideo.utils.ExtractorError: YouTube's DRM has prevented this software from obtaining the video URL

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/hypervideo/YoutubeDL.py", line 792, in extract_info
    ie_result = ie.extract(url)
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/common.py", line 508, in extract
    ie_result = self._real_extract(url)
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1806, in _real_extract
    encrypted_sig, video_id, player_url, age_gate)
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1204, in _decrypt_signature
    'Signature extraction failed: ' + tb, cause=e)
hypervideo.utils.ExtractorError: Signature extraction failed: Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1194, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.6/site-packages/hypervideo/extractor/youtube.py", line 1127, in _extract_signature_function
    raise ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL", expected=True)
hypervideo.utils.ExtractorError: YouTube's DRM has prevented this software from obtaining the video URL
 (caused by ExtractorError("YouTube's DRM has prevented this software from obtaining the video URL",)); please report this issue on https://issues.hyperbola.info/ . Make sure you are using the latest version; type 'pacman -Sy hypervideo' as root. Be sure to call hypervideo with the --verbose flag and include its complete output.
PackagesStableBug ReportVery LowCritical [python2-reportlab] python2-pip dependency Closed
100%
Task Description

Since python-pip and python2-pip have been removed, I can’t install python2-reportlab because python2-pip is a dependency of this package.
.

PackagesAnyBug ReportVery LowCritical[system-config-printer] Impossible to print some pdfs (...Assigned
0%
Task Description

Hello,

I’m unable to print some pdfs on my Hyperbola 3.0 system.
Some background :

cups is installed, service enabled and working
system-config-printer is installed and my printer has been correctly added.

I can print most pdfs and text files but recently with a pdf, it fails to print it.* And system-config-printer returned the following error (see capture) :

Printer "EPSON XP-620-Series" requires the '/usr/lib/cups/filters/epson-escpr-wrapper' but it is not currently installed.

Currently, “epson-escpr-wrapper” is installed but it is in :

/usr/libexec/cups/filters/epson-escpr-wrapper

Looking at source code of system-config-printer, it expects that wrapper to be installed in “/usr/lib/” so I tried to symlink that “epson-escpr-wrapper” to “/usr/lib/cups/filters” but it doesn’t work..

*With a Debian system and the exact same configuration, the “problematic” pdf prints just fine so it is not an issue with the pdf.

PackagesStableBug ReportVery LowCritical[smartmontools] update-smart-drivedb fails to updateRequires Testing
100%
Task Description

smartmontools 6.5-1.hyperbola1

Error while trying to update smart-drivedb :

anon@test[~] update-smart-drivedb

External Link/usr/bin/update-smart-drivedb: download from branches/RELEASE_6_5_DRIVEDB failed (curl: exit 23) /usr/bin/update-smart-drivedb: download from trunk failed (curl: exit 23)

PackagesStableSecurity IssueVery LowCritical[lts-kernel][sec] filter /dev/mem access & restrict acc...Unconfirmed
0%
Task Description

These two options could be enabled :

Kernel hacking → [*] Filter access to /dev/mem
[*] Filter I/O access to /dev/mem

Security options → [*] Restrict unprivileged access to the kernel syslog

PackagesAnyFeature RequestHighHigh [icedove-enigmail] add package Closed
100%
Task Description

Hello,

Would it be possible to add this package :

icedove-enigmail

to the repo ?

Thank you

PackagesStableBug ReportHighHigh [elogind] /usr/lib/udev/rules.d/73-seat-late.rules not  ...Closed
100%
Task Description

dmesg was showing errors about this
Apparently it is not needed and can be deleted. (No errors on my side after deletion (and reboot) and no more errors message)

See this thread : https://forum.manjaro.org/t/openrc-and-73-seat-late-rules-why-deleting-it-was-a-good-thing/24599

PackagesStableBug ReportHighHigh [qemu] add missing libseccomp dependency Closed
100%
Task Description

I cannot start qemu (2.9.0-1) on latest hyperbola stable release.

Error message : qemu-system-x86_64: error while loading shared libraries: libseccomp.so.2

Thanks for your help

PackagesAnyBug ReportHighHigh [gnome-disk-utility] error while loading shared librari ...Closed
100%
Task Description

gnome-disks doesn’t start, error :

gnome-disks: error while loading shared libraries: libsystemd.so.0: cannot open shared object file: No such file or directory

Thanks for your help

PackagesStableBug ReportHighHigh [opencollada][openimageio][openshadinglanguage][ptex] s ...Closed
100%
Task Description

Hello,

I can’t install blender.

Error message :

erreur : opencollada: signature from "Márcio Silva <coadde@hyperbola.info>" is invalid
:: Le fichier /var/cache/pacman/pkg/opencollada-1.6.45-1.hyperbola1-x86_64.pkg.tar.xz est corrompu (paquet invalide ou corrompu (signature PGP)).
Voulez-vous le supprimer ? [O/n] n
erreur : ptex: signature from "Márcio Silva <coadde@hyperbola.info>" is invalid
:: Le fichier /var/cache/pacman/pkg/ptex-2.1.28-1.hyperbola1-x86_64.pkg.tar.xz est corrompu (paquet invalide ou corrompu (signature PGP)).
Voulez-vous le supprimer ? [O/n] n
erreur : openimageio: signature from "Márcio Silva <coadde@hyperbola.info>" is invalid
:: Le fichier /var/cache/pacman/pkg/openimageio-1.6.18-1.hyperbola1-x86_64.pkg.tar.xz est corrompu (paquet invalide ou corrompu (signature PGP)).
Voulez-vous le supprimer ? [O/n] n
erreur : openshadinglanguage: signature from "Márcio Silva <coadde@hyperbola.info>" is invalid

Already tried to refresh hyperbola keyring with :

pacman-key --populate hyperbola
pacman-key --refresh-keys
pacman -Sy hyperbola-keyring

Thanks for your help

PackagesAnyBug ReportHighHigh [lightdm] is running under foreground mode and causing  ...Closed
100%
Task Description

Since latest update, many of my service do not start automatically. (I can start them manually though)
This cause multiple errors at shutdown as well.

 udev                                                                                          [  started  ]
 localmount                                                                                    [  started  ]
 dbus                                                                                          [  started  ]
 elogind                                                                                       [  started  ]
 NetworkManager                                                                                [  started  ]
 syslog-ng                                                                                     [  started  ]
 acpid                                                                                         [  started  ]
 dhcpcd                                                                                        [  started  ]
 avahi-daemon                                                                                  [  started  ]
 netmount                                                                                      [  started  ]
 lightdm                                                                                       [ starting  ]
 alsasound                                                                                     [  stopped  ]
 avahi-dnsconfd                                                                                [  stopped  ]
 cronie                                                                                        [  stopped  ]
 cupsd                                                                                         [  stopped  ]
 fuse                                                                                          [  stopped  ]
 ntpd                                                                                          [  stopped  ]
 libvirtd                                                                                      [  stopped  ]
 openrc-settingsd                                                                              [  stopped  ]
 sshd                                                                                          [  stopped  ]
 thinkfan                                                                                      [  stopped  ]
 local                                                                                         [  stopped  ]
 agetty.tty5                                                                                   [  stopped  ]
 agetty.tty3                                                                                   [  stopped  ]
 agetty.tty6                                                                                   [  stopped  ]
 agetty.tty4                                                                                   [  stopped  ]
 agetty.tty2                                                                                   [  stopped  ]
 agetty.tty1                                                                                   [  stopped  ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
 modules-load                                                                                  [  started  ]
 lvmetad                                                                                       [  started  ]

Before dbus update, everything was working fine.

Thanks for your help

PackagesAnyImplementation RequestHighHigh [dhcpcd-ui] add package Closed
100%
Task Description

Please add dhcpcd-ui, it is very nice replacement to networkmanager (and network-manager-applet). It works fine combined with wpa_supplicant for wireless networks.

“dhcpcd Monitor in GTK+”

License : BSD

https://roy.marples.name/projects/dhcpcd-ui

https://aur.archlinux.org/packages/dhcpcd-ui/

PackagesStableBug ReportMediumHigh [lightdm-gtk-greeter-settings] pam_authenticate failed: ...Closed
100%
Task Description

Hello,

When running lightdm-gtk-greeter-settings-pkexec as user.

lightdm-gtk-greeter-settings-pkexec 
==== AUTHENTICATING FOR com.ubuntu.pkexec.lightdm-gtk-greeter-settings ===
Authentication is required to run Settings editor for LightDM GTK+ Greeter
Authenticating as: root
polkit-agent-helper-1: pam_authenticate failed: Permission denied
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

Am I missing something ? Thanks for your help

groups for my username : sys disk wheel network video audio optical storage libvirt kvm users

PackagesStableBug ReportMediumHigh [gparted] gparted_polkit doesn't work Closed
100%
Task Description

Hello,

gparted_polkit doesn’t work, error message (polkit is installed on my system)

Error executing command as another user: No authentication agent found.

If using :

sudo gparted

or

gksu gparted

It works. By default with xfce, the gparted launcher uses gparted_polkit though.

Thanks for your help

PackagesTestingBug ReportVery LowHigh [iceweasel-uxp] recaptcha issue (webchat.freenode.net) Closed
100%
Task Description

recaptcha is not working on webchat.freenode.net (and probably other websites) with iceweasel-uxp (was working fine with iceweasel-esr)

https://framapic.org/ZdvYH2JCM39J/HFDSI7z0hXvS.png

PackagesStableBug ReportVery LowHigh [lm_sensors] Fail to load it87 module at boot Closed
100%
Task Description

Description:

I ran sensors-detect, it detected two modules :

coretemp
it87

Those have been added to /etc/sysconfig/lm_sensors :

# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

HWMON_MODULES="coretemp it87"

But only coretemp is loaded at boot.

I can manually load it87 module (modprobe it87) and get all sensors working but for some reason it87 module is not loaded at boot.

PackagesStableBug ReportVery LowHigh[vlc] DVB : cache_block stream error: cannot pre fill b...Unconfirmed
0%
Task Description

Current VLC version (3.0.4-3.hyperbola1.backports1) fails to play DVB stream using a RTL2832 usb dongle.

I start the playlist like this :

vlc channels.conf

but it returns the following error :

cache_block stream error: cannot pre fill buffer

Also, it asks the user to be in “video” group to access DVB device, this was not needed before with Hyperbola 0.2.9. User being in “wheel” was enough.
Anyway, even after adding my user to video group, it still fails with “cache_block stream error: cannot pre fill buffer”

This is not an issue with my DVB adapter or driver. rtl2832 is correctly loaded. And I can play the channels.conf playlist just fine with “mpv” or “mplayer”.
Also, the channels.conf used works just fine with a more recent version of VLC on an other system (Manjaro) so something is broken with the current VLC used.

Maybe a package bump would fix the issue.

PackagesAnyUpdate RequestVery LowHigh[mpv] request for package bumpUnconfirmed
0%
Task Description

Hello,

Would it be possible to get a package bump for mpv ?

Currently, Debian Buster (stable) uses 0.29.1-1. This would be great as it introduces many fixes and support for lua scripts I heavily use.
0.29.* requires a ffmpeg to 4.x series as well.

Thanks.

PackagesAnyFeature RequestMediumMedium [create_ap] needs OpenRC init script Closed
100%
Task Description
pacman -Si

Dépôt                    : community
Nom                      : create_ap
Version                  : 0.4.6-1
Description              : A shell script to create a NATed/Bridged Software Access Point
Architecture             : any
URL                      : https://github.com/oblique/create_ap
Licences                 : BSD
Groupes                  : --
Fournit                  : --
Dépend de                : bash  hostapd  iproute2  iw  dnsmasq  iptables  util-linux  procps-ng
Dépendances opt.         : haveged: boost low entropy
Est en conflit avec      : --
Remplace                 : --
Taille du téléchargement : 17,61 KiB
Taille installée         : 63,00 KiB
Paqueteur                : NicoHood <nicohood@archlinux.org>
Compilé le               : sam. 11 févr. 2017 10:53:08 CET
Validé par               : Somme MD5  Somme SHA-256  Signature
pacman -Ql

create_ap /etc/
create_ap /etc/create_ap.conf
create_ap /usr/
create_ap /usr/bin/
create_ap /usr/bin/create_ap
create_ap /usr/lib/
create_ap /usr/lib/systemd/
create_ap /usr/lib/systemd/system/
create_ap /usr/lib/systemd/system/create_ap.service
create_ap /usr/share/
create_ap /usr/share/bash-completion/
create_ap /usr/share/bash-completion/completions/
create_ap /usr/share/bash-completion/completions/create_ap
create_ap /usr/share/doc/
create_ap /usr/share/doc/create_ap/
create_ap /usr/share/doc/create_ap/README.md
create_ap /usr/share/licenses/
create_ap /usr/share/licenses/create_ap/
create_ap /usr/share/licenses/create_ap/LICENSE
PackagesAnyFeature RequestMediumMedium [iperf] needs OpenRC init script Closed
100%
Task Description
pacman -Si

Nom                      : iperf
Version                  : 2.0.9-1
Description              : A tool to measure maximum TCP bandwidth
Architecture             : x86_64
URL                      : https://sourceforge.net/projects/iperf2/
Licences                 : custom
Groupes                  : --
Fournit                  : --
Dépend de                : gcc-libs
Dépendances opt.         : --
Requis par               : --
Optionnel pour           : --
Est en conflit avec      : --
Remplace                 : --
Taille installée         : 88,00 KiB
Paqueteur                : Sébastien Luttringer <seblu@seblu.net>
Compilé le               : dim. 09 oct. 2016 14:14:34 CEST
Installé le              : ven. 04 mai 2018 17:13:21 CEST
Motif d’installation     : Explicitement installé
Script d’installation    : Oui
Validé par               : Signature
pacman -Ql

iperf /usr/
iperf /usr/bin/
iperf /usr/bin/iperf
iperf /usr/lib/
iperf /usr/lib/systemd/
iperf /usr/lib/systemd/system/
iperf /usr/lib/systemd/system/iperf-tcp.service
iperf /usr/lib/systemd/system/iperf-udp.service
iperf /usr/share/
iperf /usr/share/licenses/
iperf /usr/share/licenses/iperf/
iperf /usr/share/licenses/iperf/LICENSE
iperf /usr/share/man/
iperf /usr/share/man/man1/
iperf /usr/share/man/man1/iperf.1.gz
PackagesAnyFeature RequestMediumMedium [gammu] needs OpenRC init script Closed
100%
Task Description
pacman -Si

Dépôt                    : community
Nom                      : gammu
Version                  : 1.38.2-1
Description              : GNU All Mobile Management Utilities
Architecture             : x86_64
URL                      : http://wammu.eu/gammu/
Licences                 : GPL
Groupes                  : --
Fournit                  : --
Dépend de                : glib2  bluez-libs  curl  libmariadbclient  postgresql-libs  libusb
                           libgudev
Dépendances opt.         : dialog: support for the gammu-config script
                           python2: for python bindings
Est en conflit avec      : --
Remplace                 : --
Taille du téléchargement : 1167,86 KiB
Taille installée         : 4798,00 KiB
Paqueteur                : Jaroslav Lichtblau <svetlemodry@archlinux.org>
Compilé le               : mar. 11 avril 2017 15:16:32 CEST
Validé par               : Somme MD5  Somme SHA-256  Signature
pacman -Ql gammu | grep /usr/lib/

gammu /usr/lib/
gammu /usr/lib/libGammu.so
gammu /usr/lib/libGammu.so.8
gammu /usr/lib/libGammu.so.8.1.38.2
gammu /usr/lib/libgsmsd.so
gammu /usr/lib/libgsmsd.so.8
gammu /usr/lib/libgsmsd.so.8.1.38.2
gammu /usr/lib/pkgconfig/
gammu /usr/lib/pkgconfig/gammu-smsd.pc
gammu /usr/lib/pkgconfig/gammu.pc
gammu /usr/lib/systemd/
gammu /usr/lib/systemd/system/
gammu /usr/lib/systemd/system/gammu-smsd.service
PackagesStableBug ReportMediumMedium[linux-libre-lts] [i915] Display freeze : hpd interrupt...Deferred
0%
Task Description

Hello,

I recently acquired a T400 Thinkpad with 1440×900 panel.
On this T400, I installed Hyperbola, just like on my x200 Thinkpad with 1280×800 panel.

Both Thinkpad are running the same Hyperbola installation :

Full disk encryption (with Libreboot) so both Thinkpad are using early KMS (MODULES=”i915” in /etc/mkinitcpio.conf)
Same kernel : linux-libre-lts (4.9.99 at the moment I’m writing this message)
video driver : modesetting
DE : xfce4 with xfwm4

On the Thinkpad x200, everything works great, no issue to report.

On the T400 though, the linux-libre-lts kernel, I’m getting random display freezes, when it happens, this message appears in dmesg :

hpd interrupt storm detected on connector hdmi-a-1

And the display (and sound) freezes for 10 seconds (sometimes more !)

As Hyperbola proposes linux-libre-lts kernel only, I installed latest linux-libre-lts (4.14.40) and linux-libre (4.16.8) from Parabola GNU/Linux repo.

Results :

With 4.14.40 : Same issue as with 4.9.99 kernel from Hyperbola repo.
With 4.16.8 : Issue is not present ! No more freeze !

I’m not sure how to proceed though. Would you be kind enough helping me to find which commit in i915 driver improved the situation ? If we find it, maybe it could be added as a patch to 4.9.x kernel series.
Or maybe it is something else.. I don’t have much experience, I can provide logs if needed.

Thanks for your help

PackagesStableBug ReportMediumMedium[virt-install] ERROR '_OsVariant' object has no attribu...Requires Testing
100%
Task Description

Trying to create a VM using virt-install (1.4.1-2.hyperbola2)

virt-install --connect qemu:///system \
--name debian \
--ram 1024 \
--disk path=/home/test/debian.img,size=50 \
--vcpus 2 \
--os-type linux \
--os-variant generic \
--network bridge=virbr0 \
--graphics none \
--console pty,target_type=serial \
--location 'http://ftp.nl.debian.org/debian/dists/stretch/main/installer-amd64/' \
--extra-args 'console=ttyS0,115200n8 serial'

This error shows up :
ERROR : ‘_OsVariant’ object has no attribute ‘urldistro’

I can’t create the VM.

PS : Error is not present on Debian Stretch with virt-install 1.4.0-5

Thanks for your help.

PackagesAnyBug ReportMediumMedium [iceweasel-uxp-l10n] Impossible to remove saved login Closed
100%
Task Description

Previously (with iceweasel), when I was saving a login for a website, I was able to remove it in :

Preferences → Security > Logins > Saved logins

With iceweasel-uxp, when I click on “saved logins”, it opens a box but it is empty, I can’t remove saved login. (They are saved because iceweasel-uxp suggests me to use the saved login for concerned website)

PackagesStableBug ReportMediumMedium [udisks2] Impossible to mount ISO or IMG file Closed
100%
Task Description

When I try to mount an ISO file or IMG file (with right-click, “open with disk image mounter” on XFCE4) it fails, the following error message appears :

GDBus.Error.org.freedesktop.UDisks2.Error.Failed: Error opening /dev/loop-control: No such file or directory (udisks-error-quark, 0)

Thanks for your help

PackagesAnyBug ReportMediumMedium [sshfs] Can't mount share from desktop (FUSE2 issue) Closed
100%
Task Description

Since 0.3 release, i’m unable to mount my sshfs share from my desktop.

For reference, my fstab entry :

sshfs#anon@server:/srv/nfs/data /mnt/data fuse noauto,user,_netdev,x-gvfs-show,x-gvfs-name=data 0 0

When I double-click on the desktop icon (xfce), it says : “Impossible to mount data”

But, I’m able to mount the share if I enter the command manually in a terminal as user.

sshfs anon@server:/srv/nfs/data /mnt/data

So, it is not a problem of writing rights on mountpoint /mnt/data
I suspect an issue with fuse2 since it is a dependency of sshfs and it is in relation with mounting share from desktop.

PackagesStableBug ReportLowMediumGarbled display with xfce4-terminal (terminfo)Unconfirmed
0%
Task Description

A very nasty bug I wasn’t able to find an answer to.
I compiled stuff (buildroot) using menuconfig, the menu display was fine in xfce4-terminal (See screenshot #1)
I restarted the config a few days later with the same command :

$ make menuconfig

and this time the display was messed up (See screenshot #2)

After investigation, I noticed a directory (filled with stuff) have been created in my home folder :

.terminfo

I don’t know why. But anyway, if I delete it, then the display is ok again.
I noticed that if I use good old xterm terminal, then the display is fine even if the .terminfo directory is present. (it uses “xterm” instead of xterm-256color)

But, with xfce4-terminal (and others, I tried with gnome-terminal, sakura..), the display is messed up if the .terminfo directory is present in my home folder.

I also noticed that if I run the command in a screen session, the issue is not present.

(I open xfce4-terminal)

$ screen
$ printenv TERM
screen.xterm-256color
$ make menuconfig (or htop, or other program using ncurses)

= display ok

but with default :

(I open xfce4-terminal)

$ printenv TERM
xterm-256color
make menuconfig (or htop, or other program using ncurses)

= display messed up if .terminfo directory is present

So I have no idea why this .terminfo directory is generated. What could trigger its generation ? Is that an issue with ncurses or something else ?

Thanks for your help

PackagesStableBug ReportVery LowMedium[cowsay] perl-text-charwidth dependency missingUnconfirmed
0%
Task Description

cowsay (cowsay-3.03-9.hyperbola1) is missing perl-text-charwidth dependency

Error message :

“Can’t locate Text/CharWidth.pm in @INC (you may need to install the Text::CharWidth module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/bin/cowsay line 14.
BEGIN failed–compilation aborted at /usr/bin/cowsay line 14.”

After installing perl-text-charwidth, it works fine.

PackagesAnyImplementation RequestVery LowMedium[arm-linux-gnueabihf-gcc] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

arm-linux-gnueabihf-gcc

“The GNU Compiler Collection (arm-linux-gnueabihf)”

Also requires :

arm-linux-gnueabihf-binutils (A set of programs to assemble and manipulate binary and object files)
arm-linux-gnueabihf-glibc (GNU C Library)

https://aur.archlinux.org/packages/arm-linux-gnueabihf-gcc/

License : GPL

Thanks

PackagesStableBug ReportVery LowMedium[nfs-utils] missing idmapd.confUnconfirmed
0%
Task Description

Hello,

When mounting an NFS share, I get a warning about missing idmpad.conf

rpc.idmapd: Skipping configuration file "/etc/idmapd.conf": No such file or directory
4341: * Stopping idmapd ...

Debian includes a default config file for idmap :

[General]

Verbosity = 0
Pipefs-Directory = /run/rpc_pipefs
# set your own domain here, if id differs from FQDN minus hostname
# Domain = localdomain

[Mapping]

Nobody-User = nobody
Nobody-Group = nogroup
PackagesAnyDrop RequestVery LowMedium[hardening-wrapper] deprecated, not needed anymoreUnconfirmed
0%
Task Description

According to : https://github.com/thestinger/hardening-wrapper-deprecated

Wrapper scripts for building hardened executables by default (deprecated, replaced by standard Arch Linux toolchain changes)

PackagesAnyImplementation RequestVery LowMedium [epson-inkjet-printer-escpr] add package Closed
100%
Task Description

Hello,

Could it be possible to add :

epson-inkjet-printer-escpr

“Epson Inkjet Printer Driver (ESC/P-R) for Linux”

License : GPL2

https://aur.archlinux.org/packages/epson-inkjet-printer-escpr/ https://packages.debian.org/stretch/printer-driver-escpr

In my case, it was needed to use an Epson printer & scanner.

PackagesStableBug ReportVery LowMedium [kodi] "The Movie Database" scraper doesn't workUnconfirmed
0%
Task Description

With kodi 17.1-2.hyperbola1 “The Movie Database” scraper doesn’t work. The error message is :

"Unable to connect to remote server"
PackagesAnyImplementation RequestVery LowLow[multipath-tools] add packageDeferred
0%
Task Description

Hello,

Could it be possible to add this package :

multipath-tools

“Multipath tools for Linux (including kpartx)”

License : GPL2

to the repo ?

Thank you

PackagesAnyImplementation RequestVery LowLow[thinkfan] add packageDeferred
0%
Task Description

Could it be possible to add this package :

thinkfan

“A minimalist fan control program. Supports the sysfs hwmon interface and thinkpad_acpi”

License : GPL

to the repo ?

Thanks

PackagesAnyImplementation RequestVery LowLow [mat] add package  Closed
100%
Task Description

Could it be possible to add this package :

mat (a.k.a Metadata anonymisation toolkit)

https://mat.boum.org

License : GPL2

to the repo ?

Thanks

PackagesAnyImplementation RequestVery LowLow [mednaffe] add package Closed
100%
Task Description

Could it be possible to add :

mednaffe

“front-end (GUI) for mednafen emulator”

https://www.parabola.nu/packages/pcr/x86_64/mednaffe/ https://github.com/AmatCoder/mednaffe

License : GPL2

Thanks

Showing tasks 1 - 50 of 84 Page 1 of 21 - 2 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing