All Projects

ProjectCategoryTask TypePrioritySeveritySummaryStatusProgress
PackagesAnySecurity IssueVery HighCritical [gnome-mplayer] [gecko-mediaplayer] [gmtk] remove unsec ...Closed
100%
Task Description

Remove “gnome-mplayer”, “gecko-mediaplayer” and “gmtk” are unsecured/abandonware packages(released in 2014)
“gecko-mediaplayer” uses deprecated/unsecured NPAPI[0] and XULRunner[1][2] apis

$ pacman -Si gnome-mplayer
Repository : community
Name : gnome-mplayer
Version : 1.0.9-4
Description : A simple MPlayer GUI.
Architecture : x86_64
URL : https://sites.google.com/site/kdekorte2/gnomemplayer Licenses : GPL Groups : None
Provides : None
Depends On : mplayer dbus-glib libnotify gmtk
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 343.29 KiB
Installed Size : 1461.00 KiB
Packager : Balló György <ballogyor+arch@gmail.com>
Build Date : Sun 22 Jan 2017 04:45:38 PM -03
Validated By : MD5 Sum SHA-256 Sum Signature

$ pacman -Si gecko-mediaplayer
Repository : community
Name : gecko-mediaplayer
Version : 1.0.9-3
Description : Browser plugin that uses gnome-mplayer to play media in a web browser.
Architecture : x86_64
URL : https://sites.google.com/site/kdekorte2/gecko-mediaplayer Licenses : GPL Groups : None
Provides : None
Depends On : gnome-mplayer>=1.0.9 dbus-glib gmtk curl
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 80.92 KiB
Installed Size : 598.00 KiB
Packager : Balló György <ballogyor+arch@gmail.com>
Build Date : Sun 22 Jan 2017 04:36:31 PM -03
Validated By : MD5 Sum SHA-256 Sum Signature

$ pacman -Si gmtk
Repository : community
Name : gmtk
Version : 1.0.9-3
Description : Common functions for gnome-mplayer and gecko-mediaplayer.
Architecture : x86_64
URL : https://sites.google.com/site/kdekorte2/gmtk Licenses : GPL Groups : None
Provides : None
Depends On : glib2 gtk3 dconf
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 73.85 KiB
Installed Size : 246.00 KiB
Packager : Balló György <ballogyor+arch@gmail.com>
Build Date : Sun 22 Jan 2017 04:50:49 PM -03
Validated By : MD5 Sum SHA-256 Sum Signature

[0]:https://developer.mozilla.org/en-US/docs/Plugins/Roadmap [1]:https://hearsum.ca/blog/mozilla-will-stop-producing-automated-builds-of-xulrunner-after-the-410-cycle.html [2]:https://tracker.debian.org/pkg/xulrunner

PackagesAnySecurity IssueVery HighCritical [freewrl] remove unsecure "libFreeWRLplugin.so" Closed
100%
Task Description

Remove “libFreeWRLplugin.so”, uses deprecated/unsecure NPAPI[0] and XULRunner[1][2] apis

$ pacman -Si freewrl
Repository : community
Name : freewrl
Version : 1:2.3.3-1
Description : VRML viewer
Architecture : x86_64
URL : http://freewrl.sourceforge.net/ Licenses : GPL Groups : None
Provides : None
Depends On : java-runtime libxaw glew freeglut curl freetype2 imlib2 sox unzip imagemagick libxml2 ttf-bitstream-vera lesstif js185 glu openal

                freealut

Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 583.49 KiB
Installed Size : 2060.00 KiB
Packager : Sergej Pupykin <pupykin.s+arch@gmail.com>
Build Date : Mon 19 Dec 2016 10:31:49 AM -03
Validated By : MD5 Sum SHA-256 Sum Signature

$ sudo pacman -Ql freewrl
freewrl /usr/
freewrl /usr/bin/
freewrl /usr/bin/freewrl
freewrl /usr/bin/freewrl_msg
freewrl /usr/bin/freewrl_snd
freewrl /usr/include/
freewrl /usr/include/FreeWRLEAI/
freewrl /usr/include/FreeWRLEAI/EAIHeaders.h
freewrl /usr/include/FreeWRLEAI/EAI_C.h
freewrl /usr/include/FreeWRLEAI/GeneratedHeaders.h
freewrl /usr/include/FreeWRLEAI/X3DNode.h
freewrl /usr/include/libFreeWRL.h
freewrl /usr/lib/
freewrl /usr/lib/libFreeWRL.so
freewrl /usr/lib/libFreeWRL.so.2
freewrl /usr/lib/libFreeWRL.so.2.3.3
freewrl /usr/lib/libFreeWRLEAI.so
freewrl /usr/lib/libFreeWRLEAI.so.2
freewrl /usr/lib/libFreeWRLEAI.so.2.3.3
freewrl /usr/lib/mozilla/
freewrl /usr/lib/mozilla/plugins/
freewrl /usr/lib/mozilla/plugins/libFreeWRLplugin.so
freewrl /usr/lib/pkgconfig/
freewrl /usr/lib/pkgconfig/libFreeWRL.pc
freewrl /usr/lib/pkgconfig/libFreeWRLEAI.pc
freewrl /usr/share/
freewrl /usr/share/applications/
freewrl /usr/share/applications/freewrl.desktop
freewrl /usr/share/man/
freewrl /usr/share/man/man1/
freewrl /usr/share/man/man1/freewrl.1.gz
freewrl /usr/share/pixmaps/
freewrl /usr/share/pixmaps/freewrl.png

[0]:https://developer.mozilla.org/en-US/docs/Plugins/Roadmap [1]:https://hearsum.ca/blog/mozilla-will-stop-producing-automated-builds-of-xulrunner-after-the-410-cycle.html [2]:https://tracker.debian.org/pkg/xulrunner

PackagesAnySecurity IssueVery HighCritical [xulrunner] unmaintained and unsupportable Closed
100%
Task Description

Remove “xulrunner”[0][1] is unsecure/abandonware package

$ pacman -Si xulrunner
Repository : community
Name : xulrunner
Version : 41.0.2-10
Description : Mozilla Runtime Environment
Architecture : x86_64
URL : http://wiki.mozilla.org/XUL:Xul_Runner Licenses : MPL GPL LGPL Groups : None
Provides : None
Depends On : gtk2 mozilla-common nss>3.18 libxt hunspell startup-notification mime-types dbus-glib libpulse libevent libvpx icu python2
Optional Deps : None
Conflicts With : None
Replaces : xulrunner-oss
Download Size : 47.38 MiB
Installed Size : 171.99 MiB
Packager : Evangelos Foutras evangelos@foutrelis.com Build Date : Wed 26 Apr 2017 03:10:07 AM -03
Validated By : MD5 Sum SHA-256 Sum Signature

[0]:https://hearsum.ca/blog/mozilla-will-stop-producing-automated-builds-of-xulrunner-after-the-410-cycle.html [1]:https://tracker.debian.org/pkg/xulrunner

PackagesAnyFreedom IssueVery HighCritical [cmake-fedora] useful only for non-FSDG distros Closed
100%
Task Description

$ pacman -Si cmake-fedora
Repository : community
Name : cmake-fedora
Version : 2.7.1-3
Description : CMake helper modules for fedora developers
Architecture : any
URL : https://pagure.io/cmake-fedora Licenses : custom:BSD
Groups : None
Provides : None
Depends On : cmake
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 90.94 KiB
Installed Size : 422.00 KiB
Packager : Felix Yan felixonmars@archlinux.org Build Date : Mon 17 Apr 2017 06:39:49 AM -03
Validated By : MD5 Sum SHA-256 Sum Signature

PackagesAnyFreedom IssueVery HighCritical [cataclysm-dda] uses CC BY-SA for software Closed
100%
Task Description

Cataclysm-DDA contains a problematic license[0][1][2] for software.
Uses “Creative Commons Attribution-ShareAlike 3.0 Unported License”.

$ pacman -Si cataclysm-dda
Repository : community
Name : cataclysm-dda
Version : 0.C-3
Description : A post-apocalyptic roguelike.
Architecture : x86_64
URL : http://en.cataclysmdda.com/ Licenses : CCPL:by-sa
Groups : None
Provides : None
Depends On : ncurses lua
Optional Deps : sdl2_image: for tiles

                sdl2_ttf: for tiles
                freetype2: for tiles
                sdl2_mixer: for tiles

Conflicts With : None
Replaces : None
Download Size : 19.33 MiB
Installed Size : 53.32 MiB
Packager : Felix Yan felixonmars@archlinux.org Build Date : Mon 07 Dec 2015 03:14:02 AM -03
Validated By : MD5 Sum SHA-256 Sum Signature

[0]:https://github.com/CleverRaven/Cataclysm-DDA/blob/master/LICENSE.txt [1]:https://creativecommons.org/faq/#can-i-apply-a-creative-commons-license-to-software [2]:https://www.gnu.org/licenses/license-list.html#ccbysa

PackagesAnySecurity IssueVery HighCritical [w3m] unmaintained and unsupportable Closed
100%
Task Description

w3m is an unmaintained and unsuportable software, the latest release was 0.5.3 (2011)[0][1][2][3]

$ pacman -Qi w3m
Name : w3m
Version : 0.5.3.git20170102-2
Description : Text-based Web browser, as well as pager
Architecture : x86_64
URL : http://w3m.sourceforge.net/ Licenses : custom
Groups : None
Provides : None
Depends On : openssl gc ncurses gpm
Optional Deps : imlib2: for graphics support [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1784.00 KiB
Packager : Jan de Groot jgc@archlinux.org Build Date : Sat 04 Mar 2017 07:12:38 PM -03
Install Date : Tue 12 Sep 2017 03:43:25 AM -03
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

[0]:https://sourceforge.net/projects/w3m/files/w3m/ [1]:https://security.archlinux.org/package/w3m [2]:https://tracker.debian.org/pkg/w3m [3]:https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/w3m

PackagesAnySecurity IssueVery HighCritical [pam] pam_unix2 is orphaned and dead upstream Closed
100%
Task Description

pam_unix2 was removed from Debian Jessie because it’s buggy and unmaintained [0]

It’s included inside pam package and should be removed since it doesn’t comes from official source. Also the original upstream FTP directory (ftp://ftp.suse.com/people/kukuk/pam/pam_unix2) has disappeared.

[0]:https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=628848

$ pacman -Si pam
Repository : core
Name : pam
Version : 1.3.0-1
Description : PAM (Pluggable Authentication Modules) library
Architecture : x86_64
URL : http://linux-pam.org Licenses : GPL2
Groups : None
Provides : None
Depends On : glibc cracklib libtirpc pambase
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 609.71 KiB
Installed Size : 2980.00 KiB
Packager : Tobias Powalowski tpowa@archlinux.org Build Date : Thu 09 Jun 2016 02:44:03 PM -03
Validated By : MD5 Sum SHA-256 Sum Signature

$ pacman -Ql pam > pam_fileslist.txt

PackagesAnyBug ReportVery HighCritical [warsow] the package is not compiled from source Closed
100%
Task Description

The package is not compiled from source

PackagesAnyFreedom IssueVery HighCritical [warsow-data] the package contains nonfree assets (CC B ...Closed
100%
Task Description

The package contains nonfree assets:
data0_000_nonfree_21.pk3
data0_000_nonfree_21pure.pk3
tex_000_nonfree.pk3

PackagesAnyFreedom IssueVery HighCritical [torcs-data] contains nonfree car models Closed
100%
Task Description

The package contains nonfree car models

PackagesAnyFreedom IssueVery HighCritical [vdrift-data] contains nonfree car and track models Closed
100%
Task Description

The package contains nonfree car and track models

PackagesAnyFreedom IssueVery HighCritical [bluegriffon] contains support to nonfree "Extended Fea ...Closed
100%
Task Description

BlueGriffon contains support to nonfree “Extended Features”

$ pacman -Qi bluegriffon
Name            : bluegriffon
Version         : 2.3.1-2
Description     : The next-generation Web Editor based on the rendering engine of Firefox
Architecture    : x86_64
URL             : http://bluegriffon.org/
Licenses        : MPL  GPL  LGPL
Groups          : None
Provides        : None
Depends On      : alsa-lib  desktop-file-utils  dbus-glib  gtk2  gtk3  hunspell  mozilla-common  nss  libevent  libvpx  libxt  python2  startup-notification
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 120.72 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Tue 25 Apr 2017 12:22:30 PM -03
Install Date    : Wed 08 Nov 2017 12:46:24 AM -03
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
PackagesAnyBug ReportVery HighCritical [grub] remove the "placeholder" entry in /etc/grub.d/20 ...Closed
100%
Task Description

Description:

  • Remove the “placeholder” entry in /etc/grub.d/20_linux_xen since it has been removed from Linux kernel.

Additional info:

  • grub 2:2.02-1.hyperbola3
/etc/grub.d/20_linux_xen
----
-       module  ${rel_dirname}/${basename} placeholder root=${linux_root_device_thisversion} ro ${args}
+       module  ${rel_dirname}/${basename} root=${linux_root_device_thisversion} ro ${args}
----
$ pacman -Si grub
Repository      : core
Name            : grub
Version         : 2:2.02-1.hyperbola3
Description     : GNU GRand Unified Bootloader (2), (Hyperbola rebranded)
Architecture    : x86_64
URL             : https://www.gnu.org/software/grub/
Licenses        : GPL3
Groups          : None
Provides        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Depends On      : sh  xz  gettext  device-mapper
Optional Deps   : freetype2: For grub-mkfont usage
                  fuse: For grub-mount usage
                  dosfstools: For grub-mkrescue FAT FS and EFI support
                  efibootmgr: For grub-install EFI support
                  libisoburn: Provides xorriso for generating grub rescue iso using grub-mkrescue
                  os-prober: To detect other OSes when generating grub.cfg in BIOS systems
                  mtools: For grub-mkrescue FAT FS and EFI support
                  xen: For Xen Dom0 support
                  xen-docs: For Xen documentation
Conflicts With  : grub-common  grub-bios  grub-emu  grub-efi-x86_64  grub-legacy
Replaces        : grub-common  grub-bios  grub-emu  grub-efi-x86_64
Download Size   : 6.17 MiB
Installed Size  : 39.31 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 20 Nov 2017 06:35:41 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Turn on machine and then check Linux-libre kernel booting
PackagesAnyBug ReportVery HighCritical [openrc] rename "chroot-nspawn" keyword to "chroot+unsh ...Closed
100%
Task Description

Description:

Rename "chroot-nspawn" keyword to "chroot+unshare" one
because"chroot+unshare" subsystem (chroot and unshare command)
is more precise than "chroot-nspawn" (systemd-nspawn
compatibility script) subsystem.

The files with "chroot-nspawn" keyword are:
* /etc/init.d/binfmt
* /etc/init.d/bootmisc (as SYSTEMD-NSPAWN)
* /etc/init.d/consolefont
* /etc/init.d/devfs
* /etc/init.d/dmesg
* /etc/init.d/fsck
* /etc/init.d/hostname
* /etc/init.d/hwclock
* /etc/init.d/keymaps
* /etc/init.d/localmount
* /etc/init.d/loopback
* /etc/init.d/mtab
* /etc/init.d/modules
* /etc/init.d/modules-load
* /etc/init.d/mount-ro
* /etc/init.d/net-online
* /etc/init.d/netmount
* /etc/init.d/numlock
* /etc/init.d/procfs
* /etc/init.d/root
* /etc/init.d/swap
* /etc/init.d/swclock
* /etc/init.d/sysctl
* /etc/init.d/sysfs
* /etc/init.d/termencoding
* /etc/init.d/urandom
Note:
  chroot: run a command with special root directory
  unshare: isolate the command in a different "Linux namespace"

Additional info:

openrc 0.28-14

/etc/rc.conf


 # ""               - nothing special
 # "docker"         - Docker container manager (GNU/Linux)
 # "jail"           - Jail (DragonflyBSD or FreeBSD)
 # "lxc"            - Linux Containers
 # "openvz"         - Linux OpenVZ
 # "prefix"         - Prefix
 # "rkt"            - CoreOS container management system (GNU/Linux)
 # "subhurd"        - Hurd subhurds (to be checked)
-# "chroot-nspawn"  - Container created by chroot-nspawn
+# "chroot"         - Chroot container (to be checked)
+# "chroot+unshare" - Chroot container using unshare command (GNU/Linux)
 # "uml"            - Usermode Linux
 # "vserver"        - Linux vserver
-# "xen0"           - Xen0 Domain (GNU/Linux and NetBSD)
-# "xenU"           - XenU Domain (GNU/Linux and NetBSD)
+# "xen0"           - Xen0 Domain (GNU/HyperBK, GNU/Linux, FreeBSD and NetBSD)
+# "xenU"           - XenU Domain (GNU/Hurd, GNU/HyperBK, GNU/Linux, FreeBSD, NetBSD and OpenBSD)

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Run OpenRC init
PackagesAnyBug ReportVery HighCritical [eudev] rename "systemd-nspawn" keyword to "chroot+unsh ...Closed
100%
Task Description

Description:

Rename "systemd-nspawn" keyword to "chroot+unshare" one.

The files with "systemd-nspawn" keyword are:
* /etc/init.d/udev
* /etc/init.d/udev-settle
* /etc/init.d/udev-trigger

Additional info:

eudev 3.2.5-1
$ pacman -Si eudev
Repository      : core
Name            : eudev
Version         : 3.2.5-1
Description     : The userspace dev tools (udev) forked by Gentoo, with OpenRC support
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:Eudev
Licenses        : GPL
Groups          : None
Provides        : udev
Depends On      : libeudev  kbd  kmod  hwids  util-linux
Optional Deps   : None
Conflicts With  : udev
Replaces        : udev
Download Size   : 932.42 KiB
Installed Size  : 7069.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Thu 07 Dec 2017 11:45:57 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Run OpenRC init
PackagesAnyFeature RequestVery HighCritical [openrc] please remove "mtab", "modules-load" and "swcl ...Closed
100%
Task Description

Description:

Please remove "mtab", "modules-load" and "swclock" init scripts.

"mtab" is a deprecated and unmaintained init script,
because filesystem contains a mtab soft link.

"modules-load" init script, is a systemd compatibility configuration
to load the kernel modules from the "/etc/modules-load" configuration
directory.
This init script is useless, because the "modules" init script exists
and it's a duplicated feature.
If you need a module to load a module, just configure "/etc/conf.d/modules"
and start the "modules" init script or add a module in
the "/etc/mkinitcpio.conf" and run mkinitcpio -p $yourkernel

"swclock" is an useless init script, because is a service
setting the local clock based on last shutdown time.
If a machine doesn't support "/etc/rtc", then disable "clock_hctosys" and
"clock_systohc" from "/etc/conf.d/hwclock" with or without
NTP server/client. For chroot environments,"osclock" init script is the way.

Additional info:

openrc 0.28-14

/etc/init.d/localmount


-use lvm modules mtab root
+use lvm modules root

/etc/init.d/modules


-    want modules-load

/etc/init.d/lm_sensors


-after modules-load

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Enable the unused init scripts
PackagesAnySecurity IssueVery HighCritical [openrc] use procps-ng's "sysctl" by default instead of ...Closed
100%
Task Description

Description:

Use procps-ng's "sysctl" by default instead of inetutils's "hostname" for
hostname support.

Since [inetutils] is an extra dependency for openrc, it
contains insecure commands like: ftp/rcp/rlogin/rsh/talk/telnet
For security reasons, procps-ng should be the tool to handle hostname
configuration through hostname init script because is a base package.

Additional info:

openrc 0.28-14

/etc/init.d/hostname


-       hostname "$h"
+       case $(uname -s) in
+               GNU/Linux|Linux)
+                       sysctl -qw kernel.hostname="$h"
+                       ;;
+               *)
+                       hostname "$h"
+                       ;;
+       esac

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Set and run hostname init script
PackagesAnyBug ReportVery HighCritical [openrc] set "devfs" init script to run before than any ...Closed
100%
Task Description

Description:

Set "devfs" init script to run before than any "logger" init script.

It fixes when any "logger" server is running with rc_logger activated
without the needed to add a "logger" init script on different runlevels.

Additional info:

openrc 0.28-14

/etc/init.d/devfs


-       before dev
+       before dev logger

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Add "devfs" and any "logger" init script to default runlevel
PackagesAnyFeature RequestVery HighCritical [openrc] some init scripts are forced to load in certai ...Closed
100%
Task Description

Description:

Some init scrips are forced to load in certain runlevels by default (eg. boot) when 
OpenRC is upgraded. It isn't good for virtualization environments like chroot that
doesn't require it to work.

Those scripts are:
* /etc/init.d/dmesg
* /etc/init.d/hwclock
* /etc/init.d/keymaps
* /etc/init.d/killprocs
* /etc/init.d/local
* /etc/init.d/loopback
* /etc/init.d/modules
* /etc/init.d/mount-ro
* /etc/init.d/swap
* /etc/init.d/sysctl

Note: "/etc/init.d/dmesg" should be loaded in "boot" runlevel instead of "sysinit" one at the first installation time.
Note: "/etc/init.d/local" should be loaded in "sysinit" runlevel instead of "default" and "nonetwork" one at the first installation time.

Additional info:

openrc 0.28-14
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Re-install and/or upgrade the OpenRC package.
PackagesAnyFeature RequestVery HighCritical [openrc] some init scripts are forced to load in certai ...Closed
100%
Task Description

Description:

Some init scrips are forced to load in certain runlevels by default (eg. boot) when 
OpenRC is upgraded. Also some of them are autoloaded by other init scripts.
It isn't good for virtualization environments like chroot that doesn't require it to
work.
These files need be removed:
* /etc/runlevels/boot/binfmt (optional)
* /etc/runlevels/boot/fsck (autoloaded from "root" init script)
* /etc/runlevels/boot/localmount (autoloaded from "bootmisc" init script)
* /etc/runlevels/boot/procfs (optional, mount "binfmt_misc" only)
* /etc/runlevels/boot/termencoding (autoloaded from "keymaps" init script)
* /etc/runlevels/default/netmount (optional)
* /etc/runlevels/shutdown/savecache (optional)
* /etc/runlevels/sysinit/devfs (autoload from "udev" init script)
* /etc/runlevels/sysinit/sysfs (autoload from "udev" init script)

Additional info:

openrc 0.28-14
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

Re-install and/or upgrade the OpenRC package
PackagesAnyFeature RequestVery HighCritical [openrc] add "newinstance" mount parameter in "devpts"  ...Closed
100%
Task Description

Description:

Add "newinstance" mount parameter in "devpts" (in "devfs" init script)

Additional info:

openrc 0.28-14

/etc/init.d/devfs


- “devpts /dev/pts 0755 ,gid=5,mode=0620 devpts” \
+ “devpts /dev/pts 0755 ,gid=5,mode=0620,newinstance devpts” \


$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:
Run “devfs” init script

PackagesAnyFeature RequestVery HighCritical [openrc] add hidepid support in /proc filesystem. Closed
100%
Task Description

Description:

  • Add hidepid in /proc filesystem, needed for chroot with namespaces.
  • Revert FS#1082, but as “gid=proc,hidepid=2”, not “hidepid=2,gid=proc”.

Additional info:

  • openrc 0.28-18

/usr/lib/rc/sh/init.sh


-                mount -n -t proc -o noexec,nosuid,nodev proc /proc
+                mount -n -t proc -o noexec,nosuid,nodev,gid=proc,hidepid=2 proc /proc

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-18
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 193.18 KiB
Installed Size  : 1720.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 08 Jul 2018 01:28:16 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • On boot “openrc” on ‘chroot’ with ‘linux namespaces’ (unshare).
  • On boot “openrc” on any ‘kernel based virtual machines’ (without /proc premounted).
  • On boot the kernel without any image (initramfs-linux-libre-lts*.img).
PackagesAnyFeature RequestVery HighCritical [netifrc] add net_macsec and net_veth init scripts Closed
100%
Task Description

Description:

Add net_macsec and net_veth init scripts

Additional info:

netifrc 0.5.1-3
Repository      : core
Name            : netifrc
Version         : 0.5.1-3
Description     : Network interface management scripts
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Netifrc
Licenses        : BSD2
Groups          : base
Provides        : None
Depends On      : eudev
Optional Deps   : iproute2: for interface handler, VPN, bridging and tunneling support (recommended)
                  net-tools: for interface handler support
                  bridge-utils: for bridging support
                  linux-atm: for CLIP and RFC 2684 bridge support
                  wpa_supplicant: for wireless networking support (recommended)
                  wireless_tools: for wireless networking support
                  dhcpcd: for DHCP support (recommended)
                  dhclient: for DHCP support
                  busybox: for DHCP support
                  iputils: for APIPA support
                  ifenslave: for bonding interfaces
                  ppp: for PPP and ADSL support (recommended)
                  rp-pppoe: for ADSL support
                  macchanger: for changing MAC addresses
                  ifplugd: for cable in/out detection
Conflicts With  : None
Replaces        : None
Download Size   : 62.75 KiB
Installed Size  : 349.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Wed 24 Jan 2018 09:05:24 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyFeature RequestVery HighCritical [openrc] add chroot init config and script files Closed
100%
Task Description

Description:

Add chroot init script
Note: chroot1 and chroot2 are examples.

Additional info:

openrc 0.28-14
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyBug ReportVery HighCritical [openrc] rename "procfs" init script to "binfmt_misc",  ...Closed
100%
Task Description

Description:

Rename "procfs" init script to "binfmt_misc", it isn't a "procfs"

/etc/init.d/procfs → /etc/init.d/binfmt_misc


-description="Mounts misc filesystems in /proc."
+description="Mounts binfmt_misc filesystems in /proc."

/etc/init.d/binfmt


-        after clock procfs
+        after clock binfmt_misc

Additional info:

openrc 0.28-14
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyBug ReportVery HighCritical [eudev][openrc] rename "dev-mount" to "devfs" in "udev" ...Closed
100%
Task Description

Description:
Rename “dev-mount” to “devfs” in “udev” init script

/etc/init.d/udev (eudev package)


-        need sysfs dev-mount
+        need sysfs devfs

/etc/init.d/devfs (openrc package)


 -        provide dev-mount

Additional info:

openrc 0.28-14
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-14
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 196.71 KiB
Installed Size  : 1767.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 07 May 2018 03:54:42 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyBackport RequestVery HighCritical [netifrc] update package to 0.6.0 backport Closed
100%
Task Description

Description:

[netifrc] update package to 0.6.0 backport version

Fix security errors:

Fix errors:

Changes:

Features:



Note: Please add a extra hotfix patch from git:

Additional info:

netifrc 0.5.1-3
$ pacman -Si netifrc
Repository      : core
Name            : netifrc
Version         : 0.5.1-3
Description     : Network interface management scripts
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Netifrc
Licenses        : BSD2
Groups          : base
Provides        : None
Depends On      : eudev
Optional Deps   : iproute2: for interface handler, VPN, bridging and tunneling support (recommended)
                  net-tools: for interface handler support
                  bridge-utils: for bridging support
                  linux-atm: for CLIP and RFC 2684 bridge support
                  wpa_supplicant: for wireless networking support (recommended)
                  wireless_tools: for wireless networking support
                  dhcpcd: for DHCP support (recommended)
                  dhclient: for DHCP support
                  busybox: for DHCP support
                  iputils: for APIPA support
                  ifenslave: for bonding interfaces
                  ppp: for PPP and ADSL support (recommended)
                  rp-pppoe: for ADSL support
                  macchanger: for changing MAC addresses
                  ifplugd: for cable in/out detection
Conflicts With  : None
Replaces        : None
Download Size   : 62.75 KiB
Installed Size  : 349.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Wed 24 Jan 2018 09:05:24 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

contains errors in 0.5.1 version
PackagesAnyImplementation RequestVery HighCritical [linux-libre-lts-server] add "Linux-libre" kernel adapt ...Closed
100%
Task Description

Description:

Additional info:

  • none.

Steps to reproduce:

  • none.
PackagesAnySecurity IssueVery HighCritical [openrc] remove dangerous "local" init script Closed
100%
Task Description

Description:

  • Remove dangerous “local” init script, is a bad idea to use it, see:

https://wiki.gentoo.org/wiki//etc/local.d

Additional info:

  • openrc 0.28-17
  • remove:
    • “/etc/init.d/local”
    • “/etc/local.d/README”
    • “/etc/local.d/”
/etc/init.d/agetty
----
-        after local
+        after *
$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-17
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 194.10 KiB
Installed Size  : 1727.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Thu 05 Jul 2018 01:37:37 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • On boot.
PackagesAnyBug ReportVery HighCritical [openrc] fix "chroot" initscript Closed
100%
Task Description

Description:

  • “chroot” initscript contains some errors on “chroot” initscript.

Additional info:

  • openrc 0.28-18

/etc/conf.d/chroot


 # initial command
 CR_COMD=/sbin/openrc-init
-# network interfaces
-CR_NINF="veth_guest ethernet"
-# wifi interfaces
-CR_WINF="wifi"
-# service dependecies
-CR_DEPS="net_veth.interface_host
-         chroot.name net.interface_ethernet net.interface_wifi"
+# network interfaces, example: CR_NINF="veh0 eth0"
+CR_NINF=""
+# wifi interfaces, example: CR_WINF="wlan0"
+CR_WINF=""
+# service dependecies, example: CR_DEPS="net.veh0 chroot.dns chroot.ntp net.eth0 net.wlan0"
+CR_DEPS=""
 # wait in seconds to run CR_COMD
 CR_CDWT=1
-# wait in seconds to start the sercice
+# wait in seconds to start the service
 CR_STWT=7
 # wait in seconds to stop the service
 CR_SPWT=7

/etc/init.d/chroot


 depend() {
-        need $CR_NDEP
+        need $CR_DEPS
         after modules bootmisc localmount net netmount
         keyword -jail -prefix -vserver
         provide oslv
 }

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-18
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 193.18 KiB
Installed Size  : 1720.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 08 Jul 2018 01:28:16 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • On boot “openrc” and/or start “chroot” initscripts.
PackagesAnyBug ReportVery HighCritical [netifrc] fix "net_veth" and "net_macsec" initscripts Closed
100%
Task Description

Description:

  • “net_veth” and “net_macsec” initscripts contains some issues.

Additional info:

  • netifrc 0.6.0-2.backports1

/etc/conf.d/net_veth


-# Source Interface (host)
-IFSRC=interface_host
+# Source Interface (host), example: IFSRC=veh0
+IFSRC=veh0
 # Set custom parameters on Source Interface
 IFCTS=
-# Destination Interface (guest)
-IFDST=interface_guest
+# Destination Interface (guest), example: IFDST=veg0
+IFDST=veg0
 # Set custom parameters on Destination Interface
 IFCTD=

/etc/conf.d/net_macsec


-# Source Interface (host)
-IFSRC=interface_host
-# Network init service dependency from Source Interface
-#IFDEP=net.interface_host
-# Destination Interface (macsec/guest)
-IFDST=interface_macsec
+# Source Interface (host), example: IFSRC=eth0
+IFSRC=eth0
+# Network init service dependency from Source Interface, example: IFDEP=net.eth0
+IFDEP=
+# Destination Interface (macsec/guest), example: IFDST=macsec0
+IFDST=macsec0
 # Set custom parameters on MACsec Interface
 IFCTD=

---

 IFPAR="cipher gcm-aes-128
        icvlen 16
        encrypt on
        protect off
        replay off
        send_sci on
-       validate strict"
+       validate disabled"

---

-# Add receive channels and/or receive association keys (RXSC), examples:
-#
-# [sci_<0..ffffffffffffffff(hex)>|port_<1..65535(dec)>_address_<00:00:00:00:00:00..ff:ff:ff:ff:ff:ff(hex)>][_<on/off>]
-#
-# sci_0
-# sci_ffffffffffffffff_on
-# port_1_address_00:00:00:00:00:00
-# port_2_address_ff:ff:ff:ff:ff:ff_off
-#
-# [sci_<0..ffffffffffffffff(hex)>_|port_<1..65535(dec)>_address_<00:00:00:00:00:00..ff:ff:ff:ff:ff:ff(hex)>_]sa_<0..3(dec)>_[pn_<1..4294967295(dec)>_][<on/off>_]key_<00..ff(hex)>_<00000000000000000000000000000000..ffffffffffffffffffffffffffffffff(hex)>
-#
-# sa_0_key_00_00000000000000000000000000000000
-# sa_1_key_pn_1_01_f00f00f00f00f00f00f00f00f00f00f0
-# sa_2_key_on_32_de_de00de00de00de00de00de00de00de00
-# sa_3_key_pn_16345_off_a1_fca1fca1fca1fca1fca1fca1fca1fca1
-# sci_0_sa_0_key_00_00000000000000000000000000000000
-# sci_32_sa_1_key_pn_1_01_f00f00f00f00f00f00f00f00f00f00f0
-# sci_451_sa_2_key_on_32_de_de00de00de00de00de00de00de00de00
-# sci_7438f_sa_3_key_pn_16345_off_a1_fca1fca1fca1fca1fca1fca1fca1fca1
-# port_1_address_00:00:00:00:00:00_sa_0_key_00_00000000000000000000000000000000
-# port_2_address_ff:ff:ff:ff:ff:ff_sa_1_key_pn_1_01_f00f00f00f00f00f00f00f00f00f00f0
-# port_3_address_00:00:00:ff:ff:ff_sa_2_key_on_32_de_de00de00de00de00de00de00de00de00
-# port_4_address_ff:ff:ff:00:00:00_sa_3_key_pn_16345_off_a1_fca1fca1fca1fca1fca1fca1fca1fca1
+# Add receive channels and/or receive association keys (RXSC), examples:
+#
+# "[sci <0..ffffffffffffffff(hex)>|port <1..65535(dec)> address <00:00:00:00:00:00..ff:ff:ff:ff:ff:ff(hex)>][ <on/off>]"
+#
+# "sci 0"
+# "sci ffffffffffffffff on"
+# "port 1 address 00:00:00:00:00:00"
+# "port 2 address ff:ff:ff:ff:ff:ff off"
+#
+# "[sci <0..ffffffffffffffff(hex)> |port <1..65535(dec)> address <00:00:00:00:00:00..ff:ff:ff:ff:ff:ff(hex)> ]sa <0..3(dec)> [pn <1..4294967295(dec)> ][<on/off> ]key <00..ff(hex)> <00000000000000000000000000000000..ffffffffffffffffffffffffffffffff(hex)>"
+#
+# "sci 0 sa 0 key 00 00000000000000000000000000000000"
+# "sci 32 sa 1 pn 1 key 01 f00f00f00f00f00f00f00f00f00f00f0"
+# "sci 451 sa 2 on key de de00de00de00de00de00de00de00de00"
+# "sci 7438f sa 3 pn 16345 off key a1 fca1fca1fca1fca1fca1fca1fca1fca1"
+# "port 1 address 00:00:00:00:00:00 sa 0 key 00 00000000000000000000000000000000"
+# "port 2 address ff:ff:ff:ff:ff:ff sa 1 pn 1 key 01 f00f00f00f00f00f00f00f00f00f00f0"
+# "port 3 address 00:00:00:ff:ff:ff sa 2 on key de de00de00de00de00de00de00de00de00"
+# "port 4 address ff:ff:ff:00:00:00 sa 3 pn 16345 off key a1 fca1fca1fca1fca1fca1fca1fca1fca1"
+#
+# IFRSC=("port 1 address 00:00:00:00:00:00 on"
+#        "port 1 address 00:00:00:00:00:00 sa 0 pn 1 on key 00 00000000000000000000000000000000"
+#        "sci ffffffffffff0001 on"
+#        "sci ffffffffffff0001 sa 0 pn 1 on key 00 ffffffffffffffffffffffffffffffff")
 IFRSC=()

-# Add trasmition association keys (TXSC) , examples:
-# sa_<0..3(dec)>_[pn_<1..4294967295(dec)>_][<on/off>_]key_<00..ff(hex)>_<00000000000000000000000000000000..ffffffffffffffffffffffffffffffff(hex)>
-#
-# sa_0_key_00_00000000000000000000000000000000
-# sa_1_key_pn_1_01_f00f00f00f00f00f00f00f00f00f00f0
-# sa_2_key_on_32_de_de00de00de00de00de00de00de00de00
-# sa_3_key_pn_16345_off_a1_fca1fca1fca1fca1fca1fca1fca1fca1
+# Add trasmition association keys (TXSC) , examples:
+# "sa <0..3(dec)> [pn <1..4294967295(dec)> ][<on/off> ]key <00..ff(hex)> <00000000000000000000000000000000..ffffffffffffffffffffffffffffffff(hex)>"
+#
+# "sa 0 key 00 00000000000000000000000000000000"
+# "sa 1 pn 1 key 01 f00f00f00f00f00f00f00f00f00f00f0"
+# "sa 2 on key de de00de00de00de00de00de00de00de00"
+# "sa 3 pn 16345 off key a1 fca1fca1fca1fca1fca1fca1fca1fca1"
+#
+# IFTSC=("sa 0 pn 1 on key 00 00000000000000000000000000000000")
 IFTSC=()

/etc/init.d/net_macsec


                         if [[ $IFRSC ]]; then
-                                for mac_rxsc in ${IFRSC[@]}; do
-                                        ip macsec add $IFDST rx ${mac_rxsc/_/ }
+                                for mac_rxsc in "${IFRSC[@]}"; do
+                                        ip macsec add $IFDST rx $mac_rxsc
                                 done
                         fi
                         if [[ $IFTSC ]]; then
-                                for mac_txsc in ${IFTSC[@]}; do
-                                        ip macsec add $IFDST tx ${mac_txsc/_/ }
+                                for mac_txsc in "${IFTSC[@]}"; do
+                                        ip macsec add $IFDST tx $mac_txsc
                                 done
                         fi

$ pacman -Si netifrc
Repository      : core
Name            : netifrc
Version         : 0.6.0-2.backports1
Description     : Network interface management scripts
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Netifrc
Licenses        : BSD2
Groups          : base
Provides        : None
Depends On      : eudev
Optional Deps   : iproute2: for interface handler, VPN, bridging and tunneling support (recommended)
                  net-tools: for interface handler support
                  bridge-utils: for bridging support
                  linux-atm: for CLIP and RFC 2684 bridge support
                  wpa_supplicant: for wireless networking support (recommended)
                  wireless_tools: for wireless networking support
                  dhcpcd: for DHCP support (recommended)
                  dhclient: for DHCP support
                  busybox: for DHCP support
                  iputils: for APIPA support
                  ifenslave: for bonding interfaces
                  ppp: for PPP and ADSL support (recommended)
                  rp-pppoe: for ADSL support
                  macchanger: for changing MAC addresses
                  ifplugd: for cable in/out detection
Conflicts With  : None
Replaces        : None
Download Size   : 66.18 KiB
Installed Size  : 373.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Tue 03 Jul 2018 12:16:13 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Boot “openrc” and/or start “net_{veth,macsec}” initscripts.
PackagesAnyBug ReportVery HighCritical [netifrc] "net.lo" initscript is forced to load in "boo ...Closed
100%
Task Description

Description:

  • “net.lo” initscript is forced to load in “boot” runlevel by default.
  • “loopback” interface doesn’t need changes.
  • “net.lo” initscript conflicts with another network services, like: NetworkManager.
  • “net.lo” initscript takes extra processor and memory resources when is useless.

Additional info:

  • netifrc 0.6.0-2.backports1
This file needs be removed:
* /etc/runlevels/boot/net.lo
$ pacman -Si netifrc
Repository      : core
Name            : netifrc
Version         : 0.6.0-2.backports1
Description     : Network interface management scripts
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Netifrc
Licenses        : BSD2
Groups          : base
Provides        : None
Depends On      : eudev
Optional Deps   : iproute2: for interface handler, VPN, bridging and tunneling support (recommended)
                  net-tools: for interface handler support
                  bridge-utils: for bridging support
                  linux-atm: for CLIP and RFC 2684 bridge support
                  wpa_supplicant: for wireless networking support (recommended)
                  wireless_tools: for wireless networking support
                  dhcpcd: for DHCP support (recommended)
                  dhclient: for DHCP support
                  busybox: for DHCP support
                  iputils: for APIPA support
                  ifenslave: for bonding interfaces
                  ppp: for PPP and ADSL support (recommended)
                  rp-pppoe: for ADSL support
                  macchanger: for changing MAC addresses
                  ifplugd: for cable in/out detection
Conflicts With  : None
Replaces        : None
Download Size   : 66.18 KiB
Installed Size  : 373.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Tue 03 Jul 2018 12:16:13 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Boot “openrc”.
  • Install and update [netifrc] package.
PackagesAnyBug ReportVery HighCritical [eudev] "udev" and "udev-trigger" initscripts are force ...Closed
100%
Task Description

Description:

  • “udev” initscript is loaded by “udev-trigger”.
  • “udev-trigger” is needed load on “boot” runlevel, not”sysinit” one.
  • “udev-trigger” initscript is forced to be added in the sysinit runlevel through upgrading package process
  • It avoids use “eudev” side-by-side with “vdev”.

Additional info:

  • eudev 3.2.5-2
This file need be removed:
* /etc/runlevels/sysinit/udev
This file needs to be changed in "boot" runlevel, not "sysinit" runlevel;
This file needs be included only in the installing process not updating one.
- /etc/runlevels/sysinit/udev-trigger
+ /etc/runlevels/boot/udev-trigger
$ pacman -Si eudev
Repository      : core
Name            : eudev
Version         : 3.2.5-2
Description     : The userspace dev tools (udev) forked by Gentoo, with OpenRC support
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:Eudev
Licenses        : GPL
Groups          : None
Provides        : udev
Depends On      : libeudev  kbd  kmod  hwids  util-linux
Optional Deps   : None
Conflicts With  : udev
Replaces        : udev
Download Size   : 931.20 KiB
Installed Size  : 7072.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 01 Jul 2018 01:26:17 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Boot “openrc”.
  • Install and update [eudev] package.
PackagesAnyBug ReportVery HighCritical [openrc] run "sysctl" initscript after "net" initscript Closed
100%
Task Description

Description:

  • “sysctl” initscript doesn’t set sysctl parameters on network interfaces.
  • “sysctl” initscript needs run “sysctl” initscript after “net” initscript.

Additional info:

  • openrc 0.28-18

/etc/init.d/sysctl


-        after clock
+        after clock net

$ pacman -Si openrc
Repository      : core
Name            : openrc
Version         : 0.28-18
Description     : A dependency based init system that works with the system provided init program
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Project:OpenRC
Licenses        : BSD2
Groups          : None
Provides        : None
Depends On      : psmisc  pam
Optional Deps   : netifrc: network interface management scripts
                  networkmanager: network connection manager and user applications
Conflicts With  : None
Replaces        : None
Download Size   : 193.18 KiB
Installed Size  : 1720.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 08 Jul 2018 01:28:16 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Boot “openrc”
PackagesAnySecurity IssueVery HighCritical [schroedinger] unmaintained and unsupportable Closed
100%
Task Description

Description:

  • Remove Schrödinger in Hyperbola because it’s unmaintained and unsupportable. [0] [1]
  • Note: It requires [ffmpeg], [ffmpeg2.8] and [gst-plugins-bad] rebuilding

Additional info:

  • schroedinger 1.0.11-3
$ pacman -Si schroedinger
Repository      : extra
Name            : schroedinger
Version         : 1.0.11-3
Description     : An implemenation of the Dirac video codec in ANSI C code
Architecture    : x86_64
URL             : https://launchpad.net/schroedinger
Licenses        : GPL2  LGPL2.1  MPL  MIT
Groups          : None
Provides        : None
Depends On      : orc  gcc-libs
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 331.64 KiB
Installed Size  : 1676.00 KiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Sat 05 Dec 2015 12:28:01 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

  • Contains security holes.
PackagesAnyReplace RequestDeferCritical[bzr] replace deprecated GNU Bazaar to BrezyDeferred
0%
Task Description

Description:

  • replace deprecated GNU Bazaar to Brezy for Canis Major

Additional info:

Note: It needs a provide: bazaar and brezy

Steps to reproduce:

  • broken package
PackagesAnyReplace RequestDeferCritical[python2] replace deprecated Python 2 to TauthonDeferred
0%
Task Description

Description:

  • replace deprecated Python 2 to Tauthon for Canis Major

Additional info:

Steps to reproduce:

  • Broken python2 packages.
PackagesAnyFeature RequestVery HighHigh [linux-libre-*] add missing installed kernel configurat ...Closed
100%
Task Description

Add missing /boot/config-linux-libre-* useful for applications such as Xen.

PackagesAnyFeature RequestVery HighHigh [kmod] add init file to load kernel modules from /etc f ...Closed
100%
Task Description

Add init file to load kernel modules in system configuration

Examples:

/etc/modules.conf
----
btrfs

/etc/modules.d/*.conf
----

/etc/modules.d/nouveau.conf
----
nouveau

/etc/init.d/modules
----
#!/usr/bin/openrc-run
command="/usr/bin/modprobe"
command_args="$(cat /etc/modules.{,d/*}conf)"

/etc/runlevels/boot/modules
PackagesAnyFeature RequestVery HighHigh [procps-ng] add init file to load sysctl configuration  ...Closed
100%
Task Description

Add init file to load sysctl configuration files

Examples:

/etc/init.d/sysctl
----
#!/usr/bin/openrc-run
command="/usr/bin/sysctl"
command_args="--system"
----
/etc/runlevels/boot/sysctl
PackagesAnyFeature RequestVery HighHigh [kmod] when dummy.ko is loaded, dummy0 interface is loa ...Closed
100%
Task Description

When dummy.ko (kernel module) is loaded, dummy0 interface is loaded as “numdummies=1”.
If any dummy interface is configured in netifrc config file, dummy module loads and adds undesirable “dummy0” interface
(eg. if “dummy0” interface is configured, it generates netifrc configuration conflicts).

Please add “/usr/lib/modprobe.d/dummy.conf” file configuration to disable numdummies option by default:

options dummy numdummies=0
PackagesAnyUpdate RequestVery HighHigh [babl] update package to v0.1.50 Closed
100%
Task Description

Description:

update package to v0.1.50 version
Note: Update [gegl] or Backport [gegl] and [gimp]
      https://issues.hyperbola.info/index.php?do=details&task_id=1052
      https://issues.hyperbola.info/index.php?do=details&task_id=1053
      https://issues.hyperbola.info/index.php?do=details&task_id=1054

Additional info:

babl 0.1.38-1.hyperbola1
$ pacman -Si babl
Repository      : extra
Name            : babl
Version         : 0.1.38-1.hyperbola1
Description     : Dynamic, any to any, pixel format conversion library
Architecture    : x86_64
URL             : http://gegl.org/babl/
Licenses        : LGPL3
Groups          : None
Provides        : None
Depends On      : glibc
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 237.72 KiB
Installed Size  : 734.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 05:31:32 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyUpdate RequestVery HighHigh [gegl] update package to 0.3.34 Closed
100%
Task Description

Description:

Update package to 0.3.34 version
Note: Update package to 0.3.34 version
      or update package to 0.4.2 backport and GIMP 2.10.2 backport
      Update [babl] package
      https://issues.hyperbola.info/index.php?do=details&task_id=1051
      https://issues.hyperbola.info/index.php?do=details&task_id=1053
      https://issues.hyperbola.info/index.php?do=details&task_id=1054

Additional info:

gegl 0.3.26-2.hyperbola1
$ pacman -Si gegl
Repository      : extra
Name            : gegl
Version         : 0.3.26-2.hyperbola1
Description     : Graph based image processing framework
Architecture    : x86_64
URL             : http://www.gegl.org/
Licenses        : GPL3  LGPL3
Groups          : None
Provides        : None
Depends On      : babl  libspiro  json-glib
Optional Deps   : libraw: raw plugin
                  openexr: openexr plugin
                  ffmpeg: ffmpeg plugin
                  suitesparse: matting-levin plugin
                  librsvg: svg plugin
                  jasper: jasper plugin
                  libtiff: tiff plugin
                  lua: lua plugin
                  lensfun: lens-correct plugin
Conflicts With  : gegl02
Replaces        : gegl02
Download Size   : 1347.15 KiB
Installed Size  : 6823.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 05:37:41 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyBackport RequestVery HighHigh [gegl] update package to 0.4.2 backport Closed
100%
Task Description

Description:

Update package to 0.4.2 backport version
Note: Is needed by GIMP 2.10.2 backport or update [gegl] to 0.3.34
      Update the [babl] package
      https://issues.hyperbola.info/index.php?do=details&task_id=1051
      https://issues.hyperbola.info/index.php?do=details&task_id=1052
      https://issues.hyperbola.info/index.php?do=details&task_id=1054

Additional info:

gegl 0.3.26-2.hyperbola1
$ pacman -Si gegl
Repository      : extra
Name            : gegl
Version         : 0.3.26-2.hyperbola1
Description     : Graph based image processing framework
Architecture    : x86_64
URL             : http://www.gegl.org/
Licenses        : GPL3  LGPL3
Groups          : None
Provides        : None
Depends On      : babl  libspiro  json-glib
Optional Deps   : libraw: raw plugin
                  openexr: openexr plugin
                  ffmpeg: ffmpeg plugin
                  suitesparse: matting-levin plugin
                  librsvg: svg plugin
                  jasper: jasper plugin
                  libtiff: tiff plugin
                  lua: lua plugin
                  lensfun: lens-correct plugin
Conflicts With  : gegl02
Replaces        : gegl02
Download Size   : 1347.15 KiB
Installed Size  : 6823.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 05:37:41 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyBackport RequestVery HighHigh [gimp] update package to 2.10.2 backport Closed
100%
Task Description

Description:

Update package to 2.10.2 backport version
Note: Needs [gegl] 0.4.2 and [babl] 0.1.50
      or update [gegl] 0.3.34 only
      Update the [babl] package
      https://issues.hyperbola.info/index.php?do=details&task_id=1051
      https://issues.hyperbola.info/index.php?do=details&task_id=1052
      https://issues.hyperbola.info/index.php?do=details&task_id=1053

Additional info:

gimp 2.8.22-1.hyperbola1
Repository      : extra
Name            : gimp
Version         : 2.8.22-1.hyperbola1
Description     : GNU Image Manipulation Program, with gegl and libxslt support
Architecture    : x86_64
URL             : https://www.gimp.org/
Licenses        : GPL  LGPL
Groups          : None
Provides        : None
Depends On      : pygtk  lcms  libxpm  libwmf  libxmu  librsvg  libmng  dbus-glib  libexif  gegl  jasper  desktop-file-utils  hicolor-icon-theme  babl  openexr
                  libgudev
Optional Deps   : gutenprint: for sophisticated printing only as gimp has built-in cups print support
                  poppler-glib: for pdf support
                  alsa-lib: for MIDI event controller module
                  curl: for URI support
                  ghostscript: for postscript support
Conflicts With  : gimp-devel
Replaces        : None
Download Size   : 12.12 MiB
Installed Size  : 67.73 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 08:42:46 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
PackagesAnyUpdate RequestVery HighHigh [krita] update to 3.1.4 version Closed
100%
Task Description

Description:

Update to 3.1.4 version

Additional info:

krita 3.1.3
$ pacman -Qi krita
Name            : krita
Version         : 3.1.3-1
Description     : Edit and paint images
Architecture    : x86_64
URL             : http://krita.org
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : kio  kitemmodels  gsl  libraw  exiv2  openexr  fftw  curl  boost-libs  hicolor-icon-theme
Optional Deps   : poppler-qt5: PDF filter [installed]
                  ffmpeg: to save animations [installed]
                  opencolorio: for the LUT docker [installed]
Required By     : None
Optional For    : None
Conflicts With  : calligra-krita  krita-l10n
Replaces        : calligra-krita  krita-l10n
Installed Size  : 112.43 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Fri 28 Apr 2017 07:57:59 AM -03
Install Date    : Tue 12 Sep 2017 03:28:32 AM -03
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Steps to reproduce:
contains some bugs

PackagesAnyFeature RequestVery HighHigh [evolution-data-server] contains systemd unit files Closed
100%
Task Description

Description:

  • The Arch version of Evolution from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the Init Freedom Campaign , systemd unit files removal is required. OpenRC init script replacement isn’t possible here because Evolution is using a systemd unit file adapted for users instead of system users.

Additional info:

  • evolution-data-server 3.24.1-3.hyperbola1
$ pacman -Si evolution-data-server
Repository      : extra
Name            : evolution-data-server
Version         : 3.24.1-3.hyperbola1
Description     : Centralized access to appointments and contacts, without libgdata support
Architecture    : x86_64
URL             : https://wiki.gnome.org/Apps/Evolution
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : gnome-online-accounts  nss  krb5  libgweather  libical  db  libphonenumber
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 3.56 MiB
Installed Size  : 33.38 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Fri 12 May 2017 06:28:24 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
/usr/lib/systemd/user/evolution-addressbook-factory.service is owned by evolution-data-server 3.24.1-3.hyperbola1
/usr/lib/systemd/user/evolution-calendar-factory.service is owned by evolution-data-server 3.24.1-3.hyperbola1
/usr/lib/systemd/user/evolution-source-registry.service is owned by evolution-data-server 3.24.1-3.hyperbola1
/usr/lib/systemd/user/evolution-user-prompter.service is owned by evolution-data-server 3.24.1-3.hyperbola1

Steps to reproduce:

  • Install package.
PackagesAnyFeature RequestVery HighHigh [gnome-terminal] contains systemd unit file Closed
100%
Task Description

Description:

  • The Arch version of GNOME Terminal Emulator from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the Init Freedom Campaign , systemd unit files removal is required. OpenRC init script replacement isn’t possible here because GNOME Terminal Emulator is using a systemd unit file adapted for users instead of system users.

Additional info:

  • gnome-terminal 3.24.1-1.hyperbola1
$ pacman -Si gnome-terminal
Repository      : extra
Name            : gnome-terminal
Version         : 3.24.1-1.hyperbola1
Description     : The GNOME Terminal Emulator
Architecture    : x86_64
URL             : https://wiki.gnome.org/Apps/Terminal
Licenses        : GPL
Groups          : gnome
Provides        : None
Depends On      : vte3  gsettings-desktop-schemas  dconf
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 1012.67 KiB
Installed Size  : 7811.00 KiB
Packager        : Scott Adams <haricot@hyperbola.info>
Build Date      : Tue 06 Jun 2017 01:36:13 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
/usr/lib/systemd/user/gnome-terminal-server.service is owned by gnome-terminal 3.24.1-1.hyperbola1

Steps to reproduce:

  • Install package.
PackagesAnyFeature RequestVery HighHigh [tracker] contains systemd unit files Closed
100%
Task Description

Description:

  • The Arch version of Tracker from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the Init Freedom Campaign , systemd unit files removal is required. OpenRC init script replacement isn’t possible here because Tracker is using a systemd unit file adapted for users instead of system users.

Additional info:

  • tracker 1.12.0-2.hyperbola1
$ pacman -Si tracker
Repository      : extra
Name            : tracker
Version         : 1.12.0-2.hyperbola1
Description     : Desktop-neutral user information store, search tool and indexer
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/Tracker
Licenses        : GPL
Groups          : gnome
Provides        : None
Depends On      : libtracker-sparql=1.12.0-2.hyperbola1  libsecret  upower  libexif  exempi  poppler-glib  libgsf  enca  libiptcdata  libcue  libosinfo  libnm-glib
                  gtk3  libgxps  taglib  flac  libvorbis  totem-plparser  gst-plugins-base-libs  giflib  libgrss  gvfs
Optional Deps   : nautilus: edit files' tracker tags
Conflicts With  : None
Replaces        : None
Download Size   : 1142.60 KiB
Installed Size  : 8459.00 KiB
Packager        : Scott Adams <haricot@hyperbola.info>
Build Date      : Thu 08 Jun 2017 03:57:24 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
/usr/lib/systemd/user/tracker-extract.service is owned by tracker 1.12.0-2.hyperbola1
/usr/lib/systemd/user/tracker-miner-apps.service is owned by tracker 1.12.0-2.hyperbola1
/usr/lib/systemd/user/tracker-miner-fs.service is owned by tracker 1.12.0-2.hyperbola1
/usr/lib/systemd/user/tracker-miner-rss.service is owned by tracker 1.12.0-2.hyperbola1
/usr/lib/systemd/user/tracker-store.service is owned by tracker 1.12.0-2.hyperbola1
/usr/lib/systemd/user/tracker-writeback.service is owned by tracker 1.12.0-2.hyperbola1

Steps to reproduce:

  • Install package.
PackagesAnyFeature RequestVery HighHigh [vino] contains systemd unit file Closed
100%
Task Description

Description:

  • The Arch version of Vino from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the Init Freedom Campaign , systemd unit files removal is required. OpenRC init script replacement isn’t possible here because Vino is using a systemd unit file adapted for users instead of system users.

Additional info:

  • vino 3.22.0-1.hyperbola1
$ pacman -Si vino
Repository      : extra
Name            : vino
Version         : 3.22.0-1.hyperbola1
Description     : A VNC server for the GNOME desktop
Architecture    : x86_64
URL             : https://wiki.gnome.org/Projects/Vino
Licenses        : GPL
Groups          : gnome
Provides        : None
Depends On      : libnotify  libxtst  libsm  telepathy-glib  gtk3  libsecret  avahi  gnutls
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 368.24 KiB
Installed Size  : 2723.00 KiB
Packager        : Scott Adams <haricot@hyperbola.info>
Build Date      : Fri 09 Jun 2017 02:01:33 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
/usr/lib/systemd/user/vino-server.service is owned by vino 3.22.0-1.hyperbola1

Steps to reproduce:

  • Install package.
Showing tasks 1 - 50 of 157 Page 1 of 41 - 2 - 3 - 4 -

Available keyboard shortcuts

Tasklist

Task Details

Task Editing