Packages

Category Task Type  asc Priority Severity Summary Status Progress
TestingBug ReportMediumMedium[xfontsel] Problem with font handlingUnconfirmed
0%
Task Description

Description: Bug related to the font handling under Hyperbola. xfontsel doesn’t list the PCF bitmapped fonts, which are used for some legacy tools with Motif/Athena for instance. If you want to use a font with good coverage of symbols (misc fixed 10×20 iso10646-1) under DDD (for accented/non ASCII characters), you can’t, you are restricted to ASCII 9×15 fonts.

Additional info:
This error happens even if all -meta font meta-packages are installed.

AnyBug ReportMediumLow firejail: mpv.profile fails to work  Closed
100%
Task Description

Users trying to use firejail against mpv experience errors such as:

[ytdl_hook] AVideo failed, trying to play URL directly ...
[ffmpeg] tls: The TLS connection was non-properly terminated.
Failed to recognize file format.

The error is caused by not having avideo whitelisted in firejail.

StableBug ReportVery LowLow [lightdm] Wrong locale displayed Closed
100%
Task Description

On a fresh install, the system wide locale is not working with lightdm.
According to https://wiki.archlinux.org/index.php/LightDM#Wrong_locale_displayed

One needs to set the LANG variable in /etc/environment to have lightdm in desired language.

Example :

LANG=pt_PT.utf8

Could it be possible to implement a mechanism to automatically add the LANG variable set in /etc/locale.conf to /etc/environement when one install lightdm ?

It is not technically a bug but it could be handy to new users.

AnyBug ReportVery LowLow [remmina] impossible to connect to RDP servers after re ...Closed
100%
Task Description

remmina dev ask to inform package maintainer, here is the discussion:

https://github.com/FreeRDP/Remmina/issues/1513#issuecomment-373128671

Would be nice to update or add a patch if available

StableBug ReportVery LowLow Mupen64plus acts buggy Closed
100%
Task Description

the screen moves back and forth from left to right randomly, no matter what I do, any games any adapters do not work.

I wanted to have some fun with some old games...

Has anyone used mupen64plus successfully on hyperbola 0.2? I cannot get it to work without being completely confusing for the reasons I have mentioned and also, the glaring of the screen. Which only happens with mupen64plus...

AnyBug ReportVery LowLow [openrc] agetty.tty loads in default runlevel only and  ...Closed
100%
Task Description

agetty.tty services need be loaded in default and nonetwork runlevels, not default runlevel only.

Example:

          agetty.tty1 |      default nonetwork  # it's correct, since **agetty.tty1** should be enabled in **nonetwork** runlevel for specific cases such as a maintenance.
          agetty.tty1 |      default           # it's wrong, since it contains **default** runlevel only

agetty.tty symlinks from /etc/init.d/ need be linked to agetty instead of /etc/init.d/agetty.

Example:

agetty.tty1 -> /etc/init.d/agetty # it's a valid symlink, however is wrong because should be linked to agetty directly
agetty.tty1 -> agetty                       # correct symlink
AnyBug ReportVery HighLow [filesystem] the hyperbola manual (/usr/share/man/man7/ ...Closed
100%
Task Description

The hyperbola manual (/usr/share/man/man7/hyperbola.7.gz), the command “ln” is inverted:

ln -s /etc/localtime /usr/share/zoneinfo/Europe/Paris # wrong
ln -s /usr/share/zoneinfo/Europe/Paris /etc/localtime # correct
AnyBug ReportLowLow [x11vnc] service contains error: "Service 'x11vnc' need ...Closed
100%
Task Description

x11vnc service has been imported from Gentoo, however it forces use xdm service when it should be optional since there are users don’t like use xdm to run DMs. Also, Hyperbola contains another services alternatives such as gdm, lightdm, lxdm, sddm and slim to run directly without xdm.

AnyBug ReportVery LowLow [gimp] [gegl] Module '/usr/lib/gegl-0.3/lens-correct.so ...Closed
100%
Task Description

admin→ gimp IMG_20170909_153350828.jpg
GEGL-Message: Module ‘/usr/lib/gegl-0.3/lens-correct.so’ load error: liblensfun.so.1: cannot open shared object file: No such file or directory
GEGL-Message: Module ‘/usr/lib/gegl-0.3/matting-levin.so’ load error: libumfpack.so.5: cannot open shared object file: No such file or directory

(gimp:12519): GLib-GObject-WARNING **: g_object_set_valist: object class ‘GeglConfig’ has no property named ‘cache-size’

Those are errors I get when running Gimp.

AnyBug ReportDeferLow [texlive-most] Cannot remove from system Closed
100%
Task Description
admin-> sudo pacman -R texlive-most
checking dependencies...
:: ghostscript optionally requires texlive-core: needed for dvipdf
:: inkscape optionally requires texlive-core: latex formulas

Packages (15) texlive-bibtexextra-2016.43765-1  texlive-core-2016.43757-1.hyperbola2  texlive-fontsextra-2016.43763-1.hyperbola2  texlive-formatsextra-2016.41438-3  texlive-games-2016.43415-1
              texlive-genericextra-2016.43605-1  texlive-htmlxml-2016.43769-1  texlive-humanities-2016.43711-1  texlive-latexextra-2016.43768-1.hyperbola2  texlive-music-2016.43375-1
              texlive-pictures-2016.43767-1  texlive-plainextra-2016.43137-1  texlive-pstricks-2016.43710-1  texlive-publishers-2016.43764-1  texlive-science-2016.43747-1

Total Removed Size:  1300.90 MiB

:: Do you want to remove these packages? [Y/n] y
:: Processing package changes...
( 1/15) removing texlive-science                                                                                     [######################################################################] 100%
( 2/15) removing texlive-publishers                                                                                  [######################################################################] 100%
( 3/15) removing texlive-pstricks                                                                                    [######################################################################] 100%
( 4/15) removing texlive-plainextra                                                                                  [######################################################################] 100%
( 5/15) removing texlive-pictures                                                                                    [######################################################################] 100%
( 6/15) removing texlive-music                                                                                       [######################################################################] 100%
( 7/15) removing texlive-humanities                                                                                  [######################################################################] 100%
( 8/15) removing texlive-latexextra                                                                                  [######################################################################] 100%
( 9/15) removing texlive-htmlxml                                                                                     [######################################################################] 100%
(10/15) removing texlive-genericextra                                                                                [######################################################################] 100%
(11/15) removing texlive-games                                                                                       [######################################################################] 100%
(12/15) removing texlive-formatsextra                                                                                [######################################################################] 100%
(13/15) removing texlive-fontsextra                                                                                  [######################################################################] 100%
(14/15) removing texlive-bibtexextra                                                                                 [######################################################################] 100%
(15/15) removing texlive-core                                                                                        [######################################################################] 100%
warning: /etc/texmf/web2c/fmtutil.cnf saved as /etc/texmf/web2c/fmtutil.cnf.pacsave
:: Running post-transaction hooks...
(1/3) Updating TeXLive filename database...
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/bin:/usr/bin/share/texmf-local/web2c:/usr/bin/share/texmf-dist/web2c:/usr/bin/share/texmf/web2c:/usr/bin/texmf-local/web2c:/usr/bin/texmf-dist/web2c:/usr/bin/texmf/web2c:/usr:/usr/share/texmf-local/web2c:/usr/share/texmf-dist/web2c:/usr/share/texmf/web2c:/usr/texmf-local/web2c:/usr/texmf-dist/web2c:/usr/texmf/web2c://texmf-local/web2c:/://share/texmf-local/web2c://share/texmf-dist/web2c://share/texmf/web2c://texmf-local/web2c://texmf-dist/web2c://texmf/web2c.
/usr/share/libalpm/scripts/mktexlsr: line 4: /usr/bin/mtxrun: No such file or directory
(2/3) Updating TeXLive format files...
cp: cannot stat 'usr/share/texmf-dist/web2c/fmtutil-hdr.cnf': No such file or directory
cat: 'var/lib/texmf/arch/installedpkgs/*.fmts': No such file or directory
/usr/share/libalpm/scripts/texlive-fmtutil: line 18: /usr/bin/fmtutil-sys: No such file or directory
error: command failed to execute correctly
(3/3) Updating TeXLive font maps...
cp: cannot stat 'usr/share/texmf-dist/web2c/updmap-hdr.cfg': No such file or directory
cat: 'var/lib/texmf/arch/installedpkgs/*.maps': No such file or directory
/usr/share/libalpm/scripts/texlive-updmap: line 12: /usr/bin/updmap-sys: No such file or directory
error: command failed to execute correctly
[~]
TestingBug ReportMediumLow [iceweasel-uxp] strange bug in the FindBar when a phras ...Closed
100%
Task Description

Description:
There is a strange bug (white rectangle) in the FindBar when a phrase isn’t found.

Additional info:
* package version(s): 52.9.0_20180601-3

Steps to reproduce:
Go to Edit > Find

Then put a phrase in the FindBar to search it in any page, if it isn’t found, appears a strange “white rectangle” covering the phrase.

TestingBug ReportVery LowLow [iceweasel-uxp] minor issues in "About Iceweasel-UXP" w ...Closed
100%
Task Description

Description:
“About Iceweasel-UXP” window contains some minor issues to be fixed:

  • “Iceweasel-UXP” instead of “Iceweasel” because we are a different project.
  • “Hyperbola Project” instead of “the Hyperbola Project” as link to point to Hyperbola site.
  • “for Iceweasel-UXP application” instead of “for Iceweasel rebranding” because we are maintaining an entire application, not just rebranding.

Additional info:
* package version(s): 52.9.0_20180601-3

Steps to reproduce:
Go to Help > About Iceweasel-UXP

AnyBug ReportVery LowLow [lbreakout2]: Write permission for '/var/games/lbreakou ...Closed
100%
Task Description

Description:

This game cannot start:

admin→ lbreakout2
LBreakout2 2.6.5
Copyright 2001-2011 Michael Speck
Published under GNU GPL — Looking up data in: /usr/share/lbreakout2
Looking up highscores in: /var/games/lbreakout2
Looking up custom levels in: /home/admin/.lgames/lbreakout2-levels
Loading theme ‘AbsoluteB’ Write permission for ‘/var/games/lbreakout2/lbreakout2.hscr’ denied.
Unable to access highscore chart in ‘/var/games/lbreakout2’.
Trying to use config directory ‘/home/admin/.lgames’.
Saving highscore chart in: /home/admin/.lgames
Client finalized
GUI finalized
Audio finalized
STK finalized
SDL finalized

yet nothing is visible (just black screen and mouse)
and permissions are incorrect.

TestingBug ReportMediumLow [iceweasel-uxp] XML Parsing Error: undefined entity in  ...Closed
100%
Task Description

Description:
There’s a XML parsing error in Iceweasel-UXP when it’s accessing a non-existent site or about:help

Additional info:
* package version(s): 52.9.0_20180601-7
* config and/or log files etc:

XML Parsing Error: undefined entity Location: jar:file:///usr/lib/iceweasel-uxp/browser/omni.ja!/chrome/browser/content/browser/aboutNetError.xhtml Line Number 22, Column 12:
    <title>&loadError.label;</title>
-----------^

Steps to reproduce:

  • Install Iceweasel-UXP:
    # pacman -S iceweasel-uxp
  • Run Iceweasel-UXP:
    ~ iceweasel-uxp
  • Type about:help or a non-existent site in the address bar
TestingBug ReportMediumLow [iceweasel-uxp] XML Parsing Error: undefined entity in  ...Closed
100%
Task Description

Description:
There’s a XML parsing error in Iceweasel-UXP when it’s accessing in a feed subscription.

Additional info:
* package version(s): 52.9.0_20180601-7
* config and/or log files etc:

XML Parsing Error: undefined entity Location: jar:file:///usr/lib/iceweasel-uxp/browser/omni.ja!/chrome/browser/content/browser/feeds/subscribe.xhtml Line Number 25, Column 12:
    <title>&feedPage.title;</title>
-----------^

Steps to reproduce:

  • Install Iceweasel-UXP:
    # pacman -S iceweasel-uxp
  • Run Iceweasel-UXP:
    ~ iceweasel-uxp
  • Enter to Hyperbola RSS Feeds page and then subscribe in one of feeds available.
TestingBug ReportMediumLow [xf86-video-intel] context menu not being highlighted i ...Closed
100%
Task Description

Description:
Context menu not being highlighted in UXP applications such as Iceweasel-UXP. This issue is generated in machines with i915 graphic cards using the Intel graphics driver .

Additional info:
* package version(s): 52.9.0_20180601-7

Steps to reproduce:

  • Install Iceweasel-UXP:
    # pacman -S iceweasel-uxp
  • Run Iceweasel-UXP:
    ~ iceweasel-uxp
  • Open new tabs with right click to use context menu.
StableBug ReportVery LowLow [iceweasel-uxp] info box not translated Closed
100%
Task Description

Hello,

With iceweasel-uxp, some info boxes are not translated, for now I noticed that when the mouse cursor hovers “add tab” element, the info box showing up is still using english (although I’m using French and the rest is ok), this is very, very minor issue I know.. :o)

See picture attached

AnyBug ReportMediumLow [octopi] contains systemd unit file Closed
100%
Task Description

Description:

  • The current Octopi version has been fixed to support OpenRC in Hyperbola, however it includes its official systemd unit file yet.

Additional info:
* package version(s)

  • 0.9.0-1.hyperbola1.backports1

* config and/or log files etc.

/usr/lib/systemd/system/octopi.service is owned by octopi 0.9.0-1.hyperbola1.backports1

Steps to reproduce:

  • Install package.
StableBug ReportVery LowLow [octopi][octopi-notifier] "Aborting notifier as 'pacman ...Closed
100%
Task Description

Hello,

octopi-notifier is not starting / running on my system, when I try to run it manually in a terminal, here is the output :

Aborting notifier as 'pacmanhelper' DBus service could not be found! [ "/usr/share/dbus-1/system-services/org.octopi.pacmanhelper.service" ]

I don’t know if this is applicable / related but I found this on aur website : https://aur.archlinux.org/packages/octopi/

kikadf :

Default build octopi-notifier without knotifications support. To enable edit PKGBUILD, uncomment #USE_NOTIFIER='1'

PS : I’m using XFCE4 autostart to start octopi-notifier (See screenshot attached)

AnyBug ReportLowLow [usbutils] lsusb does not list device names Closed
100%
Task Description

Description:

lsusb does not resolve device names from /var/lib/usbutils/usb.ids

The same thing as described here: https://unix.stackexchange.com/questions/220759/lsusb-doesnt-list-device-names

AnyBug ReportVery LowLow [zathura-pdf-poppler] unable to process apostrophes di ...Closed
100%
Task Description

Description:
Something is wrong with the latest version packaged in Hyperbola. zathura-pdf-poppler is unable to process apostrophes displayed in pdf bookmarks.

Steps to reproduce:
Open any pdf file which has a summary included, then hit `Tab` to display the summary. Instead of apostrophes, zathura-pdf-poppler displays html entities while the output of zathura-pdf-mupdf is correct.

AnyBug ReportLowLow [emacs-nox] uses "nox" suffix Closed
100%
Task Description

Description:

  • Fix package name to emacs-headless that is the correct name for packages without graphical user interface support. nox suffix is incorrect because Hyperbola supports Wayland too, not only X.Org.

Additional info:
* package version(s)

  • 25.2-1

* config and/or log files etc.

Steps to reproduce:

  • None
AnyBug ReportLowLow [erlang-nox] uses "nox" suffix Closed
100%
Task Description

Description:

  • Fix package name to erlang-headless that is the correct name for packages without graphical user interface support. nox suffix is incorrect because Hyperbola supports Wayland too, not only X.Org.

Additional info:
* package version(s)

  • 19.3-3

* config and/or log files etc.

Steps to reproduce:

  • None
AnyBug ReportLowLow [qbittorrent-nox] uses "nox" suffix Closed
100%
Task Description

Description:

  • Fix package name to qbittorrent-headless that is the correct name for packages without graphical user interface support. nox suffix is incorrect because Hyperbola supports Wayland too, not only X.Org.

Additional info:
* package version(s)

  • 3.3.11-1

* config and/or log files etc.

Steps to reproduce:

  • None
AnyBug ReportLowLow [crystal] error build Invidious Closed
100%
Task Description

Description:

crystal build src/invidious.cr –release

Error in src/invidious.cr:19: while requiring "kemal"

require "kemal"
^

in lib/kemal/src/kemal.cr:4: while requiring "./kemal/*"

require "./kemal/*"
^

in lib/kemal/src/kemal/config.cr:26: expanding macro

    property static_headers : (HTTP::Server::Response, String, File::Info -> Void)?
    ^~~~~~~~

in lib/kemal/src/kemal/config.cr:26: expanding macro

    property static_headers : (HTTP::Server::Response, String, File::Info -> Void)?
    ^

in macro 'property' expanded macro: macro_48177600:567, line 4:

   1.       
   2.         
   3.           
>  4.             @static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil
   5. 
   6.             def static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil
   7.               @static_headers
   8.             end
   9. 
  10.             def static_headers=(@static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil)
  11.             end
  12.           
  13.         
  14.       
  15.     

undefined constant File::Info

Additional info:
* package version(s)

Crystal 0.22.0 (2017-04-22) LLVM 4.0.0

Steps to reproduce:

StableBug ReportVery LowLow GNOME cannot lock screen while using LightDM Closed
100%
AnyBug ReportVery LowLow marble-qt: doesn't look like a valid Marble plugin: "/ ...Closed
100%
AnyBug ReportVery LowLow [openssl-1.0] Newer version required for plowshare MEGA ...Closed
100%
AnyBug ReportVery LowLow [pacman] warnings after migration Closed
100%
StableBug ReportVery LowLow Chemical uknown media types Closed
100%
StableBug ReportVery LowLow [autofs]: default configuration is /etc/auto.master ins ...Closed
100%
AnyBug ReportLowLow [xdg-utils] doesn't work with -uxp applications and has ...Closed
100%
AnyBug ReportVery LowLow Xenocara xbacklight bug Closed
100%
AnyBug ReportVery LowLow lightdm/lxdm bug Closed
100%
StableBug ReportVery LowLow [dhcpcd-ui] Adding icons from "Network-Manager Applet" Closed
100%
AnyBug ReportVery LowLow [hypervideo] "HTTP Error 403: Forbidden" error on some  ...Closed
100%
AnyBug ReportVery LowLow [Hyperbola GNU/Linux-libre 0.4] Testing Lumina - lumina ...Closed
100%
AnyBug ReportVery LowVery Low [ntfs-3g] ldconfig: File [...] is empty, not checked Closed
100%
StableBug ReportVery LowVery Low Gajim "Unable to run gpg - it may not be available"  Closed
100%
StableBug ReportVery LowVery Low[spamassassin] has different directory permissions than...Deferred
0%
StableBug ReportVery LowVery Low[postfix] has different directory permissions than 'fil...Deferred
0%
StableBug ReportVery LowVery Low[fail2ban] update dovecot failregex to support verbose ...Unconfirmed
0%
TestingBug ReportVery LowVery Low [Hyperbola GNU/Linux-libre 0.4] [wine-stable] doesn't r ...Closed
100%
AnyDrop RequestVery HighCritical [cgmanager] unmaintained and unsupportable Closed
100%
AnyDrop RequestVery HighCritical [pm-utils] unmaintained and unsupportable Closed
100%
StableDrop RequestVery LowCritical [osdbattery] Unmaintained and unsupportable Closed
100%
AnyDrop RequestHighHigh [devtools] remove this package Closed
100%
AnyDrop RequestHighHigh [ssmtp] remove obsolete package Closed
100%
AnyDrop RequestVery LowMedium [hardening-wrapper] deprecated, not needed anymore Closed
100%
AnyDrop RequestMediumMedium [gksu] is replaced and has to be deleted from our pacma ...Closed
100%
Showing tasks 251 - 300 of 1516 Page 6 of 31

Available keyboard shortcuts

Tasklist

Task Details

Task Editing