Packages

Category Task Type  asc Priority Severity Summary Status Progress
StableBug ReportVery LowMedium PCManFM display different behavior Closed
100%
Task Description

Description:

The problem is pcmanfm is not showing any partitions on the left side. It only show Home Folder, Desktop, Applications, Filesystem and the ext. hdd. If I include dbus-launch pcmanfm -d command, it show the other partitions on the left side of window but not ext. hdd. The drive/partitions are not encrypted.
I do have dbus, gvfs & ntfs-3g installed and active services.

Additional info:
* package version(s)
PCManFM 1.2.5 - using LibFM ver. 1.2.5

Steps to reproduce:
Original install from the livecd with LXDE but I may run Openbox standalone and get the same behavior with either environment. I do not have this issue running other distros.

StableBug ReportMediumMedium [udisks2] Impossible to mount ISO or IMG file Closed
100%
Task Description

When I try to mount an ISO file or IMG file (with right-click, “open with disk image mounter” on XFCE4) it fails, the following error message appears :

GDBus.Error.org.freedesktop.UDisks2.Error.Failed: Error opening /dev/loop-control: No such file or directory (udisks-error-quark, 0)

Thanks for your help

AnyBug ReportVery LowMedium [mate-panel] country flags for keyboard layouts are mis ...Closed
100%
Task Description

After enabling show-flags via dconf-editor in org.mate.peripherals-keyboard-xkb.indicator the flags don’t show up. The simple workaround is to copy flags you want into ~/.icons/flags (after creating the directory) from here

https://github.com/linuxmint/flags/tree/master/usr/share/iso-flag-png

and then to reboot.

It seems to be this bug:

https://askubuntu.com/questions/1059324/how-to-show-current-keyboard-layout-on-mate-panel-as-country-flag/1059325#1059325

AnyBug ReportVery LowMedium [ffmpegthumbnailer] missing support for some media form ...Closed
100%
Task Description

ffmpegthumbnailer does not support some media formats since they do not appear in its configuration file ffmpegthumbnailer.thumbnailer which can be found in /usr/share/thumbnailers/. By editing the file ffmpegthumbnailer.thumbnailer one can add thumbnail support for embedded art in audio formats such as flac and mp3 (using the -m flag) and thumbnail support for webp (a new image format which iceweasel-uxp and gthumb support). I’m attaching my edited file (I just added a few common audio formats and webp and added the -m flag and removed the -f flag).

AnyBug ReportMediumMedium [iceweasel-uxp] animated webp files stop playing after  ...Closed
100%
Task Description

I converted a gif file to webp using gif2webp. The file plays back using vwebp but stops playing back after a few seconds when run in Iceweasel-UXP.

Here is a file you can test (made from Sintel):
https://coinsh.red/p/sintel.webp

AnyBug ReportMediumMedium [iceweasel-uxp] the option to choose languages for disp ...Closed
100%
Task Description

Description:

For a strange reason, the option to choose languages for displaying pages is missing in Iceweasel-UXP [0] while is available in Firefox 55 version and bellow. [1] [2]

Seems preferences were backported from Firefox 56 version or later because that option was removed in those versions. [3]

It affects websites such as https://my.virtualhosts.de/ that requires set it from browser.

Additional info:
* package version(s)

  • 52.9.20180905-2

* config and/or log files etc.

Steps to reproduce:

StableBug ReportLowMedium Garbled display with xfce4-terminal (terminfo) Closed
100%
Task Description

A very nasty bug I wasn’t able to find an answer to.
I compiled stuff (buildroot) using menuconfig, the menu display was fine in xfce4-terminal (See screenshot #1)
I restarted the config a few days later with the same command :

$ make menuconfig

and this time the display was messed up (See screenshot #2)

After investigation, I noticed a directory (filled with stuff) have been created in my home folder :

.terminfo

I don’t know why. But anyway, if I delete it, then the display is ok again.
I noticed that if I use good old xterm terminal, then the display is fine even if the .terminfo directory is present. (it uses “xterm” instead of xterm-256color)

But, with xfce4-terminal (and others, I tried with gnome-terminal, sakura..), the display is messed up if the .terminfo directory is present in my home folder.

I also noticed that if I run the command in a screen session, the issue is not present.

(I open xfce4-terminal)

$ screen
$ printenv TERM
screen.xterm-256color
$ make menuconfig (or htop, or other program using ncurses)

= display ok

but with default :

(I open xfce4-terminal)

$ printenv TERM
xterm-256color
make menuconfig (or htop, or other program using ncurses)

= display messed up if .terminfo directory is present

So I have no idea why this .terminfo directory is generated. What could trigger its generation ? Is that an issue with ncurses or something else ?

Thanks for your help

AnyBug ReportMediumMedium [hypervideo] remove "please report this issue" when hyp ...Closed
100%
Task Description

Description:

YouTube’s DRM has prevented this software from obtaining the video URL, please report this issue on https://issues.hyperbola.info/

The error is intentional when hypervideo fail to download DRM videos, so the specific part that says “please report this issue on https://issues.hyperbola.info/ should be removed in the next version.

Additional info:
* package version(s)

  • 1.0.2-1

* config and/or log files etc.

Steps to reproduce:

  • Download YouTube’s DRM videos
AnyBug ReportMediumMedium [linux-libre-lts] enable CONFIG_USER_NS Closed
100%
Task Description

Currently it’s not possible to enable “noroot” in firejail due to missing CONFIG_USER_NS in the kernel. This is a bug also in Arch.
https://github.com/netblue30/firejail/issues/1069

AnyBug ReportVery LowMedium addons compatible with seamonkey don't work with iceape ...Closed
100%
Task Description

Noscript, No Resource url leak, Random Agent Spoofer, Ublock Origin

Interestingly enough, HTTPS Always works with iceape-uxp and privacy settings and greasemonkey don’t work with either...

But I would like all of the above to work with iceape-uxp

StableBug ReportVery LowMedium Mouse curse become invisible from beginning in kde5 pla ...Closed
100%
Task Description

Description:
I install plasma and xorg to my Hyperbola GNU/Linux-libre in Arch-way.
However, after reboot, everything is fine except mouse curse.

I attempt to reinstall plasma-desktop and reboot. But nothing changes.

In attachment, the mouse stop at backward, however it is invisible.

Additional info:
* package version(s)
plasma-desktop == 5.9.5-1
xorg-server == 1.19.6-2.hyperbola1
sddm == 0.14.0-2.hyperbola6

* config and/or log files etc.

Steps to reproduce:

StableBug ReportVery LowMedium  [kodi] "The Movie Database" scraper doesn't work Closed
100%
Task Description

With kodi 17.1-2.hyperbola1 “The Movie Database” scraper doesn’t work. The error message is :

"Unable to connect to remote server"
AnyBug ReportVery LowMedium [hypervideo] YouTube no longer works Closed
100%
Task Description

When trying to download a video I get a token error.

Here is an example:

$ hypervideo https://www.youtube.com/watch?v=-2KJ-g-QgMk[youtube] -2KJ-g-QgMk: Downloading webpage
[youtube] -2KJ-g-QgMk: Downloading video info webpage
ERROR: -2KJ-g-QgMk: “token” parameter not in video info for unknown reason;

AnyBug ReportMediumMedium [adwaita-icon-theme] error when installing package Closed
100%
Task Description

Install the base system again in a pc, but when installing some packages there is the error that I describe below. I would ask please correct this problem since you can not install several programs, example: emacs, volumeicon, etc

invalid or corrupted package (PGP signature)).
error: adwaita-icon-theme: signature from “scott sradms0@openmailbox.org” is unknown trust
:: File /var/cache/pacman/pkg/adwaita-icon-theme-3.24.0-1.hyperbola1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

AnyBug ReportVery LowMedium [ rtkit ] contains systemd unit files Closed
100%
Task Description

Description:

The Arch version of tinc from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the Init Freedom Campaign , systemd unit files removal is required or add OpenRC init scripts to replace it.

Additional info:

pacman -Ql rtkit
rtkit /etc/
rtkit /etc/dbus-1/
rtkit /etc/dbus-1/system.d/
rtkit /etc/dbus-1/system.d/org.freedesktop.RealtimeKit1.conf
rtkit /usr/
rtkit /usr/bin/
rtkit /usr/bin/rtkitctl
rtkit /usr/lib/
rtkit /usr/lib/rtkit/
rtkit /usr/lib/rtkit/rtkit-daemon
rtkit /usr/share/
rtkit /usr/share/dbus-1/
rtkit /usr/share/dbus-1/interfaces/
rtkit /usr/share/dbus-1/interfaces/org.freedesktop.RealtimeKit1.xml
rtkit /usr/share/dbus-1/system-services/
rtkit /usr/share/dbus-1/system-services/org.freedesktop.RealtimeKit1.service
rtkit /usr/share/licenses/
rtkit /usr/share/licenses/rtkit/
rtkit /usr/share/licenses/rtkit/COPYING
rtkit /usr/share/licenses/rtkit/LICENSE
rtkit /usr/share/man/
rtkit /usr/share/man/man8/
rtkit /usr/share/man/man8/rtkitctl.8.gz
rtkit /usr/share/polkit-1/
rtkit /usr/share/polkit-1/actions/
rtkit /usr/share/polkit-1/actions/org.freedesktop.RealtimeKit1.policy

* package version(s)
rtkit 0.11-1.hyperbola1

* config and/or log files etc.

Jun 26 10:41:50 gnu mtp-probe: checking bus 1, device 8: “/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4”
Jun 26 10:41:50 gnu mtp-probe: bus: 1, device: 8 was not an MTP device
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu rtkit-daemon[3059]: Failed to look up client: No such file or directory
Jun 26 10:44:44 gnu pulseaudio[4401]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.bluez was not provided by any .service files

Steps to reproduce:

TestingBug ReportMediumMedium [ntop] useradd: the group "ntop" does not exist Closed
100%
Task Description

Description:

During the installation, a group error message is displayed.

Additional info:
* package version(s)

$ pacman -Si ntop
Repositorio               : community
Nombre                    : ntop
Versión                   : 5.0.1-11.hyperbola3
Descripción               : A network traffic probe that shows the network usage, with libressl and OpenRC support
Arquitectura              : x86_64
URL                       : https://www.ntop.org/
Licencias                 : GPL-3
Grupos                    : Nada
Provee                    : Nada
Depende de                : libevent  libpcap  gd  glibc libxml2  libressl  rrdtool  pcre geoip  lua  python2
Dependencias opcionales   : Nada
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 21,33 MiB
Tamaño de la instalación  : 48,51 MiB
Encargado                 : HyperBuilder
                            <hyperbuilder@hyperbola.info>
Fecha de creación         : mié 27 mar 2019 17:09:11 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

* config and/or log files etc.

$ ntop
Thu Jul 18 19:53:19 2019  Initializing gdbm databases
Thu Jul 18 19:53:19 2019  **ERROR** ....open of /var/lib/ntop/prefsCache.db failed: File open error
Thu Jul 18 19:53:19 2019  Possible solution: please use '-P <directory>'
Thu Jul 18 19:53:19 2019  **FATAL_ERROR** GDBM open failed, ntop shutting down...
Thu Jul 18 19:53:19 2019  CLEANUP[t140566150068416]: ntop caught signal 2 [state=2]
Thu Jul 18 19:53:19 2019  ntop is now quitting...

Steps to reproduce:

* Install package in Milky Way v0.3 Testing

TestingBug ReportMediumMedium [ardour] require re-build Closed
100%
Task Description

Description:

Ardour require rebuild in v0.3

Additional info:

Repositorio               : extra
Nombre                    : ardour
Versión                   : 5.8-1
Descripción               : Professional-grade digital audio workstation
Arquitectura              : x86_64
URL                       : http://ardour.org/
Licencias                 : GPL
Grupos                    : Nada
Provee                    : Nada
Depende de                : liblrdf  liblo  lilv  suil  taglib  aubio  rubberband  gtkmm
Dependencias opcionales   : xjadeo: video monitoring
                            harvid: video timeline
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 8,31 MiB
Tamaño de la instalación  : 38,16 MiB
Encargado                 : Rashif Rahman (Ray) <schiv@archlinux.org>
Fecha de creación         : mié 26 abr 2017 02:45:34 -05
Validado por              : Suma MD5  Suma SHA-256  Firma
$ ldd /usr/lib/ardour5/ardour-5.8.0 | grep 'not found'

	libardourcp.so => not found
	libcanvas.so.0 => not found
	libgtkmm2ext.so.0 => not found
	libptformat.so.0 => not found
	libardour.so.3 => not found
	libmidipp.so.4 => not found
	libevoral.so.0 => not found
	libaudiographer.so.0 => not found
	libpbd.so.4 => not found
	libtimecode.so => not found

Steps to reproduce:

* Install package in v0.3

AnyBug ReportVery LowMedium [hypervideo] YouTube downloads do not extract correct f ...Closed
100%
Task Description

See example:

hypervideo https://www.youtube.com/watch?v=3vpGZ69CBYM[youtube] 3vpGZ69CBYM: Downloading webpage
[youtube] 3vpGZ69CBYM: Downloading video info webpage
WARNING: Unable to extract video title
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[download] Destination: _-3vpGZ69CBYM.f137.mp4

AnyBug ReportVery LowMedium [clamtk] Gtk-WARNING **: Impossible to find the theme e ...Closed
100%
Task Description

Additional info:
* package version

Repositorio               : community
Nombre                    : clamtk
Versión                   : 5.24-1
Descripción               : Easy to use, light-weight, on-demand virus scanner for Linux
                            systems
Arquitectura              : any
URL                       : https://dave-theunsub.github.io/clamtk/
Licencias                 : GPL
Grupos                    : Nada
Provee                    : Nada
Depende de                : clamav  perl  gtk2-perl  perl-locale-gettext  perl-libwww
                            perl-http-message  perl-lwp-protocol-https  perl-text-csv
                            perl-json  python  zenity  desktop-file-utils  gnome-icon-theme
                            cron
Dependencias opcionales   : Nada
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 179,90 KiB
Tamaño de la instalación  : 1378,00 KiB
Encargado                 : Levente Polyak <anthraxx@archlinux.org>
Fecha de creación         : sáb 19 nov 2016 20:25:20 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

* config and/or log files etc.

$ clamtk
Gtk-WARNING **: Imposible encontrar el motor de temas en la ruta al _modulo: «clearlooks», at /usr/lib/perl5/vendor_perl/ClamTk/GUI.pm line 35.

Steps to reproduce:

* Install clamtk in all version

StableBug ReportVery LowMedium [arm-unknown-linux-gnueabi-gcc] not working; needs prop ...Closed
100%
Task Description

Description:
I believe the arm-unknown-linux-gnueabi-gcc package to be broken as described here.

Additional info:
* package version(s) - arm-unknown-linux-gnueabi-gcc - all versions

Steps to reproduce:
I don’t think “steps to reproduce” to be relevant in this case. My forum topic linked above already contains all the necessary info on the subject :) However, one could try compiling glibc and busybox as described here. Yes, these are instructions for debian-like systems. They have to be adapted accordingly

TestingBug ReportMediumMedium [qtcreator] requires libsystemd.so Closed
100%
Task Description

Description: The currently packaged version of QtCreator is built with SystemD support, and on v0.3 no longer works.

Steps to reproduce:

  • pacman -S qtcreator
  • qtcreator
  • All plugins fail to load
  • Receive following error message:

Cannot load plugin because dependency failed to load: ProjectExplorer(4.2.2)
Reason: /usr/lib/qtcreator/plugins/libProjectExplorer.so: Cannot load library /usr/lib/qtcreator/plugins/libProjectExplorer.so:
(libsystemd.so.0: cannot open shared object file: No such file or directory)

We need to see if it is possible to build binary without libsystemd.so or remove the package.

AnyBug ReportMediumMedium [sshfs] Can't mount share from desktop (FUSE2 issue) Closed
100%
Task Description

Since 0.3 release, i’m unable to mount my sshfs share from my desktop.

For reference, my fstab entry :

sshfs#anon@server:/srv/nfs/data /mnt/data fuse noauto,user,_netdev,x-gvfs-show,x-gvfs-name=data 0 0

When I double-click on the desktop icon (xfce), it says : “Impossible to mount data”

But, I’m able to mount the share if I enter the command manually in a terminal as user.

sshfs anon@server:/srv/nfs/data /mnt/data

So, it is not a problem of writing rights on mountpoint /mnt/data
I suspect an issue with fuse2 since it is a dependency of sshfs and it is in relation with mounting share from desktop.

AnyBug ReportVery LowMedium [slim] login screen not displaying correctly Closed
100%
Task Description

It worked fine on the previous version of Hyperbola. The word user/username does not show up. A workaround is to wait 10 seconds and enter the username and click enter - then it will switch correctly to the password screen (otherwise you need to enter the username and password at least twice in order to successfully login).

AnyBug ReportVery LowMedium [openrc] cannot load fuse at boot Closed
100%
Task Description

I added
<quote>modules=”fs-fuse”</quote>
to /etc/conf.d/modules (and also “fuse” instead).

I looked in /var/log/rc.log and I see this line

<quote>modprobe: FATAL: Module fs-fusetun not found in directory /lib/modules/4.9.194-gnu-1-lts</quote>

It looks like modprobe added “tun” to the filename which prevents loading the module.

AnyBug ReportVery LowMedium [exfat-utils] filesystem can only be mounted manually Closed
100%
Task Description

One can mount exfat by running commands such as “sudo modprobe fuse” and “sudo mount.exfat /dev/sdc1 /mnt/storage” but it is inconvenient.

Also, loading fuse at startup is problematic - see here:

https://issues.hyperbola.info/index.php?do=details&task_id=1433

StableBug ReportMediumMedium [ipython2] broken Closed
100%
StableBug ReportVery LowMedium [sshguard] violates Hyperbola packaging standards Closed
100%
StableBug ReportVery LowMedium [fail2ban] remove systemd integration Closed
100%
StableBug ReportVery LowMedium [fail2ban] uses old /usr/bin/sendmail location when it  ...Closed
100%
AnyBug ReportVery LowMedium [abiword] flickers Closed
100%
StableBug ReportVery LowMedium [postgrey] has systemd service and no OpenRC init scrip ...Closed
100%
AnyBug ReportVery LowMedium [hypervideo] soundcloud downloads display 401 unauthori ...Closed
100%
StableBug ReportVery LowMedium linphonec error (cli version) Closed
100%
StableBug ReportVery LowMedium Untrsuted gpg key Closed
100%
TestingBug ReportMediumMedium [Hyperbola GNU/Linux-libre 0.4] - Package [xscreensaver ...Closed
100%
StableBug ReportVery LowMedium nouveau_drv.so: undefined symbol: exaDriverAlloc Closed
100%
TestingBug ReportVery LowMedium [Hyperbola GNU/Linux-libre 0.4] [opensurge] has refused ...Closed
100%
AnyBug ReportVery LowMedium sndio doesn't autostart on all my comps... Closed
100%
TestingBug ReportMediumMedium [Hyperbola GNU/Linux 0.4] Problems with touch- / trackp ...Closed
100%
TestingBug ReportMediumMedium [Hyperbola GNU/Linux 0.4] Problems with ALSA and sndio  ...Closed
100%
TestingBug ReportMediumMedium [Hyperbola GNU/Linux-libre 0.4] - Package [android-file ...Closed
100%
TestingBug ReportVery LowMedium [adwaita-icon-theme] Most symbolic icons look brokenly  ...Closed
100%
TestingBug ReportVery LowMedium [Hyperbola GNU/Linux-libre 0.4] [numptyphysics] has cra ...Closed
100%
TestingBug ReportVery LowMedium [icu] needs to rebuild that should place genccode into  ...Closed
100%
TestingBug ReportVery LowMedium angband game Couldn't load the requested font.  Closed
100%
TestingBug ReportVery LowMedium widelands game shared library error Closed
100%
AnyBug ReportVery LowMedium wesnoth change language no works Closed
100%
TestingBug ReportVery LowMedium warzone2100 fail Closed
100%
AnyBug ReportMediumMedium [surf-2.1-1]: Unresolved dependencies Closed
100%
StableBug ReportVery LowMedium [yeahwm] has crashed that refused to initialize. Closed
100%
Showing tasks 201 - 250 of 1516 Page 5 of 31

Available keyboard shortcuts

Tasklist

Task Details

Task Editing