Packages

Category Task Type  asc Priority Severity Summary Status Progress
AnyBackport RequestVery HighCritical [netifrc] update package to 0.6.0 backport Closed
100%
Task Description

Description:

[netifrc] update package to 0.6.0 backport version

Fix security errors:

Fix errors:

Changes:

Features:



Note: Please add a extra hotfix patch from git:

Additional info:

netifrc 0.5.1-3
$ pacman -Si netifrc
Repository      : core
Name            : netifrc
Version         : 0.5.1-3
Description     : Network interface management scripts
Architecture    : x86_64
URL             : https://wiki.gentoo.org/wiki/Netifrc
Licenses        : BSD2
Groups          : base
Provides        : None
Depends On      : eudev
Optional Deps   : iproute2: for interface handler, VPN, bridging and tunneling support (recommended)
                  net-tools: for interface handler support
                  bridge-utils: for bridging support
                  linux-atm: for CLIP and RFC 2684 bridge support
                  wpa_supplicant: for wireless networking support (recommended)
                  wireless_tools: for wireless networking support
                  dhcpcd: for DHCP support (recommended)
                  dhclient: for DHCP support
                  busybox: for DHCP support
                  iputils: for APIPA support
                  ifenslave: for bonding interfaces
                  ppp: for PPP and ADSL support (recommended)
                  rp-pppoe: for ADSL support
                  macchanger: for changing MAC addresses
                  ifplugd: for cable in/out detection
Conflicts With  : None
Replaces        : None
Download Size   : 62.75 KiB
Installed Size  : 349.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Wed 24 Jan 2018 09:05:24 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

contains errors in 0.5.1 version
AnyBackport RequestVery HighHigh [gegl] update package to 0.4.2 backport Closed
100%
Task Description

Description:

Update package to 0.4.2 backport version
Note: Is needed by GIMP 2.10.2 backport or update [gegl] to 0.3.34
      Update the [babl] package
      https://issues.hyperbola.info/index.php?do=details&task_id=1051
      https://issues.hyperbola.info/index.php?do=details&task_id=1052
      https://issues.hyperbola.info/index.php?do=details&task_id=1054

Additional info:

gegl 0.3.26-2.hyperbola1
$ pacman -Si gegl
Repository      : extra
Name            : gegl
Version         : 0.3.26-2.hyperbola1
Description     : Graph based image processing framework
Architecture    : x86_64
URL             : http://www.gegl.org/
Licenses        : GPL3  LGPL3
Groups          : None
Provides        : None
Depends On      : babl  libspiro  json-glib
Optional Deps   : libraw: raw plugin
                  openexr: openexr plugin
                  ffmpeg: ffmpeg plugin
                  suitesparse: matting-levin plugin
                  librsvg: svg plugin
                  jasper: jasper plugin
                  libtiff: tiff plugin
                  lua: lua plugin
                  lensfun: lens-correct plugin
Conflicts With  : gegl02
Replaces        : gegl02
Download Size   : 1347.15 KiB
Installed Size  : 6823.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 05:37:41 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
AnyBackport RequestVery HighHigh [gimp] update package to 2.10.2 backport Closed
100%
Task Description

Description:

Update package to 2.10.2 backport version
Note: Needs [gegl] 0.4.2 and [babl] 0.1.50
      or update [gegl] 0.3.34 only
      Update the [babl] package
      https://issues.hyperbola.info/index.php?do=details&task_id=1051
      https://issues.hyperbola.info/index.php?do=details&task_id=1052
      https://issues.hyperbola.info/index.php?do=details&task_id=1053

Additional info:

gimp 2.8.22-1.hyperbola1
Repository      : extra
Name            : gimp
Version         : 2.8.22-1.hyperbola1
Description     : GNU Image Manipulation Program, with gegl and libxslt support
Architecture    : x86_64
URL             : https://www.gimp.org/
Licenses        : GPL  LGPL
Groups          : None
Provides        : None
Depends On      : pygtk  lcms  libxpm  libwmf  libxmu  librsvg  libmng  dbus-glib  libexif  gegl  jasper  desktop-file-utils  hicolor-icon-theme  babl  openexr
                  libgudev
Optional Deps   : gutenprint: for sophisticated printing only as gimp has built-in cups print support
                  poppler-glib: for pdf support
                  alsa-lib: for MIDI event controller module
                  curl: for URI support
                  ghostscript: for postscript support
Conflicts With  : gimp-devel
Replaces        : None
Download Size   : 12.12 MiB
Installed Size  : 67.73 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sun 31 Dec 2017 08:42:46 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

none
AnyBackport RequestVery HighHigh [tcpreplay] update package to 4.2.6 backport  Closed
100%
Task Description

Description:

Update package to 4.2.6 backport because of multiple security flaw and bugs

Additional info:
* current Hyperbola package version is 4.1.0-1 from December 2014

Example of fix from 4.1.0-1:

* AFL detected security crash in fuzz feature
* tcpcapinfo buffer overflow vulnerablily
* Buffer overflow bug in tcpprep

Steps to reproduce:

none

AnyBackport RequestVery HighHigh [nodejs] backporting to nodejs LTS 8.11.3 Closed
100%
Task Description

Description:

Hi dear developers of Hyperbola. I work in the field of web development. I use a lot of javascript and nodejs to compile.
Could they do the nodejs update?. I also mention this because Hyperbola works with LTS packages.

Additional info:

* package version(s)

$ sudo pacman -Si nodejs
Repositorio               : community
Nombre                    : nodejs
Versión                   : 7.10.0-1
Descripción               : Evented I/O for V8 javascript
Arquitectura              : x86_64
URL                       : http://nodejs.org/
Licencias                 : MIT
Grupos                    : Nada
Provee                    : Nada
Depende de                : openssl-1.0  zlib  icu  libuv  http-parser  c-ares
Dependencias opcionales   : npm: nodejs package manager
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 4,55 MiB
Tamaño de la instalación  : 18,49 MiB
Encargado                 : Felix Yan <felixonmars@archlinux.org>
Fecha de creación         : mié 03 may 2017 09:50:26 -05
Validado por              : Suma MD5  Suma SHA-256  Firma
$ sudo pacman -Si npm
Repositorio               : community
Nombre                    : npm
Versión                   : 4.5.0-1
Descripción               : A package manager for javascript
Arquitectura              : any
URL                       : https://www.npmjs.com/
Licencias                 : custom:Artistic
Grupos                    : Nada
Provee                    : nodejs-node-gyp
Depende de                : nodejs  semver
Dependencias opcionales   : python2: for node-gyp
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 2,72 MiB
Tamaño de la instalación  : 13,98 MiB
Encargado                 : Felix Yan <felixonmars@archlinux.org>
Fecha de creación         : mié 12 abr 2017 22:08:06 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

- NodeJS LTS (includes npm 5.6.0):

* https://nodejs.org/dist/v8.11.3/node-v8.11.3.tar.gz

* https://nodejs.org/dist/v8.11.3/SHASUMS256.txt.asc

Some errors that I suffer when compiling:
- https://stackoverflow.com/questions/46476741/nodejs-util-promisify-is-not-a-function

AnyBackport RequestVery LowMedium [iceweasel-uxp] Privacy Possum continuous support for I ...Closed
100%
Task Description

This is another addon I would like support indefinitely for Iceweasel-UXP:

It blocks etag tracking and other nasty forms of tracking.

But again, you would need to make the changes based on the newer versions only for legacy and without WebExt required of course.

StableBackport RequestVery LowMedium Zoom Page WE Backport Request Closed
100%
Task Description

Description: Zoom web pages either per-site or per-tab, with optional fit-to-width and minimum text size, using the toolbar button, context menu, keyboard shortcuts or mouse wheel.

Additional info: This extension can be used as a workaround to old Firefox bug: Set a Default Text Size (or Page Zoom Level) in Tools > Options > Content > Default Page Size - External Link

Steps to reproduce: N/A

StableBackport RequestMediumMedium [icedove-uxp] Lightning for Icedove-UXP Closed
100%
Task Description

Description: Thanks for the actual release of Icedove in combination with UXP. But for now support for Lightning / Iceowl is missing. Could you please add this package again, either within Icedove-UXP itself or as another addon compatible with UXP?

AnyBackport RequestVery LowMedium [iceowl] package request Closed
100%
Task Description

Or if you know a more libre calendar addon that is easy to use/reliable, feel free!

This is my only other package needed besides ublock origin/enigmail. :)

AnyBackport RequestLowMedium [docker] package request Closed
100%
Task Description

Please, package and backport the docker CE for Hyperbola Milky Way.

For reference, see the package docker in the Parabola.

AnyBackport RequestVery LowMedium [icedove-uxp] backport mail merge Closed
100%
Task Description

What I miss very much is “mail merge”. For example, I had to send 102 personalized emails to my students, as the term is beginning. The only way to do that was to revert to the previous non-uxp icedove.

But but immediately after that, I reinstalled icedove-uxp, of course!

AnyBackport RequestVery LowMedium [icedove-uxp] backport cardbook Closed
100%
Task Description

Another very useful addon is cardbook (or any equivalent) as it allows to work with remote calendars and contacts.

Actually, I don’t like to work with remote calendars or contacts. But some of my colleagues do. The only condition I set is to work with trustworthy providers using free software exclusively. But they do exist.

StableBackport RequestVery LowMedium Request for addon used by Iceweasel-UXP: uMatrix Closed
100%
Task Description

Hello, would it be possible to have the addon uMatrix ported to be used within the UXP-platform? The addon is complete open and can be found here https://github.com/gorhill/uMatrix

I’ve tried to install different versions and it seems to be incompatible with the concurrent version of Iceweasel-UXP from the repositoy.

AnyBackport RequestVery LowMedium Random Agent Spoofer for Iceape Closed
100%
Task Description

random_agent_spoofer-0.9.5.8.4-fx.xpi is the version I desire, can you implement it?

AnyBackport RequestVery LowMedium Greasemonkey For Iceape Closed
100%
Task Description

greasemonkey-3.31.4 version desired. I would love to see it implemented for Iceape

AnyBackport RequestVery LowMedium No Resource Url Leak for Iceape Closed
100%
Task Description

1.2.4 version would be nice for Iceape.

AnyBackport RequestVery LowLow Self Destructing Cookies for Iceape Closed
100%
Task Description

I would like this to be available for Iceape as well V4.13

AnyBackport RequestVery LowLow Ublock Origin for Iceape Closed
100%
Task Description

The version I desire is this: 1.16.4.6

AnyBackport RequestVery LowLow  elogind package Closed
100%
Task Description

Description:
Was wondering if there is any issue in terms of freedom andor privacy for the inclusion of elogind? Feedback will be apreciated Cheers.

this was recently implemented in gentoo.

source:
https://libregit.org/i3_relativism/elogind

references:
https://blogs.gentoo.org/leio/2019/03/26/gnome-3-30/#comment-9555 https://forums.gentoo.org/viewtopic-t-1094796.html

contact gentoo developer for help in implementation:
https://wiki.gentoo.org/wiki/User:Leio/TODO

AnyBackport RequestVery LowVery Low Icetray for Iceape-uxp Closed
100%
Task Description

This already works for it, but I just thought I would request it to be put in.

StableBug ReportHighCritical [vhba-module-lts] modprobe: ERROR: could not insert 'vh ...Closed
100%
Task Description
filename:       /lib/modules/4.9.77-gnu-1-lts/extramodules/vhba.ko
license:        GPL
description:    Virtual SCSI HBA
version:        20161009
author:         Chia-I Wu
srcversion:     E5A3E6F70DFD436A6B1C8D6
depends:        scsi_mod
vermagic:       4.9.27-gnu-1-lts SMP mod_unload modversions

Can’t insert module vhba

Error :

modprobe: ERROR: could not insert ‘vhba’: Exec format error

AnyBug ReportVery HighCritical [warsow] the package is not compiled from source Closed
100%
Task Description

The package is not compiled from source

StableBug ReportHighCritical [alsa-tools] create missing firmware folder since firmw ...Closed
100%
Task Description

### Some context ###

I use hdajackretask on my G41M-ES2L motherboard (Libreboot)

Alsamixer doesn’t offer automute feature so every time I plug my headphones, the sound is playing by my speakers.
So to work around this, I use hdajackretask from alsa-tools package.

It allows to install a boot override to solve the issue.

Yesterday, I reinstalled Hyperbola on my system and the boot override because of missing /lib/firmware directory. (Although it was present before, something changed ?)

The error message was (I translate)

/mv: can't move '/tmp/hda-jack-retask-VH3KIZ/hda-jack-retask.fw' to /lib/firmware/hda-jack-retask.fw' No file or folder of this type

So I created a folder “firmware” in /lib/
and copied hda-jack-retask.fw in it.

Then I rebooted, 100% working.

I don’t know if the fix should apply to the PKGBUILD of alsa-tools (to create a /lib/firmware directory) or something else ?

StableBug ReportVery HighCritical [openrc] Cowardly refusing to concatenate a logfile int ...Closed
100%
Task Description

Since the update of openrc to 0.28-11 this morning something fails during boot process as I get the following error message:

Cowardly refusing to concatenate a logfile into itself.
Please change rc_log_path to something other than /var/log/rc.log get rid of this message

But why would I do that?

Besides, once the boot process is finished, I am unable to switch between TTY consoles as I used to using Ctrl-Alt + F1-Fx. I don’t get the login prompt anymore.

AnyBug ReportHighCritical [light-locker] returns error while tries load shared li ...Closed
100%
Task Description

Description:
The light-locker package returns error while tries load shared library libsystemd.so.0.

Additional info:
* package version(s): light-locker-1.6.0-3

Steps to reproduce:

  1. Install the package:
  $ sudo pacman -S light-locker
  
  1. Run it:
  $ light-locker
  
  1. Then, you get the following message:
  light-locker: error while loading shared libraries: libsystemd.so.0: cannot open shared object file: No such file or directory
  
TestingBug ReportMediumCritical [iceweasel-uxp-ublock-origin] Can't add filters and/or  ...Closed
100%
AnyBug ReportVery HighCritical [grub] remove the "placeholder" entry in /etc/grub.d/20 ...Closed
100%
AnyBug ReportVery HighCritical [openrc] rename "chroot-nspawn" keyword to "chroot+unsh ...Closed
100%
AnyBug ReportVery HighCritical [eudev] rename "systemd-nspawn" keyword to "chroot+unsh ...Closed
100%
AnyBug ReportVery HighCritical [openrc] set "devfs" init script to run before than any ...Closed
100%
TestingBug ReportVery LowCritical [iceweasel-uxp] missing extensions Closed
100%
AnyBug ReportVery HighCritical [openrc] rename "procfs" init script to "binfmt_misc",  ...Closed
100%
AnyBug ReportVery HighCritical [eudev][openrc] rename "dev-mount" to "devfs" in "udev" ...Closed
100%
AnyBug ReportVery HighCritical [python-acme] to start crashing on June 19th  Closed
100%
AnyBug ReportLowCritical [openvswitch-lts] netifrc fails to start openvwitch int ...Closed
100%
AnyBug ReportLowCritical [hostapd] fails to start at boot when using openvwitch  ...Closed
100%
AnyBug ReportMediumCritical [wesnoth]: prevents upgrade of Hyperbola, colliding fil ...Closed
100%
AnyBug ReportVery HighCritical [openrc] fix "chroot" initscript Closed
100%
AnyBug ReportVery HighCritical [netifrc] fix "net_veth" and "net_macsec" initscripts Closed
100%
AnyBug ReportVery HighCritical [netifrc] "net.lo" initscript is forced to load in "boo ...Closed
100%
AnyBug ReportVery HighCritical [eudev] "udev" and "udev-trigger" initscripts are force ...Closed
100%
AnyBug ReportVery HighCritical [openrc] run "sysctl" initscript after "net" initscript Closed
100%
AnyBug ReportHighCritical [utox] package needs rebuilding Closed
100%
AnyBug ReportHighCritical [zathura-ps] needs to be recompiled Closed
100%
AnyBug ReportHighCritical [links][elinks] segmentation fault after start by termi ...Closed
100%
AnyBug ReportVery LowCritical [apache]: cannot start if NetworkManager is not started Closed
100%
StableBug ReportVery LowCritical [hypervideo] YouTube's DRM has prevented this software  ...Closed
100%
StableBug ReportVery LowCritical [python2-reportlab] python2-pip dependency Closed
100%
AnyBug ReportVery HighCritical [linux-libre-lts] spinlock not released on kernel by i9 ...Closed
100%
AnyBug ReportVery HighCritical [electrum] package no longer works Closed
100%
Showing tasks 1 - 50 of 1513 Page 1 of 31

Available keyboard shortcuts

Tasklist

Task Details

Task Editing