All Projects

ProjectCategoryTask Type  ascPrioritySeveritySummaryStatusProgress
PackagesAnyImplementation RequestVery LowLow[gmusicbrowser] Add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

gmusicbrowser

“A customizable open-source jukebox for large collections”

https://www.parabola.nu/packages/pcr/any/gmusicbrowser/

License : GPL3

Thanks

PackagesAnyImplementation RequestVery LowLow[quiterss] add package Unconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

quiterss

“Fast and light RSS/Atom feed reader written in Qt/С++”

https://aur.archlinux.org/packages/quiterss

License : GPL3

Thanks

PackagesAnyImplementation RequestMediumLowScid vs. PC – PGN Reader/ChessBaseUnconfirmed
0%
Task Description

http://scidvspc.sourceforge.net/

PackagesAnyImplementation RequestMediumLowStockfish Chess EngineUnconfirmed
0%
Task Description

«Unlike most chess engines, Stockfish is open source (GPL license). That means you can read the code, modify it, contribute back, and even use it in your own projects.» I do not know if it is libre. If it is, together with Scid, Hyperbola is one step closer for every chess lover out there who also loves freedom!
https://stockfishchess.org/

PackagesAnyImplementation RequestVery LowLow[powerpill] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

powerpill

“Pacman wrapper for faster downloads.”

https://aur.archlinux.org/packages/powerpill/

https://xyne.archlinux.ca/projects/powerpill

License : GPL

Thanks

PackagesAnyImplementation RequestVery LowLow[flacon] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

flacon

“Extracts individual tracks from one big audio file containing the entire album of music and saves them as separate audio files.”

https://aur.archlinux.org/packages/flacon/

https://flacon.github.io/

License : LGPL2.1

Thanks

PackagesAnyImplementation RequestVery LowMedium[arm-linux-gnueabihf-gcc] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

arm-linux-gnueabihf-gcc

“The GNU Compiler Collection (arm-linux-gnueabihf)”

Also requires :

arm-linux-gnueabihf-binutils (A set of programs to assemble and manipulate binary and object files)
arm-linux-gnueabihf-glibc (GNU C Library)

https://aur.archlinux.org/packages/arm-linux-gnueabihf-gcc/

License : GPL

Thanks

PackagesAnyImplementation RequestVery LowLow[gogs] add packageUnconfirmed
0%
Task Description

Hello,

It would be great to add this package :

gogs

“Self Hosted Git Service written in Go”

https://aur.archlinux.org/packages/gogs

openrc init scripts : https://aur.archlinux.org/packages/gogs-openrc

License : GPL

Thanks

PackagesAnyImplementation RequestVery LowLow[gimagereader] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

gimagereader

“A graphical frontend to tesseract-ocr”

https://aur.archlinux.org/packages/gimagereader

License : GPL3

Thanks

PackagesAnyImplementation RequestVery LowHigh[glom]: should depend on libgdaUnconfirmed
0%
Task Description

Description:

glom cannot run without libgda, so it should depend on libgda package

PackagesAnyImplementation RequestVery LowLow[exifread] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

exifread

“Python library to extract EXIF data from tiff and jpeg files”

https://aur.archlinux.org/packages/exifread/

Thanks

PackagesAnyImplementation RequestVery LowLow[obmenu-generator] add packageUnconfirmed
0%
Task Description

Could it be possible to add :

obmenu-generator

A fast pipe/static menu generator for the Openbox Window Manager (with icons support)

License : GPL3

https://github.com/trizen/obmenu-generator https://www.parabola.nu/packages/pcr/x86_64/obmenu-generator/

Thanks

PackagesAnyImplementation RequestVery HighHigh[murmur-headless] add a Murmur package capable of worki...In Progress
0%
Task Description

Description:

  • Add new a Murmur package capable of working without a graphical user interface. It’s common on servers and embedded devices that requires only interfaces like network (eg. SSH) or serial port to handle services.

Additional info:

  • based on murmur 1.2.19-5

Steps to reproduce:

  • none
PackagesAnyImplementation RequestVery HighHigh[asterisk-headless] add an Asterisk package capable of ...In Progress
0%
Task Description

Description:

  • Add an Asterisk package capable of working without a graphical user interface. It’s common on servers and embedded devices that requires only interfaces like network (eg. SSH) or serial port to handle services.

Additional info:

  • based on asterisk 14.4.0-1

Steps to reproduce:

  • none
PackagesAnyImplementation RequestVery HighMedium[coturn] add new packageUnconfirmed
0%
Task Description

Description:

  • add new package

Additional info:

Steps to reproduce:

  • none
PackagesAnyImplementation RequestVery HighMedium[mediagoblin] add GNU MediaGoblin packageUnconfirmed
0%
Task Description

Description:

  • add GNU MediaGoblin package

Additional info:

  • none

Steps to reproduce:

  • none
PackagesAnyImplementation RequestVery LowMedium[purple-matrix] Please add packageUnconfirmed
0%
Task Description

Package is a libpurple plugin for the Matrix protocol which is consistent with Hyperbola’s social contract as Matrix is a federated protocol.

Source code can be found here licensed under GPLv2:

https://github.com/matrix-org/purple-matrix

PKGBUILD for git version is available here (last stable release is from two years ago so git version is probably the best version to use):

https://aur.archlinux.org/packages/purple-matrix-git/

PackagesAnyImplementation RequestVery LowLow[vidcutter] add packageUnconfirmed
0%
Task Description

Could it be possible to add :

vidcutter

“A modern, simple to use, constantly evolving and hella fast MEDIA CUTTER + JOINER w/ frame-accurate SmartCut technology + Qt5, libmpv, FFmpeg and MediaInfo powering the backend.”

License : GPL3

https://aur.archlinux.org/packages/vidcutter/

https://vidcutter.ozmartians.com/

PackagesAnyImplementation RequestVery LowMediumPrivacy Settings for IceapeUnconfirmed
0%
Task Description

This addon works for any firefox based browser but not seamonkey based or this.

I wondered if you could implement the iceweasel one for Iceape.

PackagesAnyImplementation RequestVery LowLow[qarte] add packageUnconfirmed
0%
Task Description

Request for :

qarte

“Allow you to browse into the archive of arte+7 & arteLiveWeb sites and to record your prefered videos.”

https://aur.archlinux.org/packages/qarte

License : GPL3

PackagesAnyImplementation RequestVery LowMedium[nnn] package requestUnconfirmed
0%
Task Description

This is a request to package nnn - a full-featured terminal file manager for low-end devices and the regular desktop.

nnn is available on Debian, Ubuntu (and family), Fedora, OpenSUSE and Arch Linux.

Homepage: https://github.com/jarun/nnn License: BSD 2-Clause

I would highly appreciate if nnn can be added to the repository.

PackagesAnyImplementation RequestVery LowMediumSupport of MPTCP (Multipath TCP) on HyperbolaUnconfirmed
0%
Task Description

Patch for 4.9 : https://multipath-tcp.org/patches/mptcp-v4.9-c88d1d56809e.patch

AUR : https://aur.archlinux.org/packages/linux-mptcp/

PackagesAnyImplementation RequestVery LowHighAdd MPTCP (MultiPath TCP) to HyperbolaUnconfirmed
0%
Task Description

https://aur.archlinux.org/packages/linux-mptcp/

Kernel Patch for 4.9 :
http://multipath-tcp.org/patches/mptcp-v4.9-c88d1d56809e.patch

Compile :
https://multipath-tcp.org/pmwiki.php/Users/DoItYourself

PackagesAnyImplementation RequestLowLow[opmsg] add new packageResearching
0%
Task Description

Description: opmsg is a replacement for gpg which can encrypt/sign/verify your mails or create/verify detached signatures of local files. Even though the opmsg output looks similar, the concept is entirely different.

Additional info:
https://aur.archlinux.org/packages/opmsg/

PackagesAnyImplementation RequestVery LowMedium[SPF][postfix] implement pypolicyd-spf and postfix-poli...Unconfirmed
0%
Task Description

Description:
Hyperbola has the following SPF implementations:
* libspf2
* perl-mail-spf
* perl-mail-spf-query

However, none of them work out of the box with postfix. There’s postfix-policyd-spf-perl, which uses one the current perl implementations (perl-mail-spf), takes no time to build and all the dependencies are already satisfied with Hyperbola’s packages

Here I made a PKGBUILD that’s compliant with the packaging standards:

pkgname=postfix-policyd-spf-perl
pkgver=2.011
pkgrel=1
pkgdesc='Postfix SPF policy engine, written in Perl'
arch=(i686 x86_64)
url='https://launchpad.net/postfix-policyd-spf-perl/'
license=(GPL)
depends=(perl-mail-spf perl-netaddr-ip perl-sys-hostname-long)
source=("https://launchpad.net/postfix-policyd-spf-perl/trunk/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"{,.asc})
sha512sums=('22fc00bf74912056a67e937a460ac1fd878f1cb1a3bfa7b19bc5f1e6bc1c36d815dcf8c945e818d242ed5e72a6295bb0e1569446e06b09aefb2842993b8016ba'
            'SKIP')
validpgpkeys=(E7729BFFBE85400FEEEE23B178D7DEFB9AD59AF1) # Scott Kitterman

package() {
  cd "${pkgname}-${pkgver}"

  install -Dm755 "${pkgname}" "${pkgdir}/usr/libexec/postfix/${pkgname}"
  install -Dm644 CHANGES INSTALL README -t "${pkgdir}/usr/share/doc/${pkgname}"
  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

in the other hand, to give users the possibility of having more options, we could add pypolicyd-spf (AUR), which depends in pyspf (AUR) and other packages that Hyperbola has. In fact, ArchWiki talks about this implementation, but this might not be relevant.

PackagesAnyPrivacy IssueVery LowLow[purple-plugin-pack] Provides Napster support which is ...Unconfirmed
0%
Task Description

purple-plugin-pack provides access to Napster which is only useful with a single company and sever (as far as I could tell).

PackagesStableReplace RequestVery LowMediumPackage ossp has got systemd dependenciesUnconfirmed
0%
Task Description

Description: Concurrent package ossp in version 1.3.2-15 has got dependencies to systemd, which is contradicting the whole distribution and the used INIT-system. Therefore my request to port this to OpenRC!

Additional info:
* package version(s) 1.3.2-15

PackagesStableSecurity IssueVery LowCritical[lts-kernel][sec] filter /dev/mem access & restrict acc...Unconfirmed
0%
Task Description

These two options could be enabled :

Kernel hacking → [*] Filter access to /dev/mem
[*] Filter I/O access to /dev/mem

Security options → [*] Restrict unprivileged access to the kernel syslog

ServicesFlyspray IssueSecurity IssueVery LowLowAfter account confirmation, crypt: No salt parameter wa...Unconfirmed
0%
Task Description

After confirming the newly created account (typing the confirmation code, the passwoard and its confirmation, and clicking the button to continue), the following error appears:

  Notice: crypt(): No salt parameter was specified. You must use a randomly generated salt and a strong hash function to produce a secure hash. in /srv/http/flyspray/includes/class.flyspray.php on line 656 

The account login seems to work normaly.

PackagesAnySecurity IssueVery LowHigh[octopi] requires suUnconfirmed
0%
Task Description

would it be possible to make it use sudo instead?

From what I know, sudo is safer. Let me know if you agree this is a problem.

PackagesAnySecurity IssueVery LowMedium[qemu] Multiple CVEUnconfirmed
0%
Task Description

CVE-2018-20123 QEMU: pvrdma: memory leakage in device hotplug
https://www.openwall.com/lists/oss-security/2018/12/13/4

CVE-2018-16872 Qemu: usb-mtp: path traversal by host filesystem
manipulation in Media Transfer Protocol (MTP)
https://www.openwall.com/lists/oss-security/2018/12/13/11

Patches included at above URLs.

PackagesAnySecurity IssueMediumCritical[libjpeg-turbo] CVE-2019-2201Researching
0%
Task Description

In generate_jsimd_ycc_rgb_convert_neon of jsimd_arm64_neon.S, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution in an unprivileged process with no additional execution privileges needed. User interaction is needed for exploitation

https://security-tracker.debian.org/tracker/CVE-2019-2201

Patch: https://github.com/libjpeg-turbo/libjpeg-turbo/issues/388

PackagesAnySecurity IssueVery LowMediumDownload debian-fixes instead of relying on external so...Unconfirmed
0%
Task Description

It happened already with minetest and again with prosody: When trying to build own packages with makepkg there are patches downloaded from the Debian-project. But the given HTTP(S)-sources are no longer available, concrete example within prosody to be found: https://deb.debian.org/debian/pool/main/p/prosody/prosody_0.10.2-1~bpo9+1.debian.tar.xz (not available)

Please don’t rely on those external sources when creating PKGBUILD-files or just give users the possibility for a secure and granted download. Therefore I cannot build prosody on my own now!

PackagesAnySecurity IssueVery LowMediummount.davfs: unknown file system davfs due to paths cha...Unconfirmed
0%
Task Description

This is same issue as on:
https://bugzilla.redhat.com/show_bug.cgi?id=1151273

The paths changed and trying to mount davfs file system defined in /etc/fstab fails with error: unknown file system davfs

To remedy, I made symlink in /sbin to mount.davfs

The transition of paths had to take that in account as many mounted remote disks failed after upgrade.

PackagesStableUpdate RequestVery LowMedium[varnish] Missing init scriptUnconfirmed
0%
Task Description

Description:

Init script is missing for this package.

I think has some systemd dependecies.

/tmp/alpm_sYmHUS/.INSTALL: line 7: systemd-sysusers: command not found
error: command failed to execute correctly

package version: varnish-5.1.2-1

PackagesAnyUpdate RequestMediumHighMake Knock patch for Linux-libre 4.14 LTSUnconfirmed
0%
Task Description

The Knock patches for linux-libre maintained by you at https://git.hyperbola.info:50100/kernels/knock.git/ have support up to linux-libre 4.13 only (and I think it didn’t work for it when I tried it, compilation failed) but from all of those supported versions, the newest maintained generation by the upstream is 4.9.x

However, since newer kernel generations might require reprogramming the patch, I want to request it only for the latest LTS generation which is 4.14. As you know, LTS software are supported for a long time, so it’s worth to make it for linux-libre 4.14.x

This might not be really important for Hyperbola in the short term, but you are the maintainers of the TCP Stealth implementation for Linux-libre and I and maybe other people would like to use it in their projects for newer versions.

Plus, it would be great since while 4.9 kernels can use the GRSec+Knock combination like linux-libre-lts-unofficial-grsec-knock, with support for 4.14 anyone would be able to use a combination of newer patches such as Linux-hardened+Knock (Linux-hardened supports 4.14 and 4.15 as of now) which is what I’d like to do.
https://github.com/copperhead/linux-hardened/releases

PackagesAnyUpdate RequestVery LowHigh[proj]: please update to latest versionUnconfirmed
0%
Task Description

Description:

https://proj4.org/index.html

This package have valuable geodetic applications, and I intend to present Hyperbola GNU/Linux-libre soon in universities and schools in East Africa.

The coordinate system there is not WGS84 and this package only in new version is providing the conversion from East African geographic coordinates to WGS84, and will be very usable in many industrial and private applications.

Showing tasks 301 - 337 of 337 Page 7 of 7<<First - 3 - 4 - 5 - 6 - 7

Available keyboard shortcuts

Tasklist

Task Details

Task Editing