All Projects

ProjectCategoryTask TypePrioritySeveritySummaryStatusProgress
PackagesAnyFeature RequestHighHigh[mongodb-tools] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si mongodb-tools
Repository      : community
Name            : mongodb-tools
Version         : 3.4.2-2
Description     : The MongoDB tools provide import, export, and diagnostic capabilities.
Architecture    : x86_64
URL             : https://github.com/mongodb/mongo-tools
Licenses        : Apache
Groups          : None
Provides        : None
Depends On      : libsasl  libpcap  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 9.43 MiB
Installed Size  : 70.71 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:29:00 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[ncrack] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si ncrack
Repository      : community
Name            : ncrack
Version         : 0.5-3
Description     : A high-speed network authentication cracking tool
Architecture    : x86_64
URL             : https://nmap.org/ncrack/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 585.50 KiB
Installed Size  : 1496.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 07:39:03 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[nodejs] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si nodejs
Repository      : community
Name            : nodejs
Version         : 7.10.0-1
Description     : Evented I/O for V8 javascript
Architecture    : x86_64
URL             : http://nodejs.org/
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : openssl-1.0  zlib  icu  libuv  http-parser  c-ares
Optional Deps   : npm: nodejs package manager
Conflicts With  : None
Replaces        : None
Download Size   : 4.55 MiB
Installed Size  : 18.49 MiB
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Wed 03 May 2017 11:50:26 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[opensc] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si opensc
Repository      : community
Name            : opensc
Version         : 0.16.0-4
Description     : Tools and libraries for smart cards
Architecture    : x86_64
URL             : https://github.com/OpenSC/OpenSC/wiki
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : pcsclite  libltdl  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 933.26 KiB
Installed Size  : 3241.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 07:57:42 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[opensmtpd] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si opensmtpd
Repository      : community
Name            : opensmtpd
Version         : 6.0.2p1-3
Description     : Free implementation of the server-side SMTP protocol
Architecture    : x86_64
URL             : http://www.opensmtpd.org/
Licenses        : custom
Groups          : None
Provides        : smtp-server  smtp-forwarder
Depends On      : libasr  libevent  openssl-1.0  pam
Optional Deps   : None
Conflicts With  : smtp-server  smtp-forwarder
Replaces        : None
Download Size   : 237.25 KiB
Installed Size  : 672.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 07:59:38 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[phantomjs] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si phantomjs
Repository      : community
Name            : phantomjs
Version         : 2.1.1-7
Description     : Headless WebKit with JavaScript API
Architecture    : x86_64
URL             : http://www.phantomjs.org/
Licenses        : BSD  LGPL  MIT
Groups          : None
Provides        : None
Depends On      : icu  libjpeg-turbo  libpng  fontconfig  gperf  ruby  python2  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 12.70 MiB
Installed Size  : 45.09 MiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Wed 26 Apr 2017 03:53:27 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[pound] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si pound
Repository      : community
Name            : pound
Version         : 2.7-4
Description     : A reverse proxy, load balancer, and SSL wrapper
Architecture    : x86_64
URL             : http://www.apsis.ch/pound/index_html
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pcre  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 59.37 KiB
Installed Size  : 153.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:05:27 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[python2-m2crypto] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si python2-m2crypto
Repository      : community
Name            : python2-m2crypto
Version         : 0.24.0-3
Description     : A crypto and SSL toolkit for Python
Architecture    : x86_64
URL             : https://pypi.python.org/pypi/M2Crypto
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : python2  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 197.71 KiB
Installed Size  : 1298.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:08:30 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[qt5-base] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si qt5-base
Repository      : extra
Name            : qt5-base
Version         : 5.8.0-11.hyperbola1
Description     : A cross-platform application and UI framework, without systemd support
Architecture    : x86_64
URL             : https://www.qt.io/developers/
Licenses        : GPL3  LGPL3  FDL  custom
Groups          : qt  qt5
Provides        : None
Depends On      : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig  xcb-util-wm  libxrender  libxi  sqlite  xcb-util-image  icu  tslib
                  libinput  libsm  libxkbcommon-x11  libproxy  libcups  openssl-1.0
Optional Deps   : qt5-svg: to use SVG icon themes
                  postgresql-libs: PostgreSQL driver
                  libmariadbclient: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin
Conflicts With  : qtchooser
Replaces        : None
Download Size   : 11.23 MiB
Installed Size  : 56.18 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Tue 22 Aug 2017 03:22:14 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[rethinkdb] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si rethinkdb
Repository      : community
Name            : rethinkdb
Version         : 2.3.5-6
Description     : Distributed powerful and scalable NoSQL database
Architecture    : x86_64
URL             : http://www.rethinkdb.com/
Licenses        : AGPL
Groups          : None
Provides        : None
Depends On      : protobuf  ncurses  curl  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 10.19 MiB
Installed Size  : 36.50 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:25:08 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[ruby2.3] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends and makedepends on openssl-1.0.

$ pacman -Si ruby2.3
Repository      : community
Name            : ruby2.3
Version         : 2.3.4-2.hyperbola1
Description     : An object-oriented language for quick and easy programming, with free variant of json gem
Architecture    : x86_64
URL             : http://www.ruby-lang.org/en/
Licenses        : BSD  custom
Groups          : None
Provides        : None
Depends On      : gdbm  openssl-1.0  libffi  libyaml  gmp  zlib
Optional Deps   : tk: for Ruby/TK
Conflicts With  : None
Replaces        : None
Download Size   : 4.82 MiB
Installed Size  : 22.74 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Wed 05 Jul 2017 01:49:10 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[snownews] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si snownews
Repository      : community
Name            : snownews
Version         : 1.5.12-9
Description     : Text mode RSS newsreader for Linux and Unix.
Architecture    : x86_64
URL             : http://kiza.kcore.de/software/snownews/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : libxml2  ncurses  perl-xml-libxml  perl-xml-libxslt  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 118.60 KiB
Installed Size  : 352.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:54:47 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[squid] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si squid
Repository      : community
Name            : squid
Version         : 3.5.25-2.hyperbola2
Description     : Full-featured Web proxy cache server, with OpenRC support
Architecture    : x86_64
URL             : http://www.squid-cache.org
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : openssl-1.0  pam  perl  libltdl  libcap  nettle  gnutls
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 2.33 MiB
Installed Size  : 9.31 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Thu 02 Nov 2017 01:20:48 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[sslscan] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si sslscan
Repository      : community
Name            : sslscan
Version         : 1.10.2-5
Description     : A fast tools to scan SSL services, such as HTTPS to determine the ciphers that are supported
Architecture    : x86_64
URL             : https://github.com/DinoTools/sslscan/
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 16.98 KiB
Installed Size  : 45.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 09:07:32 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[wvstreams] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si wvstreams
Repository      : community
Name            : wvstreams
Version         : 4.6.1-12
Description     : A network programming library written in C++
Architecture    : x86_64
URL             : http://alumnit.ca/wiki/?page=WvStreams
Licenses        : LGPL
Groups          : None
Provides        : None
Depends On      : zlib  pam  xplc  openssl-1.0  readline
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 1098.88 KiB
Installed Size  : 8180.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 09:12:59 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[vagrant] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it makedepends on openssl-1.0.

$ pacman -Si vagrant
Repository      : community
Name            : vagrant
Version         : 1.9.3-1
Description     : Build and distribute virtualized development environments
Architecture    : x86_64
URL             : http://vagrantup.com
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : vagrant-substrate  libyaml
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 16.54 MiB
Installed Size  : 37.19 MiB
Packager        : Jonathan Steel <jsteel@archlinux.org>
Build Date      : Wed 29 Mar 2017 01:06:53 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesStableUpdate RequestHighHigh[qt5] upgrade Qt project to the 5.6 LTS version, requir...Deferred
0%
Task Description

Cannot mix incompatible Qt library (version 0×50800) with this library (version 0×50904)
Aborted

./Nextcloud-2.3.3-x86_64.AppImage: /usr/lib/libQt5Core.so.5: version `Qt_5.9’ not found (required by /tmp/.mount_NextclpprMnG/usr/bin/../lib/libqt5keychain.so.1

These two packages are directly affected by an older qt5...

Could you update all the qt packages to the LTS version available?

PackagesAnyBug ReportHighHigh[openrc] hwclock: Cannot access the Hardware Clock via ...Assigned
0%
Task Description

Warning init:

 * Setting hardware clock using the system clock [UTC] ... 
hwclock: Cannot access the Hardware Clock via any known method. 
hwclock: Use the --debug option to see the details of our search for an access method. 
 * Failed to sync clocks 
 [ !! ] 
 * ERROR: hwclock failed to stop

Restart init:

[root@hyperbola heckyel]# /etc/init.d/hwclock restart 
 * WARNING: you are stopping a boot service
 * WARNING: you are stopping a boot service
 * Stopping rsyslog ...                                                                                                                                                                    [ ok ]
 * Setting hardware clock using the system clock [UTC] ...
hwclock: Cannot access the Hardware Clock via any known method. 
hwclock: Use the --debug option to see the details of our search for an access method. 
 * Failed to sync clocks                                                                                                                                                                   [ !! ]
 * ERROR: hwclock failed to stop

References:

PackagesAnyUpdate RequestMediumHighMake Knock patch for Linux-libre 4.14 LTSUnconfirmed
0%
Task Description

The Knock patches for linux-libre maintained by you at https://git.hyperbola.info:50100/kernels/knock.git/ have support up to linux-libre 4.13 only (and I think it didn’t work for it when I tried it, compilation failed) but from all of those supported versions, the newest maintained generation by the upstream is 4.9.x

However, since newer kernel generations might require reprogramming the patch, I want to request it only for the latest LTS generation which is 4.14. As you know, LTS software are supported for a long time, so it’s worth to make it for linux-libre 4.14.x

This might not be really important for Hyperbola in the short term, but you are the maintainers of the TCP Stealth implementation for Linux-libre and I and maybe other people would like to use it in their projects for newer versions.

Plus, it would be great since while 4.9 kernels can use the GRSec+Knock combination like linux-libre-lts-unofficial-grsec-knock, with support for 4.14 anyone would be able to use a combination of newer patches such as Linux-hardened+Knock (Linux-hardened supports 4.14 and 4.15 as of now) which is what I’d like to do.
https://github.com/copperhead/linux-hardened/releases

PackagesAnyBug ReportMediumHigh[postgresql] creating directory Permission deniedUnconfirmed
0%
Task Description

In the File postgresql.install

the output is:

    ==> requires datadir /var/lib/data
    ==> run as user postgres: 'initdb -D /var/lib/data'

when it should be:

    ==> requires datadir /var/lib/postgres/data
    ==> run as user postgres: 'initdb -D /var/lib/postgres/data'

It may be necessary to change:

local datadir = "/var/lib/data"

to

local datadir = "/var/lib/postgres/data"

The comand for default fails:

creating directory /var/lib/data... initdb: could not create directory "/var/lib/data": Permission denied
Software DevelopmentHyperBKImplementation RequestMediumHighDevelop HyperBK based on LibertyBSD kernelDeferred
0%
Task Description

Develop HyperBK (Hyper Berkeley Kernel) based on LibertyBSD‘s kernel for Hyperbola GNU/HyperBK port.

TODO:

  • Push source to HyperBK’s project.
  • Rebrand LibertyBSD kernel to HyperBK.
  • Implement, develop or import new features such as Nouveau support.
  • Package HyperBK.

PATCHING NOTE

When the check concerns kernel, we obviously want to match with HyperBK.

Example of triplet check:	hyperbk-gnu)
Example of uname check:		GNU/HyperBK)
Example of C macro check:	defined(__HyperBK__)
Software DevelopmentGeneralImplementation RequestMediumHighDevelop GNU/HyperBK patchsetUnconfirmed
0%
Task Description

Develop GNU/HyperBK patchset for toolchain (Glibc, Binutils and GCC) and packages.

PATCHING NOTE

Make sure the definitions are not simply duplicated from GNU/Linux' because that will eventually result in
out-of-sync definitions that break for us.

Example of triplet check:	linux*-gnu | gnu* | hyperbk-gnu)
Example of uname check:		Linux|GNU|GNU/*)
Example of C macro check:	defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
				[note: GNU/Hurd defines __GNU__, and GNU/HyperBK define __GLIBC__ as hardcoded macro]
Example of makefile check:	ifneq (, $(filter Linux GNU GNU_%, $(shell uname -s)))
				[note1: findstring matches subwords, use filter instead]
				[note2: list must be the first parameter, otherwise matching fails]
				[note3: "%" is make's wildcard]
PackagesAnyBug ReportMediumHigh[xf86-video-intel] windows are not rendered correctly i...Requires Testing
100%
Task Description

I’m encountering this bug when using latest Pale Moon (version 2.8.0.1).

https://forum.palemoon.org/viewtopic.php?f=37&t=19941&sid=3cd95f0870b5cef74c582eb9a3ea778a

The bug doesn’t only affect the preferences dialog - other windows are not rendered correctly either such as DownThemAll! add-on (see attached image).

The suggested fix is to update the intel driver (the about:config suggested change makes the preference dialog usable but other windows such as DownThemAll! still aren’t displayed correctly).

I’m using a T60 with intel graphics.

PackagesStableBug ReportMediumHigh[tp_smapi] not working with most recent libre kernelResearching
0%
Task Description

Description:
tp_smapi fails to load

Additional info:
* package version(s)
tp_smapi-lts 0.43-1.hyperbola29.5
linux-libre-lts 4.9.143_gnu-0

* config and/or log files etc.
From dmesg:
thinkpad_ec: Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0)
thinkpad_ec: Unknown symbol __x86_indirect_thunk (err 0)

Steps to reproduce:
1. Install tp_smapi and the most recent stable linux-libre-lts
2. Reboot
3. sudo modprobe tp_smapi

PackagesAnyBug ReportLowHigh[kaccounts-integration] option to add NextCloud/OwnClou...Unconfirmed
0%
Task Description

Description:

  • Option to add NextCloud/OwnCloud accounts in ‘Online Accounts’ section of System Settings not appearing.

Additional info:
* package version(s)

  • 17.04.0-1

* config and/or log files etc.

  • N/A

Steps to reproduce:

  • Run application
  • Go to ‘Online Accounts’ section of System Settings
PackagesAnyBug ReportLowHigh[kdenetwork-kopete] clicking to add an Jabber Account o...Unconfirmed
0%
Task Description

Description:

  • Clicking to add an Jabber Account opens a dialog with no fields to enter information.

Additional info:
* package version(s)

  • 17.04.0-3.hyperbola1

* config and/or log files etc.

  • N/A

Steps to reproduce:

  • Run Application
  • Clicking to add an Jabber Account
PackagesAnyBug ReportVery LowHighDesite "noauto" specified in /etc/fstab all devices get...Unconfirmed
0%
Task Description

Description:

I have tried all combinations, but despite “noauto” specified in /etc/fstab all devices get mounted at boot.

Who can help me, not to mount a device during boot?

PackagesAnyImplementation RequestVery LowHigh[glom]: should depend on libgdaUnconfirmed
0%
Task Description

Description:

glom cannot run without libgda, so it should depend on libgda package

PackagesStableBug ReportVery LowHigh[lm_sensors] Fail to load it87 module at bootUnconfirmed
0%
Task Description

Description:

I ran sensors-detect, it detected two modules :

coretemp
it87

Those have been added to /etc/sysconfig/lm_sensors :

# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

HWMON_MODULES="coretemp it87"

But only coretemp is loaded at boot.

I can manually load it87 module (modprobe it87) and get all sensors working but for some reason it87 module is not loaded at boot.

PackagesStableBug ReportVery LowHighjava cacerts file is emptyUnconfirmed
0%
Task Description

/etc/ssl/certs/java/cacerts has 0 entries, resulting in ssl handshake errors in java applications.

Package versions:
* ca-certificates 20170307-1
* ca-certificates-utils 20170307-1

ServicesWiki Page IssueBug ReportVery LowHighHTML design on Wiki not readableUnconfirmed
0%
Task Description

The wiki pages look really too narrow and not readable on even half a screen of the laptop.

PackagesAnyUpdate RequestVery LowHighufw update/ufw bugUnconfirmed
0%
Task Description

There appears to be a bug with the current version of ufw, 0.35-2

Dunno if updating it would fix it, but it is kind of annoying and possibly security issue.

it says ufw is inactive when I reboot despite it being installed in the runlevel.

PackagesAnyImplementation RequestVery LowHigh[epson-inkjet-printer-escpr] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add :

epson-inkjet-printer-escpr

“Epson Inkjet Printer Driver (ESC/P-R) for Linux”

License : GPL2

https://aur.archlinux.org/packages/epson-inkjet-printer-escpr/ https://packages.debian.org/stretch/printer-driver-escpr

In my case, it was needed to use an Epson printer & scanner.

PackagesAnyUpdate RequestVery LowHigh[proj]: please update to latest versionUnconfirmed
0%
Task Description

Description:

https://proj4.org/index.html

This package have valuable geodetic applications, and I intend to present Hyperbola GNU/Linux-libre soon in universities and schools in East Africa.

The coordinate system there is not WGS84 and this package only in new version is providing the conversion from East African geographic coordinates to WGS84, and will be very usable in many industrial and private applications.

PackagesAnyBug ReportVery LowHigh[iceweasel-uxp] windows don't render correctly in add-o...Researching
0%
Task Description

I can’t switch windows in add-ons such as session manager.

It’s probably the same bug which appears in palemoon (inherited from UXP). See here:

https://issues.hyperbola.info/index.php?do=details&task_id=1160&opened=24&status[0]=

https://forum.palemoon.org/viewtopic.php?f=37&t=19941&sid=3cd95f0870b5cef74c582eb9a3ea778a

PackagesAnyBug ReportVery LowHigh[kdelibs4support] XDG_RUNTIME_DIR not setUnconfirmed
0%
Task Description

Description:

This bug only appears when logged in as root on terminal

# kf5-config --version
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Qt: 5.8.0
KDE Frameworks: 5.33.0
kf5-config: 1.0

Additional info:

* package version(s)

$ pacman -Si kdelibs4support
Repositorio               : extra
Nombre                    : kdelibs4support
Versión                   : 5.33.0-1
Descripción               : Porting aid from KDELibs4
Arquitectura              : x86_64
URL                       : https://community.kde.org/Frameworks
Licencias                 : LGPL
Grupos                    : kf5-aids
Provee                    : Nada
Depende de                : kunitconversion  kitemmodels  kemoticons  kded  kparts
Dependencias opcionales   : Nada
En conflicto con          : kde4support
Remplaza a                : kde4support
Tamaño de la descarga     : 3,03 MiB
Tamaño de la instalación  : 17,36 MiB
Encargado                 : Felix Yan <felixonmars@archlinux.org>
Fecha de creación         : jue 13 abr 2017 14:29:47 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

Steps to reproduce:

- Install KDE plasma

PackagesAnyBug ReportVery LowHigh[blueman] org.freedesktop.DBus.Error.NameHasNoOwnerUnconfirmed
0%
Task Description

Description:

org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name ‘org.bluez.obex’: no such name

Additional info:
* package version(s)

$ pacman -Si blueman
Repositorio               : community
Nombre                    : blueman
Versión                   : 2.0.4-3
Descripción               : GTK+ Bluetooth Manager
Arquitectura              : x86_64
URL                       : https://github.com/blueman-project/blueman
Licencias                 : GPL
Grupos                    : Nada
Provee                    : Nada
Depende de                : bluez  bluez-libs  gtk3  libnotify  python-cairo  python-dbus
                            python-gobject
Dependencias opcionales   : dnsmasq: Network Access Point (NAP) support
                            networkmanager: Dial Up Networking (DUN) and Personal Area
                            Networking (PAN) support
                            pulseaudio-bluetooth: audio devices support
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 1814,18 KiB
Tamaño de la instalación  : 5345,00 KiB
Encargado                 : Felix Yan <felixonmars@archlinux.org>
Fecha de creación         : dom 25 dic 2016 12:00:42 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

* config and/or log files etc.

(blueman-applet | ccze -A):
- https://paste.debian.net/plain/1049476

(pkgfile -l blueman):
- https://paste.debian.net/plain/1049477

Steps to reproduce:

- Install blueman

PackagesAnyBug ReportVery LowHigherror: extract: not overwriting dir with file /usr/loca...Unconfirmed
0%
Task Description

Description:

after upgrade there are errors that shall not be there. I cannot know why.

admin-> upgrade-hyperbola
:: Synchronizing package databases...
 core                             186.6 KiB   283K/s 00:01 [###############################] 100%
 extra                           1918.8 KiB   259K/s 00:07 [###############################] 100%
 community                          4.1 MiB   217K/s 00:19 [###############################] 100%
 DEB_Arch_Extra                     4.2 KiB  0.00B/s 00:00 [###############################] 100%
 DEB_Arch_Extra.sig               280.0   B  0.00B/s 00:00 [###############################] 100%
:: Starting full system upgrade...
warning: elinks: local (0.13-18) is newer than community (0.12pre6-1.hyperbola1)
resolving dependencies...
looking for conflicting packages...

Packages (5) filesystem-2017.03-2.hyperbola10.4  icedove-uxp-52.9.20181107-1
             iceweasel-uxp-52.9.20181107-1  licenses-20140629-2.hyperbola3
             pacman-mirrorlist-20181031-1.hyperbola1.1

Total Download Size:    79.91 MiB
Total Installed Size:  226.65 MiB
Net Upgrade Size:        0.26 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
 filesystem-2017.03-2.hyperb...    13.0 KiB  0.00B/s 00:00 [###############################] 100%
 licenses-20140629-2.hyperbo...    68.4 KiB   171K/s 00:00 [###############################] 100%
 pacman-mirrorlist-20181031-...     5.6 KiB  0.00B/s 00:00 [###############################] 100%
 icedove-uxp-52.9.20181107-1...    37.6 MiB   403K/s 00:06 [############################---]  93     icedove-uxp-52.9.20181107-1...    37.9 MiB   41-----------------------------]      iceweasel-uxp-52.9.20181107...     3.8 MiB   867K/s 00:42 [##-----------------------------]       iceweasel-uxp-52.9.20181107...     3.8 MiB   600K/s 01:01 [##-----------------------------      iceweasel-uxp-52.9.20181107...     4.0 MiB   773K/s 00:47 [###----------------------------]    iceweasel-uxp-52.9.20181107...     4.1 MiB   702K/s 00:51 [###----------------------------]   iceweasel-uxp-52.9.20181107...    39.8 MiB   212K/s 03:12 [###############################] 100%
(5/5) checking keys in keyring                             [###############################] 100%
(5/5) checking package integrity                           [###############################] 100%
(5/5) loading package files                                [###############################] 100%
(5/5) checking for file conflicts                          [###############################] 100%
(5/5) checking available disk space                        [###############################] 100%
:: Processing package changes...
(1/5) upgrading filesystem                                 [###############################] 100%
error: extract: not overwriting dir with file /usr/local/share/man
error: problem occurred while upgrading filesystem
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
PackagesAnyBug ReportDeferHigh[texlive-most] cannot export LaTeX - input csr10' fail...Deferred
50%
Task Description

I was using GNU Emacs, and tried to export LaTeX file or make a PDF. It seems that texlive package is broken, some fonts are missing.

The group named texlive-most cannot be properly installed.

admin→ pacsearch texlive

extra/texlive-bibtexextra 2016.43765-1 (texlive-most)
    TeX Live - Additional BibTeX styles and bibliography databases
extra/texlive-bin 2016.41290-12.hyperbola1 [installed]
    TeX Live binaries (Hyperbola rebranded)
extra/texlive-core 2016.43757-1.hyperbola2 (texlive-most) [installed]
    TeX Live core distribution, without nonfree add-on packages (Hyperbola rebranded)
extra/texlive-fontsextra 2016.43763-1.hyperbola2 (texlive-most) [installed]
    TeX Live - all sorts of extra fonts, without nonfree add-on packages
extra/texlive-formatsextra 2016.41438-3 (texlive-most) [installed]
    TeX Live - collection of extra TeX 'formats'
extra/texlive-games 2016.43415-1 (texlive-most)
    TeX Live - Setups for typesetting various board games, including chess
extra/texlive-genericextra 2016.43605-1 (texlive-most) [installed]
    TeX Live - mixed bag of generic macro packages and fonts
extra/texlive-htmlxml 2016.43769-1 (texlive-most)
    TeX Live - Packages to convert LaTeX to XML/HTML, and typeset XML/SGML
extra/texlive-humanities 2016.43711-1 (texlive-most)
    TeX Live - LaTeX packages for law, linguistics, social sciences, and humanities
extra/texlive-langchinese 2016.43669-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Chinese texts
extra/texlive-langcjk 2014.0-1
    TeX Live - CJK (Chinese, Japanese, Korean) metapackage
extra/texlive-langcyrillic 2016.43417-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Cyrillic texts
extra/texlive-langextra 2016.43739-1 (texlive-lang)
    TeX Live - Bundle of all extra language support
extra/texlive-langgreek 2016.43222-1 (texlive-lang)
    TeX Live - Fonts and support for typesetting Greek
extra/texlive-langjapanese 2016.43741-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Japanese texts
extra/texlive-langkorean 2016.43130-1 (texlive-lang)
    TeX Live - Fonts and macro packages to typeset Korean texts
extra/texlive-latexextra 2016.43768-1.hyperbola2 (texlive-most) [installed]
    TeX Live - Large collection of add-on packages for LaTeX, without nonfree add-on packages
extra/texlive-music 2016.43375-1 (texlive-most)
    TeX Live - Music typesetting packages
extra/texlive-pictures 2016.43767-1 (texlive-most) [installed]
    TeX Live - Packages for drawings graphics
extra/texlive-plainextra 2016.43137-1 (texlive-most) [installed]
    TeX Live - A collection of add-on packages and macros for plain TeX
extra/texlive-pstricks 2016.43710-1 (texlive-most) [installed]
    TeX Live - Additional PSTricks packages
extra/texlive-publishers 2016.43764-1 (texlive-most)
    TeX Live - LaTeX classes and packages for specific publishers
extra/texlive-science 2016.43747-1 (texlive-most)
    TeX Live - Typesetting for mathematics, natural and computer sciences

[~]
admin→ sudo pacman -S texlive-most

:: There are 15 members in group texlive-most:
:: Repository extra
   1) texlive-bibtexextra  2) texlive-core  3) texlive-fontsextra  4) texlive-formatsextra  5) texlive-games  6) texlive-genericextra
   7) texlive-htmlxml  8) texlive-humanities  9) texlive-latexextra  10) texlive-music  11) texlive-pictures  12) texlive-plainextra
   13) texlive-pstricks  14) texlive-publishers  15) texlive-science

Enter a selection (default=all):
warning: texlive-core-2016.43757-1.hyperbola2 is up to date -- reinstalling
warning: texlive-fontsextra-2016.43763-1.hyperbola2 is up to date -- reinstalling
warning: texlive-formatsextra-2016.41438-3 is up to date -- reinstalling
warning: texlive-genericextra-2016.43605-1 is up to date -- reinstalling
warning: texlive-latexextra-2016.43768-1.hyperbola2 is up to date -- reinstalling
warning: texlive-pictures-2016.43767-1 is up to date -- reinstalling
warning: texlive-plainextra-2016.43137-1 is up to date -- reinstalling
warning: texlive-pstricks-2016.43710-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (15) texlive-bibtexextra-2016.43765-1  texlive-core-2016.43757-1.hyperbola2  texlive-fontsextra-2016.43763-1.hyperbola2
              texlive-formatsextra-2016.41438-3  texlive-games-2016.43415-1  texlive-genericextra-2016.43605-1
              texlive-htmlxml-2016.43769-1  texlive-humanities-2016.43711-1  texlive-latexextra-2016.43768-1.hyperbola2
              texlive-music-2016.43375-1  texlive-pictures-2016.43767-1  texlive-plainextra-2016.43137-1  texlive-pstricks-2016.43710-1
              texlive-publishers-2016.43764-1  texlive-science-2016.43747-1

Total Download Size:     27.66 MiB
Total Installed Size:  1300.90 MiB
Net Upgrade Size:       110.88 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 texlive-bibtexextra-2016.43765-1-any                   1541.4 KiB   275K/s 00:06 [###############################################] 100%
 texlive-games-2016.43415-1-any                          416.5 KiB   356K/s 00:01 [###############################################] 100%
 texlive-htmlxml-2016.43769-1-any                       1197.6 KiB   300K/s 00:04 [###############################################] 100%
 texlive-humanities-2016.43711-1-any                     299.0 KiB   664K/s 00:00 [###############################################] 100%
 texlive-music-2016.43375-1-any                           12.2 MiB   398K/s 00:31 [###############################################] 100%
 texlive-publishers-2016.43764-1-any                       9.2 MiB   471K/s 00:20 [###############################################] 100%
 texlive-science-2016.43747-1-any                          2.9 MiB   376K/s 00:08 [###############################################] 100%
(15/15) checking keys in keyring                                                  [###############################################] 100%
(15/15) checking package integrity                                                [###############################################] 100%
(15/15) loading package files                                                     [###############################################] 100%
(15/15) checking for file conflicts                                               [###############################################] 100%
(15/15) checking available disk space                                             [###############################################] 100%
:: Processing package changes...
( 1/15) reinstalling texlive-core                                                 [###############################################] 100%
>>> updmap custom entries should go into /etc/texmf/web2c/updmap-local.cfg
>>> fmtutil custom entries should go into /etc/texmf/web2c/fmtutil-local.cnf
( 2/15) installing texlive-bibtexextra                                            [###############################################] 100%
( 3/15) reinstalling texlive-fontsextra                                           [###############################################] 100%
( 4/15) reinstalling texlive-formatsextra                                         [###############################################] 100%
( 5/15) installing texlive-games                                                  [###############################################] 100%
( 6/15) reinstalling texlive-genericextra                                         [###############################################] 100%
( 7/15) installing texlive-htmlxml                                                [###############################################] 100%
( 8/15) reinstalling texlive-latexextra                                           [###############################################] 100%
( 9/15) installing texlive-humanities                                             [###############################################] 100%
Optional dependencies for texlive-humanities
    texlive-pictures: for package qtree [installed]
(10/15) installing texlive-music                                                  [###############################################] 100%
Optional dependencies for texlive-music
    python2: for scripts from the lilyglyphs packages [installed]
(11/15) reinstalling texlive-pictures                                             [###############################################] 100%
(12/15) reinstalling texlive-plainextra                                           [###############################################] 100%
(13/15) reinstalling texlive-pstricks                                             [###############################################] 100%
(14/15) installing texlive-publishers                                             [###############################################] 100%
(15/15) installing texlive-science                                                [###############################################] 100%
Optional dependencies for texlive-science
    python2-pygments: for pygmentex
:: Running post-transaction hooks...
(1/3) Updating TeXLive filename database...
(2/3) Updating TeXLive format files...

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf ecrm1000

! I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm ecrm1000
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf ecrm1000

! I can't find file `ecrm1000'.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Please type another input file name
! Emergency stop.
<*> ...ljfour; mag:=1; nonstopmode; input ecrm1000

Transcript written on mfput.log.
grep: ecrm1000.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input ecrm1000' failed to make ecrm1000.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.

kpathsea: Running mktextfm csr10
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10
This is METAFONT, Version 2.7182818 (TeX Live 2016/Hyperbola) (preloaded base=mf)

kpathsea: Running mktexmf csr10

! I can't find file `csr10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input csr10

Transcript written on mfput.log.
grep: csr10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input csr10' failed to make csr10.tfm.
kpathsea: Appending font creation commands to missfont.log.
fmtutil [ERROR]: running `pdftex -ini   -jobname=utf8mex -progname=utf8mex -enc *utf8mex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [WARNING]: inifile pdfmex.ini for pdfmex/pdftex not found.
fmtutil [ERROR]: running `pdftex -ini   -jobname=csplain -progname=csplain -etex -enc csplain-utf8.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfjadetex -progname=pdfjadetex *pdfjadetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=jadetex -progname=jadetex *jadetex.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [WARNING]: inifile mex.ini for mex/pdftex not found.
fmtutil [ERROR]: running `xetex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex csplain.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `pdftex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex -enc csplain-utf8.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
fmtutil [ERROR]: running `luatex -ini   -jobname=pdfcsplain -progname=pdfcsplain -etex csplain.ini </dev/null' return status 1
fmtutil [ERROR]: return error due to options --strict
error: command failed to execute correctly
(3/3) Updating TeXLive font maps...
[~]
a
PackagesAnyImplementation RequestVery HighMedium[coturn] add new packageUnconfirmed
0%
Task Description

Description:

  • add new package

Additional info:

Steps to reproduce:

  • none
PackagesAnyImplementation RequestVery HighMedium[mediagoblin] add GNU MediaGoblin packageUnconfirmed
0%
Task Description

Description:

  • add GNU MediaGoblin package

Additional info:

  • none

Steps to reproduce:

  • none
PackagesAnySecurity IssueMediumMedium[cinepaint] unmaintained and unsupportableIn Progress
50%
Task Description

Remove “cinepaint” package since it’s unmaintained and unsupportable. Also, it doesn’t contains any file format support in the latest version (previous version supported multiple file formats).

I suggest use Krita (or Gimp 2.10) to edit 16bit and 32bit file formats or convert with imagemagick/graphicsmagick.

$ pacman -Si cinepaint
Repository      : community
Name            : cinepaint
Version         : 1:1.0.4-5
Description     : Sophisticated graphics manipulation programm supporting > 8bit pictures
Architecture    : x86_64
URL             : http://www.cinepaint.org
Licenses        : LGPL  GPL  MIT
Groups          : None
Provides        : None
Depends On      : gtk2  openexr  lcms  libxpm  fltk  ftgl  libxxf86vm
Optional Deps   : python2: for python plug-ins
                  gutenprint: for print plug-ins
                  ghostscript: for pdf plug-ins
Conflicts With  : None
Replaces        : None
Download Size   : 3.75 MiB
Installed Size  : 13.91 MiB
Packager        : Christian Hesse <arch@eworm.de>
Build Date      : Thu 28 Apr 2016 05:17:05 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyImplementation RequestMediumMedium[uzem][uzebox] add uzem emulator and uzebox firmware pa...Assigned
0%
Task Description

Add “uzem” emulator and “uzebox” firmware packages[0][1].

It’s a emulator and firmware for fully free 8bit game console.

[0]:http://belogic.com/uzebox/index.asp (no https found)
[1]:https://github.com/Uzebox/uzebox

PackagesAnyImplementation RequestMediumMedium[ncdu] add new packageDeferred
0%
Task Description

PKGBUILD

# $Id: PKGBUILD 187611 2016-08-26 15:44:01Z bisson $
# Contributor: lp76 <l.peduto@gmail.com>
# Contributor: Daenyth <Daenyth+Arch AT gmail DOT com>
# Maintainer: Gaetan Bisson <bisson@archlinux.org>

pkgname=ncdu
pkgver=1.12
pkgrel=1.hyperbola1
pkgdesc='Disk usage analyzer with an ncurses interface'
url='https://dev.yorhel.nl/ncdu'
license=('custom:MIT')
depends=('ncurses')
arch=('i686' 'x86_64')
validpgpkeys=('74460D32B80810EBA9AFA2E962394C698C2739FA')
source=("https://dev.yorhel.nl/download/${pkgname}-${pkgver}.tar.gz"{,.asc})
sha512sums=('20620dd79d2af878442769e097f13806f64f23875dcb85ebccd573a3de43aba5663d496049b64015d13f9a79d624298032c008ef61dfb6f61d8b12902b8dca12'
            'SKIP')

build() {
    cd "${srcdir}/${pkgname}-${pkgver}"
    ./configure --prefix=/usr
    make
}

package() {
    cd "${srcdir}/${pkgname}-${pkgver}"
    make DESTDIR="${pkgdir}" install
    install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
PackagesAnyImplementation RequestMediumMedium[searx] add new packageDeferred
0%
Task Description

Hi André, you could make an init for the searx search engine, it happens that
I want to launch it from local to avoid being in searx.me or
searx.riseup.net.

I have seen that there is a PKGBUILD in AUR [0]. I think it is necessary to make one with the init Openrc

[0]: https://aur.archlinux.org/packages/searx-py3/

PackagesAnyBug ReportMediumMedium[rxvt-unicode] rc-status command print "bug" tableResearching
0%
Task Description

If you do a command line rc-status on urxvt terminal, the name of the column of services are hidden. You will only see the status columns. Example:

Runlevel: default
  started  ]
  started  ]
  started  ]
  started  ]
  started 00:36:20 (0) ]
  started 00:36:20 (0) ]
  started 00:36:20 (0) ]
  started 00:36:20 (0) ]
Dynamic Runlevel: hotplugged
Dynamic Runlevel: needed/wanted
  started  ]
  started  ]
  started  ]d
Dynamic Runlevel: manual
ServicesFlyspray BrandingImplementation RequestMediumMediumAdd Hyperbola branding to HyperTaskIn Progress
40%
Task Description

Add Hyperbola branding to HyperTask such as HyperWiki and HyperForum for prolixity reasons.

PackagesAnyFeature RequestMediumMedium[epiphany] restore the hidden setting to disable JavaSc...Researching
0%
Task Description

Please restore the hidden setting (which can be enabled via dconf-editor) to disable JavaScript, which was removed last year (see here for details: https://github.com/GNOME/epiphany/blob/master/NEWS ).
Please do not remove the browser from the repos, as it renders this website correctly, unlike Mozlla based browsers (see here for more info: https://issues.hyperbola.info/index.php?do=details&task_id=131). The browser also provides other functions currently unavailable in Mozilla browsers, such as accessing LibreCMC router’s non-SSL web interface.

ServicesHyperWiki/DokuWikiImplementation RequestMediumMediumLibreboot hardening grub guideUnconfirmed
0%
Task Description

I don’t know if this is the best place for this, but I get stuck on the hardening the grub guide from libreboot,

https://libreboot.org/docs/gnulinux/grub_hardening.html

I wondered if there is anything different that needs to be done to get this part done:

gpg –homedir keys –detach-sign my.initramfs
gpg –homedir keys –detach-sign my.kernel
gpg –homedir keys –detach-sign libreboot_grub.cfg
gpg –homedir keys –detach-sign my.grubtest.cfg

it gives me a bunch of weird errors

PackagesStableBug ReportMediumMedium[libusb] error when mounting USB memories on virtual ma...Researching
0%
Task Description

## Bug ##

libusb: error [_get_usbfs_fd] libusb couldn’t open USB device /dev/bus/usb/003/003: permission denied libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.

Reference links: https://askubuntu.com/questions/526962/libusb-couldnt-open-usb-device-dev-bus-usb-002-006-permission-denied-libusb

Showing tasks 201 - 250 of 614 Page 5 of 13<<First - 3 - 4 - 5 - 6 - 7 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing