All Projects

ProjectCategoryTask TypePrioritySeveritySummary  descStatusProgress
PackagesAnyFreedom IssueVery LowLow[qt5-svg]: using "contents" in descriptionUnconfirmed
0%
Task Description

Description:

extra/qt5-svg 5.8.0-1 (qt qt5) [installed]
    Classes for displaying the contents of SVG files

The description is vague.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFeature RequestHighHigh[qt5-base] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si qt5-base
Repository      : extra
Name            : qt5-base
Version         : 5.8.0-11.hyperbola1
Description     : A cross-platform application and UI framework, without systemd support
Architecture    : x86_64
URL             : https://www.qt.io/developers/
Licenses        : GPL3  LGPL3  FDL  custom
Groups          : qt  qt5
Provides        : None
Depends On      : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig  xcb-util-wm  libxrender  libxi  sqlite  xcb-util-image  icu  tslib
                  libinput  libsm  libxkbcommon-x11  libproxy  libcups  openssl-1.0
Optional Deps   : qt5-svg: to use SVG icon themes
                  postgresql-libs: PostgreSQL driver
                  libmariadbclient: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin
Conflicts With  : qtchooser
Replaces        : None
Download Size   : 11.23 MiB
Installed Size  : 56.18 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Tue 22 Aug 2017 03:22:14 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyImplementation RequestVery LowLow[qpdfview] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

qpdfview

“A tabbed PDF viewer using the poppler library.”

https://www.parabola.nu/packages/community/x86_64/qpdfview/

License : GPL2

Thanks

PackagesAnyFreedom IssueVery LowLow[qpdf]: using "Content" in descriptionUnconfirmed
0%
Task Description

Description:

extra/qpdf 6.0.0-2
    QPDF: A Content-Preserving PDF Transformation System

The description is vague.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFreedom IssueVery LowLow[qlandkartegt]: using kernel name instead of operating ...Unconfirmed
0%
Task Description

Description:

community/qlandkartegt 1.8.1-8
     Use your GPS with Linux

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnySecurity IssueVery LowMedium[qemu] Multiple CVEUnconfirmed
0%
Task Description

CVE-2018-20123 QEMU: pvrdma: memory leakage in device hotplug
https://www.openwall.com/lists/oss-security/2018/12/13/4

CVE-2018-16872 Qemu: usb-mtp: path traversal by host filesystem
manipulation in Media Transfer Protocol (MTP)
https://www.openwall.com/lists/oss-security/2018/12/13/11

Patches included at above URLs.

PackagesAnyBug ReportLowLow[qbittorrent-nox] uses "nox" suffixIn Progress
0%
Task Description

Description:

  • Fix package name to qbittorrent-headless that is the correct name for packages without graphical user interface support. nox suffix is incorrect because Hyperbola supports Wayland too, not only X.Org.

Additional info:
* package version(s)

  • 3.3.11-1

* config and/or log files etc.

Steps to reproduce:

  • None
PackagesAnyReplace RequestDeferCritical[python2] replace deprecated Python 2 to TauthonDeferred
0%
Task Description

Description:

  • replace deprecated Python 2 to Tauthon for Canis Major

Additional info:

Steps to reproduce:

  • Broken python2 packages.
PackagesAnyFreedom IssueMediumLow[python2-tornado] vague terminology "Open Source" in de...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/python2-tornado 4.5.1-1 [installed]
    open source version of the scalable, non-blocking web server and tools

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

free software version of the scalable, non-blocking web server and tools
PackagesAnyFreedom IssueMediumLow[python2-scipy] vague terminology "Open Source" in desc...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/python2-scipy 0.19.0-1 [installed]
    SciPy is open-source software for mathematics, science, and engineering.

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

SciPy is free software for mathematics, science, and engineering.
PackagesStableBug ReportVery LowCritical[python2-reportlab] python2-pip dependencyUnconfirmed
0%
Task Description

Since python-pip and python2-pip have been removed, I can’t install python2-reportlab because python2-pip is a dependency of this package.
.

PackagesAnyFeature RequestHighHigh[python2-pyopenssl] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si python2-pyopenssl
Repository      : extra
Name            : python2-pyopenssl
Version         : 17.0.0-1
Description     : Python2 wrapper module around the OpenSSL library
Architecture    : any
URL             : http://pypi.python.org/pypi/pyOpenSSL
Licenses        : LGPL2.1
Groups          : None
Provides        : None
Depends On      : openssl  python2-six  python2-cryptography
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 69.85 KiB
Installed Size  : 556.00 KiB
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Sat 22 Apr 2017 02:17:19 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueVery LowLow[python2-pyinotify]: using kernel name instead of opera...Unconfirmed
0%
Task Description

Description:

community/python2-pyinotify 0.9.6-3 [installed]
     Python module used for monitoring filesystems events on Linux platforms with inotify.
 community/qlandkartegt 1.8.1-8

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[python2-pam]: using kernel name instead of operating s...Unconfirmed
0%
Task Description

Description:

community/python2-pam 0.1.4-3 [installed]
     Module that provides an authenticate function that allows the caller to authenticate a given username / password against the PAM sy stem on Linux.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFeature RequestHighHigh[python2-m2crypto] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si python2-m2crypto
Repository      : community
Name            : python2-m2crypto
Version         : 0.24.0-3
Description     : A crypto and SSL toolkit for Python
Architecture    : x86_64
URL             : https://pypi.python.org/pypi/M2Crypto
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : python2  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 197.71 KiB
Installed Size  : 1298.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:08:30 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueMediumLow[python2-biopython]: using vague "freely available" ter...Deferred
0%
Task Description
community/python2-biopython 1.69-1
    Freely available Python tools for computational molecular biology

See:
https://www.gnu.org/philosophy/words-to-avoid.html#FreelyAvailable

Don’t use “freely available software” as a synonym for “free software.” The terms are not equivalent. Software is “freely available” if anyone can easily get a copy. “Free software” is defined in terms of the freedom of users that have a copy of it. These are answers to different questions.

PackagesAnyFreedom IssueMediumLow[python-tornado] vague terminology "Open Source" in des...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/python-tornado 4.5.1-1 [installed]
    open source version of the scalable, non-blocking web server and tools

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

free software version of the scalable, non-blocking web server and tools
PackagesAnyFreedom IssueMediumLow[python-scipy] vague terminology "Open Source" in descr...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/python-scipy 0.19.0-1
    SciPy is open-source software for mathematics, science, and engineering.

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

SciPy is free software for mathematics, science, and engineering.
PackagesAnyFeature RequestHighHigh[python-pyopenssl] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si python-pyopenssl
Repository      : extra
Name            : python-pyopenssl
Version         : 17.0.0-1
Description     : Python3 wrapper module around the OpenSSL library
Architecture    : any
URL             : http://pypi.python.org/pypi/pyOpenSSL
Licenses        : LGPL2.1
Groups          : None
Provides        : pyopenssl
Depends On      : openssl  python-six  python-cryptography
Optional Deps   : None
Conflicts With  : pyopenssl
Replaces        : pyopenssl
Download Size   : 71.49 KiB
Installed Size  : 507.00 KiB
Packager        : Felix Yan <felixonmars@archlinux.org>
Build Date      : Sat 22 Apr 2017 02:17:19 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueVery LowLow[python-pyinotify]: using kernel name instead of operat...Unconfirmed
0%
Task Description

Description:

community/python-pyinotify 0.9.6-3
     Python module used for monitoring filesystems events on Linux platforms with inotify.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyImplementation RequestVery LowLow[python-cheat] add package Unconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

python-cheat

“Cheat allows you to create and view interactive cheatsheets on the command-line.”

https://aur.archlinux.org/packages/python-cheat/

https://github.com/chrisallenlane/cheat

License : GPL3

Thanks

PackagesAnyFreedom IssueMediumLow[python-biopython]: using vague "freely" term in descri...Deferred
0%
Task Description
community/python-biopython 1.69-1
    Freely available Python tools for computational molecular biology

See:
https://www.gnu.org/philosophy/words-to-avoid.html#FreelyAvailable

Don’t use “freely available software” as a synonym for “free software.” The terms are not equivalent. Software is “freely available” if anyone can easily get a copy. “Free software” is defined in terms of the freedom of users that have a copy of it. These are answers to different questions.

PackagesAnyFeature RequestHighHigh[pyrit] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si pyrit
Repository      : community
Name            : pyrit
Version         : 0.5.0-2.hyperbola1
Description     : The famous WPA precomputed cracker, without nonfree cpyrit-cuda recommendation
Architecture    : x86_64
URL             : https://github.com/JPaulMora/Pyrit
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : openssl  python2  zlib  libpcap
Optional Deps   : cpyrit-opencl: opencl support
                  scapy: packet capture analyzation support
                  python2-sqlalchemy: storage support
Conflicts With  : None
Replaces        : None
Download Size   : 113.65 KiB
Installed Size  : 752.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sat 17 Jun 2017 12:10:36 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[pypy] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si pypy
Repository      : community
Name            : pypy
Version         : 5.7.1-1
Description     : A Python implementation written in Python, JIT enabled
Architecture    : x86_64
URL             : http://pypy.org
Licenses        : custom:MIT
Groups          : None
Provides        : None
Depends On      : expat  bzip2  gdbm  openssl  libffi  zlib
Optional Deps   : sqlite: sqlite module
                  tk: tk module
Conflicts With  : None
Replaces        : None
Download Size   : 16.77 MiB
Installed Size  : 95.02 MiB
Packager        : Sven-Hendrik Haase <sh@lutzhaase.com>
Build Date      : Wed 05 Apr 2017 05:26:04 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueMediumLow[pymol] vague terminology "Open Source" in description ...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/pymol 1.8.6.0-2
    Molecular visualization system on an Open Source foundation

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

Molecular visualization system on a Free Software foundation
PackagesAnyFeature RequestMediumMedium[pybitmessage] Package RequestUnconfirmed
0%
Task Description

PyBitmessage is a secure p2p e-mail alternative. It could be useful to package it.

https://github.com/Bitmessage/PyBitmessage/releases https://aur.archlinux.org/packages/pybitmessage/ https://aur.archlinux.org/packages/pybitmessage-git/ (contains a firejail profile)

PackagesAnyFeature RequestHighHigh[pwsafe] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si pwsafe
Repository      : community
Name            : pwsafe
Version         : 20160304-2
Description     : A commandline program for managing encrypted password databases
Architecture    : x86_64
URL             : https://github.com/nsd20463/pwsafe
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : openssl  libxmu
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 40.61 KiB
Installed Size  : 126.00 KiB
Packager        : Sergej Pupykin <pupykin.s+arch@gmail.com>
Build Date      : Fri 17 Feb 2017 03:34:16 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyPrivacy IssueVery LowLow[purple-plugin-pack] Provides Napster support which is ...Unconfirmed
0%
Task Description

purple-plugin-pack provides access to Napster which is only useful with a single company and sever (as far as I could tell).

PackagesAnyImplementation RequestVery LowMedium[purple-matrix] Please add packageUnconfirmed
0%
Task Description

Package is a libpurple plugin for the Matrix protocol which is consistent with Hyperbola’s social contract as Matrix is a federated protocol.

Source code can be found here licensed under GPLv2:

https://github.com/matrix-org/purple-matrix

PKGBUILD for git version is available here (last stable release is from two years ago so git version is probably the best version to use):

https://aur.archlinux.org/packages/purple-matrix-git/

PackagesAnyFeature RequestHighHigh[pulseaudio-zeroconf] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si pulseaudio-zeroconf
Repository      : extra
Name            : pulseaudio-zeroconf
Version         : 10.0-3.hyperbola1
Description     : Zeroconf support for PulseAudio, with eudev support
Architecture    : x86_64
URL             : https://www.freedesktop.org/wiki/Software/PulseAudio/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pulseaudio=10.0-3.hyperbola1  avahi  openssl
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 20.99 KiB
Installed Size  : 94.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Tue 08 Aug 2017 03:36:33 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueMediumLow[publicsuffix-list] vague terminology "Vendor" in descr...Deferred
0%
Task Description

This package contains vague terminology “Vendor”:

extra/publicsuffix-list 20170118.560.45a2bf8-1
    Cross-vendor public domain suffix database

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Vendor”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Vendor

It would be good example to set to have proper description of packages without using “Vendor”.

eg.

Cross-supplier public domain suffix database
PackagesAnyFeature RequestHighHigh[proxytunnel] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si proxytunnel
Repository      : community
Name            : proxytunnel
Version         : 1.9.0.253-2
Description     : a program that connects stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy
Architecture    : x86_64
URL             : http://proxytunnel.sourceforge.net
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : openssl
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 21.20 KiB
Installed Size  : 71.00 KiB
Packager        : Sergej Pupykin <pupykin.s+arch@gmail.com>
Build Date      : Fri 17 Feb 2017 03:32:14 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[prosody] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si prosody
Repository      : community
Name            : prosody
Version         : 1:0.10.r7198+.2fd20f372cb1+-2
Description     : Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)
Architecture    : x86_64
URL             : https://prosody.im/
Licenses        : MIT
Groups          : None
Provides        : prosody
Depends On      : lua51  lua51-socket  lua51-expat  lua51-filesystem  libidn  openssl
Optional Deps   : lua51-sec: TLS encryption support
                  lua51-bitop: websocket support
                  lua51-event: libevent support
                  lua51-dbi: SQL storage support
Conflicts With  : prosody
Replaces        : None
Download Size   : 245.43 KiB
Installed Size  : 1290.00 KiB
Packager        : Sergej Pupykin <pupykin.s+arch@gmail.com>
Build Date      : Tue 28 Feb 2017 02:48:30 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestVery HighHigh[prosody] needs OpenRC init script and contains systemd...Assigned
0%
Task Description

Description:

  • needs OpenRC init script and contains systemd files

Additional info:

  • prosody 1:0.10.r7198+.2fd20f372cb1+-2
prosody /usr/lib/systemd/system/prosody.service
prosody /usr/lib/sysusers.d/prosody.conf
prosody /usr/lib/tmpfiles.d/prosody.conf

Steps to reproduce:

  • none
PackagesAnyUpdate RequestVery LowHigh[proj]: please update to latest versionUnconfirmed
0%
Task Description

Description:

https://proj4.org/index.html

This package have valuable geodetic applications, and I intend to present Hyperbola GNU/Linux-libre soon in universities and schools in East Africa.

The coordinate system there is not WGS84 and this package only in new version is providing the conversion from East African geographic coordinates to WGS84, and will be very usable in many industrial and private applications.

PackagesAnyImplementation RequestVery LowLow[powerpill] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

powerpill

“Pacman wrapper for faster downloads.”

https://aur.archlinux.org/packages/powerpill/

https://xyne.archlinux.ca/projects/powerpill

License : GPL

Thanks

PackagesAnyFeature RequestHighHigh[powerdns] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si powerdns
Repository      : community
Name            : powerdns
Version         : 4.0.3-3.hyperbola1
Description     : Authoritative DNS server, without systemd support
Architecture    : x86_64
URL             : https://www.powerdns.com/
Licenses        : GPL2
Groups          : None
Provides        : pdns
Depends On      : boost-libs  libsodium  lua  openssl  protobuf  sqlite
Optional Deps   : libmariadbclient: MariaDB/MySQL backend
                  postgresql-libs: PostgreSQL backend
                  libldap: LDAP backend
                  geoip: GeoIP backend
                  yaml-cpp: GeoIP backend
Conflicts With  : pdns
Replaces        : None
Download Size   : 2.70 MiB
Installed Size  : 18.38 MiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Mon 18 Sep 2017 01:37:08 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[powerdns-recursor] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si powerdns-recursor
Repository      : community
Name            : powerdns-recursor
Version         : 4.0.4-3.hyperbola1
Description     : Resolving DNS server, without systemd and libsystemd support
Architecture    : x86_64
URL             : https://www.powerdns.com/
Licenses        : GPL2
Groups          : None
Provides        : pdns-recursor
Depends On      : gcc-libs  boost-libs  lua  openssl  protobuf  libboost_context.so=1.63.0-64
Optional Deps   : None
Conflicts With  : pdns-recursor
Replaces        : None
Download Size   : 1234.97 KiB
Installed Size  : 4870.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Wed 20 Sep 2017 03:43:30 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[pound] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl-1.0.

$ pacman -Si pound
Repository      : community
Name            : pound
Version         : 2.7-4
Description     : A reverse proxy, load balancer, and SSL wrapper
Architecture    : x86_64
URL             : http://www.apsis.ch/pound/index_html
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : pcre  openssl-1.0
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 59.37 KiB
Installed Size  : 153.00 KiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Wed 05 Apr 2017 08:05:27 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyBug ReportMediumHigh[postgresql] creating directory Permission deniedUnconfirmed
0%
Task Description

In the File postgresql.install

the output is:

    ==> requires datadir /var/lib/data
    ==> run as user postgres: 'initdb -D /var/lib/data'

when it should be:

    ==> requires datadir /var/lib/postgres/data
    ==> run as user postgres: 'initdb -D /var/lib/postgres/data'

It may be necessary to change:

local datadir = "/var/lib/data"

to

local datadir = "/var/lib/postgres/data"

The comand for default fails:

creating directory /var/lib/data... initdb: could not create directory "/var/lib/data": Permission denied
PackagesAnyFeature RequestHighHigh[postgresql-old-upgrade] rebuild package against libres...Deferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si postgresql-old-upgrade
Repository      : extra
Name            : postgresql-old-upgrade
Version         : 9.5.6-1
Description     : PostgreSQL build for migrating between major versions with pg_upgrade
Architecture    : x86_64
URL             : https://www.postgresql.org/
Licenses        : custom:PostgreSQL
Groups          : None
Provides        : None
Depends On      : postgresql-libs>=9.5  libxml2  openssl>=1.0.0  pam
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 3.74 MiB
Installed Size  : 16.06 MiB
Packager        : Levente Polyak <anthraxx@archlinux.org>
Build Date      : Sun 05 Mar 2017 08:27:59 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueMediumLow[portaudio] vague terminology "Open Source" in descript...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/portaudio 190600_20161030-1
    A free, cross-platform, open source, audio I/O library.

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

A free software, cross-platform, audio I/O library.
PackagesAnyFreedom IssueMediumLow[polymake] vague terminology "Open Source" in descripti...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/polymake 3.1-1
    Open source software for research in polyhedral geometry

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

Free software for research in polyhedral geometry
PackagesAnyFreedom IssueMediumLow[pokerth] vague terminology "Open Source" in descriptio...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/pokerth 1.1.1-17
    Open source Texas Hold'em Poker simulator

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

Free software Texas Hold'em Poker simulator
PackagesAnyFeature RequestHighHigh[podofo] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si podofo
Repository      : community
Name            : podofo
Version         : 0.9.5-2.hyperbola1
Description     : A C++ library to work with the PDF file format
Architecture    : x86_64
URL             : http://podofo.sourceforge.net
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : lua  openssl  fontconfig  libtiff  libidn  libjpeg-turbo
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 775.34 KiB
Installed Size  : 4509.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Sat 21 Oct 2017 12:20:14 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFeature RequestHighHigh[poco] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si poco
Repository      : community
Name            : poco
Version         : 1.7.8-2
Description     : C++ class libraries for network-centric, portable applications, complete edition with debug libraries
Architecture    : x86_64
URL             : http://www.pocoproject.org/
Licenses        : custom:boost
Groups          : None
Provides        : None
Depends On      : libmariadbclient  openssl  unixodbc
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 2.94 MiB
Installed Size  : 13.91 MiB
Packager        : Sergej Pupykin <pupykin.s+arch@gmail.com>
Build Date      : Tue 25 Apr 2017 09:58:48 AM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyImplementation RequestVery LowLow[plymouth] add packageDeferred
0%
Task Description

Plymouth is an application that runs very early in the boot process (even before the root filesystem is mounted!) that provides a graphical boot animation while the boot process happens in the background.

Please implement plymouth as an optional package.

PackagesAnyFreedom IssueVery LowLow[pkgdiff]: using kernel name instead of operating syste...Unconfirmed
0%
Task Description

Description:

community/pkgdiff 1.7.1-1
     A tool for analyzing changes in Linux software packages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFeature RequestHighHigh[pjproject] rebuild package against libresslDeferred
0%
Task Description

Rebuild package against libressl, since it depends on openssl.

$ pacman -Si pjproject
Repository      : community
Name            : pjproject
Version         : 2.6-3
Description     : Libre SIP stack and media stack
Architecture    : x86_64
URL             : http://www.pjsip.org/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : openssl  portaudio  speex  alsa-lib  libsamplerate  util-linux-ng  ffmpeg  libsrtp  opus
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 1716.12 KiB
Installed Size  : 10143.00 KiB
Packager        : André Silva <emulatorman@hyperbola.info>
Build Date      : Fri 05 May 2017 04:45:03 PM -03
Validated By    : MD5 Sum  SHA-256 Sum  Signature
PackagesAnyFreedom IssueVery LowLow[pinta] mentioning proprietary software Paint.NETUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

community/pinta 1.6-2 [installed]
     Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users

I am not quite sure what the policy is in Hyperbola on this one. I am referring to the reference to the proprietary software Paint.NET. That is for me steering users to verify what is Paint.NET – we shall not be doing it. It should be removed from description.

I am fine if authors have in documentation something explaining how they started software project. But I am not fine in descriptions which are public and accessible on Internet to have such references to illegitimate proprietary software.

Just to clarify, the word “alternative” is just fine in this description and need not be removed.

Showing tasks 151 - 200 of 613 Page 4 of 13<<First - 2 - 3 - 4 - 5 - 6 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing