All Projects

ProjectCategoryTask Type  ascPrioritySeveritySummaryStatusProgress
ServicesPunBB BrandingBug ReportHighHighForum appearance bugsIn Progress
100%
Task Description

Some forum display errors:

  1. preview button with the orange border.
  1. Error message when logging in gray color making it difficult to read
ServicesPunBB IssueBug ReportVery LowLowhyperbola forum smtp error and profile updateUnconfirmed
0%
Task Description

here i will report 2 issues and one change to make
issues:
1- there is a failed smtp error with post and reply
2- in the forum profile one cant add website with .xyz domain name

the change:
1- with pgp key one would add a short key link just like what was mentioned in here:
https://forums.hyperbola.info/viewtopic.php?pid=2639#p2639

PackagesStableBug ReportVery LowMedium[kodi-addons-visualization] addons don't workUnconfirmed
0%
Task Description

After installation, none of the addons is present in Kodi!

PackagesStableBug ReportVery LowLowMupen64plus acts buggyUnconfirmed
0%
Task Description

the screen moves back and forth from left to right randomly, no matter what I do, any games any adapters do not work.

I wanted to have some fun with some old games...

Has anyone used mupen64plus successfully on hyperbola 0.2? I cannot get it to work without being completely confusing for the reasons I have mentioned and also, the glaring of the screen. Which only happens with mupen64plus...

PackagesStableBug ReportVery LowMedium[cowsay] perl-text-charwidth dependency missingUnconfirmed
0%
Task Description

cowsay (cowsay-3.03-9.hyperbola1) is missing perl-text-charwidth dependency

Error message :

“Can’t locate Text/CharWidth.pm in @INC (you may need to install the Text::CharWidth module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/bin/cowsay line 14.
BEGIN failed–compilation aborted at /usr/bin/cowsay line 14.”

After installing perl-text-charwidth, it works fine.

PackagesStableBug ReportMediumMedium[linux-libre-lts] [i915] Display freeze : hpd interrupt...Deferred
0%
Task Description

Hello,

I recently acquired a T400 Thinkpad with 1440×900 panel.
On this T400, I installed Hyperbola, just like on my x200 Thinkpad with 1280×800 panel.

Both Thinkpad are running the same Hyperbola installation :

Full disk encryption (with Libreboot) so both Thinkpad are using early KMS (MODULES=”i915” in /etc/mkinitcpio.conf)
Same kernel : linux-libre-lts (4.9.99 at the moment I’m writing this message)
video driver : modesetting
DE : xfce4 with xfwm4

On the Thinkpad x200, everything works great, no issue to report.

On the T400 though, the linux-libre-lts kernel, I’m getting random display freezes, when it happens, this message appears in dmesg :

hpd interrupt storm detected on connector hdmi-a-1

And the display (and sound) freezes for 10 seconds (sometimes more !)

As Hyperbola proposes linux-libre-lts kernel only, I installed latest linux-libre-lts (4.14.40) and linux-libre (4.16.8) from Parabola GNU/Linux repo.

Results :

With 4.14.40 : Same issue as with 4.9.99 kernel from Hyperbola repo.
With 4.16.8 : Issue is not present ! No more freeze !

I’m not sure how to proceed though. Would you be kind enough helping me to find which commit in i915 driver improved the situation ? If we find it, maybe it could be added as a patch to 4.9.x kernel series.
Or maybe it is something else.. I don’t have much experience, I can provide logs if needed.

Thanks for your help

PackagesStableBug ReportVery LowMedium[nfs-utils] missing idmapd.confUnconfirmed
0%
Task Description

Hello,

When mounting an NFS share, I get a warning about missing idmpad.conf

rpc.idmapd: Skipping configuration file "/etc/idmapd.conf": No such file or directory
4341: * Stopping idmapd ...

Debian includes a default config file for idmap :

[General]

Verbosity = 0
Pipefs-Directory = /run/rpc_pipefs
# set your own domain here, if id differs from FQDN minus hostname
# Domain = localdomain

[Mapping]

Nobody-User = nobody
Nobody-Group = nogroup
PackagesStableBug ReportMediumMedium[virt-install] ERROR '_OsVariant' object has no attribu...Requires Testing
100%
Task Description

Trying to create a VM using virt-install (1.4.1-2.hyperbola2)

virt-install --connect qemu:///system \
--name debian \
--ram 1024 \
--disk path=/home/test/debian.img,size=50 \
--vcpus 2 \
--os-type linux \
--os-variant generic \
--network bridge=virbr0 \
--graphics none \
--console pty,target_type=serial \
--location 'http://ftp.nl.debian.org/debian/dists/stretch/main/installer-amd64/' \
--extra-args 'console=ttyS0,115200n8 serial'

This error shows up :
ERROR : ‘_OsVariant’ object has no attribute ‘urldistro’

I can’t create the VM.

PS : Error is not present on Debian Stretch with virt-install 1.4.0-5

Thanks for your help.

PackagesStableBug ReportVery LowVery LowGajim "Unable to run gpg - it may not be available" Assigned
0%
Task Description

Description:

Gajim XMPP Client wont start after installing python2-gnupg.

Additional info:
* package version(s)

  community/python2-gnupg 0.4.0-2
  extra/gajim 0.16.8-1.hyperbola2

* config and/or log files etc.

/usr/lib/python2.7/site-packages/gajim/common/gajim.py

Steps to reproduce:

With Gajim working is not possible to assign an OpenPGP key because it needs a wrapper. Therefore python2-gnupgp package is needed. But after installing python2-gnupgp, Gajim doesn’t start. The following output is displayed from the console:


07/21/2018 18:00:41 (E) gajim.c.gnupg Unable to run gpg - it may not be available.
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/gnupg.py", line 757, in __init__
  p = self._open_subprocess(["--version"])
File "/usr/lib/python2.7/site-packages/gnupg.py", line 832, in _open_subprocess
  startupinfo=si)
File "/usr/lib/python2.7/subprocess.py", line 394, in __init__
  errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1047, in _execute_child
  raise child_exception

OSError: [Errno 2] No such file or directory
Traceback (most recent call last):

File "gajim.py", line 513, in <module>
  interface.run()
File "/usr/lib/python2.7/site-packages/gajim/gui_interface.py", line 2704, in run
  self.roster = roster_window.RosterWindow()
File "/usr/lib/python2.7/site-packages/gajim/roster_window.py", line 6611, in __init__
  connection_zeroconf.ConnectionZeroconf(gajim.ZEROCONF_ACC_NAME)
File "/usr/lib/python2.7/site-packages/gajim/common/zeroconf/connection_zeroconf.py", line 68, in __init__
  CommonConnection.__init__(self, name)
File "/usr/lib/python2.7/site-packages/gajim/common/connection.py", line 150, in __init__
  self.gpg = gpg.GnuPG()
File "/usr/lib/python2.7/site-packages/gajim/common/gpg.py", line 37, in __init__
  gnupg.GPG.__init__(self, gpgbinary=gajim.GPG_BINARY, use_agent=use_agent)
File "/usr/lib/python2.7/site-packages/gnupg.py", line 761, in __init__
  raise OSError(msg)

OSError: Unable to run gpg - it may not be available.


After doing some search, the issue is that gajim.py is trying to call ‘gpg’ as ‘gpg1’.

# grep -n GPG_BINARY /usr/lib/python2.7/site-packages/gajim/common/gajim.py
162:GPG_BINARY = ‘gpg1’

By replacing ‘gpg’ instead of ‘gpg1’, Gajim will start normally with OpenPGP feature available.

Maybe a newer revision of python2-gnupg is required or maybe a small patch in the current package.

PackagesStableBug ReportVery LowHighjava cacerts file is emptyUnconfirmed
0%
Task Description

/etc/ssl/certs/java/cacerts has 0 entries, resulting in ssl handshake errors in java applications.

Package versions:
* ca-certificates 20170307-1
* ca-certificates-utils 20170307-1

PackagesStableBug ReportVery LowMediumPCManFM display different behaviorUnconfirmed
0%
Task Description

Description:

The problem is pcmanfm is not showing any partitions on the left side. It only show Home Folder, Desktop, Applications, Filesystem and the ext. hdd. If I include dbus-launch pcmanfm -d command, it show the other partitions on the left side of window but not ext. hdd. The drive/partitions are not encrypted.
I do have dbus, gvfs & ntfs-3g installed and active services.

Additional info:
* package version(s)
PCManFM 1.2.5 - using LibFM ver. 1.2.5

Steps to reproduce:
Original install from the livecd with LXDE but I may run Openbox standalone and get the same behavior with either environment. I do not have this issue running other distros.

PackagesStableBug ReportLowMediumGarbled display with xfce4-terminal (terminfo)Unconfirmed
0%
Task Description

A very nasty bug I wasn’t able to find an answer to.
I compiled stuff (buildroot) using menuconfig, the menu display was fine in xfce4-terminal (See screenshot #1)
I restarted the config a few days later with the same command :

$ make menuconfig

and this time the display was messed up (See screenshot #2)

After investigation, I noticed a directory (filled with stuff) have been created in my home folder :

.terminfo

I don’t know why. But anyway, if I delete it, then the display is ok again.
I noticed that if I use good old xterm terminal, then the display is fine even if the .terminfo directory is present. (it uses “xterm” instead of xterm-256color)

But, with xfce4-terminal (and others, I tried with gnome-terminal, sakura..), the display is messed up if the .terminfo directory is present in my home folder.

I also noticed that if I run the command in a screen session, the issue is not present.

(I open xfce4-terminal)

$ screen
$ printenv TERM
screen.xterm-256color
$ make menuconfig (or htop, or other program using ncurses)

= display ok

but with default :

(I open xfce4-terminal)

$ printenv TERM
xterm-256color
make menuconfig (or htop, or other program using ncurses)

= display messed up if .terminfo directory is present

So I have no idea why this .terminfo directory is generated. What could trigger its generation ? Is that an issue with ncurses or something else ?

Thanks for your help

PackagesStableBug ReportVery LowLowGNOME cannot lock screen while using LightDMUnconfirmed
0%
Task Description

Description:
Screen locking does not work in GNOME, either with keyboard shortcuts or from the menu, while using LightDM.

Additional info:
* According to this thread[1] this bug has been patched in Ubuntu. Please consider applying this patch.[2]

Steps to reproduce:
# pacman -S gnome lightdm lightdm-gtk-greeter
# rc-update add lightdm default
Reboot, log in to a GNOME session and attempt to lock screen.

[1] https://www.reddit.com/r/gnome/comments/9klvej/is_there_a_way_to_get_the_screen_to_lock_with/ [2] https://git.launchpad.net/~ubuntu-desktop/ubuntu/+source/gnome-shell/tree/debian/patches/ubuntu/lightdm-user-switching.patch

PackagesStableBug ReportVery LowMediumMouse curse become invisible from beginning in kde5 pla...Unconfirmed
0%
Task Description

Description:
I install plasma and xorg to my Hyperbola GNU/Linux-libre in Arch-way.
However, after reboot, everything is fine except mouse curse.

I attempt to reinstall plasma-desktop and reboot. But nothing changes.

In attachment, the mouse stop at backward, however it is invisible.

Additional info:
* package version(s)
plasma-desktop == 5.9.5-1
xorg-server == 1.19.6-2.hyperbola1
sddm == 0.14.0-2.hyperbola6

* config and/or log files etc.

Steps to reproduce:

PackagesStableBug ReportVery LowMedium [kodi] "The Movie Database" scraper doesn't workUnconfirmed
0%
Task Description

With kodi 17.1-2.hyperbola1 “The Movie Database” scraper doesn’t work. The error message is :

"Unable to connect to remote server"
PackagesStableBug ReportVery LowMedium[arm-unknown-linux-gnueabi-gcc] not working; needs prop...Unconfirmed
0%
Task Description

Description:
I believe the arm-unknown-linux-gnueabi-gcc package to be broken as described here.

Additional info:
* package version(s) - arm-unknown-linux-gnueabi-gcc - all versions

Steps to reproduce:
I don't think "steps to reproduce" to be relevant in this case. My forum topic linked above already contains all the necessary info on the subject :) However, one could try compiling glibc and busybox as described here. Yes, these are instructions for debian-like systems. They have to be adapted accordingly

PackagesStableBug ReportVery LowHigh[vlc] DVB : cache_block stream error: cannot pre fill b...Unconfirmed
0%
Task Description

Current VLC version (3.0.4-3.hyperbola1.backports1) fails to play DVB stream using a RTL2832 usb dongle.

I start the playlist like this :

vlc channels.conf

but it returns the following error :

cache_block stream error: cannot pre fill buffer

Also, it asks the user to be in “video” group to access DVB device, this was not needed before with Hyperbola 0.2.9. User being in “wheel” was enough.
Anyway, even after adding my user to video group, it still fails with “cache_block stream error: cannot pre fill buffer”

This is not an issue with my DVB adapter or driver. rtl2832 is correctly loaded. And I can play the channels.conf playlist just fine with “mpv” or “mplayer”.
Also, the channels.conf used works just fine with a more recent version of VLC on an other system (Manjaro) so something is broken with the current VLC used.

Maybe a package bump would fix the issue.

PackagesStableBug ReportMediumCritical[torsocks] which: no getcapRequires Testing
90%
Task Description

Current torsocks version is broken.
It returns the following error when attempting to torify application :

which: no getcap
PackagesStableBug ReportVery LowVery Low[spamassassin] has different directory permissions than...Deferred
0%
Task Description

Description:
The /usr/sbin directory in spamassassin has permissions 755
https://git.hyperbola.info:50100/packages/extra.git/tree/spamassassin/PKGBUILD#n88

And ‘filesystem’ sets it to 750
https://git.hyperbola.info:50100/packages/core.git/tree/filesystem/PKGBUILD#n135

So when installing spamassassin, pacman throws a warning

warning: directory permissions differ on /usr/sbin/
filesystem: 750  package: 755

Additional info:
* spamassassin 3.4.2-1.hyperbola2

PackagesStableBug ReportVery LowLowChemical uknown media typesResearching
50%
Task Description

I do not know how to solve this. Some of packages is causing this problem. I do not know which one.

Description:

(4/4) Updating the MIME type database...
Unknown media type in type ‘chemical/x-alchemy’ Unknown media type in type ‘chemical/x-cache’ Unknown media type in type ‘chemical/x-cactvs-ascii’ Unknown media type in type ‘chemical/x-cactvs-binary’ Unknown media type in type ‘chemical/x-cactvs-table’ Unknown media type in type ‘chemical/x-cdx’ Unknown media type in type ‘chemical/x-cdxml’ Unknown media type in type ‘chemical/x-chem3d’ Unknown media type in type ‘chemical/x-cif’ Unknown media type in type ‘chemical/x-cml’ Unknown media type in type ‘chemical/x-daylight-smiles’ Unknown media type in type ‘chemical/x-dmol’ Unknown media type in type ‘chemical/x-gamess-input’ Unknown media type in type ‘chemical/x-gamess-output’ Unknown media type in type ‘chemical/x-gaussian-input’ Unknown media type in type ‘chemical/x-gaussian-log’ Unknown media type in type ‘chemical/x-genbank’ Unknown media type in type ‘chemical/x-gulp’ Unknown media type in type ‘chemical/x-hin’ Unknown media type in type ‘chemical/x-inchi’ Unknown media type in type ‘chemical/x-inchi-xml’ Unknown media type in type ‘chemical/x-jcamp-dx’ Unknown media type in type ‘chemical/x-macromodel-input’ Unknown media type in type ‘chemical/x-mdl-molfile’ Unknown media type in type ‘chemical/x-mdl-rdfile’ Unknown media type in type ‘chemical/x-mdl-rxnfile’ Unknown media type in type ‘chemical/x-mdl-sdfile’ Unknown media type in type ‘chemical/x-mdl-tgf’ Unknown media type in type ‘chemical/x-mmcif’ Unknown media type in type ‘chemical/x-mol2’ Unknown media type in type ‘chemical/x-mopac-graph’ Unknown media type in type ‘chemical/x-mopac-input’ Unknown media type in type ‘chemical/x-mopac-out’ Unknown media type in type ‘chemical/x-msi-car’ Unknown media type in type ‘chemical/x-msi-hessian’ Unknown media type in type ‘chemical/x-msi-mdf’ Unknown media type in type ‘chemical/x-msi-msi’ Unknown media type in type ‘chemical/x-ncbi-asn1’ Unknown media type in type ‘chemical/x-ncbi-asn1-binary’ Unknown media type in type ‘chemical/x-ncbi-asn1-xml’ Unknown media type in type ‘chemical/x-pdb’ Unknown media type in type ‘chemical/x-shelx’ Unknown media type in type ‘chemical/x-vmd’ Unknown media type in type ‘chemical/x-xyz’ Unknown media type in type ‘all/all’ Unknown media type in type ‘all/allfiles’

PackagesStableBug ReportVery LowVery Low[postfix] has different directory permissions than 'fil...Deferred
0%
Task Description

Description:
The /usr/sbin directory in postfix has permissions 755
https://git.hyperbola.info:50100/packages/extra.git/tree/postfix/PKGBUILD#n115

And ‘filesystem’ sets it to 750
https://git.hyperbola.info:50100/packages/core.git/tree/filesystem/PKGBUILD#n135

So when installing postfix, pacman throws a warning

warning: directory permissions differ on /usr/sbin/
filesystem: 750  package: 755

Additional info:
* postfix-3.2.2-1.hyperbola6

PackagesStableBug ReportVery LowMedium[sshguard] violates Hyperbola packaging standardsUnconfirmed
0%
Task Description

Description:
The sshguard package should have its /usr/bin/sshguard executable in /usr/sbin, has systemd service files and no OpenRC init script

Additional info:
* sshguard-2.0.0-4
* when I run `sshguard`:

# sshguard
/usr/bin/sshguard: line 87: /usr/bin/journalctl: No such file or directory

* default /etc/sshguard.conf

LOGREADER="LANG=C /usr/bin/journalctl -afb -p info -n1 -t sshd -o cat"
BLACKLIST_FILE=120:/var/db/sshguard/blacklist.db
BACKEND="/usr/lib/sshguard/sshg-fw-iptables"

(commenting the first line temporally solves the issue)

PackagesStableBug ReportVery LowMedium[fail2ban] remove systemd integrationUnconfirmed
0%
Task Description

Description:
This package has a strong systemd integration. It has a systemd backend to get files modifications:

(from /etc/fail2ban/jail.conf)

# systemd:   uses systemd python library to access the systemd journal.
#              Specifying "logpath" is not valid for this backend.
#              See "journalmatch" in the jails associated filter config

and many files at /etc/fail2ban/filter.d have systemd stuff

[/etc/fail2ban/filter.d] [0]
$ grep -i systemd *
dovecot.conf:#journalmatch = _SYSTEMD_UNIT=dovecot.service
ejabberd-auth.conf:# Notes.:  systemd journalctl style match filter for journal based backend
postfix.conf:journalmatch = _SYSTEMD_UNIT=postfix.service
postfix-sasl.conf:#journalmatch = _SYSTEMD_UNIT=postfix.service
pure-ftpd.conf:journalmatch = _SYSTEMD_UNIT=pure-ftpd.service + _COMM=pure-ftpd
recidive.conf:journalmatch = _SYSTEMD_UNIT=fail2ban.service PRIORITY=5
sshd.conf:journalmatch = _SYSTEMD_UNIT=sshd.service + _COMM=sshd
sshd-ddos.conf:journalmatch = _SYSTEMD_UNIT=sshd.service + _COMM=sshd

Additional info:
* fail2ban-0.9.6-2.hyperbola3

PackagesStableBug ReportVery LowVery Low[fail2ban] update dovecot failregex to support verbose ...Unconfirmed
0%
Task Description

Description:
The /etc/fail2ban/filter.d/dovecot.conf file has a failregex with the following:

^%(__prefix_line)s(?:auth|auth-worker\(\d+\)): (?:pam|passwd-file)\(\S+,<HOST>\): unknown user\s*$

and works with things like:

Month day time hostname dovecot: auth: passwd-file(user@domain.com,IP): unknown user

but with verbosity enabled in Dovecot, this output looks like this:

Month day time hostname dovecot: auth: passwd-file(user@domain.com,IP): unknown user (given password: password)

and in this case it doesn’t work, but it does if we fix the failregex if we replace it with:

^%(__prefix_line)s(?:auth|auth-worker\(\d+\)): (?:pam|passwd-file)\(\S+,<HOST>\): unknown user( \(given password: \S*\))?\s*$

with this new expression, it works with and without verbosity

And regarding postfix, to make it work correctly I “backported” some pieces from newest failregex:

/etc/fail2ban/postfixr-rbl.conf:

^%(__prefix_line)sNOQUEUE: reject: RCPT from \S+\[<HOST>\]: [45]54 [45]\.7\.1 Service unavailable; Client host \[\S+\] blocked using .* from=<\S*> to=<\S+> proto=ESMTP helo=<\S*>$

/etc/fail2ban/postfix.conf: (second failregex)

^%(__prefix_line)sNOQUEUE: reject: RCPT from \S+\[<HOST>\]: 45[04] 4\.7\.1 Client host rejected: cannot find your (reverse )?hostname, (\[\S*\]); from=<\S*> to=<\S+> proto=ESMTP helo=<\S*>$

I can create a patch if you want. Note that I haven’t tested all filters, some others may also need some rework

Additional info:
* fail2ban-0.9.6-2.hyperbola3

PackagesStableBug ReportVery LowMedium[fail2ban] uses old /usr/bin/sendmail location when it ...Unconfirmed
0%
Task Description

Description:

I saw errors in logs because fail2ban couldn’t find /usr/bin/sendmail, and discovered this:

[/etc/fail2ban] [0]
$ grep /usr/bin/sendmail */*
action.d/sendmail-buffered.conf:              Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:                 Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:             Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:                Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-common.conf:              Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-common.conf:             Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-geoip-lines.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-ipjailmatches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-ipmatches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-lines.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-matches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>

Please, also check for other binaries with wrong locations

As of now, the solution is as simple as removing this line → https://git.hyperbola.info:50100/packages/community.git/tree/fail2ban/PKGBUILD#n79

Additional info:
* fail2ban-0.9.6-2.hyperbola3

PackagesStableBug ReportVery LowHigh[nftables] init service ERROR: nftables failed to startUnconfirmed
0%
Task Description

Error: conflicting protocols specified: inet-service vs. icmp

when using

ip protocol icmp icmp type echo-request counter accept comment “accept ICMP echo-request type” ip6 nexthdr icmpv6 icmpv6 type { destination-unreachable, packet-too-big, time-exceeded, parameter-problem, mld-listener-query, mld-listener-report, mld-listener-reduction, nd-router-solicit, nd-router-advert, nd-neighbor-solicit, nd-neighbor-advert } accept comment “Accept ICMPv6”

It is a known bug on 0.7 and solved on 0.9

https://bugzilla.netfilter.org/show_bug.cgi?id=1073 commit 0011985554e269e1cc8f8e5b41eb9dcd795ebe8c fixes this problem upstream.

PackagesStableBug ReportVery LowMedium[postgrey] has systemd service and no OpenRC init scrip...Unconfirmed
0%
Task Description

Description:
The title says everything

Also, it doesn’t follow the FHS (/usr/bin/postgrey should be in /usr/sbin)

Additional info:
* postgrey-1.37-1

PackagesStableBug ReportMediumHighopensmtpd: permission problemsIn Progress
0%
Task Description

Description:

cat msg | /usr/sbin/sendmail – sendmail: No such file or directorycannot create temporary file /var/spool/smtpd/offline/1572544775.XXXXIqNsFX

Additional info:
* package version: 6.4.2p1-1.hyperbola2.backports1

It is same problem as here:
https://github.com/OpenSMTPD/OpenSMTPD/issues/839

I could solve it with:

sudo chmod g+s /usr/sbin/smtpctl
sudo chmod g+s /usr/sbin/smtpctl

and then

sudo rc-service smtpd start

Even though I think I should not need to start it to use only sendmail.

PackagesStableBug ReportVery LowLow[autofs]: default configuration is /etc/auto.master ins...Unconfirmed
0%
Task Description

Description:

default configuration is /etc/auto.master instead of /etc/autofs/auto.master

admin→ sudo /usr/bin/automount -v -f -p /run/autofs.pid
Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup(file): file map /etc/auto.master missing or not readable
no mounts in table

PackagesStableBug ReportVery LowMediumlinphonec error (cli version)Unconfirmed
0%
Task Description

Description:
linphonec is unusable because a error produce a continuous log

Additional info:
linphone 3.11.1-1.hyperbola1

Steps to reproduce:
linphonec

Log:
linphonec> 2019-12-15 19:25:58:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:03:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:08:018 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:13:013 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:18:016 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:23:014 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:28:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:33:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:38:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:43:015 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:48:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:53:010 ortp-error-Error in connect: Network is unreachable

PackagesStableBug ReportVery LowCritical[smartmontools] update-smart-drivedb fails to updateRequires Testing
100%
Task Description

smartmontools 6.5-1.hyperbola1

Error while trying to update smart-drivedb :

anon@test[~] update-smart-drivedb

External Link/usr/bin/update-smart-drivedb: download from branches/RELEASE_6_5_DRIVEDB failed (curl: exit 23) /usr/bin/update-smart-drivedb: download from trunk failed (curl: exit 23)

PackagesStableBug ReportVery LowLow[dhcpcd-ui] Adding icons from "Network-Manager Applet"Unconfirmed
0%
Task Description

When using the package for wireless connections no further icon is displayed without having the package [b]network-manager-applet[/b] installed.

PackagesStableBug ReportVery LowHigh[ispell] require FHSRequires Testing
100%
Task Description

Description:

cant open /usr/local/lib/english.hash

Additional info:

Repository      : extra
Name            : ispell
Version         : 3.3.02-7
Description     : An interactive spell-checking program for Unix
Architecture    : x86_64
URL             : http://ficus-www.cs.ucla.edu/geoff/ispell.html
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : ncurses
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 321.26 KiB
Installed Size  : 1336.00 KiB
Packager        : Evangelos Foutras <evangelos@foutrelis.com>
Build Date      : Sun Sep 6 12:07:06 2015
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Steps to reproduce:

- Install package

PackagesStableBug ReportVery LowCritical[gtk-2] Severe problems with GTK2-applicationsUnconfirmed
0%
Task Description

Description: Since the migration to xenocara there seems to be a bug with applications using GTK-2. From time to time there are crashes with assertion `!xcb_xlib_threads_sequence_lost’.

Looking into this a little bit more deep there are also other distributions affected and this is an upstream-bug. But the concrete situation is not that easy, while it could be also part of the library libX11 itself. Looking therefore here: https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/1782984

Affected are for example LXDE in general, icedove, iceweasel and many more!

PackagesStableBug ReportVery LowMediumUntrsuted gpg keyUnconfirmed
0%
Task Description

Description:
There is an issue with Christian Rebischke key, i’ve tried to delete /etc/pacman.d/gnupg/ and repopulate it but it doesn’t fix the issue.

error: ascii: signature from “Christian Rebischke (Arch Linux Security Team-Member) Chris.Rebischke@archlinux.org” is unknown trust
File /var/cache/pacman/pkg/ascii-3.15-2-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).

Steps to reproduce:

sudo pacman -S ascii

PackagesStableBug ReportVery LowMediumnouveau_drv.so: undefined symbol: exaDriverAllocUnconfirmed
0%
Task Description

Any attempt to load Nouveau in X server results in the following error:

nouveau_drv.so: undefined symbol: exaDriverAlloc

Additional info

Steps to reproduce

  1. Stop the X server.
  2. Add a section such as the following to “/etc/X11/xorg.conf”:
    Section "Device"
      Identifier "Video card"
      Driver "nouveau"
      Option "Backlight" "nv_backlight"
    EndSection
  3. Start the X server.
PackagesTestingBug ReportMediumMedium[emacs] crush after swayResearching
0%
Task Description

I have installed Hyperbola on two laptops. And I have noticed that after running sway and exiting out of sway, GNU emacs crushers on console. It is easy to repeat it:

1. Run sway
2. Exit sway or killall sway
3. Try running emacs on console, there will be crush
4. log out, log in, and emacs will work on console again

Yet it should not crush.

PackagesTestingBug ReportVery LowCritical[Hyperbola GNU/Linux-libre 0.4] Installation issue for ...Unconfirmed
0%
Task Description

Description: Problem with execution of “pacstrap /mnt base base-devel syslinux” from 0.3.1-chroot ISO-image with modified pacman.conf and mirrorlist for testing. There are errors for the packages “libxcrypt” and “man-pages” as both have “/usr/share/man/man3/crypt.3.gz” and “/usr”share/man/man3/crypt_r.3.gz” included.

PackagesTestingBug ReportVery LowCritical[Hyperbola GNU/Linux-libre 0.4] Installation for syslin...Unconfirmed
0%
Task Description

Description: Configuration file “syslinux.cfg” under /boot/syslinux/ has to be adjusted. Problem with kernel-images loaded and the concurrent booting device is per default configured to /dev/sda3. Kernel-images are named as “linux-libre” not “linux-libre-lts”.

PackagesTestingBug ReportHighCritical[Hyperbola GNU/Linux-libre 0.4] Problems with sndio fai...Requires Testing
90%
Task Description

There are issues with the current sndio-package as it seems not possible to get this to work with ALSA.

PackagesTestingBug ReportVery LowHigh[xenocara-xkbcomp] Could not resolve keysym XF86FullScr...Unconfirmed
0%
Task Description

While the X session is still running, did anyone happen key bindings being unresponsive? A few lines of errors appeared from xkbcomp because of a missing keyboard symbol on the single TTY. It reads:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> error:   Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server

See also related issues affected on other existing distros, were eventually resolved:

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux 0.4] Problems with touch- / trackp...Assigned
0%
Task Description

Description: Not finally tested, only getting the logs from chat within here for better analysis later on. User reported that touchpad is not working for now with Hyperbola GNU/Linux 0.4. dmesg-messagelog:

[anonymous@anonymous ~]$ dmesg | grep pad
[ 4.766853] psmouse serio1: synaptics: The touchpad can support a better bus than the too old PS/2 protocol. Make sure MOUSE_PS2_SYNAPTICS_SMBUS and RMI4_SMB are enabled to get a better touchpad experience.
[ 4.823723] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xf00123/0×840300/0x2e800/0×0, board id: 3127, fw id: 8526786

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux 0.4] Problems with ALSA and sndio ...Unconfirmed
0%
Task Description

Description: User reporting problems with sndio. A further check with ALSA showed no active device being used. User has HDMI-sound in usage.

PackagesTestingBug ReportVery LowVery Low[Hyperbola GNU/Linux-libre 0.4] [wine-stable] doesn't r...Unconfirmed
0%
Task Description

The title says that above if without having required library dependencies for most of them under 32-bit.

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux-libre 0.4] - Package [android-file...Researching
0%
Task Description

Application is not starting and needs therefore a rework.

PackagesTestingBug ReportVery LowHigh[Hyperbola GNU/Linux-libre 0.4] Video driver issues wit...Unconfirmed
0%
Task Description

After setting up and testing our 32-bit QEMU instance, we often tried to initialize the X11, but it refused to do because of video driver issues.

As well as changing to other video drivers on our instance is still the exact issue.

Here is a log from X11 below we attached.

Software Developmentchroot-nspawnBug ReportMediumMedium[chroot-nspawn] Create mount points if mountpoint exit ...Unconfirmed
0%
Task Description

The actual behavior is to create mount points if mountpoint exits with exit status 1, however it may also exit with code 32 and thus creating a real mess:

$ sudo chroot-nspawn
Spawning container megver83 on /var/lib/archbuild/chroot1/megver83
Press ^] three times within 1s to kill container.
mount: /sys/fs/cgroup: mount point does not exist.
mkdir: cannot create directory '/sys/fs/cgroup/blkio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpu': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpu,cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpuset': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/devices': No such file or directory  
mkdir: cannot create directory '/sys/fs/cgroup/freezer': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/memory': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_cls': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/net_cls,net_prio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_prio': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/pids': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/systemd': No such file or directory
mount: /sys/fs/cgroup/blkio: mount point does not exist.
mount: /sys/fs/cgroup/cpuset: mount point does not exist.
mount: /sys/fs/cgroup/devices: mount point does not exist.
mount: /sys/fs/cgroup/freezer: mount point does not exist.
mount: /sys/fs/cgroup/memory: mount point does not exist.
mount: /sys/fs/cgroup/pids: mount point does not exist.

So I created a patch to fix this.

P.S.: although I can git clone the repo with ssh access, whenever I do a push I get:

error: remote unpack failed: unable to create temporary object directory
To ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git
 ! [remote rejected] master -> master (unpacker error)
error: failed to push some refs to 'ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git'

Do I have the permission to write in this repo? If not, I’d like it, as I’m planning to improve this great script

PackagesAnyDrop RequestVery LowMedium[hardening-wrapper] deprecated, not needed anymoreUnconfirmed
0%
Task Description

According to : https://github.com/thestinger/hardening-wrapper-deprecated

Wrapper scripts for building hardened executables by default (deprecated, replaced by standard Arch Linux toolchain changes)

PackagesAnyDrop RequestMediumMedium[gksu] is replaced and has to be deleted from our pacma...Researching
0%
Task Description

Description:
From the author’s webpage gksu has been replaced.

Additional info:
* package version(s) : extra/gksu 2.0.2-5

http://www.nongnu.org/gksu/

PackagesAnyFeature RequestVery LowLow[i3lock-color] adding package into pacmanDeferred
0%
Task Description

We already have i3lock, this version is an enhanced version available in Arch AUR:
https://aur.archlinux.org/packages/i3lock-color https://aur.archlinux.org/packages/i3lock-color-git/

Showing tasks 51 - 100 of 511 Page 2 of 11 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing