All Projects

ProjectCategoryTask TypePrioritySeveritySummary  ascStatusProgress
PackagesStableFreedom IssueVery LowMedium[xfe] Replace with Hyperbola Iceweasel-UXP for HTML and...Unconfirmed
0%
Task Description

Two formats (including HTML and PHP) are provided to run semi-libre/free web browser Mozilla Firefox in the original code base, but it currently got blacklisted due to numerous branding, security and privacy issues, and replaced by the Hyperbola Iceweasel-UXP. To replace existing strings at the web section in xferc.in:

html = "iceweasel-uxp,iceweasel-uxp,<txteditor>;Hyper Text;html_32x32.png;html_16x16.png;;"
htm = "iceweasel-uxp,iceweasel-uxp,<txteditor>;Hyper Text;html_32x32.png;html_16x16.png;;"
php = "iceweasel-uxp,iceweasel-uxp,<txteditor>;PHP Source;html_32x32.png;html_16x16.png;;"
PackagesAnyFreedom IssueVery LowLow[xorg-xev]: mentioning "content" in descriptionsUnconfirmed
0%
Task Description

Description:

extra/xorg-xev 1.2.2-1 (xorg-apps xorg)
    Print contents of X events

Description is vague because of the word “content”. Why not say “X events information”. At least description shall be changed which is very public. For man page I am not sure.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFreedom IssueMediumLow[xsd] vague terminology "Open Source" in description of...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

extra/xsd 4.0.0-2
    An open-source, cross-platform W3C XML Schema to C++ data binding compiler

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

A free-software, cross-platform W3C XML Schema to C++ data binding compiler
PackagesAnyFreedom IssueMediumLow[xvidcore] vague terminology "Open Source" in descripti...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

extra/xvidcore 1.3.4-1 [installed]
    XviD is an open source MPEG-4 video codec

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

XviD is a free software MPEG-4 video codec
PackagesAnyFreedom IssueMediumLow[xwax] vague terminology "Open Source" and "Linux" in d...Deferred
0%
Task Description

This package contains vague terminology “Open Source” and “Linux”:

community/xwax 1.6-1
    Open-source vinyl emulation software for Linux.

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source” and “Linux” as operating system, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

https://www.gnu.org/philosophy/words-to-avoid.html#Linux

It would be good example to set to have proper description of packages without using “Open Source” and “Linux” as operating system.

eg.

Free-software vinyl emulation software for GNU/Linux.
PackagesAnyFreedom IssueVery LowLow[xwax]: using kernel name when referring to operating s...Unconfirmed
0%
Task Description

Description:

community/xwax 1.6-1
     Open-source vinyl emulation software for Linux.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesTestingImplementation RequestVery LowMedium[yaics] add packageDeferred
0%
Task Description

Yaics is a simple GNU social client written in C++ and Qt and licensed under the GNU GPL 3.0 (or later).

Please implement yaics as an optional package.

https://stigatle.no/yaics/

https://gitlab.com/stigatle/yaics

PackagesAnyBug ReportVery LowLow[zathura-pdf-poppler] unable to process apostrophes di...Researching
0%
Task Description

Description:
Something is wrong with the latest version packaged in Hyperbola. zathura-pdf-poppler is unable to process apostrophes displayed in pdf bookmarks.

Steps to reproduce:
Open any pdf file which has a summary included, then hit `Tab` to display the summary. Instead of apostrophes, zathura-pdf-poppler displays html entities while the output of zathura-pdf-mupdf is correct.

PackagesAnyFreedom IssueMediumLow[zynaddsubfx] vague terminology "Open Source" in descri...Deferred
0%
Task Description

This package contains vague terminology “Open Source”:

community/zynaddsubfx 3.0.1-1
    Opensource software synthesizer capable of making a countless number of instruments.

According to:
https://www.gnu.org/distros/free-system-distribution-guidelines.html

We shall avoid vague terminology such as “Open Source”, please see here:
https://www.gnu.org/philosophy/words-to-avoid.html#Open

It would be good example to set to have proper description of packages without using “Open Source”.

eg.

Free software synthesizer capable of making a countless number of instruments.
PackagesAnyFeature RequestVery LowLowadd package powerkitUnconfirmed
0%
Task Description

https://github.com/rodlie/powerkit/releases

Version 1.0 requested

When you add Lumina desktop, add this package for sure. Although it is compatible with other desktops too. So it would be good to add it regardless.

PackagesAnyBug ReportVery LowHighgroff: package not built with URW fonts properly or suc...Unconfirmed
0%
Task Description

Description:

groff is typesetting system similar to TeX/LaTeX however, it is very small and very usable. It is not built properly with URW fonts, or such are missing, I cannot know all details. Overall groff package is basically somehow broken.

It shall depend on proper fonts, and such fonts should already be built, including their Unicode versions.

Package is only partially built.

ServicesGeneralFeature RequestVery LowLowhyperbola branding - add guidelines to packagesUnconfirmed
0%
Task Description

I could not find any regarding using arch or other branded themes. Parabola apparently rebrands some stuff in their libre repository, eg. they have their own parabola-themes-slim package for slim based themes.

https://issues.hyperbola.info/index.php?do=details&task_id=1213&opened=24&status[0]=

ServicesPunBB IssueBug ReportVery LowLowhyperbola forum smtp error and profile updateUnconfirmed
0%
Task Description

here i will report 2 issues and one change to make
issues:
1- there is a failed smtp error with post and reply
2- in the forum profile one cant add website with .xyz domain name

the change:
1- with pgp key one would add a short key link just like what was mentioned in here:
https://forums.hyperbola.info/viewtopic.php?pid=2639#p2639

PackagesStableBug ReportVery LowHighjava cacerts file is emptyUnconfirmed
0%
Task Description

/etc/ssl/certs/java/cacerts has 0 entries, resulting in ssl handshake errors in java applications.

Package versions:
* ca-certificates 20170307-1
* ca-certificates-utils 20170307-1

PackagesAnyBug ReportVery LowLowlightdm/lxdm bugUnconfirmed
0%
Task Description

It appears when I plug in my libreboot laptop x200 in, it appears to dim the screen and when its unplugged, the screen is bright again. Something peculiar is at work, I wondered if this could be fixed.

My assumption is it is related to lxdm or lightdm. Any thoughts?

I am currently using 0.4, so I don’t expect this to be a fast process, just when you get a chance okay?

PackagesStableBug ReportVery LowMediumlinphonec error (cli version)Unconfirmed
0%
Task Description

Description:
linphonec is unusable because a error produce a continuous log

Additional info:
linphone 3.11.1-1.hyperbola1

Steps to reproduce:
linphonec

Log:
linphonec> 2019-12-15 19:25:58:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:03:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:08:018 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:13:013 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:18:016 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:23:014 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:28:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:33:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:38:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:43:015 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:48:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:53:010 ortp-error-Error in connect: Network is unreachable

PackagesTestingImplementation RequestMediumMediumlinux-libre-lts-hypersec: New package with extra securi...Deferred
0%
Task Description

Description: Per a user request and to better secure the kernel, we can embed the cryptsetup and ciphers in the kernel. This would mean rather than exposed modules, they are built-in to the kernel and ready to use even without an intramfs.

To be embedded: ciphers aes, twofish, serpent; sha256, sha512 - and the necessary modules (don’t forget the block modes xts, lvm and cryptsetup ...)

Additionally, we could include USB Guard and any other features that meet our social contract and security outlook.

PackagesAnyBug ReportVery LowLowmarble-qt: doesn't look like a valid Marble plugin: "/...Unconfirmed
0%
Task Description

Description:

$ marble-qt –latlone=0.5,6.5
Ignoring to load the following file since it doesn’t look like a valid Marble plugin: “/usr/lib/marble/plugins/libWlocatePositionProviderPlugin.so” Reason: “Cannot load library /usr/lib/marble/plugins/libWlocatePositionProviderPlugin.so: (libwlocate.so: cannot open shared object file: No such file or directory)”

When package libwlocate is installed, it is not showing this error.

Shall that package be dependency?

PackagesAnyPrivacy IssueMediumHighmidori new Support for cross-browser web extensionsResearching
0%
Task Description

Description:
idk what to do with it i add the PKGBUILD but this new extension needs to be checked left or patched,
https://git.hyperbola.info:50100/~team/packages/extra.git/plain/midori/PKGBUILD?h=rachad

Additional info:
* package version(9.0)

important links to check:
* https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions * https://github.com/midori-browser/core/issues/244

PackagesAnySecurity IssueVery LowMediummount.davfs: unknown file system davfs due to paths cha...Unconfirmed
0%
Task Description

This is same issue as on:
https://bugzilla.redhat.com/show_bug.cgi?id=1151273

The paths changed and trying to mount davfs file system defined in /etc/fstab fails with error: unknown file system davfs

To remedy, I made symlink in /sbin to mount.davfs

The transition of paths had to take that in account as many mounted remote disks failed after upgrade.

PackagesStableBug ReportVery LowMediumnouveau_drv.so: undefined symbol: exaDriverAllocUnconfirmed
0%
Task Description

Any attempt to load Nouveau in X server results in the following error:

nouveau_drv.so: undefined symbol: exaDriverAlloc

Additional info

Steps to reproduce

  1. Stop the X server.
  2. Add a section such as the following to “/etc/X11/xorg.conf”:
    Section "Device"
      Identifier "Video card"
      Driver "nouveau"
      Option "Backlight" "nv_backlight"
    EndSection
  3. Start the X server.
PackagesStableBug ReportMediumHighopensmtpd: permission problemsIn Progress
0%
Task Description

Description:

cat msg | /usr/sbin/sendmail – sendmail: No such file or directorycannot create temporary file /var/spool/smtpd/offline/1572544775.XXXXIqNsFX

Additional info:
* package version: 6.4.2p1-1.hyperbola2.backports1

It is same problem as here:
https://github.com/OpenSMTPD/OpenSMTPD/issues/839

I could solve it with:

sudo chmod g+s /usr/sbin/smtpctl
sudo chmod g+s /usr/sbin/smtpctl

and then

sudo rc-service smtpd start

Even though I think I should not need to start it to use only sendmail.

Showing tasks 501 - 522 of 522 Page 11 of 11<<First - 7 - 8 - 9 - 10 - 11

Available keyboard shortcuts

Tasklist

Task Details

Task Editing