All Projects

ProjectCategory  ascTask TypePrioritySeveritySummaryStatusProgress
PackagesTestingFeature RequestVery LowMedium[Hyperbola GNU/Linux-Libre 0.4] [lumina-core] Replace t...Unconfirmed
0%
Task Description

Also known as “Replace the distributor logo as the startup dialogue, and app menu and start button icons from generic” in the long title because of character limitation.

If the distributor logo icon isn’t present, simply insert it and link few others into the appropriate paths that I made and attached below there.

Here is the list of the paths you do:

/usr/share/icons/material-design-{dark,light}/scalable/places/:

  • distributor-logo.svg
  • distributor-logo-hyperbola.svg (symlink of * distributor-logo.svg)
  • start-here{,-hyperbola,-lumina}.svg (symlink of distributor-logo.svg)
PackagesTestingFeature RequestVery LowMedium[Hyperbola GNU/Linux-libre 0.4] [xorg-xdm] Replace the ...Unconfirmed
0%
Task Description

Few other distros like Debian, NetBSD, and OpenBSD have some own customized login screens, while right here, the actual distro didn’t. I suggest you replacing them for the following paths on the list to come up next package release, which I have three files attached below there.

/etc/X11/xdm:

  • Xresources
  • Xsetup_0

/usr/share/xdm/pixmaps:

  • hyperbola.xpm
  • xorg{,-bw}.xpm (removed as unused)
PackagesTestingBug ReportMediumMedium[emacs] crush after swayResearching
0%
Task Description

I have installed Hyperbola on two laptops. And I have noticed that after running sway and exiting out of sway, GNU emacs crushers on console. It is easy to repeat it:

1. Run sway
2. Exit sway or killall sway
3. Try running emacs on console, there will be crush
4. log out, log in, and emacs will work on console again

Yet it should not crush.

PackagesTestingBug ReportVery LowCritical[Hyperbola GNU/Linux-libre 0.4] Installation issue for ...Unconfirmed
0%
Task Description

Description: Problem with execution of “pacstrap /mnt base base-devel syslinux” from 0.3.1-chroot ISO-image with modified pacman.conf and mirrorlist for testing. There are errors for the packages “libxcrypt” and “man-pages” as both have “/usr/share/man/man3/crypt.3.gz” and “/usr”share/man/man3/crypt_r.3.gz” included.

PackagesTestingBug ReportVery LowCritical[Hyperbola GNU/Linux-libre 0.4] Installation for syslin...Unconfirmed
0%
Task Description

Description: Configuration file “syslinux.cfg” under /boot/syslinux/ has to be adjusted. Problem with kernel-images loaded and the concurrent booting device is per default configured to /dev/sda3. Kernel-images are named as “linux-libre” not “linux-libre-lts”.

PackagesTestingBug ReportHighCritical[Hyperbola GNU/Linux-libre 0.4] Problems with sndio fai...Requires Testing
90%
Task Description

There are issues with the current sndio-package as it seems not possible to get this to work with ALSA.

PackagesTestingBug ReportVery LowHigh[xenocara-xkbcomp] Could not resolve keysym XF86FullScr...Unconfirmed
0%
Task Description

While the X session is still running, did anyone happen key bindings being unresponsive? A few lines of errors appeared from xkbcomp because of a missing keyboard symbol on the single TTY. It reads:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> error:   Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server

See also related issues affected on other existing distros, were eventually resolved:

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux 0.4] Problems with touch- / trackp...Assigned
0%
Task Description

Description: Not finally tested, only getting the logs from chat within here for better analysis later on. User reported that touchpad is not working for now with Hyperbola GNU/Linux 0.4. dmesg-messagelog:

[anonymous@anonymous ~]$ dmesg | grep pad
[ 4.766853] psmouse serio1: synaptics: The touchpad can support a better bus than the too old PS/2 protocol. Make sure MOUSE_PS2_SYNAPTICS_SMBUS and RMI4_SMB are enabled to get a better touchpad experience.
[ 4.823723] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xf00123/0×840300/0x2e800/0×0, board id: 3127, fw id: 8526786

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux 0.4] Problems with ALSA and sndio ...Unconfirmed
0%
Task Description

Description: User reporting problems with sndio. A further check with ALSA showed no active device being used. User has HDMI-sound in usage.

PackagesTestingBug ReportVery LowVery Low[Hyperbola GNU/Linux-libre 0.4] [wine-stable] doesn't r...Unconfirmed
0%
Task Description

The title says that above if without having required library dependencies for most of them under 32-bit.

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux-libre 0.4] - Package [android-file...Researching
0%
Task Description

Application is not starting and needs therefore a rework.

PackagesTestingBug ReportVery LowHigh[Hyperbola GNU/Linux-libre 0.4] Video driver issues wit...Unconfirmed
0%
Task Description

After setting up and testing our 32-bit QEMU instance, we often tried to initialize the X11, but it refused to do because of video driver issues.

As well as changing to other video drivers on our instance is still the exact issue.

Here is a log from X11 below we attached.

PackagesTestingBug ReportVery LowMedium[adwaita-icon-theme] Most symbolic icons look brokenly ...Assigned
0%
Task Description

As the title says, some affected symbolic icons look like on a screencap of the GTK3 Widget Factory we attached below.

PackagesTestingBug ReportVery LowMedium[icu] needs to rebuild that should place genccode into ...Unconfirmed
0%
Task Description

Here is the problem with ICU where LibreOffice has refused to build without genccode, yet an output log results like this.

makepkg -CLfs:

-- snip --
checking for genccode... no
configure: error: 'genccode' not found in $PATH, install the icu development tool 'genccode'
Error running configure at ./autogen.sh line 299.
-- snip --

pacman -Ql icu:

-- snip --
icu /usr/sbin/
icu /usr/sbin/escapesrc
icu /usr/sbin/genccode
icu /usr/sbin/gencmn
icu /usr/sbin/gennorm2
-- snip --
PackagesTestingBug ReportVery LowCriticalangband game Couldn't load the requested font. Unconfirmed
0%
Task Description

Description:
When run angband game, the emulator of terminal show me the next, at hyperbola v0.4 testing

[ user | 2021-10-23 | 06:05 ]
[/home/user] [0]
$ angband
angband: Couldn't load the requested font. (10x20)

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
- Install the package
- Run in terminal

ServicesWiki Page IssueImplementation RequestVery LowMediumAdd notification/subscription capabilities when a page ...Unconfirmed
0%
Task Description

After talking to Emulatorman, we think this would be a nice feature to add to our Hyperwiki to be able to subscribe to the original page in English to help tracking changing to the translated pages.
This implies to add the email notifications to the dokuwiki system

Software Developmentchroot-nspawnBug ReportMediumMedium[chroot-nspawn] Create mount points if mountpoint exit ...Unconfirmed
0%
Task Description

The actual behavior is to create mount points if mountpoint exits with exit status 1, however it may also exit with code 32 and thus creating a real mess:

$ sudo chroot-nspawn
Spawning container megver83 on /var/lib/archbuild/chroot1/megver83
Press ^] three times within 1s to kill container.
mount: /sys/fs/cgroup: mount point does not exist.
mkdir: cannot create directory '/sys/fs/cgroup/blkio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpu': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpu,cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpuset': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/devices': No such file or directory  
mkdir: cannot create directory '/sys/fs/cgroup/freezer': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/memory': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_cls': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/net_cls,net_prio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_prio': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/pids': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/systemd': No such file or directory
mount: /sys/fs/cgroup/blkio: mount point does not exist.
mount: /sys/fs/cgroup/cpuset: mount point does not exist.
mount: /sys/fs/cgroup/devices: mount point does not exist.
mount: /sys/fs/cgroup/freezer: mount point does not exist.
mount: /sys/fs/cgroup/memory: mount point does not exist.
mount: /sys/fs/cgroup/pids: mount point does not exist.

So I created a patch to fix this.

P.S.: although I can git clone the repo with ssh access, whenever I do a push I get:

error: remote unpack failed: unable to create temporary object directory
To ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git
 ! [remote rejected] master -> master (unpacker error)
error: failed to push some refs to 'ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git'

Do I have the permission to write in this repo? If not, I’d like it, as I’m planning to improve this great script

Showing tasks 501 - 517 of 517 Page 11 of 11<<First - 7 - 8 - 9 - 10 - 11

Available keyboard shortcuts

Tasklist

Task Details

Task Editing