All Projects

Project Category Task Type Priority Severity Summary Status Progress
PackagesAnyFreedom IssueVery HighCritical [clementine] using non-free services and interfaces Closed
100%
Task Description

The audioplayer clementine uses interfaces for non-free services like Dropbox, Google Drive, OneDrive, Subsonic and VK.com regarding storage and accessing files. So of course the software is licensed under the GPL, therefore Copyleft and free, libre software in the first place, but is also using anti-features with those interfaces to mentioned unfree services later on.

So the proposal would be: Creating a fork with removing those interfaces or otherwise removal of the whole package.

PackagesTestingBug ReportVery HighCritical [Hyperbola GNU/Linux 0.4] QtSSL is not working Closed
100%
Task Description

Description: Tried with new compiled version of mumble no open and secured with SSL-certificate is reachable. Log within console:

qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_options
qt.network.ssl: QSslSocket: cannot resolve SSL_session_reused
qt.network.ssl: QSslSocket: cannot resolve SSL_set_options
qt.network.ssl: QSslSocket: cannot resolve BN_is_word
qt.network.ssl: QSslSocket: cannot resolve SSL_in_init

<W>2021-08-23 01:00:18.814 QSslSocket: cannot call unresolved function sk_num

<W>2021-08-23 01:00:20.270 QSslSocket: cannot call unresolved function SSL_CTX_set_options

Software DevelopmentGeneralBug ReportVery HighCritical [Hyperbola GNU/Linux-libre 0.4] Reworking xenocara and  ...Closed
100%
Task Description

Within the concurrent version of xenocara for version 0.4 there is a problem in vesa, generating the error-message “V_BIOS address 0×0 out of range”. It is a known old bug that was fixed when D-Bus arrived by default.

This issue is oriented onto to document the steps to test further solutions and rework the x-server.

PackagesStableFreedom IssueHighCritical [smplayer] Removal of unfree "Chromecast"-plugin Closed
100%
Task Description

Within the current version of smplayer in the repositories a proprietary interface to Chromecast is activated and therefore a risk for privacy of the users as this hardware is the complete opposite of freedom.

PackagesTestingBug ReportHighCritical [Hyperbola GNU/Linux-libre 0.4] Installation for syslin ...Closed
100%
Task Description

Description: Configuration file “syslinux.cfg” under /boot/syslinux/ has to be adjusted. Problem with kernel-images loaded and the concurrent booting device is per default configured to /dev/sda3. Kernel-images are named as “linux-libre” not “linux-libre-lts”.

PackagesTestingBug ReportHighCritical [Hyperbola GNU/Linux-libre 0.4] Problems with sndio fai ...Closed
100%
Task Description

There are issues with the current sndio-package as it seems not possible to get this to work with ALSA.

InstallationGeneralBug ReportHighCritical Can't refresh pacman keys on 0.4 installation disk Closed
100%
Task Description

After making sure that the system date is correct, when one tries to refresh the
pacman keys (`pacman-key –refresh-keys`) they will be given an error:
Server indicated a failure

The error will not be fixed if you remove all the pacman gnupg assets nor if you
attempt to fix `dirmngr`.

This seams to only be reproducable as well when pacman-init fails to load on but, dont know if it is just a coiencidence but it seams both are related

Also both irelativism and reports by users in IRC where able to reproduce this on version 0.3.1 and might even come from previous release, so issue is presistant over new release cycle.

Software DevelopmentGeneralBug ReportMediumCritical [xenocara] Server is not able to be started via xdm Closed
100%
Task Description

With the newest package-update the xserver xenocara has missing dependencies towards adobe-fonts and twm.

PackagesStableReplace RequestVery LowCritical [spamassassin] includes dependencies for systemd Closed
100%
Task Description

Description: The package spamassassin has no further init-script for OpenRC and instead includes service-definitions for systemd

Additional info:
* package version(s) 3.4.1-7

PackagesStableReplace RequestVery LowCritical [opendkim] includes dependencies for systemd Closed
100%
Task Description

Description: The package opendkim has no further init-script for OpenRC and instead includes service-definitions for systemd

Additional info:
* package version(s) 2.10.3-4

PackagesAnyFreedom IssueVery LowCritical [flatpak] Access to proprietary applications Closed
100%
Task Description

Description:

Additional info:
* 0.9.10-2.hyperbola2

Steps to reproduce: Flatpak gives access to interesting features for the deployment of applications, but in fact it also gives access to proprietary applications like Skype (https://flathub.org/apps/details/com.skype.Client), Steam (https://flathub.org/apps/details/com.valvesoftware.Steam) and many more. So it should be checked if this should be part of the repositories within an open, libre distribution. In my point of view this violates the freedom of users, because there can be not tolerance about intolerance even regarding this.

PackagesStableBug ReportVery LowCritical [gtk-2] Severe problems with GTK2-applications Closed
100%
Task Description

Description: Since the migration to xenocara there seems to be a bug with applications using GTK-2. From time to time there are crashes with assertion `!xcb_xlib_threads_sequence_lost’.

Looking into this a little bit more deep there are also other distributions affected and this is an upstream-bug. But the concrete situation is not that easy, while it could be also part of the library libX11 itself. Looking therefore here: https://bugs.launchpad.net/ubuntu/+source/pcmanfm/+bug/1782984

Affected are for example LXDE in general, icedove, iceweasel and many more!

PackagesStableFreedom IssueVery LowCritical [keybase] Complete removal of tool Closed
100%
Task Description

There is only the source code of the client available and since years nothing more happened. With keybase joining “Zoom” nothing more seems to happen. Look also here in the forum: https://forums.hyperbola.info/viewtopic.php?id=368

PackagesTestingBug ReportVery LowCritical [Hyperbola GNU/Linux-libre 0.4] Installation issue for  ...Closed
100%
Task Description

Description: Problem with execution of “pacstrap /mnt base base-devel syslinux” from 0.3.1-chroot ISO-image with modified pacman.conf and mirrorlist for testing. There are errors for the packages “libxcrypt” and “man-pages” as both have “/usr/share/man/man3/crypt.3.gz” and “/usr”share/man/man3/crypt_r.3.gz” included.

Software DevelopmentGeneralBug ReportHighHigh [fair-viewer] Problems with running package Closed
100%
Task Description

User reports a problem with the concurrent version of fair-viewer and gtk-fair-viewer, not being able to start and run the application. More details in the posting: https://forums.hyperbola.info/viewtopic.php?pid=3476#p3476

PackagesAnyFeature RequestMediumHigh [supervisor] contains systemd unit file Closed
100%
Task Description

The Arch version of “supervisor” from the snapshot used by Hyperbola comes with systemd support. Since Hyperbola follows the a global ruleset for INIT-freedom, systemd unit files removal is required and adding support for other init-systems (preferred OpenRC for now) to replace it.

PackagesAnyBug ReportMediumHigh [cdemu-daemon] Malfunctioning service Closed
100%
Task Description

The daemon is not working and the following error-message occurs when trying to starting up:

cdemu: Daemon: D-Bus: failed to get proxy for 'org.freedesktop.DBus' on session bus: Cannot autolaunch D-Bus without X11 $DISPLAY!
Daemon initialization and start failed!
PackagesAnyBug ReportVery LowHigh [vhba] Kernel module could not be loaded Closed
100%
Task Description

After installing and adding it to the configuration under /etc/conf.d/modules the concurrent module won’t be loaded at all.

PackagesStableImplementation RequestVery LowHigh [simplescreenrecorder] Malfunctional when not removing  ...Closed
100%
Task Description

Within the last commit regarding the package simplescreenrecorder the interface for pulseaudio was removed. So far, so good. But without the complete removal of pulseaudio the application is enforced to use ALSA emulation for PulseAudio on systems with libpulse installed and that usually only makes things worse.

Please undo this for version 0.3 until the removal of pulseaudio is complete.

PackagesStableBackport RequestMediumMedium [icedove-uxp] Lightning for Icedove-UXP Closed
100%
Task Description

Description: Thanks for the actual release of Icedove in combination with UXP. But for now support for Lightning / Iceowl is missing. Could you please add this package again, either within Icedove-UXP itself or as another addon compatible with UXP?

PackagesTestingBug ReportMediumMedium [Hyperbola GNU/Linux 0.4] Problems with touch- / trackp ...Closed
100%
Task Description

Description: Not finally tested, only getting the logs from chat within here for better analysis later on. User reported that touchpad is not working for now with Hyperbola GNU/Linux 0.4. dmesg-messagelog:

[anonymous@anonymous ~]$ dmesg | grep pad
[ 4.766853] psmouse serio1: synaptics: The touchpad can support a better bus than the too old PS/2 protocol. Make sure MOUSE_PS2_SYNAPTICS_SMBUS and RMI4_SMB are enabled to get a better touchpad experience.
[ 4.823723] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xf00123/0×840300/0x2e800/0×0, board id: 3127, fw id: 8526786

PackagesTestingBug ReportMediumMedium [Hyperbola GNU/Linux 0.4] Problems with ALSA and sndio  ...Closed
100%
Task Description

Description: User reporting problems with sndio. A further check with ALSA showed no active device being used. User has HDMI-sound in usage.

PackagesTestingBug ReportMediumMedium [Hyperbola GNU/Linux-libre 0.4] - Package [android-file ...Closed
100%
Task Description

Application is not starting and needs therefore a rework.

PackagesStableBackport RequestVery LowMedium Request for addon used by Iceweasel-UXP: uMatrix Closed
100%
Task Description

Hello, would it be possible to have the addon uMatrix ported to be used within the UXP-platform? The addon is complete open and can be found here https://github.com/gorhill/uMatrix

I’ve tried to install different versions and it seems to be incompatible with the concurrent version of Iceweasel-UXP from the repositoy.

PackagesStableReplace RequestVery LowMedium Package ossp has got systemd dependencies Closed
100%
Task Description

Description: Concurrent package ossp in version 1.3.2-15 has got dependencies to systemd, which is contradicting the whole distribution and the used INIT-system. Therefore my request to port this to OpenRC!

Additional info:
* package version(s) 1.3.2-15

PackagesStableImplementation RequestVery LowMedium [gcc] Renew to version 8 or 9, including multilib Closed
100%
Software DevelopmentIceweasel-UXPUpdate RequestVery LowMedium [iceweasel-uxp] changing the default search-engines Closed
100%
PackagesAnySecurity IssueVery LowMedium Download debian-fixes instead of relying on external so ...Closed
100%
PackagesAnyFeature RequestMediumLow [Hyperbola GNU/Linux 0.4] Reactivate ALSA for all UXP-a ...Closed
100%
Software DevelopmentGeneralFeature RequestMediumLow[Website] Rework for the onion-pageUnconfirmed
0%
PackagesStableImplementation RequestVery LowLow [codelite] Adding new package Closed
100%
PackagesAnyFreedom IssueVery LowLow [gnome] Complete remval of desktop-environment Closed
100%
PackagesStableUpdate RequestVery LowLow [icewm] Upgrade package version Closed
100%
PackagesAnyFreedom IssueVery LowLow [hedgewars] Crash when starting a new singleplayer-camp ...Closed
100%
PackagesStableBug ReportVery LowLow [dhcpcd-ui] Adding icons from "Network-Manager Applet" Closed
100%
PackagesAnyFreedom IssueVery LowLow [Hyperbola GNU/Linux-libre 0.4] No login after installa ...Closed
100%
PackagesAnyBug ReportVery LowLow [Hyperbola GNU/Linux-libre 0.4] Testing Lumina - lumina ...Closed
100%
Showing tasks 1 - 37 of 37 Page 1 of 1

Available keyboard shortcuts

Tasklist

Task Details

Task Editing