All Projects

ProjectCategory  ascTask TypePrioritySeveritySummaryStatusProgress
ServicesHyperWiki/DokuWikiImplementation RequestMediumMediumLibreboot hardening grub guideUnconfirmed
0%
Task Description

I don’t know if this is the best place for this, but I get stuck on the hardening the grub guide from libreboot,

https://libreboot.org/docs/gnulinux/grub_hardening.html

I wondered if there is anything different that needs to be done to get this part done:

gpg –homedir keys –detach-sign my.initramfs
gpg –homedir keys –detach-sign my.kernel
gpg –homedir keys –detach-sign libreboot_grub.cfg
gpg –homedir keys –detach-sign my.grubtest.cfg

it gives me a bunch of weird errors

ServicesHyperWiki/DokuWikiImplementation RequestVery LowMediumProvide binaries for the Ice*-UXP applications in their...Unconfirmed
0%
Task Description

This would ease their usage on other distros.

Software DevelopmentIceape-UXPImplementation RequestVery LowMediumRandom agent spoofer for IceapeUnconfirmed
0%
Task Description

0.9.5.8.4 version would be good to have.

Software DevelopmentIcedove-UXPImplementation RequestDeferLowSwiftdove-UXP theme for Icedove-UXPUnconfirmed
0%
Task Description

Description:
Historically, Swiftdove was a Thunderbird-based application built on XUL platform around 2007 and abandoned in 2010. It was optimized for several architectures using the following methods such as the Profile-Guided Optimization (PGO) and binary code optimization for computers with limited resources.

Since FossaMail may potentially be revived on UXP in the future [0] and Swiftdove contains non-trademarked graphics and logos, we could port Swiftdove to UXP platform as theme for Icedove-UXP.

Software DevelopmentIceweasel-UXPBackport RequestVery LowMediumRequest browser add-on: New Tab ToolsUnconfirmed
0%
Task Description

Name: New Tab Tools
Version: 81 (compatible Firefox version 52)
Source code: Github
Description: Customize Firefox’s. Tabs Page

https://github.com/darktrojan/newtabtools

https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/

Software DevelopmentIceweasel-UXPImplementation RequestDeferLowSwiftweasel-UXP theme for Iceweasel-UXPUnconfirmed
0%
Task Description

Description:
Historically, Swiftweasel was a Firefox-based application built on XUL platform around 2007 and abandoned in 2010. It was optimized for several architectures using the following methods such as the Profile-Guided Optimization (PGO) and binary code optimization for computers with limited resources.

Since there are users encouraging us develop a Palemoon-based application , and Swiftweasel contains non-trademarked graphics and logos, we could port Swiftweasel to UXP platform as theme for Iceweasel-UXP.

Software DevelopmentIceweasel-UXPBackport RequestVery LowVery LowRequest browser add-on: FireGesturesUnconfirmed
0%
Task Description

Name: FireGestures
Version: 1.11.1 (compatible Firefox version 52)
Source code: Github
Description: A customizable mouse gestures extension which enables to execute various commands and user scripts with six types of gestures.

https://github.com/gomita/firegestures/

https://addons.mozilla.org/en-US/firefox/addon/firegestures/

ServicesPunBB BrandingBug ReportHighHighForum appearance bugsIn Progress
100%
Task Description

Some forum display errors:

  1. preview button with the orange border.
  1. Error message when logging in gray color making it difficult to read
PackagesStableUpdate RequestHighHigh[qt5] upgrade Qt project to the 5.6 LTS version, requir...Deferred
0%
Task Description

Cannot mix incompatible Qt library (version 0×50800) with this library (version 0×50904)
Aborted

./Nextcloud-2.3.3-x86_64.AppImage: /usr/lib/libQt5Core.so.5: version `Qt_5.9’ not found (required by /tmp/.mount_NextclpprMnG/usr/bin/../lib/libqt5keychain.so.1

These two packages are directly affected by an older qt5...

Could you update all the qt packages to the LTS version available?

PackagesStableBug ReportVery LowHigh[lm_sensors] Fail to load it87 module at bootAssigned
0%
Task Description

Description:

I ran sensors-detect, it detected two modules :

coretemp
it87

Those have been added to /etc/sysconfig/lm_sensors :

# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

HWMON_MODULES="coretemp it87"

But only coretemp is loaded at boot.

I can manually load it87 module (modprobe it87) and get all sensors working but for some reason it87 module is not loaded at boot.

PackagesStableBug ReportVery LowHighjava cacerts file is emptyUnconfirmed
0%
Task Description

/etc/ssl/certs/java/cacerts has 0 entries, resulting in ssl handshake errors in java applications.

Package versions:
* ca-certificates 20170307-1
* ca-certificates-utils 20170307-1

PackagesStableFeature RequestVery HighHigh[hiawatha]: remove systemd files, provide openrcResearching
0%
Task Description

Description:

Hiawatha contains only systemd files.

It shall be removed and openrc shall be provided

PackagesStableBug ReportMediumHigh[tp_smapi] not working with most recent libre kernelResearching
0%
Task Description

Description:
tp_smapi fails to load

Additional info:
* package version(s)
tp_smapi-lts 0.43-1.hyperbola29.5
linux-libre-lts 4.9.143_gnu-0

* config and/or log files etc.
From dmesg:
thinkpad_ec: Unknown symbol _GLOBAL_OFFSET_TABLE_ (err 0)
thinkpad_ec: Unknown symbol __x86_indirect_thunk (err 0)

Steps to reproduce:
1. Install tp_smapi and the most recent stable linux-libre-lts
2. Reboot
3. sudo modprobe tp_smapi

PackagesStableBug ReportVery LowHigh[devede] xorriso unsupported option '-dvd-video'Assigned
0%
Task Description

Description:

Devede fails to convert transcoded videos to iso format with libburn-1.5.0.

Drive current: -outdev 'stdio:/home/heckyel/movie/movie.iso'
Media current: stdio file, overwriteable
Media status : is blank
Media summary: 0 sessions, 0 data blocks, 0 data,  334g free
xorriso : FAILURE : -as genisofs: Unsupported option '-dvd-video'
xorriso : NOTE : -return_with SORRY 32 triggered by problem severity FAI

Additional info:

$ pacman -Si devede
Repositorio               : community
Nombre                    : devede
Versión                   : 4.8.8-1
Descripción               : A program to create VideoDVDs and CDs
Arquitectura              : any
URL                       : http://www.rastersoft.com/programas/devede.html
Licencias                 : GPL3
Grupos                    : Nada
Provee                    : Nada
Depende de                : mencoder  ffmpeg  dvdauthor  vcdimager  cdrkit  ttf-dejavu
                            gtk3  python-cairo  python-gobject  python-setuptools
Dependencias opcionales   : mplayer
                            vlc
                            mpv
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 1640,88 KiB
Tamaño de la instalación  : 3331,00 KiB
Encargado                 : Sergej Pupykin <pupykin.s+arch@gmail.com>
Fecha de creación         : vie 10 feb 2017 05:06:37 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

Link’s code:

- https://gitlab.com/rastersoft/devedeng/blob/master/src/devedeng/mkisofs.py#L61

- https://gitlab.com/rastersoft/devedeng/blob/master/src/devedeng/genisoimage.py#L61

Steps to reproduce:

- Install devede
- Create video DVD disc

PackagesStableFreedom IssueVery LowHighGNU Privacy Assistant (GPA)Unconfirmed
0%
Task Description

Hello Hyperbola!

GPA gives out the following errors upon opening the app.

First:

```
The GPGME library returned an unexpected
error at confdialog.c:1459. The error was:

    Unsupported protocol

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.
```

Second:

```
Fatal Error in GPGME library
(invoked from file options.c, line 302):

    Unsupported protocol

The application will be terminated

What can I do to overcome these errors?
```
As this issue makes gpa app completely unusable, I have set this bug report’s severity as high.

I also request the admin to set priority to high due to it’s severity.

Thank you!

Regards,
RG.

PackagesStableBug ReportVery LowHigh[gufw] error response to PolicyKit daemonUnconfirmed
0%
Task Description

Description:

Additional info:
* package version(s)

$ pacman -Si gufw
Repositorio               : community
Nombre                    : gufw
Versión                   : 17.04.1-3.hyperbola1
Descripción               : Uncomplicated way to manage your GNU/Linux firewall
Arquitectura              : any
URL                       : https://gufw.org/
Licencias                 : GPL-3
Grupos                    : Nada
Provee                    : Nada
Depende de                : gtk3  polkit  python-gobject  ufw  webkit2gtk  net-tools  desktop-file-utils  gtk-update-icon-cache
Dependencias opcionales   : Nada
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 886,27 KiB
Tamaño de la instalación  : 3827,00 KiB
Encargado                 : HyperBuilder <hyperbuilder@hyperbola.info>
Fecha de creación         : mar 01 oct 2019 14:35:51 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

* config and/or log files etc.

==== AUTHENTICATING FOR com.ubuntu.pkexec.gufw ===
Authentication is required to run the Firewall Configuration
Authenticating as: freedom
Password: 
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

Steps to reproduce:
- install gufw

PackagesStableBug ReportVery LowHigh[firewalld] Failed to read file "/proc/sys/net/netfilte...Unconfirmed
0%
Task Description

Additional info:
* package version(s)

# pacman -Si firewalld
Repositorio               : community
Nombre                    : firewalld
Versión                   : 0.4.4.4-1.hyperbola1
Descripción               : Firewall daemon with D-Bus interface, with OpenRC support
Arquitectura              : any
URL                       : https://github.com/t-woerner/firewalld
Licencias                 : GPL2
Grupos                    : Nada
Provee                    : Nada
Depende de                : dbus-glib  dconf  ebtables  hicolor-icon-theme  ipset  iptables
                            python-slip
Dependencias opcionales   : bash-completion: bash completion
                            gtk3: firewall-config
                            libnm-glib: firewall-config and firewall-applet
                            libnotify: firewall-applet
                            python-pyqt5: firewall-applet
En conflicto con          : Nada
Remplaza a                : Nada
Tamaño de la descarga     : 532,05 KiB
Tamaño de la instalación  : 4865,00 KiB
Encargado                 : André Silva <emulatorman@hyperbola.info>
Fecha de creación         : lun 25 sep 2017 21:00:50 -05
Validado por              : Suma MD5  Suma SHA-256  Firma

* config and/or log files etc.

# tail -F /var/log/firewalld


2019-10-02 22:09:45 DEBUG1: Loading zone file ‘/usr/lib/firewalld/zones/internal.xml’
2019-10-02 22:09:45 DEBUG1: Loading zone file ‘/usr/lib/firewalld/zones/public.xml’
2019-10-02 22:09:45 DEBUG1: Loading zone file ‘/usr/lib/firewalld/zones/trusted.xml’
2019-10-02 22:09:45 DEBUG1: Loading zone file ‘/usr/lib/firewalld/zones/work.xml’
2019-10-02 22:09:45 DEBUG1: Using default zone ‘public’
2019-10-02 22:09:45 ERROR: Failed to read file “/proc/sys/net/netfilter/nf_conntrack_helper”: [Errno 2] No existe el fichero o el directorio: ‘/proc/sys/net/netfilter/nf_conntrack_helper’
2019-10-02 22:09:45 WARNING: Failed to get and parse nf_conntrack_helper setting
2019-10-02 22:09:45 FATAL ERROR: No IPv4 and IPv6 firewall.
2019-10-02 22:09:45 ERROR: Raising SystemExit in run_server

Steps to reproduce:

- Install package
- rc-service firewalld start
- firewalld –debug

PackagesStableBug ReportVery LowHigh[vlc] DVB : cache_block stream error: cannot pre fill b...Unconfirmed
0%
Task Description

Current VLC version (3.0.4-3.hyperbola1.backports1) fails to play DVB stream using a RTL2832 usb dongle.

I start the playlist like this :

vlc channels.conf

but it returns the following error :

cache_block stream error: cannot pre fill buffer

Also, it asks the user to be in “video” group to access DVB device, this was not needed before with Hyperbola 0.2.9. User being in “wheel” was enough.
Anyway, even after adding my user to video group, it still fails with “cache_block stream error: cannot pre fill buffer”

This is not an issue with my DVB adapter or driver. rtl2832 is correctly loaded. And I can play the channels.conf playlist just fine with “mpv” or “mplayer”.
Also, the channels.conf used works just fine with a more recent version of VLC on an other system (Manjaro) so something is broken with the current VLC used.

Maybe a package bump would fix the issue.

PackagesStableBug ReportVery LowMedium[kodi-addons-visualization] addons don't workUnconfirmed
0%
Task Description

After installation, none of the addons is present in Kodi!

PackagesStableBug ReportMediumMedium[libusb] error when mounting USB memories on virtual ma...Researching
0%
Task Description

## Bug ##

libusb: error [_get_usbfs_fd] libusb couldn’t open USB device /dev/bus/usb/003/003: permission denied libusb: error [_get_usbfs_fd] libusb requires write access to USB device nodes.

Reference links: https://askubuntu.com/questions/526962/libusb-couldnt-open-usb-device-dev-bus-usb-002-006-permission-denied-libusb

PackagesStableBug ReportVery LowMedium[cowsay] perl-text-charwidth dependency missingUnconfirmed
0%
Task Description

cowsay (cowsay-3.03-9.hyperbola1) is missing perl-text-charwidth dependency

Error message :

“Can’t locate Text/CharWidth.pm in @INC (you may need to install the Text::CharWidth module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/bin/cowsay line 14.
BEGIN failed–compilation aborted at /usr/bin/cowsay line 14.”

After installing perl-text-charwidth, it works fine.

PackagesStableBug ReportMediumMedium[linux-libre-lts] [i915] Display freeze : hpd interrupt...Deferred
0%
Task Description

Hello,

I recently acquired a T400 Thinkpad with 1440×900 panel.
On this T400, I installed Hyperbola, just like on my x200 Thinkpad with 1280×800 panel.

Both Thinkpad are running the same Hyperbola installation :

Full disk encryption (with Libreboot) so both Thinkpad are using early KMS (MODULES=”i915” in /etc/mkinitcpio.conf)
Same kernel : linux-libre-lts (4.9.99 at the moment I’m writing this message)
video driver : modesetting
DE : xfce4 with xfwm4

On the Thinkpad x200, everything works great, no issue to report.

On the T400 though, the linux-libre-lts kernel, I’m getting random display freezes, when it happens, this message appears in dmesg :

hpd interrupt storm detected on connector hdmi-a-1

And the display (and sound) freezes for 10 seconds (sometimes more !)

As Hyperbola proposes linux-libre-lts kernel only, I installed latest linux-libre-lts (4.14.40) and linux-libre (4.16.8) from Parabola GNU/Linux repo.

Results :

With 4.14.40 : Same issue as with 4.9.99 kernel from Hyperbola repo.
With 4.16.8 : Issue is not present ! No more freeze !

I’m not sure how to proceed though. Would you be kind enough helping me to find which commit in i915 driver improved the situation ? If we find it, maybe it could be added as a patch to 4.9.x kernel series.
Or maybe it is something else.. I don’t have much experience, I can provide logs if needed.

Thanks for your help

PackagesStableBug ReportVery LowMedium[nfs-utils] missing idmapd.confUnconfirmed
0%
Task Description

Hello,

When mounting an NFS share, I get a warning about missing idmpad.conf

rpc.idmapd: Skipping configuration file "/etc/idmapd.conf": No such file or directory
4341: * Stopping idmapd ...

Debian includes a default config file for idmap :

[General]

Verbosity = 0
Pipefs-Directory = /run/rpc_pipefs
# set your own domain here, if id differs from FQDN minus hostname
# Domain = localdomain

[Mapping]

Nobody-User = nobody
Nobody-Group = nogroup
PackagesStableBug ReportMediumMedium[virt-install] ERROR '_OsVariant' object has no attribu...Requires Testing
100%
Task Description

Trying to create a VM using virt-install (1.4.1-2.hyperbola2)

virt-install --connect qemu:///system \
--name debian \
--ram 1024 \
--disk path=/home/test/debian.img,size=50 \
--vcpus 2 \
--os-type linux \
--os-variant generic \
--network bridge=virbr0 \
--graphics none \
--console pty,target_type=serial \
--location 'http://ftp.nl.debian.org/debian/dists/stretch/main/installer-amd64/' \
--extra-args 'console=ttyS0,115200n8 serial'

This error shows up :
ERROR : ‘_OsVariant’ object has no attribute ‘urldistro’

I can’t create the VM.

PS : Error is not present on Debian Stretch with virt-install 1.4.0-5

Thanks for your help.

PackagesStableBug ReportVery LowMediumPCManFM display different behaviorUnconfirmed
0%
Task Description

Description:

The problem is pcmanfm is not showing any partitions on the left side. It only show Home Folder, Desktop, Applications, Filesystem and the ext. hdd. If I include dbus-launch pcmanfm -d command, it show the other partitions on the left side of window but not ext. hdd. The drive/partitions are not encrypted.
I do have dbus, gvfs & ntfs-3g installed and active services.

Additional info:
* package version(s)
PCManFM 1.2.5 - using LibFM ver. 1.2.5

Steps to reproduce:
Original install from the livecd with LXDE but I may run Openbox standalone and get the same behavior with either environment. I do not have this issue running other distros.

PackagesStableBug ReportLowMediumGarbled display with xfce4-terminal (terminfo)Unconfirmed
0%
Task Description

A very nasty bug I wasn’t able to find an answer to.
I compiled stuff (buildroot) using menuconfig, the menu display was fine in xfce4-terminal (See screenshot #1)
I restarted the config a few days later with the same command :

$ make menuconfig

and this time the display was messed up (See screenshot #2)

After investigation, I noticed a directory (filled with stuff) have been created in my home folder :

.terminfo

I don’t know why. But anyway, if I delete it, then the display is ok again.
I noticed that if I use good old xterm terminal, then the display is fine even if the .terminfo directory is present. (it uses “xterm” instead of xterm-256color)

But, with xfce4-terminal (and others, I tried with gnome-terminal, sakura..), the display is messed up if the .terminfo directory is present in my home folder.

I also noticed that if I run the command in a screen session, the issue is not present.

(I open xfce4-terminal)

$ screen
$ printenv TERM
screen.xterm-256color
$ make menuconfig (or htop, or other program using ncurses)

= display ok

but with default :

(I open xfce4-terminal)

$ printenv TERM
xterm-256color
make menuconfig (or htop, or other program using ncurses)

= display messed up if .terminfo directory is present

So I have no idea why this .terminfo directory is generated. What could trigger its generation ? Is that an issue with ncurses or something else ?

Thanks for your help

PackagesStableBug ReportVery LowMediumMouse curse become invisible from beginning in kde5 pla...Unconfirmed
0%
Task Description

Description:
I install plasma and xorg to my Hyperbola GNU/Linux-libre in Arch-way.
However, after reboot, everything is fine except mouse curse.

I attempt to reinstall plasma-desktop and reboot. But nothing changes.

In attachment, the mouse stop at backward, however it is invisible.

Additional info:
* package version(s)
plasma-desktop == 5.9.5-1
xorg-server == 1.19.6-2.hyperbola1
sddm == 0.14.0-2.hyperbola6

* config and/or log files etc.

Steps to reproduce:

PackagesStableReplace RequestVery LowMediumPackage ossp has got systemd dependenciesUnconfirmed
0%
Task Description

Description: Concurrent package ossp in version 1.3.2-15 has got dependencies to systemd, which is contradicting the whole distribution and the used INIT-system. Therefore my request to port this to OpenRC!

Additional info:
* package version(s) 1.3.2-15

PackagesStableBug ReportVery LowMedium [kodi] "The Movie Database" scraper doesn't workUnconfirmed
0%
Task Description

With kodi 17.1-2.hyperbola1 “The Movie Database” scraper doesn’t work. The error message is :

"Unable to connect to remote server"
PackagesStableUpdate RequestVery LowMedium[cantarell-fonts] update package version to 0.111Unconfirmed
0%
Task Description

Prior version 0.0.25 and below are outdated.

Since version 0.100 and later, there are some changes being redesigned from scratch, added three new weights (including extra bold, light and thin) but not italic or oblique styles, AppStream metadata translations from contributors, and more.

See the version history releases for more details: https://gitlab.gnome.org/GNOME/cantarell-fonts/raw/master/NEWS

PackagesStableBug ReportVery LowMedium[arm-unknown-linux-gnueabi-gcc] not working; needs prop...Unconfirmed
0%
Task Description

Description:
I believe the arm-unknown-linux-gnueabi-gcc package to be broken as described here.

Additional info:
* package version(s) - arm-unknown-linux-gnueabi-gcc - all versions

Steps to reproduce:
I don't think "steps to reproduce" to be relevant in this case. My forum topic linked above already contains all the necessary info on the subject :) However, one could try compiling glibc and busybox as described here. Yes, these are instructions for debian-like systems. They have to be adapted accordingly

PackagesStableBug ReportVery LowLowMupen64plus acts buggyUnconfirmed
0%
Task Description

the screen moves back and forth from left to right randomly, no matter what I do, any games any adapters do not work.

I wanted to have some fun with some old games...

Has anyone used mupen64plus successfully on hyperbola 0.2? I cannot get it to work without being completely confusing for the reasons I have mentioned and also, the glaring of the screen. Which only happens with mupen64plus...

PackagesStableFeature RequestVery LowLow[digikam]: /usr/bin/cleanup_digikamdb: line 61: kreadco...Unconfirmed
0%
Task Description

Description:

I just guess that this script cleanup_digikamdb depends on kreadconfig which is not there.

Additional info:

extra/digikam 5.5.0-2.hyperbola1 [installed]

  Digital photo management application for KDE

Steps to reproduce:

$ cleanup_digikamdb

/usr/bin/cleanup_digikamdb: line 61: kreadconfig: command not found


                  Cleanup Databases v1.1 (digiKam )                    

————————————————————————-
/usr/bin/cleanup_digikamdb: line 61: kreadconfig: command not found
This program only handles SQLite databases.
[~]

PackagesStableFeature RequestVery LowLow[iceweasel-uxp] Request browser add-on: Privacy Setting...Unconfirmed
0%
Task Description

Name: Privacy Settings
Version: 0.2.6 (compatible Firefox version 52.* to 56.*)
Author: Jeremy Schomery (j_schomery)
Licence: Mozilla Public Licence (MPL) 2.0
Source code: Github
Description: Alter Firefox’s built-in privacy settings easily with a toolbar panel.

PackagesStableFeature RequestVery LowLow[iceweasel-uxp] Request browser add-on: Classic Theme R...Unconfirmed
0%
Task Description

Name: Classic Theme Restorer
Version: 1.7.7.2 (compatible Firefox version 45.* to 56.*)
Author: Aris (Aris-t2)
Licence: Mozilla Public Licence (MPL) 2.0
Source code: Github
Description: Squared tabs, application menu, add-on bar, small button view and many more ‘old’ features for ‘Firefox 29-56’, not for Firefox 57+!

PackagesStableImplementation RequestVery LowLow[materia-theme] add packageUnconfirmed
0%
Task Description

A Material-like flat theme for GTK+ 2/3, and GNOME shell, released under a GNU General Public Licence (GNU GPL) 2 and later.

PackagesStableBug ReportVery LowLowGNOME cannot lock screen while using LightDMUnconfirmed
0%
Task Description

Description:
Screen locking does not work in GNOME, either with keyboard shortcuts or from the menu, while using LightDM.

Additional info:
* According to this thread[1] this bug has been patched in Ubuntu. Please consider applying this patch.[2]

Steps to reproduce:
# pacman -S gnome lightdm lightdm-gtk-greeter
# rc-update add lightdm default
Reboot, log in to a GNOME session and attempt to lock screen.

[1] https://www.reddit.com/r/gnome/comments/9klvej/is_there_a_way_to_get_the_screen_to_lock_with/ [2] https://git.launchpad.net/~ubuntu-desktop/ubuntu/+source/gnome-shell/tree/debian/patches/ubuntu/lightdm-user-switching.patch

PackagesStableBug ReportVery LowVery LowGajim "Unable to run gpg - it may not be available" Assigned
0%
Task Description

Description:

Gajim XMPP Client wont start after installing python2-gnupg.

Additional info:
* package version(s)

  community/python2-gnupg 0.4.0-2
  extra/gajim 0.16.8-1.hyperbola2

* config and/or log files etc.

/usr/lib/python2.7/site-packages/gajim/common/gajim.py

Steps to reproduce:

With Gajim working is not possible to assign an OpenPGP key because it needs a wrapper. Therefore python2-gnupgp package is needed. But after installing python2-gnupgp, Gajim doesn’t start. The following output is displayed from the console:


07/21/2018 18:00:41 (E) gajim.c.gnupg Unable to run gpg - it may not be available.
Traceback (most recent call last):

File "/usr/lib/python2.7/site-packages/gnupg.py", line 757, in __init__
  p = self._open_subprocess(["--version"])
File "/usr/lib/python2.7/site-packages/gnupg.py", line 832, in _open_subprocess
  startupinfo=si)
File "/usr/lib/python2.7/subprocess.py", line 394, in __init__
  errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1047, in _execute_child
  raise child_exception

OSError: [Errno 2] No such file or directory
Traceback (most recent call last):

File "gajim.py", line 513, in <module>
  interface.run()
File "/usr/lib/python2.7/site-packages/gajim/gui_interface.py", line 2704, in run
  self.roster = roster_window.RosterWindow()
File "/usr/lib/python2.7/site-packages/gajim/roster_window.py", line 6611, in __init__
  connection_zeroconf.ConnectionZeroconf(gajim.ZEROCONF_ACC_NAME)
File "/usr/lib/python2.7/site-packages/gajim/common/zeroconf/connection_zeroconf.py", line 68, in __init__
  CommonConnection.__init__(self, name)
File "/usr/lib/python2.7/site-packages/gajim/common/connection.py", line 150, in __init__
  self.gpg = gpg.GnuPG()
File "/usr/lib/python2.7/site-packages/gajim/common/gpg.py", line 37, in __init__
  gnupg.GPG.__init__(self, gpgbinary=gajim.GPG_BINARY, use_agent=use_agent)
File "/usr/lib/python2.7/site-packages/gnupg.py", line 761, in __init__
  raise OSError(msg)

OSError: Unable to run gpg - it may not be available.


After doing some search, the issue is that gajim.py is trying to call ‘gpg’ as ‘gpg1’.

# grep -n GPG_BINARY /usr/lib/python2.7/site-packages/gajim/common/gajim.py
162:GPG_BINARY = ‘gpg1’

By replacing ‘gpg’ instead of ‘gpg1’, Gajim will start normally with OpenPGP feature available.

Maybe a newer revision of python2-gnupg is required or maybe a small patch in the current package.

PackagesTestingImplementation RequestVery LowMedium[yaics] add packageDeferred
0%
Task Description

Yaics is a simple GNU social client written in C++ and Qt and licensed under the GNU GPL 3.0 (or later).

Please implement yaics as an optional package.

https://stigatle.no/yaics/

https://gitlab.com/stigatle/yaics

PackagesTestingImplementation RequestLowMedium[spacefm] add new packageIn Progress
0%
Task Description

Add SpaceFM File Manager for Hyperbola

Aur Package: spacefm Debian Package: spacefm

PackagesTestingBug ReportMediumMedium[emacs] crush after swayResearching
0%
Task Description

I have installed Hyperbola on two laptops. And I have noticed that after running sway and exiting out of sway, GNU emacs crushers on console. It is easy to repeat it:

1. Run sway
2. Exit sway or killall sway
3. Try running emacs on console, there will be crush
4. log out, log in, and emacs will work on console again

Yet it should not crush.

PackagesTestingImplementation RequestMediumMediumlinux-libre-lts-hypersec: New package with extra securi...Deferred
0%
Task Description

Description: Per a user request and to better secure the kernel, we can embed the cryptsetup and ciphers in the kernel. This would mean rather than exposed modules, they are built-in to the kernel and ready to use even without an intramfs.

To be embedded: ciphers aes, twofish, serpent; sha256, sha512 - and the necessary modules (don’t forget the block modes xts, lvm and cryptsetup ...)

Additionally, we could include USB Guard and any other features that meet our social contract and security outlook.

PackagesTestingReplace RequestVery LowMedium replace request: NetworkManager with wpa_cuteUnconfirmed
0%
Task Description

https://github.com/loh-tar/wpa-cute/releases

I know there are plans to remove NetworkManager. I wondered if we could replace it in 0.4 with Wpa_Cute. seen in the above link.

I haven’t been able to compile it, but it has been updated as recent as 2018 december (stable)

or 2019 january. :)

WPA_GUI doesn’t seem to work well for me, it runs into weird errors when I start it. Long story short, I run into this issue with wpa_supplicant when i do it manually:

https://wiki.archlinux.org/index.php/Wpa_supplicant:

Password-related problems

wpa_supplicant may not work properly if directly passed via stdin particularly long or complex passphrases which include special characters. This may lead to errors such as failed 4-way WPA handshake, PSK may be wrong when launching wpa_supplicant.

In order to solve this try using here strings wpa_passphrase <MYSSID> «< “<passphrase>” or passing a file to the -c flag instead:

# wpa_supplicant -i <interface> -c /etc/wpa_supplicant/example.conf

In some instances it was found that storing the passphrase cleartext in the psk key of the wpa_supplicant.conf network block gave positive results (see [2]). However, this approach is rather insecure. Using wpa_cli to create this file instead of manually writing it gives the best results most of the time and therefore is the recommended way to proceed.
Problems with eduroam and other MSCHAPv2 connections

This is my issue with wpa_supplicant sadly... and I do not know how to workaround that without a GUI.

but Wpa_Supplicant_gui does not fix it either, it doesn’t even load properly on my other laptop.

It says it cannot get the status of wpa_supplicant when I load it.

This could be an issue if you get rid of NetworkManager for some users.

So yeah, please take a look at my request okay? Wait for 0.3 to be released to add this if possible. I know you guys are overworked, etc... and it doesn’t need to be done now anyhow. ;)

PackagesTestingImplementation RequestVery LowLow[sirikata] add packageDeferred
0%
Task Description

Sirikata a platform for virtual worlds.

Sirikata is a platform for virtual worlds. We provide a set of libraries and protocols which can be used to deploy a virtual world, as well as fully featured sample implementations of services for hosting and deploying these worlds.

Please implement sirikata as an optional package.

ServicesWiki Page IssueBug ReportVery LowHighHTML design on Wiki not readableUnconfirmed
0%
Task Description

The wiki pages look really too narrow and not readable on even half a screen of the laptop.

ServicesWiki Page IssueImplementation RequestVery LowMediumAdd notification/subscription capabilities when a page ...Unconfirmed
0%
Task Description

After talking to Emulatorman, we think this would be a nice feature to add to our Hyperwiki to be able to subscribe to the original page in English to help tracking changing to the translated pages.
This implies to add the email notifications to the dokuwiki system

Showing tasks 401 - 446 of 446 Page 9 of 9<<First - 5 - 6 - 7 - 8 - 9

Available keyboard shortcuts

Tasklist

Task Details

Task Editing