All Projects

ProjectCategoryTask TypePriority  ascSeveritySummaryStatusProgress
PackagesAnyFreedom IssueVery LowLow[tenshi]: please refer to GNU/Linux or remove reference...Unconfirmed
0%
Task Description

Description:

community/tenshi 0.15-2
     real-time log monitor from the Gentoo Linux project

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[tea]: using kernel name instead of operating system na...Unconfirmed
0%
Task Description

Description:

community/tea 43.1.0-5
     A Qt-based text editor for Linux and *BSD. With an ultimate small size TEA provides you hundreds of functions

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyBug ReportVery LowCritical[system-config-printer] Impossible to print some pdfs (...Assigned
0%
Task Description

Hello,

I’m unable to print some pdfs on my Hyperbola 3.0 system.
Some background :

cups is installed, service enabled and working
system-config-printer is installed and my printer has been correctly added.

I can print most pdfs and text files but recently with a pdf, it fails to print it.* And system-config-printer returned the following error (see capture) :

Printer "EPSON XP-620-Series" requires the '/usr/lib/cups/filters/epson-escpr-wrapper' but it is not currently installed.

Currently, “epson-escpr-wrapper” is installed but it is in :

/usr/libexec/cups/filters/epson-escpr-wrapper

Looking at source code of system-config-printer, it expects that wrapper to be installed in “/usr/lib/” so I tried to symlink that “epson-escpr-wrapper” to “/usr/lib/cups/filters” but it doesn’t work..

*With a Debian system and the exact same configuration, the “problematic” pdf prints just fine so it is not an issue with the pdf.

PackagesStableBug ReportVery LowMedium[sshguard] violates Hyperbola packaging standardsUnconfirmed
0%
Task Description

Description:
The sshguard package should have its /usr/bin/sshguard executable in /usr/sbin, has systemd service files and no OpenRC init script

Additional info:
* sshguard-2.0.0-4
* when I run `sshguard`:

# sshguard
/usr/bin/sshguard: line 87: /usr/bin/journalctl: No such file or directory

* default /etc/sshguard.conf

LOGREADER="LANG=C /usr/bin/journalctl -afb -p info -n1 -t sshd -o cat"
BLACKLIST_FILE=120:/var/db/sshguard/blacklist.db
BACKEND="/usr/lib/sshguard/sshg-fw-iptables"

(commenting the first line temporally solves the issue)

PackagesAnyFreedom IssueVery LowLow[squashfs-tools]: using kernel name instead of operatin...Unconfirmed
0%
Task Description

Description:

community/squashfs-tools 4.3-4
     Tools for squashfs, a highly compressed read-only filesystem for Linux.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesStableBug ReportVery LowVery Low[spamassassin] has different directory permissions than...Deferred
0%
Task Description

Description:
The /usr/sbin directory in spamassassin has permissions 755
https://git.hyperbola.info:50100/packages/extra.git/tree/spamassassin/PKGBUILD#n88

And ‘filesystem’ sets it to 750
https://git.hyperbola.info:50100/packages/core.git/tree/filesystem/PKGBUILD#n135

So when installing spamassassin, pacman throws a warning

warning: directory permissions differ on /usr/sbin/
filesystem: 750  package: 755

Additional info:
* spamassassin 3.4.2-1.hyperbola2

PackagesAnyFreedom IssueVery LowLow[snownews]: using kernel name instead of operating syst...Unconfirmed
0%
Task Description

Description:

community/snownews 1.5.12-9
     Text mode RSS newsreader for Linux and Unix.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesStableBug ReportVery LowCritical[smartmontools] update-smart-drivedb fails to updateAssigned
0%
Task Description

smartmontools 6.5-1.hyperbola1

Error while trying to update smart-drivedb :

anon@test[~] update-smart-drivedb

External Link/usr/bin/update-smart-drivedb: download from branches/RELEASE_6_5_DRIVEDB failed (curl: exit 23) /usr/bin/update-smart-drivedb: download from trunk failed (curl: exit 23)

PackagesAnyBug ReportVery LowMedium[slim] login screen not displaying correctlyAssigned
0%
Task Description

It worked fine on the previous version of Hyperbola. The word user/username does not show up. A workaround is to wait 10 seconds and enter the username and click enter - then it will switch correctly to the password screen (otherwise you need to enter the username and password at least twice in order to successfully login).

PackagesAnyFeature RequestVery LowMedium[slim-themes] please add hyperbola branded variantUnconfirmed
0%
Task Description

slim-themes seems to be considered free according to Parabola - they have an issue with arch branding (slim-themes::::[branding][FIXME:package] has “archlinux” theme) which they resolve be creating the package parabola-themes-slim. Perhaps this can be the basis for hyperbola branded themes.

https://git.parabola.nu/blacklist.git/plain/blacklist.txt https://www.parabola.nu/packages/libre/x86_64/parabola-themes-slim/

PackagesTestingImplementation RequestVery LowLow[sirikata] add packageDeferred
0%
Task Description

Sirikata a platform for virtual worlds.

Sirikata is a platform for virtual worlds. We provide a set of libraries and protocols which can be used to deploy a virtual world, as well as fully featured sample implementations of services for hosting and deploying these worlds.

Please implement sirikata as an optional package.

PackagesAnyFreedom IssueVery LowLow[simh]: license unclear for VAX ROM file ka655x.bin Unconfirmed
0%
Task Description

Description:

simh is very nice simulator.

Yet it is unclear the license for the ROM file: /usr/lib/simh/ka655x.bin and if license is not free and/or source of VAX ROM is missing, this package is not free.

PackagesAnyFreedom IssueVery LowLow[shorewall]: using kernel name instead of operating sys...Unconfirmed
0%
Task Description

Description:

community/shorewall 5.1.4-1
     An iptables-based firewall for Linux systems

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[shorewall6]: using kernel name instead of operating sy...Unconfirmed
0%
Task Description

Description:

 

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[shfs-utils]: using kernel name instead of operating sy...Unconfirmed
0%
Task Description

Description:

community/shfs-utils 0.35-5
     SHell FileSystem Linux utils

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyImplementation RequestVery LowLow[sayonara] add packageUnconfirmed
0%
Task Description

Hello,

I stumbled upon this music player recently, it is very promising and fully free (GPL3)

“Sayonara is a small, clear and fast audio player for Linux written in C++, supported by the Qt framework. It uses GStreamer as audio backend. Sayonara is open source and uses the GPLv3 license. One of Sayonara’s goals is intuitive and easy usablility. Currently, it is only available for Linux and BSD.

Although Sayonara can be considered as a lightweight player, it holds a lot of features in order to organize even big music collections.”

Latest version is 1.1.1 and it is very stable on my hyperbola system. I think it would be a great addition to Hyperbola repo.

https://sayonara-player.com/

A PKGBUILD is available here :

https://sayonara-player.com/sw/arch_linux/PKGBUILD

PackagesAnyImplementation RequestVery LowLow[sacd-extract] add packageUnconfirmed
0%
Task Description

Could it be possible to add :

sacd-extract

“Extract DSD files from an SACD image”

https://www.parabola.nu/packages/pcr/x86_64/sacd-extract/ https://sourceforge.net/p/sacd-ripper/

License : GPL2

Thanks

PackagesAnyBug ReportVery LowHigh[rubyripper] GUI doesn't workUnconfirmed
0%
Task Description

rrip_gui does not work. The fix is to install cairo-gobject which is not in the repos. Attached is a working PKGBUILD adapted from the official one.

PackagesAnyFreedom IssueVery LowLow[retroarch-assets-xmb]: referring to assets in descript...Unconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

To refer to published works as “assets”, or “digital assets”, is even worse than calling them “content” — it presumes they have no value to society except commercial value.

community/retroarch-assets-xmb 401-1 (libretro)
    XMB menu assets for RetroArch

Why not use “elements” instead?

PackagesAnyFreedom IssueVery LowLow[repose]: consider to change it to name of operating sy...Unconfirmed
0%
Task Description

Description:

community/repose 7.1-2
     Arch Linux repo building tool

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

I think this shall be changed to Hyperbola GNU/Linux repo building tool

PackagesAnyBug ReportVery LowLow[remmina] impossible to connect to RDP servers after re...Unconfirmed
0%
Task Description

remmina dev ask to inform package maintainer, here is the discussion:

https://github.com/FreeRDP/Remmina/issues/1513#issuecomment-373128671

Would be nice to update or add a patch if available

PackagesAnyFreedom IssueVery LowLow[recoll]: optional dependency: untex: for dvi support w...Unconfirmed
0%
Task Description

Upon installation of recoll, I can see:

optional dependency: untex: for dvi support with dvips

but untex cannot be installed

PackagesAnyImplementation RequestVery LowLow[radiotray] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add :

radiotray

“An online radio streaming player that runs on a Linux system tray.”

https://aur.archlinux.org/packages/radiotray/

License : GPL

Thanks

PackagesAnyImplementation RequestVery LowLow[quiterss] add package Unconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

quiterss

“Fast and light RSS/Atom feed reader written in Qt/С++”

https://aur.archlinux.org/packages/quiterss

License : GPL3

Thanks

PackagesAnyFreedom IssueVery LowLow[qt5-svg]: using "contents" in descriptionUnconfirmed
0%
Task Description

Description:

extra/qt5-svg 5.8.0-1 (qt qt5) [installed]
    Classes for displaying the contents of SVG files

The description is vague.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyImplementation RequestVery LowLow[qpdfview] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

qpdfview

“A tabbed PDF viewer using the poppler library.”

https://www.parabola.nu/packages/community/x86_64/qpdfview/

License : GPL2

Thanks

PackagesAnyFreedom IssueVery LowLow[qpdf]: using "Content" in descriptionUnconfirmed
0%
Task Description

Description:

extra/qpdf 6.0.0-2
    QPDF: A Content-Preserving PDF Transformation System

The description is vague.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Content

PackagesAnyFreedom IssueVery LowLow[qlandkartegt]: using kernel name instead of operating ...Unconfirmed
0%
Task Description

Description:

community/qlandkartegt 1.8.1-8
     Use your GPS with Linux

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnySecurity IssueVery LowMedium[qemu] Multiple CVEUnconfirmed
0%
Task Description

CVE-2018-20123 QEMU: pvrdma: memory leakage in device hotplug
https://www.openwall.com/lists/oss-security/2018/12/13/4

CVE-2018-16872 Qemu: usb-mtp: path traversal by host filesystem
manipulation in Media Transfer Protocol (MTP)
https://www.openwall.com/lists/oss-security/2018/12/13/11

Patches included at above URLs.

PackagesAnyImplementation RequestVery LowLow[qarte] add packageUnconfirmed
0%
Task Description

Request for :

qarte

“Allow you to browse into the archive of arte+7 & arteLiveWeb sites and to record your prefered videos.”

https://aur.archlinux.org/packages/qarte

License : GPL3

PackagesAnyFreedom IssueVery LowLow[python2-pyinotify]: using kernel name instead of opera...Unconfirmed
0%
Task Description

Description:

community/python2-pyinotify 0.9.6-3 [installed]
     Python module used for monitoring filesystems events on Linux platforms with inotify.
 community/qlandkartegt 1.8.1-8

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[python2-pam]: using kernel name instead of operating s...Unconfirmed
0%
Task Description

Description:

community/python2-pam 0.1.4-3 [installed]
     Module that provides an authenticate function that allows the caller to authenticate a given username / password against the PAM sy stem on Linux.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[python-pyinotify]: using kernel name instead of operat...Unconfirmed
0%
Task Description

Description:

community/python-pyinotify 0.9.6-3
     Python module used for monitoring filesystems events on Linux platforms with inotify.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyImplementation RequestVery LowLow[python-cheat] add package Unconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

python-cheat

“Cheat allows you to create and view interactive cheatsheets on the command-line.”

https://aur.archlinux.org/packages/python-cheat/

https://github.com/chrisallenlane/cheat

License : GPL3

Thanks

PackagesAnyPrivacy IssueVery LowLow[purple-plugin-pack] Provides Napster support which is ...Unconfirmed
0%
Task Description

purple-plugin-pack provides access to Napster which is only useful with a single company and sever (as far as I could tell).

PackagesAnyImplementation RequestVery LowMedium[purple-matrix] Please add packageUnconfirmed
0%
Task Description

Package is a libpurple plugin for the Matrix protocol which is consistent with Hyperbola’s social contract as Matrix is a federated protocol.

Source code can be found here licensed under GPLv2:

https://github.com/matrix-org/purple-matrix

PKGBUILD for git version is available here (last stable release is from two years ago so git version is probably the best version to use):

https://aur.archlinux.org/packages/purple-matrix-git/

PackagesAnyUpdate RequestVery LowHigh[proj]: please update to latest versionUnconfirmed
0%
Task Description

Description:

https://proj4.org/index.html

This package have valuable geodetic applications, and I intend to present Hyperbola GNU/Linux-libre soon in universities and schools in East Africa.

The coordinate system there is not WGS84 and this package only in new version is providing the conversion from East African geographic coordinates to WGS84, and will be very usable in many industrial and private applications.

PackagesAnyImplementation RequestVery LowLow[powerpill] add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

powerpill

“Pacman wrapper for faster downloads.”

https://aur.archlinux.org/packages/powerpill/

https://xyne.archlinux.ca/projects/powerpill

License : GPL

Thanks

PackagesStableBug ReportVery LowMedium[postgrey] has systemd service and no OpenRC init scrip...Unconfirmed
0%
Task Description

Description:
The title says everything

Also, it doesn’t follow the FHS (/usr/bin/postgrey should be in /usr/sbin)

Additional info:
* postgrey-1.37-1

PackagesStableBug ReportVery LowVery Low[postfix] has different directory permissions than 'fil...Deferred
0%
Task Description

Description:
The /usr/sbin directory in postfix has permissions 755
https://git.hyperbola.info:50100/packages/extra.git/tree/postfix/PKGBUILD#n115

And ‘filesystem’ sets it to 750
https://git.hyperbola.info:50100/packages/core.git/tree/filesystem/PKGBUILD#n135

So when installing postfix, pacman throws a warning

warning: directory permissions differ on /usr/sbin/
filesystem: 750  package: 755

Additional info:
* postfix-3.2.2-1.hyperbola6

PackagesAnyImplementation RequestVery LowLow[plymouth] add packageDeferred
0%
Task Description

Plymouth is an application that runs very early in the boot process (even before the root filesystem is mounted!) that provides a graphical boot animation while the boot process happens in the background.

Please implement plymouth as an optional package.

PackagesAnyFreedom IssueVery LowLow[pkgdiff]: using kernel name instead of operating syste...Unconfirmed
0%
Task Description

Description:

community/pkgdiff 1.7.1-1
     A tool for analyzing changes in Linux software packages

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyFreedom IssueVery LowLow[pinta] mentioning proprietary software Paint.NETUnconfirmed
0%
Task Description

Description:

The description of the package need to be changed to accommodate:
https://www.gnu.org/philosophy/words-to-avoid.html

community/pinta 1.6-2 [installed]
     Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users

I am not quite sure what the policy is in Hyperbola on this one. I am referring to the reference to the proprietary software Paint.NET. That is for me steering users to verify what is Paint.NET – we shall not be doing it. It should be removed from description.

I am fine if authors have in documentation something explaining how they started software project. But I am not fine in descriptions which are public and accessible on Internet to have such references to illegitimate proprietary software.

Just to clarify, the word “alternative” is just fine in this description and need not be removed.

PackagesAnyFreedom IssueVery LowLow[pflask]: using kernel name instead of operating system...Unconfirmed
0%
Task Description

Description:

community/pflask 0.2.20151217-1
     Lightweight process containers for Linux

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesAnyImplementation RequestVery LowMedium[peertube] Add new PackageUnconfirmed
0%
Task Description

Description:

Hi guys. Could they add PeerTube to Hyperbola?

It’s on AUR.

Under the AGPLv3 license

Additional info:

I see that the PeerTube help configuration with an init.d

PackagesAnySecurity IssueVery LowMedium[patch] CVE-2018-6951 - NULL pointer DoSAssigned
0%
Task Description

An issue was discovered in GNU patch through 2.7.6. There is a segmentation fault, associated with a NULL pointer dereference, leading to a denial of service in the intuit_diff_type function in pch.c, aka a “mangled rename” issue.

https://security-tracker.debian.org/tracker/CVE-2018-6951

PackagesAnyImplementation RequestVery LowLow[pacpl] Add packageUnconfirmed
0%
Task Description

Hello,

Could it be possible to add this package :

pacpl

“Convert multiple audio types from one format to another.”

https://aur.archlinux.org/packages/pacpl/

License : GPL

Dependencies needed (and currently missing in Hyperbola repo) :

perl-ogg-vorbis-header perl-mp4-info perl-mp3-tag perl-audio-flac-header perl-audio-musepack perl-parallel-forkmanager perl-cddb
PackagesAnyFreedom IssueVery LowLow[packeth]: using kernel name instead of operating syste...Unconfirmed
0%
Task Description

Description:

community/packeth 1.8.1-1
     A Linux GUI packet generator tool for ethernet.

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

PackagesStableDrop RequestVery LowCritical[osdbattery] Unmaintained and unsupportableUnconfirmed
0%
Task Description

osdbattery is (probably) useless and broken so Conky did compete because It is still unmaintained and unsupported over 14 years ago (last released version 1.4 on August 23, 2005), and should be removed per anti-abandonware rule at the packaging guidelines.

Also, the default config file contains non-libre/free Microsoft font Verdana as X11 font format property in font variable.

PackagesAnyFreedom IssueVery LowLow[oprofile]: using kernel name instead of operating syst...Unconfirmed
0%
Task Description

Description:

community/oprofile 1.1.0-3
     System-wide profiler for Linux systems

See:
https://www.gnu.org/philosophy/words-to-avoid.html#Linux

Showing tasks 51 - 100 of 492 Page 2 of 10 - 1 - 2 - 3 - 4 - 5 - Last >>

Available keyboard shortcuts

Tasklist

Task Details

Task Editing