All Projects

ProjectCategoryTask TypePrioritySeveritySummaryStatus  descProgress
ServicesHyperWeb IssueBug ReportVery LowLowRSS needs fixingUnconfirmed
0%
Task Description

Seems deleted items reappearing in the Hyperbola feeds since it gives its feed items empty ID string.

PackagesStableBug ReportVery LowMedium[cowsay] perl-text-charwidth dependency missingUnconfirmed
0%
Task Description

cowsay (cowsay-3.03-9.hyperbola1) is missing perl-text-charwidth dependency

Error message :

“Can’t locate Text/CharWidth.pm in @INC (you may need to install the Text::CharWidth module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/bin/cowsay line 14.
BEGIN failed–compilation aborted at /usr/bin/cowsay line 14.”

After installing perl-text-charwidth, it works fine.

PackagesStableBug ReportVery LowMedium[nfs-utils] missing idmapd.confUnconfirmed
0%
Task Description

Hello,

When mounting an NFS share, I get a warning about missing idmpad.conf

rpc.idmapd: Skipping configuration file "/etc/idmapd.conf": No such file or directory
4341: * Stopping idmapd ...

Debian includes a default config file for idmap :

[General]

Verbosity = 0
Pipefs-Directory = /run/rpc_pipefs
# set your own domain here, if id differs from FQDN minus hostname
# Domain = localdomain

[Mapping]

Nobody-User = nobody
Nobody-Group = nogroup
PackagesAnyBug ReportVery LowHighDesite "noauto" specified in /etc/fstab all devices get...Unconfirmed
0%
Task Description

Description:

I have tried all combinations, but despite “noauto” specified in /etc/fstab all devices get mounted at boot.

Who can help me, not to mount a device during boot?

PackagesStableBug ReportVery LowMediumPCManFM display different behaviorUnconfirmed
0%
Task Description

Description:

The problem is pcmanfm is not showing any partitions on the left side. It only show Home Folder, Desktop, Applications, Filesystem and the ext. hdd. If I include dbus-launch pcmanfm -d command, it show the other partitions on the left side of window but not ext. hdd. The drive/partitions are not encrypted.
I do have dbus, gvfs & ntfs-3g installed and active services.

Additional info:
* package version(s)
PCManFM 1.2.5 - using LibFM ver. 1.2.5

Steps to reproduce:
Original install from the livecd with LXDE but I may run Openbox standalone and get the same behavior with either environment. I do not have this issue running other distros.

PackagesAnyBug ReportVery LowMedium[ffmpegthumbnailer] missing support for some media form...Unconfirmed
0%
Task Description

ffmpegthumbnailer does not support some media formats since they do not appear in its configuration file ffmpegthumbnailer.thumbnailer which can be found in /usr/share/thumbnailers/. By editing the file ffmpegthumbnailer.thumbnailer one can add thumbnail support for embedded art in audio formats such as flac and mp3 (using the -m flag) and thumbnail support for webp (a new image format which iceweasel-uxp and gthumb support). I’m attaching my edited file (I just added a few common audio formats and webp and added the -m flag and removed the -f flag).

PackagesAnyBug ReportVery LowLowmarble-qt: doesn't look like a valid Marble plugin: "/...Unconfirmed
0%
Task Description

Description:

$ marble-qt –latlone=0.5,6.5
Ignoring to load the following file since it doesn’t look like a valid Marble plugin: “/usr/lib/marble/plugins/libWlocatePositionProviderPlugin.so” Reason: “Cannot load library /usr/lib/marble/plugins/libWlocatePositionProviderPlugin.so: (libwlocate.so: cannot open shared object file: No such file or directory)”

When package libwlocate is installed, it is not showing this error.

Shall that package be dependency?

PackagesAnyBug ReportVery LowHighgroff: package not built with URW fonts properly or suc...Unconfirmed
0%
Task Description

Description:

groff is typesetting system similar to TeX/LaTeX however, it is very small and very usable. It is not built properly with URW fonts, or such are missing, I cannot know all details. Overall groff package is basically somehow broken.

It shall depend on proper fonts, and such fonts should already be built, including their Unicode versions.

Package is only partially built.

PackagesStableBug ReportVery LowMedium[arm-unknown-linux-gnueabi-gcc] not working; needs prop...Unconfirmed
0%
Task Description

Description:
I believe the arm-unknown-linux-gnueabi-gcc package to be broken as described here.

Additional info:
* package version(s) - arm-unknown-linux-gnueabi-gcc - all versions

Steps to reproduce:
I don't think "steps to reproduce" to be relevant in this case. My forum topic linked above already contains all the necessary info on the subject :) However, one could try compiling glibc and busybox as described here. Yes, these are instructions for debian-like systems. They have to be adapted accordingly

ServicesFlyspray IssueBug ReportVery LowMedium[Flyspray] long tags break the backendUnconfirmed
0%
Task Description

When I was adding this task, I put some long tags on it (html form allowed that) and got an error concerning too long tags field to fit in an sql datatype (max is 40 chars). Task got added anyway (just without tags). I didn’t know that and created it again.

PackagesAnyBug ReportVery LowMedium[openrc] cannot load fuse at bootUnconfirmed
0%
Task Description

I added
<quote>modules=”fs-fuse”</quote>
to /etc/conf.d/modules (and also “fuse” instead).

I looked in /var/log/rc.log and I see this line

<quote>modprobe: FATAL: Module fs-fusetun not found in directory /lib/modules/4.9.194-gnu-1-lts</quote>

It looks like modprobe added “tun” to the filename which prevents loading the module.

PackagesAnyBug ReportVery LowMedium[exfat-utils] filesystem can only be mounted manuallyUnconfirmed
0%
Task Description

One can mount exfat by running commands such as “sudo modprobe fuse” and “sudo mount.exfat /dev/sdc1 /mnt/storage” but it is inconvenient.

Also, loading fuse at startup is problematic - see here:

https://issues.hyperbola.info/index.php?do=details&task_id=1433

PackagesStableBug ReportVery LowHigh[vlc] DVB : cache_block stream error: cannot pre fill b...Unconfirmed
0%
Task Description

Current VLC version (3.0.4-3.hyperbola1.backports1) fails to play DVB stream using a RTL2832 usb dongle.

I start the playlist like this :

vlc channels.conf

but it returns the following error :

cache_block stream error: cannot pre fill buffer

Also, it asks the user to be in “video” group to access DVB device, this was not needed before with Hyperbola 0.2.9. User being in “wheel” was enough.
Anyway, even after adding my user to video group, it still fails with “cache_block stream error: cannot pre fill buffer”

This is not an issue with my DVB adapter or driver. rtl2832 is correctly loaded. And I can play the channels.conf playlist just fine with “mpv” or “mplayer”.
Also, the channels.conf used works just fine with a more recent version of VLC on an other system (Manjaro) so something is broken with the current VLC used.

Maybe a package bump would fix the issue.

PackagesAnyBug ReportVery LowHigh[rubyripper] GUI doesn't workUnconfirmed
0%
Task Description

rrip_gui does not work. The fix is to install cairo-gobject which is not in the repos. Attached is a working PKGBUILD adapted from the official one.

PackagesStableBug ReportVery LowMedium[sshguard] violates Hyperbola packaging standardsUnconfirmed
0%
Task Description

Description:
The sshguard package should have its /usr/bin/sshguard executable in /usr/sbin, has systemd service files and no OpenRC init script

Additional info:
* sshguard-2.0.0-4
* when I run `sshguard`:

# sshguard
/usr/bin/sshguard: line 87: /usr/bin/journalctl: No such file or directory

* default /etc/sshguard.conf

LOGREADER="LANG=C /usr/bin/journalctl -afb -p info -n1 -t sshd -o cat"
BLACKLIST_FILE=120:/var/db/sshguard/blacklist.db
BACKEND="/usr/lib/sshguard/sshg-fw-iptables"

(commenting the first line temporally solves the issue)

PackagesStableBug ReportVery LowVery Low[fail2ban] update dovecot failregex to support verbose ...Unconfirmed
0%
Task Description

Description:
The /etc/fail2ban/filter.d/dovecot.conf file has a failregex with the following:

^%(__prefix_line)s(?:auth|auth-worker\(\d+\)): (?:pam|passwd-file)\(\S+,<HOST>\): unknown user\s*$

and works with things like:

Month day time hostname dovecot: auth: passwd-file(user@domain.com,IP): unknown user

but with verbosity enabled in Dovecot, this output looks like this:

Month day time hostname dovecot: auth: passwd-file(user@domain.com,IP): unknown user (given password: password)

and in this case it doesn’t work, but it does if we fix the failregex if we replace it with:

^%(__prefix_line)s(?:auth|auth-worker\(\d+\)): (?:pam|passwd-file)\(\S+,<HOST>\): unknown user( \(given password: \S*\))?\s*$

with this new expression, it works with and without verbosity

And regarding postfix, to make it work correctly I “backported” some pieces from newest failregex:

/etc/fail2ban/postfixr-rbl.conf:

^%(__prefix_line)sNOQUEUE: reject: RCPT from \S+\[<HOST>\]: [45]54 [45]\.7\.1 Service unavailable; Client host \[\S+\] blocked using .* from=<\S*> to=<\S+> proto=ESMTP helo=<\S*>$

/etc/fail2ban/postfix.conf: (second failregex)

^%(__prefix_line)sNOQUEUE: reject: RCPT from \S+\[<HOST>\]: 45[04] 4\.7\.1 Client host rejected: cannot find your (reverse )?hostname, (\[\S*\]); from=<\S*> to=<\S+> proto=ESMTP helo=<\S*>$

I can create a patch if you want. Note that I haven’t tested all filters, some others may also need some rework

Additional info:
* fail2ban-0.9.6-2.hyperbola3

PackagesStableBug ReportVery LowMedium[fail2ban] uses old /usr/bin/sendmail location when it ...Unconfirmed
0%
Task Description

Description:

I saw errors in logs because fail2ban couldn’t find /usr/bin/sendmail, and discovered this:

[/etc/fail2ban] [0]
$ grep /usr/bin/sendmail */*
action.d/sendmail-buffered.conf:              Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:                 Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:             Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-buffered.conf:                Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-common.conf:              Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-common.conf:             Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-geoip-lines.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-ipjailmatches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-ipmatches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-lines.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>
action.d/sendmail-whois-matches.conf:            Fail2Ban" | /usr/bin/sendmail -f <sender> <dest>

Please, also check for other binaries with wrong locations

As of now, the solution is as simple as removing this line → https://git.hyperbola.info:50100/packages/community.git/tree/fail2ban/PKGBUILD#n79

Additional info:
* fail2ban-0.9.6-2.hyperbola3

PackagesStableBug ReportVery LowLow[autofs]: default configuration is /etc/auto.master ins...Unconfirmed
0%
Task Description

Description:

default configuration is /etc/auto.master instead of /etc/autofs/auto.master

admin→ sudo /usr/bin/automount -v -f -p /run/autofs.pid
Starting automounter version 5.1.2, master map /etc/auto.master
using kernel protocol version 5.02
lookup(file): file map /etc/auto.master missing or not readable
no mounts in table

PackagesStableBug ReportVery LowMediumlinphonec error (cli version)Unconfirmed
0%
Task Description

Description:
linphonec is unusable because a error produce a continuous log

Additional info:
linphone 3.11.1-1.hyperbola1

Steps to reproduce:
linphonec

Log:
linphonec> 2019-12-15 19:25:58:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:03:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:08:018 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:13:013 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:18:016 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:23:014 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:28:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:33:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:38:012 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:43:015 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:48:010 ortp-error-Error in connect: Network is unreachable
2019-12-15 19:26:53:010 ortp-error-Error in connect: Network is unreachable

PackagesAnyBug ReportVery LowLowXenocara xbacklight bugUnconfirmed
0%
Task Description

When i try to set the brightness on my screen, with xbacklight -set 100,

it does this:

No outputs have backlight property

and it doesn’t really matter if I set it lower than 100 or what it currently is at.

Fix when you can please!

ServicesHyperWebBug ReportVery LowMediumThe Mailling list don't workUnconfirmed
0%
Task Description

The Mailling list don't work : https://lists.hyperbola.info//mailman/listinfo/

Software DevelopmentIcedove-UXPBug ReportVery LowMediumCardBook addon make icedove crash wen adding or editing...Unconfirmed
0%
Task Description

the cardbook version is 30.9 i tried with vcard 4.0 and vcard 3.0 same issue editing or creating a contact makes
icedove-uxp crash!

ServicesPunBB IssueBug ReportVery LowLowhyperbola forum smtp error and profile updateUnconfirmed
0%
Task Description

here i will report 2 issues and one change to make
issues:
1- there is a failed smtp error with post and reply
2- in the forum profile one cant add website with .xyz domain name

the change:
1- with pgp key one would add a short key link just like what was mentioned in here:
https://forums.hyperbola.info/viewtopic.php?pid=2639#p2639

PackagesStableBug ReportVery LowMediumnouveau_drv.so: undefined symbol: exaDriverAllocUnconfirmed
0%
Task Description

Any attempt to load Nouveau in X server results in the following error:

nouveau_drv.so: undefined symbol: exaDriverAlloc

Additional info

Steps to reproduce

  1. Stop the X server.
  2. Add a section such as the following to “/etc/X11/xorg.conf”:
    Section "Device"
      Identifier "Video card"
      Driver "nouveau"
      Option "Backlight" "nv_backlight"
    EndSection
  3. Start the X server.
Software Developmentchroot-nspawnBug ReportMediumMedium[chroot-nspawn] Create mount points if mountpoint exit ...Unconfirmed
0%
Task Description

The actual behavior is to create mount points if mountpoint exits with exit status 1, however it may also exit with code 32 and thus creating a real mess:

$ sudo chroot-nspawn
Spawning container megver83 on /var/lib/archbuild/chroot1/megver83
Press ^] three times within 1s to kill container.
mount: /sys/fs/cgroup: mount point does not exist.
mkdir: cannot create directory '/sys/fs/cgroup/blkio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpu': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpu,cpuacct': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/cpuset': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/devices': No such file or directory  
mkdir: cannot create directory '/sys/fs/cgroup/freezer': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/memory': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_cls': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/net_cls,net_prio': No such file or directory
ln: failed to create symbolic link '/sys/fs/cgroup/net_prio': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/pids': No such file or directory
mkdir: cannot create directory '/sys/fs/cgroup/systemd': No such file or directory
mount: /sys/fs/cgroup/blkio: mount point does not exist.
mount: /sys/fs/cgroup/cpuset: mount point does not exist.
mount: /sys/fs/cgroup/devices: mount point does not exist.
mount: /sys/fs/cgroup/freezer: mount point does not exist.
mount: /sys/fs/cgroup/memory: mount point does not exist.
mount: /sys/fs/cgroup/pids: mount point does not exist.

So I created a patch to fix this.

P.S.: although I can git clone the repo with ssh access, whenever I do a push I get:

error: remote unpack failed: unable to create temporary object directory
To ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git
 ! [remote rejected] master -> master (unpacker error)
error: failed to push some refs to 'ssh://git.hyperbola.info:51100/~git/software/chroot-nspawn.git'

Do I have the permission to write in this repo? If not, I’d like it, as I’m planning to improve this great script

PackagesTestingBug ReportHighCriticalRunit errors,Unconfirmed
0%
Task Description

/sbin/openrc-run: bad interpreter: No such file or directory

I get this error whenever I try to start dhcpcd with sv /etc/runit/

And for sndiod I get this doing the same guide,

warning: sndiod: unable to open supervise/ok: file does not exist

Although rather ironically, If I type sndiod or dhcpcd into root, it works just fine.

Maybe its an FHS issue or possibly, I am screwing up? I am not sure. Feedback is welcome.

This is what I did:

=⇒ Add a service:

ln -s /etc/sv/<service> /var/service
==> Start/stop/restart a service:
sv <start/stop/restart> <service>

more or less, I used this guide.

PackagesTestingBug ReportVery LowHigh[xenocara-xkbcomp] Could not resolve keysym XF86FullScr...Unconfirmed
0%
Task Description

While the X session is still running, did anyone happen key bindings being unresponsive? A few lines of errors appeared from xkbcomp because of a missing keyboard symbol on the single TTY. It reads:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> error:   Could not resolve keysym XF86FullScreen
Errors from xkbcomp are not fatal to the X server

See also related issues affected on other existing distros, were eventually resolved:

PackagesTestingBug ReportMediumMedium[Hyperbola GNU/Linux 0.4] Problems with ALSA and sndio ...Unconfirmed
0%
Task Description

Description: User reporting problems with sndio. A further check with ALSA showed no active device being used. User has HDMI-sound in usage.

ServicesFlyspray IssueBug ReportVery LowMediumhypertask screen after write taskUnconfirmed
0%
Task Description

after write a task, hypertask show me this screen, and for some users think 'oh hypertask no works' attach image

Software DevelopmentGeneralBug ReportMediumCritical[xenocara] Server is not able to be started via xdmUnconfirmed
0%
Task Description

With the newest package-update the xserver xenocara has missing dependencies towards adobe-fonts and twm.

Software DevelopmentIceweasel-UXPBackport RequestVery LowMediumRequest browser add-on: New Tab ToolsUnconfirmed
0%
Task Description

Name: New Tab Tools
Version: 81 (compatible Firefox version 52)
Source code: Github
Description: Customize Firefox’s. Tabs Page

https://github.com/darktrojan/newtabtools

https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/

Software DevelopmentIceweasel-UXPBackport RequestVery LowVery LowRequest browser add-on: FireGesturesUnconfirmed
0%
Task Description

Name: FireGestures
Version: 1.11.1 (compatible Firefox version 52)
Source code: Github
Description: A customizable mouse gestures extension which enables to execute various commands and user scripts with six types of gestures.

https://github.com/gomita/firegestures/

https://addons.mozilla.org/en-US/firefox/addon/firegestures/

PackagesAnyBackport RequestVery LowMediumRandom Agent Spoofer for IceapeUnconfirmed
0%
Task Description

random_agent_spoofer-0.9.5.8.4-fx.xpi is the version I desire, can you implement it?

PackagesAnyBackport RequestVery LowMediumGreasemonkey For IceapeUnconfirmed
0%
Task Description

greasemonkey-3.31.4 version desired. I would love to see it implemented for Iceape

PackagesAnyBackport RequestVery LowLowSelf Destructing Cookies for IceapeUnconfirmed
0%
Task Description

I would like this to be available for Iceape as well V4.13

PackagesAnyBackport RequestVery LowMediumNo Resource Url Leak for IceapeUnconfirmed
0%
Task Description

1.2.4 version would be nice for Iceape.

Showing tasks 301 - 336 of 336 Page 7 of 7<<First - 3 - 4 - 5 - 6 - 7

Available keyboard shortcuts

Tasklist

Task Details

Task Editing