• Status Closed
  • Percent Complete
  • Task Type Update Request
  • Category Stable
  • Assigned To
    Jesús E.
    Márcio Silva
    André Silva
  • Operating System All
  • Severity High
  • Priority High
  • Reported Version Any
  • Due in Version Milky Way v0.4
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Packages
Opened by winter - 13/04/2018
Last edited by Jesús E. - 27/10/2021

FS#696 - [qt5] upgrade Qt project to the 5.6 LTS version, required by KDE Plasma 5.8 LTS

Cannot mix incompatible Qt library (version 0×50800) with this library (version 0×50904)

./Nextcloud-2.3.3-x86_64.AppImage: /usr/lib/ version `Qt_5.9’ not found (required by /tmp/.mount_NextclpprMnG/usr/bin/../lib/

These two packages are directly affected by an older qt5...

Could you update all the qt packages to the LTS version available?

Closed by  Jesús E.
27.10.2021 21:24
Reason for closing:  Won't implement
Additional comments about closing:  

Issue cannot be resolved as Plasma KDE was removed in Hyperbola Milky Way 0.4

André Silva commented on 14.04.2018 07:16

Hyperbola is a LTS distro and we have our own packaging guidelines to maintain our releases . See 6th amendment about snapshots versions in our packaging guidelines for further details.

By the way, is it a package maintained by us? If it is not the case (eg. a package built from AUR), i suggest looking for a LTS version of that package, or try build a version released around May 2017.

winter commented on 14.04.2018 16:31

It is a package you guys have. I am not entirely sure which qt5, so upgrading them all would be nice, but yeah, it is not from AUR as far as I know.

The latest stable image would be awesome from the qt5 website. IF you cannot do that though, I guess I could build from source. I just don't know how hard that would be.

winter commented on 14.04.2018 16:47

ps, qt 5.9 is supported till 2020.

However, 5.8 is not supported anymore.

5.6 is supported till 2019 but its better to do 5.9 when possible. :)

André Silva commented on 14.04.2018 18:01

Thanks for let me know, seems Qt 5.9 is a LTS version and therefore it should be used by default since our packaging guidelines (4th amendment) requires Hyperbola use LTS free software projects only; if available.

Márcio Silva commented on 14.04.2018 19:26

Since we have plans to upgrade our KDE Plasma to 5.8 LTS version (that is adapted for Milky Way), we should use the Qt 5.6 LTS that is required, not 5.9 LTS. [0] . Qt 5.9 LTS is another generation and should be used for our next release generation (Canis Major).

André Silva commented on 14.04.2018 19:45

Yes you are right, Qt 5.9 LTS was released at 31th May 2017 [0] and is adapted to work against the new KDE Plasma 5.12 LTS that was released at 06th February 2018 [1] , both were released after our official snapshot of Milky Way that was 8th May 2017 [3]

Thank you for let us know.

winter commented on 14.04.2018 20:34

okay, when is 0.4 coming out of curoisity?

That would be good to know.

I do wish you would move to 5.9 though at some point. But 5.6 is better than what we have now.

André Silva commented on 14.04.2018 21:54

coadde is structuring our build server (it's 99% ready) for v0.3 that contains around 200 packages to be stabilized. If our build server will be ready the next week, then i think v0.4 will be released around August with all [extra] stabilized. Meanwhile, i could create some bugfixes for nextcloud split packages to solve your issue.

winter commented on 15.04.2018 00:46

That would be helpful. Although, I actually need some update even for my nitrokey appimage package too.

winter commented on 15.04.2018 00:48

QT 5.6 would be useful in general for a bunch of this stuff. But yeah, at least update it to 5.6 for 0.3 if possible.

I need it for the new nitrokey app.

winter commented on 09.06.2019 22:00

I highly recommend you change it from 5.6 to 5.9 or better yet 5.12.

I think 5.6 has been deprecated by the qt devs.

I cannot even download 5.6 anymore. So there's that... :0

winter commented on 09.06.2019 22:02

ps, Nextcloud-client 2.5.2 now depends on qtwebengine and qt 5.12

I wondered if you can change those things for any build added here. ;)

Date User Effort (H:M)


Available keyboard shortcuts


Task Details

Task Editing