Packages

  • Status Assigned
  • Percent Complete
    50%
  • Task Type Bug Report
  • Category Any
  • Assigned To
    heckyel
    tobias
    rachad
  • Operating System All
  • Severity Medium
  • Priority Medium
  • Reported Version White Hole
  • Due in Version Starfix
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Packages
Opened by heckyel - 02/05/2022
Last edited by heckyel - 02/05/2022

FS#1604 - [surf-2.1-1]: Unresolved dependencies

Description:
Unresolved dependiencies

Additional info:
* package version(s)

$ doas pacman -Si surf
Repository      : extra
Name            : surf
Version         : 2.1-1
Description     : A simple web browser based on WebKit/GTK+.
Architecture    : x86_64
URL             : https://surf.suckless.org/
Licenses        : Expat
Groups          : None
Provides        : None
Depends On      : webkitgtk  gcr  xenocara-xprop
Optional Deps   : dmenu: URL-bar
                  ca-certificates: SSL verification
                  xterm: default download handler
                  curl: default download handler
Conflicts With  : None
Replaces        : None
Download Size   : 26.06 KiB
Installed Size  : 134.00 KiB
Packager        : HyperBuilder <hyperbuilder@hyperbola.info>
Build Date      : Fri Jul 9 21:49:07 2021
Validated By    : MD5 Sum  SHA-256 Sum  Signature

* config and/or log files etc.

$ doas pacman -S surf
resolving dependencies...
warning: cannot resolve "libfdk-aac", a dependency of "gst-plugins-bad"
warning: cannot resolve "gst-plugins-bad", a dependency of "webkitgtk"
warning: cannot resolve "webkitgtk", a dependency of "surf"
:: The following package cannot be upgraded due to unresolvable dependencies:
      surf

:: Do you want to skip the above package for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: gst-plugins-bad: requires libfdk-aac
:: webkitgtk: requires gst-plugins-bad
:: surf: requires webkitgtk

Steps to reproduce:

This error only occurs in the testing branch, that is to say in the Mirror Testing.

We need not to forget to add extra/libfdk-aac package in testing for Milky Way v0.4.1

libfdk-acc was detected as nonfree. This issue was already solved by Tobias, it is necessary to building the packages

Date User Effort (H:M)
watch my effort tracking timers

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing