Packages

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Any
  • Assigned To
    André Silva
    Tobias Dausend
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version Any
  • Due in Version Starfix
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Packages
Opened by Irene Yacila - 18/12/2018
Last edited by Tobias Dausend - 19/01/2022

FS#1304 - [crystal] error build Invidious

Description:

crystal build src/invidious.cr –release

Error in src/invidious.cr:19: while requiring "kemal"

require "kemal"
^

in lib/kemal/src/kemal.cr:4: while requiring "./kemal/*"

require "./kemal/*"
^

in lib/kemal/src/kemal/config.cr:26: expanding macro

    property static_headers : (HTTP::Server::Response, String, File::Info -> Void)?
    ^~~~~~~~

in lib/kemal/src/kemal/config.cr:26: expanding macro

    property static_headers : (HTTP::Server::Response, String, File::Info -> Void)?
    ^

in macro 'property' expanded macro: macro_48177600:567, line 4:

   1.       
   2.         
   3.           
>  4.             @static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil
   5. 
   6.             def static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil
   7.               @static_headers
   8.             end
   9. 
  10.             def static_headers=(@static_headers : (HTTP::Server::Response, String, File::Info -> Void) | ::Nil)
  11.             end
  12.           
  13.         
  14.       
  15.     

undefined constant File::Info

Additional info:
* package version(s)

Crystal 0.22.0 (2017-04-22) LLVM 4.0.0

Steps to reproduce:

Closed by  Tobias Dausend
19.01.2022 20:58
Reason for closing:  Won't implement
Additional comments about closing:  

Cannot be implemented with version 0.4 and so no fix possible.

Admin
André Silva commented on 28.12.2018 12:19

Hi, did you build it with a version based on our snapshot (2017-05-08) instead the latest one?

I mean it because we are a LTS distro, not a rolling release one. If we will upgrade crystal to the latest version (0.27.0); it will require upgrade some part of our entire environment (upgrade LLVM 4 to LLVM 6) by violating our packaging guidelines . I suggest you build a version based on our snapshot (2017-05-08) or request a LTS version for them since there are LTS distros such as Debian and Hyperbola using packages based on that date.

Irene Yacila commented on 24.05.2019 01:06

I tried it with version 0.22.0-1 and it does not work

Tobias Dausend commented on 19.01.2022 20:58

To implement a version of crystal we would have to violate our packaging-guidelines: You need a version of crystal to do it and that means a precompiled one. So this package cannot be part of any newer Hyperbola-version.

Date User Effort (H:M)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing