HyperTask Mon, 10 Feb 2020 20:00:30 +0000 installation https://issues.hyperbola.info/ FS#1506: Download Authenticity check, key has expired, key ID differs from instructions ithink314 Fri, 07 Feb 2020 17:44:51 +0000 After download of iso, following verify instructions, https://wiki.hyperbola.info/doku.php?id=en:guide:verify_live_images ,

What was done:
$ gpg –keyserver pgp.mit.edu –recv-key “C92B AA71 3B8D 53D3 CAE6 3FC9 E697 4752 F970 4456” $ gpg –verify hyperbola-milky-way-v0.3-dual.iso.sha512.sig

Expected response:
file signature is ‘good’ and that it was signed with the following key: F9704456.

Actual response:
gpg: assuming signed data in ‘hyperbola-milky-way-v0.3-dual.iso.sha512’ gpg: Signature made Mon 23 Sep 2019 12:51:43 PM EDT
gpg: using RSA key C92BAA713B8D53D3CAE63FC9E6974752F9704456
gpg: Good signature from “AndrĂ© Silva emulatorman@hyperbola.info” [expired]
gpg: aka “AndrĂ© Silva emulatorman@riseup.net” [expired]
gpg: aka “[jpeg image of size 24564]” [expired]
gpg: Note: This key has expired!
Primary key fingerprint: C92B AA71 3B8D 53D3 CAE6 3FC9 E697 4752 F970 4456

https://issues.hyperbola.info/index.php?do=details&task_id=1506 https://issues.hyperbola.info/index.php?do=details&task_id=1506
FS#1447: FS#1445 - [fluxbox] provides nonfree software support in the menu winter Tue, 15 Oct 2019 20:56:53 +0000 recommended fix, remove non-free software entries in menu and replace them with applications that actually exist.

https://issues.hyperbola.info/index.php?do=details&task_id=1447 https://issues.hyperbola.info/index.php?do=details&task_id=1447
FS#1446: [jwm] provides nonfree software support in the menu winter Tue, 15 Oct 2019 20:50:30 +0000 my recommended fix, make it reflect the applications that are actually installed on the system after removing non-free software support.

https://issues.hyperbola.info/index.php?do=details&task_id=1446 https://issues.hyperbola.info/index.php?do=details&task_id=1446
FS#1445: [openbox] provides nonfree software support in the menu winter Tue, 15 Oct 2019 20:47:20 +0000 my recommended fix, make it reflect the applications that are actually installed on the system after removing non-free software support.

https://issues.hyperbola.info/index.php?do=details&task_id=1445 https://issues.hyperbola.info/index.php?do=details&task_id=1445
FS#162: [calamares] add graphical installer with FDE support winter Tue, 28 Nov 2017 10:04:07 +0000 Package Request: https://github.com/calamares/calamares

Original Bug Report:
— I would also like to test the beta isos when they are ready through qemu. If it looks good I plan to fully install them onto my laptop. My libreboot x200.

I don’t know if I should make a separate feature for this, but xfce is a good stable desktop environment for such a choice. that and lxde.

Though lxde is going to die...

https://issues.hyperbola.info/index.php?do=details&task_id=162 https://issues.hyperbola.info/index.php?do=details&task_id=162
FS#1373: installation successful, but buggy winter Sun, 21 Apr 2019 21:36:24 +0000 https://forums.hyperbola.info/viewtopic.php?pid=745#p745

This was the guide I followed, but there was one small issue:

The issue is attached within a picture. You will notice that a bunch of unneeded shortcuts are on my desktop right? well... I wondered how I can remove them. multiple filesystem root(s) and home(s) and boot(s)

but yeah, its extremely weird and messed up. a bit funny but troublesome and annoying.

Should I email the user who made that guide or leave it here? That’s what I am wondering.

https://issues.hyperbola.info/index.php?do=details&task_id=1373 https://issues.hyperbola.info/index.php?do=details&task_id=1373
FS#1366: [ISO][UEFI] Replace Syslinux with rEFInd David P. Tue, 12 Mar 2019 22:18:45 +0000 Actual v0.2 ISOs use Syslinux UEFI Boot Manager for supporting EFI systems. However, I wanted to request its replacement by rEFInd, which is much, much better.

Here is why Syslinux should not be used, at least for more advanced tasks than just booting the OS:

  • UEFI Syslinux application syslinux.efi cannot be signed by sbsign (from sbsigntools) for UEFI Secure Boot. Bug report: [3]
  • Using TAB to edit kernel parameters in UEFI Syslinux menu might lead to garbaged display (text on top of one another). Bug report: [4]
  • UEFI Syslinux does not support chainloading other EFI applications like UEFI Shell or Memtest86+. Enhancement request: [5]
  • In some cases, UEFI Syslinux might not boot in some Virtual Machines like QEMU/OVMF or VirtualBox or some VMware products/versions and in some UEFI emulation environments like DUET. A Syslinux contributor has confirmed no such issues present on VMware Workstation 10.0.2 and Syslinux-6.02 or later. Bug reports: [6], [7] and [8]
  • Memdisk is not available for UEFI. Enhancement request: [9]

The citations are from the ArchWiki, check it out for more info.

From all of those points, I have confirmed the 3rd and 4th ones. These are a PITA, because EFI Shell is super useful (Parabola and Arch has it in its ISOs) and not being able to test it in VMs make it harded for ISO testers since they’ve to take more time on writing the image to the USB... etc.

rEFInd doesn’t have these issues, plus, it can be easily testes with QEMU. Try this:

  1. install ovmf package
  2. run the following, and specify the latest Milky Way ISO:
/bin/qemu-system-x86_64 -soundhw ac97 \
      -k es -machine accel=kvm -m 1024 \
      -boot once=d,menu=off -net nic -net user -rtc base=localtime \
      -bios /usr/share/ovmf/x64/OVMF_CODE.fd -cdrom /path/to/file.iso

You will see errors in the CLI. Now, try with my customized ISO (dir with ISO file, sign [key: 6DB9C4B4F0D8C0DC432CF6E4227CA7C556B2BA78], and sha512 checksum), the same steps as above. You’ll see that it successfully boots, and has UEFI Shell apps.

Here is my hyperiso fork. Take a look at the refind/* branches. The refind/with-uefi-shell has EFI Shell from Tianocore EDK2 latest stable tag, and refind/without-uefi-shell, well, doesn’t have it. Note that the binary files from refind/with-uefi-shell are downloaded from upstream and they’re sha512 checksumed. If for any reason you cannot do that way, there’s the other branch as an alternative.

P.S.: I see that actual configs have configured syslinux.efi to show other boot menus rather than the “Boot Hyperbola” option, but I tested it in my PC with UEFI enabled and it just showed the mentioned option

https://issues.hyperbola.info/index.php?do=details&task_id=1366 https://issues.hyperbola.info/index.php?do=details&task_id=1366
FS#1140: [FAQ]Please note that not all RAR archives are supported by unar Alon Ivtsan Sun, 19 Aug 2018 15:40:44 +0000 I tried to extract a RAR v5 archive using unar that works fine when using the non-free unrar.

Here is the log (with the file name altered)

$ unar file.part1.rar
file.part1.rar: RAR 5

file.mp4  (-2144860915 B)... Failed! (Attempted to read more data than was available)

Extraction to current directory failed! (1 file failed.)

Please add in the FAQ that newer RAR archives (version 5) may not work when using unar.

https://issues.hyperbola.info/index.php?do=details&task_id=1140 https://issues.hyperbola.info/index.php?do=details&task_id=1140
FS#758: To make installation instructions and get use of live ISO Jean Louis Mon, 04 Jun 2018 06:29:56 +0000 I have installed multiple times Hyperbola, 4 times on 4 different notebooks.

What I have noticed is that the live ISO is quite huge in relation to the task that should be done. Namely. the live ISO shall at least contain some first packages, so that they do not need to be downloaded online.

Best would be if the live ISO can be copied straight and that system can run from ISO/DVD without having Internet. At least one simple graphical environment shall be included.

Further, I have noticed that there is only network instructions as HTML file.

I would rather call it installation-instructions.html to make it clear for people what it is. Or simply: INSTALL.html so that people understand what it is.

It says just network.html if I remember well.

Then there is absolutely no point or link or reference to the installation instructions.

Each time I got a network I had to go to either duckduckgo search engine or to hyperbola.info website and then I tried with lynx to find installation instructions.

It is not straight, not quite clearly in open, it is in Wiki, but that is quite hard to find.

We have to put ourselves in the shoes of those in need of free software. Millions of people need free software.

Many of us live in a developed western countries.

Yet millions of people in need of this software live in South America, Africa, Asia, Eastern Europe.

There are millions of students that could advance their study, and that could progress faster with free software.

In those countries Internet is often non-existent, universities may be located in poor network areas, Internet is being fetched by using mobile phones.

So if there is a live distribution, such shall at least contain basic software, which really can fit onto any DVD, and that as such can be copied on the computer without using Internet. Upgrades could be fetched by using Internet.

And there shall be clear reference, link or file about installation. There shall be no need to go to Internet to install the software.

https://issues.hyperbola.info/index.php?do=details&task_id=758 https://issues.hyperbola.info/index.php?do=details&task_id=758
FS#183: UEFI boot not working J. Doe Sat, 30 Dec 2017 18:27:59 +0000 Booting from UEFI with a USB gives the message:

No configuration file found

0.2 and 0.2.1

https://issues.hyperbola.info/index.php?do=details&task_id=183 https://issues.hyperbola.info/index.php?do=details&task_id=183