HyperTask https://issues.hyperbola.info/ software 2019-12-06T00:34:38Z FS#1486: [iceweasel-uxp] changing the default search-engines https://issues.hyperbola.info/index.php?do=details&task_id=1486 2019-12-06T00:34:38Z Tobias Dausend Hello, some of the current search-engines and websites used within Iceweasel-UXP per default are not reachable or even out of function. To be named are the following for now: - Yacy- Quitter / GNUSocial-instance- Invidious-instance It would be good to change or replace those. Hello,

some of the current search-engines and websites used within Iceweasel-UXP per default are not reachable or even out of function. To be named are the following for now:

- Yacy
- Quitter / GNUSocial-instance
- Invidious-instance

It would be good to change or replace those.

]]>
FS#1309: Random agent spoofer for Iceape https://issues.hyperbola.info/index.php?do=details&task_id=1309 2019-12-05T12:25:10Z winter 0.9.5.8.4 version would be good to have. 0.9.5.8.4 version would be good to have.

]]>
FS#1369: a libre version of Navigator, https://issues.hyperbola.info/index.php?do=details&task_id=1369 2019-09-22T14:54:22Z winter http://repository.binaryoutcast.com/artifacts/navigator-builds/ http://binaryoutcast.com/projects/borealis/ unlike Navigator though, it needs two things: compatibility with seamonkey addons, (the ones that effect web browsing, not the mail email parts) and to be based off of the latest version of seamonkey, only obviously just the navigator part. I understand this might be hard to implement now, so I can wait if need be, Just thought I would show this to you. PS, if you ever make HyperBK, port it to that too, but until then, just the os that I mentioned. Also, last thing, any seamonkey addons that I have already asked for seamonkey, again that aren’t email/mail based, implement them for this too. :) I will put the severity at very low if that’s okay, just until you have actual time/whatever... Let me know if this is even remotely possible with this build. http://repository.binaryoutcast.com/artifacts/navigator-builds/

http://binaryoutcast.com/projects/borealis/

unlike Navigator though, it needs two things: compatibility with seamonkey addons, (the ones that effect web browsing, not the mail email parts)

and to be based off of the latest version of seamonkey, only obviously just the navigator part. I understand this might be hard to implement now, so I can wait if need be, Just thought I would show this to you.

PS, if you ever make HyperBK, port it to that too, but until then, just the os that I mentioned.

Also, last thing, any seamonkey addons that I have already asked for seamonkey, again that aren’t email/mail based, implement them for this too. :)

I will put the severity at very low if that’s okay, just until you have actual time/whatever...

Let me know if this is even remotely possible with this build.

]]>
FS#1313: Search Engine Addon Request: Startpage https://issues.hyperbola.info/index.php?do=details&task_id=1313 2019-09-22T14:05:53Z Alice Grey Icecat currently has the FSF approved addon for Startpage.com.It would be helpful to have it ported to iceweasel-uxp.https://directory.fsf.org/wiki/Startpage_HTTPS_Privacy_Search_Engine Icecat currently has the FSF approved addon for Startpage.com.
It would be helpful to have it ported to iceweasel-uxp.
https://directory.fsf.org/wiki/Startpage_HTTPS_Privacy_Search_Engine

]]>
FS#1411: [msmtp] needs to be recompiled with libressl https://issues.hyperbola.info/index.php?do=details&task_id=1411 2019-09-22T13:05:11Z Robert Alessi I may be wrong as I did not migrate to 0.3 yet, but I think that `msmtp` has been forgotten and needs to be recompiled with `libressl`. Please remove this report if I am wrong. I may be wrong as I did not migrate to 0.3 yet, but I think that `msmtp` has been forgotten and needs to be recompiled with `libressl`.

Please remove this report if I am wrong.

]]>
FS#1414: [msmtp] needs libressl https://issues.hyperbola.info/index.php?do=details&task_id=1414 2019-09-22T13:04:42Z Robert Alessi I may be wrong for I did not migrate to 0.3 as of yet, but I think that `msmtp` has been forgotten and needs to be recompiled with `libressl`. Please remove this report if I am mistaken. I may be wrong for I did not migrate to 0.3 as of yet, but I think that `msmtp` has been forgotten and needs to be recompiled with `libressl`.

Please remove this report if I am mistaken.

]]>
FS#1415: [msmtp] needs libressl https://issues.hyperbola.info/index.php?do=details&task_id=1415 2019-09-22T13:04:14Z Robert Alessi From what I can see, `msmtp` still needs to be recompiled with `libressl`. Please remove this report if I am mistaken. From what I can see, `msmtp` still needs to be recompiled with `libressl`. Please remove this report if I am mistaken.

]]>
FS#1404: [ice{ape,weasel}-uxp-l10n] Default bookmarks are different but not synchronized from origin https://issues.hyperbola.info/index.php?do=details&task_id=1404 2019-09-13T23:21:35Z Jayvee Enaguas In the library manager: At bookmarks toolbar by default, an entry of the Hyperbola website favicon is different, affected in both localization and non-localization (origin). At bookmarks menu by default, a folder of Hyperbola with some clearnet and onion entries appeared in non-localization (origin), but not in localization. In the library manager:

  • At bookmarks toolbar by default, an entry of the Hyperbola website favicon is different, affected in both localization and non-localization (origin).
  • At bookmarks menu by default, a folder of Hyperbola with some clearnet and onion entries appeared in non-localization (origin), but not in localization.
]]>
FS#763: Develop GNU/HyperBK patchset https://issues.hyperbola.info/index.php?do=details&task_id=763 2019-06-20T00:52:13Z André Silva Develop GNU/HyperBK patchset for toolchain (Glibc, Binutils and GCC) and packages. PATCHING NOTE Make sure the definitions are not simply duplicated from GNU/Linux' because that will eventually result in out-of-sync definitions that break for us. Example of triplet check: linux*-gnu | gnu* | hyperbk-gnu) Example of uname check: Linux|GNU|GNU/*) Example of C macro check: defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) [note: GNU/Hurd defines __GNU__, and GNU/HyperBK define __GLIBC__ as hardcoded macro] Example of makefile check: ifneq (, $(filter Linux GNU GNU_%, $(shell uname -s))) [note1: findstring matches subwords, use filter instead] [note2: list must be the first parameter, otherwise matching fails] [note3: "%" is make's wildcard] Develop GNU/HyperBK patchset for toolchain (Glibc, Binutils and GCC) and packages.

PATCHING NOTE

Make sure the definitions are not simply duplicated from GNU/Linux' because that will eventually result in
out-of-sync definitions that break for us.

Example of triplet check:	linux*-gnu | gnu* | hyperbk-gnu)
Example of uname check:		Linux|GNU|GNU/*)
Example of C macro check:	defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
				[note: GNU/Hurd defines __GNU__, and GNU/HyperBK define __GLIBC__ as hardcoded macro]
Example of makefile check:	ifneq (, $(filter Linux GNU GNU_%, $(shell uname -s)))
				[note1: findstring matches subwords, use filter instead]
				[note2: list must be the first parameter, otherwise matching fails]
				[note3: "%" is make's wildcard]
]]>
FS#219: ARM/POWER porting https://issues.hyperbola.info/index.php?do=details&task_id=219 2019-01-10T22:57:03Z winter In particular, I would like to see the a20 arm processor supported and also, the talos 2 desktop supported. (powerpc) The a20 is important because it will be supported by this: https://www.crowdsupply.com/eoma68/micro-desktop I would really love to have buy this and see it supported by Hyperbola. :) Within a year if you can support that, I would be extremely, extremely pleased. as for the powerpc one, I don’t really plan on getting it, but I know that some people may, and I think that it would be good for them to be able to move onto hyperbola. The first is more important to me though. By either December or next January, is when I would probably want it to be supported. :) Also, ath9k usb wifi cards would need to be supported for this though... just to warn you. I already am donating to you guys though through liberapay, please make this happen in the future. ;) In particular, I would like to see the a20 arm processor supported and also, the talos 2 desktop supported. (powerpc)

The a20 is important because it will be supported by this: https://www.crowdsupply.com/eoma68/micro-desktop

I would really love to have buy this and see it supported by Hyperbola. :)

Within a year if you can support that, I would be extremely, extremely pleased.

as for the powerpc one, I don’t really plan on getting it, but I know that some people may, and I think that it would be good for them to be able to move onto hyperbola. The first is more important to me though.

By either December or next January, is when I would probably want it to be supported. :)

Also, ath9k usb wifi cards would need to be supported for this though... just to warn you.

I already am donating to you guys though through liberapay, please make this happen in the future. ;)

]]>